Subsequent Address Family Identifiers (SAFI) Parameters

Created

  • 2000-07

Last Updated

  • 2026-03-19

Available Formats


SAFI Values

Reference

  • RFC 4760: Multiprotocol Extensions for BGP-4

Note

When this registry is modified, the YANG module iana-routing-types must be updated as defined in RFC 8294.

Available Formats

Range Registration Procedures Note
1-63 Standards Action
64-127 First Come First Served
128-240 Some recognized assignments below, others Reserved
241-254 Reserved for Private Use Not to be assigned
Value Description Reference
0 Reserved RFC 4760
1 Network Layer Reachability Information used for unicast forwarding RFC 4760
2 Network Layer Reachability Information used for multicast forwarding RFC 4760
3 Reserved RFC 4760
4 Network Layer Reachability Information (NLRI) with MPLS Labels RFC 8277
5 MCAST-VPN RFC 6514
6 Network Layer Reachability Information used for Dynamic Placement of Multi-Segment Pseudowires RFC 7267
7 Encapsulation SAFI (OBSOLETE) RFC 9012
8 MCAST-VPLS RFC 7117
9 BGP SFC RFC 9015
10-63 Unassigned
64 Tunnel SAFI Gargi Nalawade; draft-nalawade-kapoor-tunnel-safi-01
65 Virtual Private LAN Service (VPLS) RFC 4761; RFC 6074
66 BGP MDT SAFI RFC 6037
67 BGP 4over6 SAFI RFC 5747
68 BGP 6over4 SAFI Yong Cui
69 Layer-1 VPN auto-discovery information RFC 5195
70 BGP EVPNs RFC 7432
71 BGP-LS RFC 9552
72 BGP-LS-VPN RFC 9552
73 SR Policy SAFI RFC 9830
74 SD-WAN Capabilities draft-ietf-idr-sdwan-edge-discovery-03
75 Routing Policy SAFI draft-ietf-idr-rpd-02
76 Classful Transport (CT) RFC 9832
77 Tunneled Traffic Flowspec draft-ietf-idr-flowspec-nvo3-10
78 MCAST-TREE draft-ietf-bess-bgp-multicast-03
79 BGP-DPS (Dynamic Path Selection) https://eos.arista.com/eos-4-26-2f/dps-vpn-scaling-using-bgp; Venkit Kasiviswanathan
80 BGP-LS-SPF RFC 9815
81 Unreachability Information SAFI Jeff Tantsura; draft-tantsura-idr-unreachability-safi-01
82 Unassigned
83 BGP CAR RFC 9871
84 BGP VPN CAR RFC 9871
85 BGP-MUP SAFI draft-mpmz-bess-mup-safi-00
86-127 Unassigned
128 MPLS-labeled VPN address RFC 4364; RFC 8277; RFC 9252
129 Multicast for BGP/MPLS IP Virtual Private Networks (VPNs) RFC 6513; RFC 6514
130-131 Reserved RFC 4760
132 Route Target constrains RFC 4684
133 Dissemination of Flow Specification rules RFC 8955
134 L3VPN Dissemination of Flow Specification rules RFC 8955
135-139 Reserved RFC 4760
140 VPN auto-discovery draft-ietf-l3vpn-bgpvpn-auto-08
141-240 Reserved RFC 4760
241-254 Reserved for Private Use RFC 4760
255 Reserved RFC 4760

Contact Information

Name Contact URI Last Updated
Gargi Nalawade gargi&cisco.com 2004-01
Jeff Tantsura jefftant.ietf&gmail.com 2026-03-19
Venkit Kasiviswanathan venkit&arista.com 2021-09-08
Yong Cui cuiyong&tsinghua.edu.cn 2006-09-20