Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
smakynet 122 tcp SMAKYNET Pierre Arnaud Pierre Arnaud
smakynet 122 udp SMAKYNET Pierre Arnaud Pierre Arnaud
ltp-deepspace 1113 udp Licklider Transmission Protocol 2014-02-21 RFC 5326; RFC 7122
ltp-deepspace 1113 dccp Licklider Transmission Protocol 2013-11-12 2014-02-21 RFC 7122 7107696
availant-mgr 1122 tcp availant-mgr Steven Pelletier Steven Pelletier
availant-mgr 1122 udp availant-mgr Steven Pelletier Steven Pelletier
c1222-acse 1153 tcp ANSI C12.22 Port RFC 6142
c1222-acse 1153 udp ANSI C12.22 Port RFC 6142
qt-serveradmin 1220 tcp QT SERVER ADMIN Chris LeCroy Chris LeCroy
qt-serveradmin 1220 udp QT SERVER ADMIN Chris LeCroy Chris LeCroy
sweetware-apps 1221 tcp SweetWARE Apps David Dunetz David Dunetz
sweetware-apps 1221 udp SweetWARE Apps David Dunetz David Dunetz
nerv 1222 tcp SNI R&D network Martin Freiss Martin Freiss
nerv 1222 udp SNI R&D network Martin Freiss Martin Freiss
tgp 1223 tcp TrulyGlobal Protocol Gur Kimchi Gur Kimchi 2008-05-20
tgp 1223 udp TrulyGlobal Protocol Gur Kimchi Gur Kimchi 2008-05-20
vpnz 1224 tcp VPNz Tom Strack Tom Strack
vpnz 1224 udp VPNz Tom Strack Tom Strack
slinkysearch 1225 tcp SLINKYSEARCH Desmond Chan Desmond Chan
slinkysearch 1225 udp SLINKYSEARCH Desmond Chan Desmond Chan
stgxfws 1226 tcp STGXFWS Tetsuya Shioda Tetsuya Shioda
stgxfws 1226 udp STGXFWS Tetsuya Shioda Tetsuya Shioda
dns2go 1227 tcp DNS2Go Deerfield Communications Inc. Mike Courterier 2015-07-15
dns2go 1227 udp DNS2Go Deerfield Communications Inc. Mike Courterier 2015-07-15
florence 1228 tcp FLORENCE Brian Trammell Brian Trammell
florence 1228 udp FLORENCE Brian Trammell Brian Trammell
zented 1229 tcp ZENworks Tiered Electronic Distribution Ty Ellis Ty Ellis
zented 1229 udp ZENworks Tiered Electronic Distribution Ty Ellis Ty Ellis
caupc-remote 2122 tcp CauPC Remote Control Environics Oy Environics Oy
caupc-remote 2122 udp CauPC Remote Control Environics Oy Environics Oy
vtr-emulator 3122 tcp MTI VTR Emulator port John Mertus John Mertus
vtr-emulator 3122 udp MTI VTR Emulator port John Mertus John Mertus
fprams 4122 tcp Fiber Patrol Alarm Service Zhizhong Zhuang Zhizhong Zhuang 2006-12
fprams 4122 udp Fiber Patrol Alarm Service Zhizhong Zhuang Zhizhong Zhuang 2006-12
dtn-bundle 4556 udp DTN Bundle UDP CL Protocol 2006-11 2014-02-21 RFC 7122
dtn-bundle 4556 dccp DTN Bundle DCCP CL Protocol 2013-11-12 2014-02-21 RFC 7122 1685351985
bex-webadmin 6122 tcp Backup Express Web Server Catalogic Software, Inc. Chi Shih Chang 2008-03-19 2015-02-04
bex-webadmin 6122 udp Backup Express Web Server Catalogic Software, Inc. Chi Shih Chang 2008-03-19 2015-02-04
7122 Unassigned
apollo-admin 8122 tcp Apollo Admin Port Anthony Carrabino Anthony Carrabino 2003-08
apollo-admin 8122 udp Apollo Admin Port Anthony Carrabino Anthony Carrabino 2003-08
grcmp 9122 tcp Global Relay compliant mobile instant messaging protocol Global Relay Communications Inc Lu Vo 2012-11-28 2025-06-12
9122 udp Reserved
12122-12167 Unassigned
12173-12299 Unassigned
21214-21220 Unassigned
aigairserver 21221 tcp Services for Air Server AIG S.L. Edelmiro_Gonzalez_Martinez 2017-03-16
21221 udp Reserved
21222-21336 Unassigned
33061-33122 Unassigned
41122-41229 Unassigned
43442-44122 Unassigned

Contact Information

Name Organization Contact URI Last Updated
AIG S.L. pitin&aigclassic.com 2017-03-16
Anthony Carrabino anthonyc&vistasoftware.com 2003-08
Brian Trammell btrammell&iventurelab.com
Catalogic Software, Inc. cchang&catalogicsoftware.com 2015-02-04
Chi Shih Chang Catalogic Software, Inc. cchang&catalogicsoftware.com 2015-02-04
Chris LeCroy lecroy&apple.com
David Dunetz david&sweetware.com
Deerfield Communications Inc. mikec&deerfield.net 2015-07-15
Desmond Chan deschan&prismedia.com
Edelmiro_Gonzalez_Martinez AIG S.L. pitin&aigclassic.com 2017-03-16
Environics Oy pasi.nuutinmaki&environics.fi
Global Relay Communications Inc info&globalrelay.net 2025-06-12
Gur Kimchi gkimchi&microsoft.com 2008-05-20
John Mertus mertus&mathtech.com
Lu Vo Global Relay Communications Inc lu.vo&globalrelay.net 2025-06-12
Martin Freiss freiss.pad&sni.de
Mike Courterier Deerfield Communications Inc. mikec&deerfield.net 2015-07-15
Pierre Arnaud pierre.arnaud&iname.com
Steven Pelletier stevep&availant.com
Tetsuya Shioda tetsuya&saint.nm.fujitsu.co.jp
Tom Strack TSTRACK&advnw.com
Ty Ellis tellis&novell.com 2006-05
Zhizhong Zhuang ZZhuang&optellios.com 2006-12