Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| bgp | 179 | tcp | Border Gateway Protocol | Kirk Lougheed | Kirk Lougheed | ||||||
| bgp | 179 | udp | Border Gateway Protocol | Kirk Lougheed | Kirk Lougheed | ||||||
| bgp | 179 | sctp | BGP | Randall Stewart | Randall Stewart | 2022-02-07 | RFC 9260 | ||||
| b2n | 1179 | tcp | Backup To Neighbor | Thomas Fok | Thomas Fok | 2004-11 | |||||
| b2n | 1179 | udp | Backup To Neighbor | Thomas Fok | Thomas Fok | 2004-11 | |||||
| nmsp | 1790 | tcp | Narrative Media Streaming Protocol | Paul Santinelli Jr. | Paul Santinelli Jr. | ||||||
| nmsp | 1790 | udp | Narrative Media Streaming Protocol | Paul Santinelli Jr. | Paul Santinelli Jr. | ||||||
| ea1 | 1791 | tcp | EA1 | Kirk MacLean | Kirk MacLean | ||||||
| ea1 | 1791 | udp | EA1 | Kirk MacLean | Kirk MacLean | ||||||
| ibm-dt-2 | 1792 | tcp | ibm-dt-2 | Sam Borman | Sam Borman | ||||||
| ibm-dt-2 | 1792 | udp | ibm-dt-2 | Sam Borman | Sam Borman | ||||||
| rsc-robot | 1793 | tcp | rsc-robot | Andrew Jay Schneider | Andrew Jay Schneider | ||||||
| rsc-robot | 1793 | udp | rsc-robot | Andrew Jay Schneider | Andrew Jay Schneider | ||||||
| cera-bcm | 1794 | tcp | cera-bcm | Leo Moesgaard | Leo Moesgaard | ||||||
| cera-bcm | 1794 | udp | cera-bcm | Leo Moesgaard | Leo Moesgaard | ||||||
| dpi-proxy | 1795 | tcp | dpi-proxy | Charles Gordon | Charles Gordon | ||||||
| dpi-proxy | 1795 | udp | dpi-proxy | Charles Gordon | Charles Gordon | ||||||
| vocaltec-admin | 1796 | tcp | Vocaltec Server Administration | Scott Petrack | Scott Petrack | ||||||
| vocaltec-admin | 1796 | udp | Vocaltec Server Administration | Scott Petrack | Scott Petrack | ||||||
| uma | 1797 | tcp | UMA | Martin Kirk | Martin Kirk | ||||||
| uma | 1797 | udp | UMA | Martin Kirk | Martin Kirk | ||||||
| etp | 1798 | tcp | Event Transfer Protocol | Mike Wray | Mike Wray | ||||||
| etp | 1798 | udp | Event Transfer Protocol | Mike Wray | Mike Wray | ||||||
| netrisk | 1799 | tcp | NETRISK | Kevin Green | Kevin Green | ||||||
| netrisk | 1799 | udp | NETRISK | Kevin Green | Kevin Green | ||||||
| vmrdp | 2179 | tcp | Microsoft RDP for virtual machines | Brian Henry | Brian Henry | 2007-03 | |||||
| vmrdp | 2179 | udp | Microsoft RDP for virtual machines | Brian Henry | Brian Henry | 2007-03 | |||||
| h2gf-w-2m | 3179 | tcp | H2GF W.2m Handover prot. | Arne Norefors | Arne Norefors | ||||||
| h2gf-w-2m | 3179 | udp | H2GF W.2m Handover prot. | Arne Norefors | Arne Norefors | ||||||
| MaxumSP | 4179 | tcp | Maxum Services | Greg Stine | Greg Stine | 2007-07-05 | |||||
| MaxumSP | 4179 | udp | Maxum Services | Greg Stine | Greg Stine | 2007-07-05 | |||||
| 11752-11795 | Unassigned | ||||||||||
| lanschool | 11796 | tcp | LanSchool | Stoneware Inc. | Dana Doggett | 2012-05-18 | |||||
| lanschool-mpt | 11796 | udp | Lanschool Multipoint | Stoneware Inc. | Dana Doggett | 2012-05-18 | |||||
| 11797-11875 | Unassigned | ||||||||||
| 17778-17999 | Unassigned | ||||||||||
| 21591-21799 | Unassigned | ||||||||||
| 41231-41793 | Unassigned | ||||||||||
| crestron-cip | 41794 | tcp | Crestron Control Port | Crestron Electronics, Inc. | John Pavlik | 2003-01 | 2019-10-17 | ||||
| crestron-cip | 41794 | udp | Crestron Control Port | Crestron Electronics, Inc. | John Pavlik | 2003-01 | 2019-10-17 | ||||
| crestron-ctp | 41795 | tcp | Crestron Terminal Port | Crestron Electronics, Inc. | John Pavlik | 2003-01 | 2019-10-17 | ||||
| crestron-ctp | 41795 | udp | Crestron Terminal Port | Crestron Electronics, Inc. | John Pavlik | 2003-01 | 2019-10-17 | ||||
| crestron-cips | 41796 | tcp | Crestron Secure Control Port | Crestron Electronics, Inc. | John Pavlik | 2012-06-27 | 2019-10-17 | ||||
| 41796 | udp | Reserved | |||||||||
| crestron-ctps | 41797 | tcp | Crestron Secure Terminal Port | Crestron Electronics, Inc. | John Pavlik | 2012-06-27 | 2019-10-17 | ||||
| 41797 | udp | Reserved | |||||||||
| 41798-42507 | Unassigned | Unauthorized Use Known on port 42000 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Andrew Jay Schneider | ajs&relsoft.com | ||
| Arne Norefors | Arne.Norefors&ericsson.com | ||
| Brian Henry | brian.henryµsoft.com | 2007-03 | |
| Charles Gordon | cgordon&digprod.com | ||
| Crestron Electronics, Inc. | jpavlik&crestron.com | 2019-10-17 | |
| Dana Doggett | Stoneware Inc. | dana.doggett&stone-ware.com | 2012-05-18 |
| Greg Stine | greg.stine&siemens.com | 2007-07-05 | |
| John Pavlik | jpavlik&crestron.com | 2019-10-17 | |
| Kevin Green | Kevin_Green&tds.com | ||
| Kirk Lougheed | LOUGHEED&mathom.cisco.com | ||
| Kirk MacLean | kmaclean&ea.com | ||
| Leo Moesgaard | leo_moesgaard&dk.ibm.com | ||
| Martin Kirk | m.kirk&opengroup.org | ||
| Mike Wray | mjw&hplb.hpl.hp.com | ||
| Paul Santinelli Jr. | psantinelli&narrative.com | ||
| Randall Stewart | IETF TSVWG | rrs&lakerest.net | |
| Sam Borman | sam_borman&uk.ibm.com | ||
| Scott Petrack | Scott_Petrack&vocaltec.com | ||
| Stoneware Inc. | coby.gurr&stone-ware.com | 2012-05-18 | |
| Thomas Fok | thomas&melody-soft.com | 2004-11 |