Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| ocserver | 184 | tcp | OCServer | Jerrilynn Okamura | Jerrilynn Okamura | ||||||
| ocserver | 184 | udp | OCServer | Jerrilynn Okamura | Jerrilynn Okamura | ||||||
| llsurfup-https | 1184 | tcp | LL Surfup HTTPS | Katy Lynn McCullough | Katy Lynn McCullough | ||||||
| llsurfup-https | 1184 | udp | LL Surfup HTTPS | Katy Lynn McCullough | Katy Lynn McCullough | ||||||
| netopia-vo2 | 1840 | tcp | netopia-vo2 | ||||||||
| netopia-vo2 | 1840 | udp | netopia-vo2 | ||||||||
| netopia-vo3 | 1841 | tcp | netopia-vo3 | ||||||||
| netopia-vo3 | 1841 | udp | netopia-vo3 | ||||||||
| netopia-vo4 | 1842 | tcp | netopia-vo4 | ||||||||
| netopia-vo4 | 1842 | udp | netopia-vo4 | ||||||||
| netopia-vo5 | 1843 | tcp | netopia-vo5 | Marc Epard | Marc Epard | ||||||
| netopia-vo5 | 1843 | udp | netopia-vo5 | Marc Epard | Marc Epard | ||||||
| direcpc-dll | 1844 | tcp | DirecPC-DLL | Chris Kerrigan | Chris Kerrigan | ||||||
| direcpc-dll | 1844 | udp | DirecPC-DLL | Chris Kerrigan | Chris Kerrigan | ||||||
| altalink | 1845 | tcp | altalink | Alberto Raydan | Alberto Raydan | ||||||
| altalink | 1845 | udp | altalink | Alberto Raydan | Alberto Raydan | ||||||
| tunstall-pnc | 1846 | tcp | Tunstall PNC | Robert M. Moore | Robert M. Moore | ||||||
| tunstall-pnc | 1846 | udp | Tunstall PNC | Robert M. Moore | Robert M. Moore | ||||||
| slp-notify | 1847 | tcp | SLP Notification | RFC 3082 | |||||||
| slp-notify | 1847 | udp | SLP Notification | RFC 3082 | |||||||
| fjdocdist | 1848 | tcp | fjdocdist | Yuichi Ohiwa | Yuichi Ohiwa | ||||||
| fjdocdist | 1848 | udp | fjdocdist | Yuichi Ohiwa | Yuichi Ohiwa | ||||||
| alpha-sms | 1849 | tcp | ALPHA-SMS | Benjamin Grimm | Benjamin Grimm | ||||||
| alpha-sms | 1849 | udp | ALPHA-SMS | Benjamin Grimm | Benjamin Grimm | ||||||
| nvd | 2184 | tcp | NVD User | Yves Gattegno | Yves Gattegno | 2004-12 | |||||
| nvd | 2184 | udp | NVD User | Yves Gattegno | Yves Gattegno | 2004-12 | |||||
| apogeex-port | 3184 | tcp | ApogeeX Port | Tom Nys | Tom Nys | ||||||
| apogeex-port | 3184 | udp | ApogeeX Port | Tom Nys | Tom Nys | ||||||
| universe-suite | 4184 | tcp | UNIVERSE SUITE MESSAGE SERVICE IANA assigned this well-formed service name as a replacement for "universe_suite". |
Gary ANDREWS | Gary ANDREWS | 2008-01-07 | |||||
| universe_suite | 4184 | tcp | UNIVERSE SUITE MESSAGE SERVICE | Gary ANDREWS | Gary ANDREWS | 2008-01-07 | This entry is an alias to "universe-suite". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| universe-suite | 4184 | udp | UNIVERSE SUITE MESSAGE SERVICE IANA assigned this well-formed service name as a replacement for "universe_suite". |
Gary ANDREWS | Gary ANDREWS | 2008-01-07 | |||||
| universe_suite | 4184 | udp | UNIVERSE SUITE MESSAGE SERVICE | Gary ANDREWS | Gary ANDREWS | 2008-01-07 | This entry is an alias to "universe-suite". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| itach | 8184 | tcp | Remote iTach Connection | Barend Jacobus van der Merwe | Barend Jacobus van der Merwe | 2010-04-27 | |||||
| itach | 8184 | udp | Remote iTach Connection | Barend Jacobus van der Merwe | Barend Jacobus van der Merwe | 2010-04-27 | |||||
| 9184-9190 | Unassigned | ||||||||||
| vestasdlp | 17184 | tcp | Vestas Data Layer Protocol | Vestas Wind Systems | Teunis de Wit | 2013-10-30 | |||||
| 17184 | udp | Reserved | |||||||||
| opsec-lea | 18184 | tcp | OPSEC LEA | Alon Kantor | Alon Kantor | ||||||
| opsec-lea | 18184 | udp | OPSEC LEA | Alon Kantor | Alon Kantor | ||||||
| 18263-18462 | Unassigned | ||||||||||
| ac-cluster | 18463 | tcp | AC Cluster | Lisa Zhong | Lisa Zhong | ||||||
| ac-cluster | 18463 | udp | AC Cluster | Lisa Zhong | Lisa Zhong | ||||||
| 18464-18515 | Unassigned | ||||||||||
| 21802-21844 | Unassigned | ||||||||||
| webphone | 21845 | tcp | webphone | Toby Hosterman | Toby Hosterman | ||||||
| webphone | 21845 | udp | webphone | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-is | 21846 | tcp | NetSpeak Corp. Directory Services | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-is | 21846 | udp | NetSpeak Corp. Directory Services | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-cs | 21847 | tcp | NetSpeak Corp. Connection Services | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-cs | 21847 | udp | NetSpeak Corp. Connection Services | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-acd | 21848 | tcp | NetSpeak Corp. Automatic Call Distribution | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-acd | 21848 | udp | NetSpeak Corp. Automatic Call Distribution | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-cps | 21849 | tcp | NetSpeak Corp. Credit Processing System | Toby Hosterman | Toby Hosterman | ||||||
| netspeak-cps | 21849 | udp | NetSpeak Corp. Credit Processing System | Toby Hosterman | Toby Hosterman | ||||||
| 45055-45184 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alberto Raydan | alberto&altasol.com | ||
| Alon Kantor | alonk&checkpoint.com | ||
| Barend Jacobus van der Merwe | berneau.v&gmail.com | 2010-04-27 | |
| Benjamin Grimm | bg&webnetix.de | ||
| Chris Kerrigan | ckerrigan&hns.com | ||
| Gary ANDREWS | gan&orsyp.com | 2008-01-07 | |
| Jerrilynn Okamura | |||
| Katy Lynn McCullough | KatyM&laplink.com | ||
| Lisa Zhong | lzhong&cup.hp.com | ||
| Marc Epard | marc&netopia.com | ||
| Robert M. Moore | robert.moore&tunstall.co.uk | ||
| Teunis de Wit | Vestas Wind Systems | tdwi&vestas.com | 2013-10-30 |
| Toby Hosterman | root&netspeak.com | ||
| Tom Nys | tom.nys.tn&belgium.agfa.com | ||
| Vestas Wind Systems | tdwi&vestas.com | 2013-10-30 | |
| Yuichi Ohiwa | y-ohiwa&ael.fujitsu.co.jp | ||
| Yves Gattegno | iana&qualystem.org | 2004-12 |