Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| dn6-nlm-aud | 195 | tcp | DNSIX Network Level Module Audit | ||||||||
| dn6-nlm-aud | 195 | udp | DNSIX Network Level Module Audit | ||||||||
| syslog-conn | 601 | tcp | Reliable Syslog Service | RFC 3195 | |||||||
| syslog-conn | 601 | udp | Reliable Syslog Service | RFC 3195 | |||||||
| rsf-1 | 1195 | tcp | RSF-1 clustering | Dave Hines | Dave Hines | 2004-11 | |||||
| rsf-1 | 1195 | udp | RSF-1 clustering | Dave Hines | Dave Hines | 2004-11 | |||||
| ismaeasdaqtest | 1950 | tcp | ISMA Easdaq Test | Stephen Dunne | Stephen Dunne | ||||||
| ismaeasdaqtest | 1950 | udp | ISMA Easdaq Test | Stephen Dunne | Stephen Dunne | ||||||
| bcs-lmserver | 1951 | tcp | bcs-lmserver | Andy Warner | Andy Warner | ||||||
| bcs-lmserver | 1951 | udp | bcs-lmserver | Andy Warner | Andy Warner | ||||||
| mpnjsc | 1952 | tcp | mpnjsc | Takenori Miyahara | Takenori Miyahara | ||||||
| mpnjsc | 1952 | udp | mpnjsc | Takenori Miyahara | Takenori Miyahara | ||||||
| rapidbase | 1953 | tcp | Rapid Base | Antoni Wolski | Antoni Wolski | ||||||
| rapidbase | 1953 | udp | Rapid Base | Antoni Wolski | Antoni Wolski | ||||||
| abr-api | 1954 | tcp | ABR-API (diskbridge) | ||||||||
| abr-api | 1954 | udp | ABR-API (diskbridge) | ||||||||
| abr-secure | 1955 | tcp | ABR-Secure Data (diskbridge) | Graham Wooden | Graham Wooden | ||||||
| abr-secure | 1955 | udp | ABR-Secure Data (diskbridge) | Graham Wooden | Graham Wooden | ||||||
| vrtl-vmf-ds | 1956 | tcp | Vertel VMF DS | Alan Akahoshi | Alan Akahoshi | ||||||
| vrtl-vmf-ds | 1956 | udp | Vertel VMF DS | Alan Akahoshi | Alan Akahoshi | ||||||
| unix-status | 1957 | tcp | unix-status | Thomas Erskine | Thomas Erskine | ||||||
| unix-status | 1957 | udp | unix-status | Thomas Erskine | Thomas Erskine | ||||||
| dxadmind | 1958 | tcp | CA Administration Daemon | John Birrell | John Birrell | ||||||
| dxadmind | 1958 | udp | CA Administration Daemon | John Birrell | John Birrell | ||||||
| simp-all | 1959 | tcp | SIMP Channel | Tim Hunnewell | Tim Hunnewell | ||||||
| simp-all | 1959 | udp | SIMP Channel | Tim Hunnewell | Tim Hunnewell | ||||||
| ncu-1 | 3195 | tcp | Network Control Unit | ||||||||
| ncu-1 | 3195 | udp | Network Control Unit | ||||||||
| aws-wsp | 4195 | tcp | AWS protocol for cloud remoting solution | Amazon.com Services LLC | Lauren Townsend | 2020-04-06 | |||||
| aws-wsp | 4195 | udp | AWS protocol for cloud remoting solution | Amazon.com Services LLC | Lauren Townsend | 2020-04-06 | |||||
| aws-wsp | 4195 | sctp | AWS protocol for cloud remoting solution | Amazon.com Services LLC | Lauren Townsend | 2020-04-06 | |||||
| aws-wsp | 4195 | dccp | AWS protocol for cloud remoting solution | Amazon.com Services LLC | Lauren Townsend | 2020-04-06 | |||||
| ampl-lic | 5195 | tcp | The protocol is used by a license server and client programs to control use of program licenses that float to networked machines | AMPL Optimization, Inc. | David M. Gay | 2012-05-25 | |||||
| 5195 | udp | Reserved | |||||||||
| blp2 | 8195 | tcp | Bloomberg feed | Albert Hou | Albert Hou | 2006-05 | |||||
| blp2 | 8195 | udp | Bloomberg feed | Albert Hou | Albert Hou | 2006-05 | |||||
| 19195-19219 | Unassigned | ||||||||||
| 19413-19538 | Unassigned | ||||||||||
| fxuptp | 19539 | tcp | FXUPTP | Keiji Okuma | Keiji Okuma | 2005-08 | |||||
| fxuptp | 19539 | udp | FXUPTP | Keiji Okuma | Keiji Okuma | 2005-08 | |||||
| sxuptp | 19540 | tcp | SXUPTP | Keiji Okuma | Keiji Okuma | 2002-08 | |||||
| sxuptp | 19540 | udp | SXUPTP | Keiji Okuma | Keiji Okuma | 2002-08 | |||||
| jcp | 19541 | tcp | JCP Client | Yuji Sasaki | Yuji Sasaki | ||||||
| jcp | 19541 | udp | JCP Client | Yuji Sasaki | Yuji Sasaki | ||||||
| 19542-19787 | Unassigned | ||||||||||
| 31950-32033 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alan Akahoshi | alan-akahoshi&vertel.com | ||
| Albert Hou | ahou1&bloomberg.com | 2006-05 | |
| Amazon.com Services LLC | aws-iana&amazon.com | 2022-11-07 | |
| AMPL Optimization, Inc. | dmg&l.com | 2012-05-25 | |
| Andy Warner | andyw&knoware.nl | ||
| Antoni Wolski | antoni.wolski&vtt.fi | ||
| Dave Hines | d.hines&high-availability.com | 2004-11 | |
| David M. Gay | AMPL Optimization, Inc. | dmg&l.com | 2012-05-25 |
| Graham Wooden | graham&g-rock.net | ||
| John Birrell | birjo99&cai.com | ||
| Keiji Okuma | okuma&silex.jp | 2005-08 | |
| Lauren Townsend | Amazon.com Services LLC | townslau&amazon.com | 2020-04-06 |
| Stephen Dunne | sdun&isma.co.uk | ||
| Takenori Miyahara | miyahara&pfu.co.jp | ||
| Thomas Erskine | erskine&sourceworks.com | ||
| Tim Hunnewell | thunnewell&pinna.com | ||
| Yuji Sasaki | sasaki&silex.jp |