Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
subntbcst-tftp 247 tcp SUBNTBCST_TFTP

IANA assigned this well-formed service name as a replacement for "subntbcst_tftp".
John Fake John Fake
subntbcst_tftp 247 tcp SUBNTBCST_TFTP John Fake John Fake This entry is an alias to "subntbcst-tftp". This entry is now historic, not usable for use with many common service discovery mechanisms.
subntbcst-tftp 247 udp SUBNTBCST_TFTP

IANA assigned this well-formed service name as a replacement for "subntbcst_tftp".
John Fake John Fake
subntbcst_tftp 247 udp SUBNTBCST_TFTP John Fake John Fake This entry is an alias to "subntbcst-tftp". This entry is now historic, not usable for use with many common service discovery mechanisms.
visionpyramid 1247 tcp VisionPyramid Gavin Hutchinson Gavin Hutchinson
visionpyramid 1247 udp VisionPyramid Gavin Hutchinson Gavin Hutchinson
antidotemgrsvr 2247 tcp Antidote Deployment Manager Service Rod Waltermann Rod Waltermann 2006-02
antidotemgrsvr 2247 udp Antidote Deployment Manager Service Rod Waltermann Rod Waltermann 2006-02
taskman-port 2470 tcp taskman port Boris Panteleev Boris Panteleev
taskman-port 2470 udp taskman port Boris Panteleev Boris Panteleev
seaodbc 2471 tcp SeaODBC Adrian Hornby Adrian Hornby
seaodbc 2471 udp SeaODBC Adrian Hornby Adrian Hornby
c3 2472 tcp C3 Eckhard Grieger Eckhard Grieger
c3 2472 udp C3 Eckhard Grieger Eckhard Grieger
aker-cdp 2473 tcp Aker-cdp Rodrigo Ormonde Rodrigo Ormonde
aker-cdp 2473 udp Aker-cdp Rodrigo Ormonde Rodrigo Ormonde
vitalanalysis 2474 tcp Vital Analysis Srinivas Reddy Srinivas Reddy
vitalanalysis 2474 udp Vital Analysis Srinivas Reddy Srinivas Reddy
ace-server 2475 tcp ACE Server
ace-server 2475 udp ACE Server
ace-svr-prop 2476 tcp ACE Server Propagation
ace-svr-prop 2476 udp ACE Server Propagation
ssm-cvs 2477 tcp SecurSight Certificate Valifation Service
ssm-cvs 2477 udp SecurSight Certificate Valifation Service
ssm-cssps 2478 tcp SecurSight Authentication Server (SSL)
ssm-cssps 2478 udp SecurSight Authentication Server (SSL)
ssm-els 2479 tcp SecurSight Event Logging Server (SSL) John Linn John Linn
ssm-els 2479 udp SecurSight Event Logging Server (SSL) John Linn John Linn
dvt-data 3247 tcp DVT DATA LINK Phillip Heil Phillip Heil 2002-02
dvt-data 3247 udp DVT DATA LINK Phillip Heil Phillip Heil 2002-02
5247 tcp Reserved
capwap-data 5247 udp CAPWAP Data Protocol RFC 5415
24681-24726 Unassigned
24727 Unassigned Unauthorized Use Known on port 24727
24728-24753 Unassigned
cslg 24754 tcp Citrix StorageLink Gateway Mark Nijmeijer Mark Nijmeijer 2009-04-17
24754 udp Reserved
24755-24849 Unassigned

Contact Information

Name Contact URI Last Updated
Adrian Hornby Adrian.Hornby&aran.co.uk
Boris Panteleev bpanteleev&himel.com
Eckhard Grieger e.grieger&com-on.de
Gavin Hutchinson gavinh&visionlogistics.com
John Fake fake&us.ibm.com
John Linn jlinn&securitydynamics.com
Mark Nijmeijer Mark.Nijmeijer&citrix.com 2009-04-17
Phillip Heil phil.heil&dvtsensors.com 2002-02
Rod Waltermann walterma&us.lenovo.com 2006-02
Rodrigo Ormonde ormonde&aker.com.br
Srinivas Reddy sreddy&vitalsigns.com