Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
nsw-fe 27 tcp NSW User System FE Robert Thomas Robert Thomas
nsw-fe 27 udp NSW User System FE Robert Thomas Robert Thomas
locus-con 127 tcp Locus PC-Interface Conn Server Eric Peterson Eric Peterson
locus-con 127 udp Locus PC-Interface Conn Server Eric Peterson Eric Peterson
dsp3270 246 tcp Display Systems Protocol Weldon J. Showalter Weldon J. Showalter
dsp3270 246 udp Display Systems Protocol Weldon J. Showalter Weldon J. Showalter
270 tcp Reserved
gist 270 udp Q-mode encapsulation for GIST messages RFC 5971
pt-tls 271 tcp IETF Network Endpoint Assessment (NEA) Posture Transport Protocol over TLS (PT-TLS) IESG IETF Chair 2012-07-31 RFC 6876
271 udp Reserved
272-279 Unassigned
svrloc 427 tcp Server Location Veizades Veizades
svrloc 427 udp Server Location Veizades Veizades
stx 527 tcp Stock IXChange Ferdi Ladeira Ferdi Ladeira 2022-01-25
stx 527 udp Stock IXChange Ferdi Ladeira Ferdi Ladeira 2022-01-25
soap-beep 605 tcp SOAP over BEEP RFC 4227
soap-beep 605 udp SOAP over BEEP RFC 4227
passgo-tivoli 627 tcp PassGo Tivoli John Rainford John Rainford
passgo-tivoli 627 udp PassGo Tivoli John Rainford John Rainford
811-827 Unassigned
exp1 1021 tcp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 udp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 sctp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 dccp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 tcp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 udp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 sctp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 dccp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
6a44 1027 udp IPv6 Behind NAT44 CPEs IESG IETF Chair 2012-08-02 RFC 6751
1027 tcp Reserved
kwdb-commn 1127 tcp KWDB Remote Communication Lal Samuel Varghese Lal Samuel Varghese 2005-08
kwdb-commn 1127 udp KWDB Remote Communication Lal Samuel Varghese Lal Samuel Varghese 2005-08
dns2go 1227 tcp DNS2Go Deerfield Communications Inc. Mike Courterier 2015-07-15
dns2go 1227 udp DNS2Go Deerfield Communications Inc. Mike Courterier 2015-07-15
opsmgr 1270 tcp Microsoft Operations Manager Ashvin Sanghvi Ashvin Sanghvi
opsmgr 1270 udp Microsoft Operations Manager Ashvin Sanghvi Ashvin Sanghvi
excw 1271 tcp eXcW Norm Freedman Norm Freedman
excw 1271 udp eXcW Norm Freedman Norm Freedman
cspmlockmgr 1272 tcp CSPMLockMgr Ibtsam Mahfouz Ibtsam Mahfouz
cspmlockmgr 1272 udp CSPMLockMgr Ibtsam Mahfouz Ibtsam Mahfouz
emc-gateway 1273 tcp EMC-Gateway Rene Fontaine Rene Fontaine
emc-gateway 1273 udp EMC-Gateway Rene Fontaine Rene Fontaine
t1distproc 1274 tcp t1distproc Julian Biddle Julian Biddle
t1distproc 1274 udp t1distproc Julian Biddle Julian Biddle
ivcollector 1275 tcp ivcollector
ivcollector 1275 udp ivcollector
1276 tcp Reserved 2014-05-23 This entry has been removed on 2014-05-23.
1276 udp Reserved 2014-05-23 This entry has been removed on 2014-05-23.
miva-mqs 1277 tcp mqs Miva Corporation Miva Corporation
miva-mqs 1277 udp mqs Miva Corporation Miva Corporation
dellwebadmin-1 1278 tcp Dell Web Admin 1 Bridget Navoda Bridget Navoda
dellwebadmin-1 1278 udp Dell Web Admin 1 Bridget Navoda Bridget Navoda
dellwebadmin-2 1279 tcp Dell Web Admin 2 Bridget Navoda Bridget Navoda
dellwebadmin-2 1279 udp Dell Web Admin 2 Bridget Navoda Bridget Navoda
ultrex 1327 tcp Ultrex Tim Walsh Tim Walsh
ultrex 1327 udp Ultrex Tim Walsh Tim Walsh
mloadd 1427 tcp mloadd monitoring tool Bob Braden Bob Braden
mloadd 1427 udp mloadd monitoring tool Bob Braden Bob Braden
tlisrv 1527 tcp oracle
tlisrv 1527 udp oracle
t128-gateway 1627 tcp T.128 Gateway Phil May Phil May
t128-gateway 1627 udp T.128 Gateway Phil May Phil May
winddx 1727 tcp winddx Bill Andrews Bill Andrews
winddx 1727 udp winddx Bill Andrews Bill Andrews
asi 1827 tcp ASI Bob Tournoux Bob Tournoux
asi 1827 udp ASI Bob Tournoux Bob Tournoux
videte-cipc 1927 tcp Videte CIPC Port Videte IT Videte IT
videte-cipc 1927 udp Videte CIPC Port Videte IT Videte IT
shadowserver 2027 tcp
shadowserver 2027 udp
index-pc-wb 2127 tcp INDEX-PC-WB James David Fisher James David Fisher
index-pc-wb 2127 udp INDEX-PC-WB James David Fisher James David Fisher
di-msg 2227 tcp DI Messaging Service Sean Ni Sean Ni 2006-02
di-msg 2227 udp DI Messaging Service Sean Ni Sean Ni 2006-02
starschool 2270 tcp starSchool Adam Ernst Adam Ernst 2004-12
starschool 2270 udp starSchool Adam Ernst Adam Ernst 2004-12
mmcals 2271 tcp Secure Meeting Maker Scheduling
mmcals 2271 udp Secure Meeting Maker Scheduling
mmcal 2272 tcp Meeting Maker Scheduling Andrew H Derbyshire Andrew H Derbyshire 2004-12
mmcal 2272 udp Meeting Maker Scheduling Andrew H Derbyshire Andrew H Derbyshire 2004-12
mysql-im 2273 tcp MySQL Instance Manager Petr Chardin Petr Chardin 2004-12
mysql-im 2273 udp MySQL Instance Manager Petr Chardin Petr Chardin 2004-12
pcttunnell 2274 tcp PCTTunneller ProControl Technology AB ProControl Technology AB 2004-12
pcttunnell 2274 udp PCTTunneller ProControl Technology AB ProControl Technology AB 2004-12
ibridge-data 2275 tcp iBridge Conferencing
ibridge-data 2275 udp iBridge Conferencing
ibridge-mgmt 2276 tcp iBridge Management Patrick Fisher Patrick Fisher 2004-12
ibridge-mgmt 2276 udp iBridge Management Patrick Fisher Patrick Fisher 2004-12
bluectrlproxy 2277 tcp Bt device control proxy Mark de Rooi Mark de Rooi 2004-12
bluectrlproxy 2277 udp Bt device control proxy Mark de Rooi Mark de Rooi 2004-12
s3db 2278 tcp Simple Stacked Sequences Database David Brandon David Brandon 2006-08
s3db 2278 udp Simple Stacked Sequences Database David Brandon David Brandon 2006-08
xmquery 2279 tcp xmquery Niels Christiansen Niels Christiansen
xmquery 2279 udp xmquery Niels Christiansen Niels Christiansen
ansysli 2325 tcp ANSYS Licensing Interconnect Suzanne Lorrin Suzanne Lorrin Modified: 27 October 2008
ansysli 2325 udp ANSYS Licensing Interconnect Suzanne Lorrin Suzanne Lorrin Modified: 27 October 2008
xingcsm 2327 tcp xingcsm Dave Spencer Dave Spencer
xingcsm 2327 udp xingcsm Dave Spencer Dave Spencer
mgcp-gateway 2427 tcp Media Gateway Control Protocol Gateway Christian Huitema Christian Huitema
mgcp-gateway 2427 udp Media Gateway Control Protocol Gateway Christian Huitema Christian Huitema

Contact Information

Name Organization Contact URI Last Updated
Adam Ernst cosmicsoft&cosmicsoft.net 2004-12
Andrew H Derbyshire ahd&meetingmaker.plus.kew.com 2004-12
Ashvin Sanghvi AshvinS&microsoft.com
Bill Andrews billa&vnd.tek.com
Bob Braden braden&isi.edu
Bob Tournoux bob.tournoux&usiny.mail.abb.com
Bridget Navoda Bridget_Navoda&dell.com
Christian Huitema huitema&research.telcordia.com
Dave Spencer dspencer&xingtech.com
David Brandon dade&smoolabs.net 2006-08
Deerfield Communications Inc. mikec&deerfield.net 2015-07-15
Eric Peterson lcc.eric&seas.ucla.edu
Ferdi Ladeira f.lad.mail&gmail.com 2022-01-25
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ibtsam Mahfouz imahfouz&cisco.com
James David Fisher jfisher1&avaya.com
John Rainford john.rainford&passgo.com
Julian Biddle julian_biddle&technologyonecorp.com
Lal Samuel Varghese lalsam&hp.com 2005-08
Mark de Rooi derooi&xs4all.nl 2004-12
Mike Courterier Deerfield Communications Inc. mikec&deerfield.net 2015-07-15
Miva Corporation jwoods&miva.com.au
Niels Christiansen nchris&austin.ibm.com
Norm Freedman normfree&san.rr.com 2003-08
Patrick Fisher pfisher&hns.com 2004-12
Petr Chardin petr&mysql.com 2004-12
Phil May pm&datcon.co.uk
ProControl Technology AB info&pctworld.com 2004-12
Rene Fontaine fontaine_rene&emc.com
Robert Thomas BThomas&f.bbn.com
Sean Ni seanni&digitalinstinct.com.tw 2006-02
Suzanne Lorrin suzanne.lorrin&ansys.com
Tim Walsh tim&ultrex.com
veizades&ftp.com
Videte IT info&videte.com
Weldon J. Showalter Gamma&mintaka.dca.mil