Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
bhmds 310 tcp bhmds John Kelly John Kelly
bhmds 310 udp bhmds John Kelly John Kelly
husky 1310 tcp Husky Mark Zang Mark Zang
husky 1310 udp Husky Mark Zang Mark Zang
sdclient 2310 tcp SD Client Jeurgen Broesamle Jeurgen Broesamle
sdclient 2310 udp SD Client Jeurgen Broesamle Jeurgen Broesamle
opcon-xps 3100 tcp OpCon/xps David Bourland David Bourland
opcon-xps 3100 udp OpCon/xps David Bourland David Bourland
hp-pxpib 3101 tcp HP PolicyXpert PIB Server Brian O'Keefe Brian O'Keefe
hp-pxpib 3101 udp HP PolicyXpert PIB Server Brian O'Keefe Brian O'Keefe
slslavemon 3102 tcp SoftlinK Slave Mon Port Moshe Livne Moshe Livne
slslavemon 3102 udp SoftlinK Slave Mon Port Moshe Livne Moshe Livne
autocuesmi 3103 tcp Autocue SMI Protocol
autocuesmi 3103 udp Autocue SMI Protocol
autocuelog 3104 tcp Autocue Logger Protocol
autocuetime 3104 udp Autocue Time Service Geoff Back Geoff Back
cardbox 3105 tcp Cardbox
cardbox 3105 udp Cardbox
cardbox-http 3106 tcp Cardbox HTTP Martin Kochanski Martin Kochanski
cardbox-http 3106 udp Cardbox HTTP Martin Kochanski Martin Kochanski
business 3107 tcp Business protocol
business 3107 udp Business protocol
geolocate 3108 tcp Geolocate protocol
geolocate 3108 udp Geolocate protocol
personnel 3109 tcp Personnel protocol William Randolph Royere III William Randolph Royere III
personnel 3109 udp Personnel protocol William Randolph Royere III William Randolph Royere III
dyna-access 3310 tcp Dyna Access Dave Belliveau Dave Belliveau
dyna-access 3310 udp Dyna Access Dave Belliveau Dave Belliveau
mirrtex 4310 tcp Mir-RT exchange service Sylvain Robert Sylvain Robert 2008-02-14
mirrtex 4310 udp Mir-RT exchange service Sylvain Robert Sylvain Robert 2008-02-14
rsip 4555 tcp RSIP Port RFC 3103
rsip 4555 udp RSIP Port RFC 3103
outlaws 5310 tcp Outlaws Richard Fife Richard Fife
outlaws 5310 udp Outlaws Richard Fife Richard Fife
sapms 9310 tcp SAP Message Server SAP SE Stefan Hagen 2020-03-12
9310 udp Reserved
pduncs 16310 tcp Policy Distribute, Update Notification Diane I. Shannon Diane I. Shannon 2006-08
pduncs 16310 udp Policy Distribute, Update Notification Diane I. Shannon Diane I. Shannon 2006-08
31000-31015 Unassigned
ka-sddp 31016 tcp Kollective Agent Secure Distributed Delivery Protocol Kollective Technology Inc. John Wainwright 2016-12-11
ka-kdp 31016 udp Kollective Agent Kollective Delivery Protocol Kollective Technology Inc. John Wainwright 2016-12-11
31017-31019 Unassigned
autotrac-acp 31020 tcp Autotrac ACP 245 Roberto Jorge Dino Roberto Jorge Dino
31020 udp Reserved
31021-31028 Unassigned
31029 tcp Reserved
yawn 31029 udp YaWN - Yet Another Windows Notifier David Spivey David Spivey 2010-08-30
31030-31336 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Brian O'Keefe bokeefe&cnd.hp.com
Dave Belliveau DaveBelliveau&cornerstonesoftware.com
David Bourland DBourland&smausa.com
David Spivey DavidTSpivey&gmail.com 2010-08-30
Diane I. Shannon shannond&us.ibm.com 2007-04
Geoff Back geoff&autocue.co.uk 2002-03
Jeurgen Broesamle juergb&bbn.hp.com
John Kelly johnk&bellhow.com
John Wainwright jwainwright&kollective.com 2016-12-11
Kollective Technology Inc. info&kollective.com 2016-12-11
Mark Zang mark&zang.com
Martin Kochanski martin&cardbox.co.uk
Moshe Livne moshe&softlinkusa.com
Richard Fife richardf&lucasarts.com
Roberto Jorge Dino roberto.dino&autotrac.com.br
SAP SE stefan.hagen&sap.com 2020-03-12
Stefan Hagen stefan.hagen&sap.com 2020-03-12
Sylvain Robert sylvain.robert&datadis.com 2008-02-14
William Randolph Royere III william&royere.net