Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| rpki-rtr | 323 | tcp | Resource PKI to Router Protocol | IESG | IETF Chair | RFC 6810 | |||||
| 323 | udp | Reserved | |||||||||
| h323hostcallsc | 1300 | tcp | H.323 Secure Call Control Signalling | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| h323hostcallsc | 1300 | udp | H.323 Secure Call Control Signalling | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| brcd | 1323 | tcp | brcd | Todd Picquelle | Todd Picquelle | ||||||
| brcd | 1323 | udp | brcd | Todd Picquelle | Todd Picquelle | ||||||
| h323gatedisc | 1718 | tcp | H.323 Multicast Gatekeeper Discover | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| h323gatedisc | 1718 | udp | H.323 Multicast Gatekeeper Discover | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| h323gatestat | 1719 | tcp | H.323 Unicast Gatekeeper Signaling | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| h323gatestat | 1719 | udp | H.323 Unicast Gatekeeper Signaling | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| h323hostcall | 1720 | tcp | H.323 Call Control Signalling | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| h323hostcall | 1720 | udp | H.323 Call Control Signalling | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| h323hostcall | 1720 | sctp | H.323 Call Control | ITU-T | 2014-07-30 | ||||||
| 3d-nfsd | 2323 | tcp | 3d-nfsd | Mike Sherrill | Mike Sherrill | ||||||
| 3d-nfsd | 2323 | udp | 3d-nfsd | Mike Sherrill | Mike Sherrill | ||||||
| call-sig-trans | 2517 | tcp | H.323 Annex E Call Control Signalling Transport | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| call-sig-trans | 2517 | udp | H.323 Annex E Call Control Signalling Transport | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| sftdst-port | 3230 | tcp | Software Distributor Port | Andrea Lanza | Andrea Lanza | 2014-02-21 | |||||
| sftdst-port | 3230 | udp | Software Distributor Port | Andrea Lanza | Andrea Lanza | 2014-02-21 | |||||
| vidigo | 3231 | tcp | VidiGo communication (previous was: Delta Solutions Direct) | Peter Ijkhout | Peter Ijkhout | ||||||
| vidigo | 3231 | udp | VidiGo communication (previous was: Delta Solutions Direct) | Peter Ijkhout | Peter Ijkhout | ||||||
| mdtp | 3232 | tcp | MDT port | 2012-02-21 | RFC 6513 | ||||||
| mdtp | 3232 | udp | MDT port | 2012-02-21 | RFC 6513 | ||||||
| whisker | 3233 | tcp | WhiskerControl main port | Rudolf Cardinal | Rudolf Cardinal | 2002-02 | |||||
| whisker | 3233 | udp | WhiskerControl main port | Rudolf Cardinal | Rudolf Cardinal | 2002-02 | |||||
| alchemy | 3234 | tcp | Alchemy Server | Mikhail Belov | Mikhail Belov | 2002-02 | |||||
| alchemy | 3234 | udp | Alchemy Server | Mikhail Belov | Mikhail Belov | 2002-02 | |||||
| mdap-port | 3235 | tcp | MDAP port | Johan Deleu | Johan Deleu | 2002-02 | |||||
| mdap-port | 3235 | udp | MDAP Port | Johan Deleu | Johan Deleu | 2002-02 | |||||
| apparenet-ts | 3236 | tcp | appareNet Test Server | ||||||||
| apparenet-ts | 3236 | udp | appareNet Test Server | ||||||||
| apparenet-tps | 3237 | tcp | appareNet Test Packet Sequencer | ||||||||
| apparenet-tps | 3237 | udp | appareNet Test Packet Sequencer | ||||||||
| apparenet-as | 3238 | tcp | appareNet Analysis Server | ||||||||
| apparenet-as | 3238 | udp | appareNet Analysis Server | ||||||||
| apparenet-ui | 3239 | tcp | appareNet User Interface | Fred Klassen | Fred Klassen | 2002-02 | |||||
| apparenet-ui | 3239 | udp | appareNet User Interface | Fred Klassen | Fred Klassen | 2002-02 | |||||
| trim-ice | 4323 | tcp | TRIM ICE Service | Siva Poobalasingam | Siva Poobalasingam | 2007-02 | |||||
| trim-ice | 4323 | udp | TRIM ICE Service | Siva Poobalasingam | Siva Poobalasingam | 2007-02 | |||||
| coap | 5683 | tcp | Constrained Application Protocol (CoAP) | IESG | IETF Chair | 2017-12-22 | RFC 8323 | ||||
| coaps | 5684 | tcp | Constrained Application Protocol (CoAP) | IESG | IETF Chair | 2017-12-22 | RFC 7301; RFC 8323 | ||||
| 6323 | Unassigned | ||||||||||
| 8323-8350 | Unassigned | ||||||||||
| h323callsigalt | 11720 | tcp | H.323 Call Control Signalling Alternate | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| h323callsigalt | 11720 | udp | H.323 Call Control Signalling Alternate | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| 12323-12344 | Unassigned | ||||||||||
| vrmg-ip | 24323 | tcp | Verimag mobile class protocol over TCP | Verimag, OOO | Denis Ionov | 2018-08-15 | |||||
| 24323 | udp | Reserved | |||||||||
| 32250-32399 | Unassigned | ||||||||||
| pmwebapi | 44323 | tcp | HTTP binding for Performance Co-Pilot client API | Performance Co-Pilot (PCP) Project | Ken McDonell | 2013-10-09 | |||||
| 44323 | udp | Unassigned | "pcp" assignment withdrawn, moved to port 5351 per RFC 6887 | ||||||||
| h323 | H.323 Real-time audio, video and data communication call setup protocol | Will MacDonald | Will MacDonald | Defined TXT keys: None |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Andrea Lanza | andrea&andrealanza.eu | 2014-02-21 | |
| Denis Ionov | Verimag, OOO | iddi&verimag.ru | 2018-07-20 |
| Fred Klassen | fklassen&jaalam.com | 2002-02 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| ITU-T | tsbsg16&itu.int | 2013-01-31 | |
| ITU-T TSB | ITU-T | tsbsg16&itu.int | 2013-01-31 |
| Johan Deleu | johan.deleu&alcatel.be | 2002-02 | |
| Ken McDonell | kenj&kenj.id.au | 2025-09-26 | |
| Mike Sherrill | sherrill&commvault.com | ||
| Mikhail Belov | mikhail&imrgold.com | 2002-02 | |
| Performance Co-Pilot (PCP) Project | pcp-maintainers&groups.io | 2025-09-26 | |
| Peter Ijkhout | peter&deltasolutions.nl | ||
| Rudolf Cardinal | rudolf&pobox.com | 2002-02 | |
| Siva Poobalasingam | Siva.Poobalasingam&towersoft.com.au | 2007-02 | |
| Todd Picquelle | todd&picquelle.com | ||
| Verimag, OOO | support&verimag.ru | 2018-07-20 | |
| Will MacDonald | will&codian.com |