Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
dtk 365 tcp DTK Fred Cohen Fred Cohen
dtk 365 udp DTK Fred Cohen Fred Cohen
adapt-sna 1365 tcp Network Software Associates Jeffery Chiao Jeffery Chiao
adapt-sna 1365 udp Network Software Associates Jeffery Chiao Jeffery Chiao
dbref 2365 tcp dbref Yoshihiro Yamazaki Yoshihiro Yamazaki
dbref 2365 udp dbref Yoshihiro Yamazaki Yoshihiro Yamazaki
contentserver 3365 tcp Content Server
contentserver 3365 udp Content Server
prismiq-plugin 3650 tcp PRISMIQ VOD plug-in Richard Hodges Richard Hodges 2003-01
prismiq-plugin 3650 udp PRISMIQ VOD plug-in Richard Hodges Richard Hodges 2003-01
xrpc-registry 3651 tcp XRPC Registry Slava Monich Slava Monich 2003-01
xrpc-registry 3651 udp XRPC Registry Slava Monich Slava Monich 2003-01
vxcrnbuport 3652 tcp VxCR NBU Default Port Boris Star Boris Star 2003-01
vxcrnbuport 3652 udp VxCR NBU Default Port Boris Star Boris Star 2003-01
tsp 3653 tcp Tunnel Setup Protocol Marc Blanchet Marc Blanchet 2003-01 RFC 5572
tsp 3653 udp Tunnel Setup Protocol Marc Blanchet Marc Blanchet 2003-01 RFC 5572
vaprtm 3654 tcp VAP RealTime Messenger Boris Polevoy Boris Polevoy 2003-01
vaprtm 3654 udp VAP RealTime Messenger Boris Polevoy Boris Polevoy 2003-01
abatemgr 3655 tcp ActiveBatch Exec Agent
abatemgr 3655 udp ActiveBatch Exec Agent
abatjss 3656 tcp ActiveBatch Job Scheduler Ben Rosenberg Ben Rosenberg 2003-01
abatjss 3656 udp ActiveBatch Job Scheduler Ben Rosenberg Ben Rosenberg 2003-01
immedianet-bcn 3657 tcp ImmediaNet Beacon Bill Homan Bill Homan 2003-01
immedianet-bcn 3657 udp ImmediaNet Beacon Bill Homan Bill Homan 2003-01
ps-ams 3658 tcp PlayStation AMS (Secure) Edgar Alan Tu Edgar Alan Tu 2003-01
ps-ams 3658 udp PlayStation AMS (Secure) Edgar Alan Tu Edgar Alan Tu 2003-01
apple-sasl 3659 tcp Apple SASL David M. O'Rourke David M. O'Rourke 2003-01
apple-sasl 3659 udp Apple SASL David M. O'Rourke David M. O'Rourke 2003-01
mupdate 3905 tcp Mailbox Update (MUPDATE) protocol RFC 3656
mupdate 3905 udp Mailbox Update (MUPDATE) protocol RFC 3656
4363-4365 Unassigned
5365-5396 Unassigned
lcm-server 7365 tcp LifeKeeper Communications James Bottomley James Bottomley 2006-02
lcm-server 7365 udp LifeKeeper Communications James Bottomley James Bottomley 2006-02
33436-33655 Unassigned Known Unauthorized Use on ports 33436-33534
snip-slave 33656 tcp SNIP Slave Dr. Chris Tucker Dr. Chris Tucker 2005-08
snip-slave 33656 udp SNIP Slave Dr. Chris Tucker Dr. Chris Tucker 2005-08
33657-33889 Unassigned
36463-36523 Unassigned
febooti-aw 36524 tcp Febooti Automation Workshop Maris Bormanis Maris Bormanis 2011-06-10
36524 udp Reserved
36525-36601 Unassigned

Contact Information

Name Contact URI Last Updated
Ben Rosenberg brosenberg&advsyscon.com 2003-01
Bill Homan bhoman&spanworks.com 2003-01
Boris Polevoy vapcom&mail.ru 2003-01
Boris Star boris.star&veritas.com 2003-01
David M. O'Rourke daveo&apple.com 2003-01
Dr. Chris Tucker chris.tucker&ioltd.co.uk 2005-08
Edgar Alan Tu Edgar_Tu&playstation.sony.com 2003-01
Fred Cohen fc&all.net
James Bottomley James.Bottomley&steeleye.com 2006-02
Jeffery Chiao tel:+714-768-401
Marc Blanchet marc.blanchet&viagenie.ca 2003-01
Maris Bormanis info&febooti.com 2011-06-10
Richard Hodges rhodges&prismiq.com 2003-01
Slava Monich Slava.Monich&nokia.com 2003-01
Yoshihiro Yamazaki yamazaki&ael.fujitsu.co.jp