Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
is99c 379 tcp TIA/EIA/IS-99 modem client
is99c 379 udp TIA/EIA/IS-99 modem client
dbreporter 1379 tcp Integrity Solutions Tim Dawson Tim Dawson
dbreporter 1379 udp Integrity Solutions Tim Dawson Tim Dawson
etcd-client 2379 tcp etcd client communication CoreOS Brian Harrington 2014-07-09
2379 udp Reserved
socorfs 3379 tcp SOCORFS Hugo Charbonneau Hugo Charbonneau
socorfs 3379 udp SOCORFS Hugo Charbonneau Hugo Charbonneau
quickbooksrds 3790 tcp QuickBooks RDS Almira Almira 2003-07
quickbooksrds 3790 udp QuickBooks RDS Almira Almira 2003-07
tvnetworkvideo 3791 tcp TV NetworkVideo Data port Kevin Brunner Kevin Brunner 2003-07
tvnetworkvideo 3791 udp TV NetworkVideo Data port Kevin Brunner Kevin Brunner 2003-07
sitewatch 3792 tcp e-Watch Corporation SiteWatch John M. Baird John M. Baird 2003-07
sitewatch 3792 udp e-Watch Corporation SiteWatch John M. Baird John M. Baird 2003-07
dcsoftware 3793 tcp DataCore Software Andre Cato Andre Cato 2003-07
dcsoftware 3793 udp DataCore Software Andre Cato Andre Cato 2003-07
jaus 3794 tcp JAUS Robots Steven B. Cliff Steven B. Cliff 2003-07
jaus 3794 udp JAUS Robots Steven B. Cliff Steven B. Cliff 2003-07
myblast 3795 tcp myBLAST Mekentosj port Alexander Griekspoor Alexander Griekspoor 2003-07
myblast 3795 udp myBLAST Mekentosj port Alexander Griekspoor Alexander Griekspoor 2003-07
spw-dialer 3796 tcp Spaceway Dialer Patrick Fisher Patrick Fisher 2003-07
spw-dialer 3796 udp Spaceway Dialer Patrick Fisher Patrick Fisher 2003-07
idps 3797 tcp idps Jean-Francois Rabasse Jean-Francois Rabasse 2003-07
idps 3797 udp idps Jean-Francois Rabasse Jean-Francois Rabasse 2003-07
minilock 3798 tcp Minilock Daniel Julio Reyes Daniel Julio Reyes 2003-08
minilock 3798 udp Minilock Daniel Julio Reyes Daniel Julio Reyes 2003-08
radius-dynauth 3799 tcp RADIUS Dynamic Authorization RFC 3576
radius-dynauth 3799 udp RADIUS Dynamic Authorization RFC 3576
ctdb 4379 tcp CTDB Ronnie Sahlberg Ronnie Sahlberg 2007-07-05
ctdb 4379 udp CTDB Ronnie Sahlberg Ronnie Sahlberg 2007-07-05
redis 6379 tcp An advanced key-value cache and store Salvatore Sanfilippo Itamar Haber 2015-04-23
6379 udp Reserved
cruise-diags 8379 tcp Cruise DIAGS Steve Husak Steve Husak
cruise-diags 8379 udp Cruise DIAGS Steve Husak Steve Husak
3gpp-monp 8809 udp MCPTT Off-Network Protocol (MONP) 3GPP Dongwook Kim 2019-04-15 2026-01-23 3GPP TS 24.379 v13.5.0s
9375-9379 Unassigned
p-net-remote 34379 tcp P-Net on IP remote Kurt Nissen Kurt Nissen 2004-02
p-net-remote 34379 udp P-Net on IP remote Kurt Nissen Kurt Nissen 2004-02
37655-37999 Unassigned

Contact Information

Name Organization Contact URI Last Updated
3GPP dongwook.kim&etsi.org 2026-01-23
Alexander Griekspoor a.griekspoor&nki.nl 2003-07
Almira almira_niciu&intuit.com 2003-07
Andre Cato andre.cato&datacore.com 2003-07
Brian Harrington CoreOS brian.harrington&coreos.com 2014-07-09
CoreOS brian.harrington&coreos.com 2014-07-09
Daniel Julio Reyes danieljreyes&yahoo.com 2003-08
Dongwook Kim 3GPP dongwook.kim&etsi.org 2026-01-23
Hugo Charbonneau
Itamar Haber Salvatore Sanfilippo itamar&redislabs.com 2015-04-23
Jean-Francois Rabasse jfr&idps.org 2003-07
John M. Baird jbaird&e-watch.com 2003-07
Kevin Brunner brunner&tivo.com 2003-07
Kurt Nissen kn&proces-data.com 2004-02
Patrick Fisher pfisher&hns.com 2004-12
Ronnie Sahlberg ronniesahlberg&gmail.com 2007-07-05
Salvatore Sanfilippo antirez&gmail.com 2015-04-23
Steve Husak portmaster&cruisetech.com
Steven B. Cliff scliff&remotec-andros.com 2003-07
Tim Dawson tdawson%25mspboss@uunet.uu.net