Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| embl-ndt | 394 | tcp | EMBL Nucleic Data Transfer | Peter Gad | Peter Gad | ||||||
| embl-ndt | 394 | udp | EMBL Nucleic Data Transfer | Peter Gad | Peter Gad | ||||||
| iclpv-nlc | 1394 | tcp | Network Log Client | ||||||||
| iclpv-nlc | 1394 | udp | Network Log Client | ||||||||
| ms-olap2 | 2394 | tcp | MS OLAP 2 | Mosha Pasumansky | Mosha Pasumansky | ||||||
| ms-olap2 | 2394 | udp | MS OLAP 2 | Mosha Pasumansky | Mosha Pasumansky | ||||||
| d2k-tapestry2 | 3394 | tcp | D2K Tapestry Server to Server | Eric Lan | Eric Lan | ||||||
| d2k-tapestry2 | 3394 | udp | D2K Tapestry Server to Server | Eric Lan | Eric Lan | ||||||
| xecp-node | 3940 | tcp | XeCP Node Service | Brent McCullough | Brent McCullough | 2003-11 | |||||
| xecp-node | 3940 | udp | XeCP Node Service | Brent McCullough | Brent McCullough | 2003-11 | |||||
| homeportal-web | 3941 | tcp | Home Portal Web Server | Christian Beaumont | Christian Beaumont | 2003-11 | |||||
| homeportal-web | 3941 | udp | Home Portal Web Server | Christian Beaumont | Christian Beaumont | 2003-11 | |||||
| srdp | 3942 | tcp | satellite distribution | Simone Molendini | Simone Molendini | 2003-11 | |||||
| srdp | 3942 | udp | satellite distribution | Simone Molendini | Simone Molendini | 2003-11 | |||||
| tig | 3943 | tcp | TetraNode Ip Gateway | B. van Klinken | B. van Klinken | 2003-12 | |||||
| tig | 3943 | udp | TetraNode Ip Gateway | B. van Klinken | B. van Klinken | 2003-12 | |||||
| sops | 3944 | tcp | S-Ops Management | Stefan Hochuli | Stefan Hochuli | 2003-12 | |||||
| sops | 3944 | udp | S-Ops Management | Stefan Hochuli | Stefan Hochuli | 2003-12 | |||||
| emcads | 3945 | tcp | EMCADS Server Port | Lars Struwe Christensen | Lars Struwe Christensen | 2004-01 | |||||
| emcads | 3945 | udp | EMCADS Server Port | Lars Struwe Christensen | Lars Struwe Christensen | 2004-01 | |||||
| backupedge | 3946 | tcp | BackupEDGE Server | Microlite Corporation | D. Thomas Podnar | 2004-06 | |||||
| backupedge | 3946 | udp | BackupEDGE Server | Microlite Corporation | D. Thomas Podnar | 2004-06 | |||||
| ccp | 3947 | tcp | Connect and Control Protocol for Consumer, Commercial, and Industrial Electronic Devices | Aaron Myer | Aaron Myer | 2004-06 | |||||
| ccp | 3947 | udp | Connect and Control Protocol for Consumer, Commercial, and Industrial Electronic Devices | Aaron Myer | Aaron Myer | 2004-06 | |||||
| apdap | 3948 | tcp | Anton Paar Device Administration Protocol | Martin Leitner | Martin Leitner | 2004-06 | |||||
| apdap | 3948 | udp | Anton Paar Device Administration Protocol | Martin Leitner | Martin Leitner | 2004-06 | |||||
| drip | 3949 | tcp | Dynamic Routing Information Protocol | Dana Blair | Dana Blair | 2004-06 | |||||
| drip | 3949 | udp | Dynamic Routing Information Protocol | Dana Blair | Dana Blair | 2004-06 | |||||
| 4394 | tcp | Reserved | |||||||||
| apwi-disc | 4394 | udp | American Printware Discovery | Lech Lakomy | Lech Lakomy | 2009-02-12 | |||||
| ipsec-nat-t | 4500 | udp | IPsec NAT-Traversal | 2017-07-07 | RFC 3948; RFC 7296 | ||||||
| fse | 7394 | tcp | File system export of backup images | Weibao Wu | Weibao Wu | 2006-04 | |||||
| fse | 7394 | udp | File system export of backup images | Weibao Wu | Weibao Wu | 2006-04 |
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| Aaron Myer | aaron.myer&in2nets.com | 2004-06 |
| B. van Klinken | b.vklinken&rohill.nl | 2003-12 |
| Brent McCullough | bmccullough&timemgmt.com | 2003-11 |
| Christian Beaumont | chrisb&lantronix.com | 2003-11 |
| D. Thomas Podnar | tomµlite.com | 2015-11-04 |
| Dana Blair | dblair&cisco.com | 2004-06 |
| Eric Lan | elan&d2k.com | |
| Lars Struwe Christensen | lsc&giritech.com | 2004-01 |
| Lech Lakomy | llakomy&apwi.com | 2009-02-12 |
| Martin Leitner | info&anton-paar.com | 2004-06 |
| Microlite Corporation | tomµlite.com | 2015-11-04 |
| Mosha Pasumansky | moshapµsoft.com | |
| Peter Gad | peter&bmc.uu.se | |
| Simone Molendini | simone.molendini&unile.it | 2003-11 |
| Stefan Hochuli | iana.org&dunes.ch | 2003-12 |
| Weibao Wu | weibao_wu&symantec.com | 2006-04 |