Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
prm-nm 409 tcp Prospero Resource Manager Node Man. B. Clifford Neuman B. Clifford Neuman
prm-nm 409 udp Prospero Resource Manager Node Man. B. Clifford Neuman B. Clifford Neuman
submission 587 tcp Message Submission 2011-11-17 RFC 6409
submission 587 udp Message Submission 2011-11-17 RFC 6409
here-lm 1409 tcp Here License Manager David Ison David Ison
here-lm 1409 udp Here License Manager David Ison David Ison
sns-protocol 2409 tcp SNS Protocol Amir Blich Amir Blich
sns-protocol 2409 udp SNS Protocol Amir Blich Amir Blich
networklens 3409 tcp NetworkLens Event Port
networklens 3409 udp NetworkLens Event Port
omasgport 4090 tcp OMA BCAST Service Guide Mark Lipford Mark Lipford 2006-07
omasgport 4090 udp OMA BCAST Service Guide Mark Lipford Mark Lipford 2006-07
ewinstaller 4091 tcp EminentWare Installer
ewinstaller 4091 udp EminentWare Installer
ewdgs 4092 tcp EminentWare DGS David A. Gayler David A. Gayler 2006-07
ewdgs 4092 udp EminentWare DGS David A. Gayler David A. Gayler 2006-07
pvxpluscs 4093 tcp Pvx Plus CS Host Michael King Michael King 2006-07
pvxpluscs 4093 udp Pvx Plus CS Host Michael King Michael King 2006-07
sysrqd 4094 tcp sysrq daemon Julien Danjou Julien Danjou 2006-07
sysrqd 4094 udp sysrq daemon Julien Danjou Julien Danjou 2006-07
xtgui 4095 tcp xtgui information service Jim Robanske Jim Robanske 2006-05
xtgui 4095 udp xtgui information service Jim Robanske Jim Robanske 2006-05
bre 4096 tcp BRE (Bridge Relay Element) Stephen Egbert Stephen Egbert
bre 4096 udp BRE (Bridge Relay Element) Stephen Egbert Stephen Egbert
patrolview 4097 tcp Patrol View Portnoy Boxman Portnoy Boxman
patrolview 4097 udp Patrol View Portnoy Boxman Portnoy Boxman
drmsfsd 4098 tcp drmsfsd Masao Iwai Masao Iwai
drmsfsd 4098 udp drmsfsd Masao Iwai Masao Iwai
dpcp 4099 tcp DPCP John Croft John Croft
dpcp 4099 udp DPCP John Croft John Croft
netcabinet-com 4409 tcp Net-Cabinet comunication Ian Manning Ian Manning 2009-12-16
4409 udp Reserved
salient-dtasrv 5409 tcp Salient Data Server Richard Farnham Richard Farnham
salient-dtasrv 5409 udp Salient Data Server Richard Farnham Richard Farnham
boe-resssvr3 6409 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
7403-7409 Unassigned
19399-19409 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Amir Blich amir&netmanage.co.il
B. Clifford Neuman bcn&isi.edu 2022-02-18
David A. Gayler dgayler&eminentware.com 2006-07
David Ison here&dialup.oar.net
Giriraj Harapanahalli giriraj.harapanahalli&sap.com 2026-05-27
Ian Manning ian&baycastle.co.uk 2009-12-16
Jim Robanske jimr&cray.com 2006-05
John Croft john.croft&calista.demon.co.uk
Julien Danjou acid&debian.org 2006-07
Mark Lipford mark.a.lipford&sprint.com 2006-07
Masao Iwai iwai&kel.fujitsu.co.jp
Michael King mike.king&pvxplus.com 2006-07
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Richard Farnham rfarnham&salient.com
SAP Giriraj Harapanahalli 2026-05-27
Stephen Egbert egbert&ra.timeplex.com