Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
bnet 415 tcp BNet Jim Mertz Jim Mertz
bnet 415 udp BNet Jim Mertz Jim Mertz
dbstar 1415 tcp DBStar Jeffrey Millman Jeffrey Millman
dbstar 1415 udp DBStar Jeffrey Millman Jeffrey Millman
codima-rtp 2415 tcp Codima Remote Transaction Protocol Sylvia Ross Sylvia Ross
codima-rtp 2415 udp Codima Remote Transaction Protocol Sylvia Ross Sylvia Ross
bcinameservice 3415 tcp BCI Name Service Dennis Parker Dennis Parker 2002-02
bcinameservice 3415 udp BCI Name Service Dennis Parker Dennis Parker 2002-02
PowerAlert-nsa 4150 tcp PowerAlert Network Shutdown Agent Mike Delgrosso Mike Delgrosso 2007-07-02
PowerAlert-nsa 4150 udp PowerAlert Network Shutdown Agent Mike Delgrosso Mike Delgrosso 2007-07-02
menandmice-noh 4151 tcp Men & Mice Remote Control

IANA assigned this well-formed service name as a replacement for "menandmice_noh".
Eggert Thorlacius Eggert Thorlacius 2007-08-30
menandmice_noh 4151 tcp Men & Mice Remote Control Eggert Thorlacius Eggert Thorlacius 2007-08-30 This entry is an alias to "menandmice-noh". This entry is now historic, not usable for use with many common service discovery mechanisms.
menandmice-noh 4151 udp Men & Mice Remote Control

IANA assigned this well-formed service name as a replacement for "menandmice_noh".
Eggert Thorlacius Eggert Thorlacius 2007-08-30
menandmice_noh 4151 udp Men & Mice Remote Control Eggert Thorlacius Eggert Thorlacius 2007-08-30 This entry is an alias to "menandmice-noh". This entry is now historic, not usable for use with many common service discovery mechanisms.
idig-mux 4152 tcp iDigTech Multiplex

IANA assigned this well-formed service name as a replacement for "idig_mux".
Robin Findley Robin Findley 2007-05
idig_mux 4152 tcp iDigTech Multiplex Robin Findley Robin Findley 2007-05 This entry is an alias to "idig-mux". This entry is now historic, not usable for use with many common service discovery mechanisms.
idig-mux 4152 udp iDigTech Multiplex

IANA assigned this well-formed service name as a replacement for "idig_mux".
Robin Findley Robin Findley 2007-05
idig_mux 4152 udp iDigTech Multiplex Robin Findley Robin Findley 2007-05 This entry is an alias to "idig-mux". This entry is now historic, not usable for use with many common service discovery mechanisms.
mbl-battd 4153 tcp MBL Remote Battery Monitoring Claudio Procida Claudio Procida 2007-05
mbl-battd 4153 udp MBL Remote Battery Monitoring Claudio Procida Claudio Procida 2007-05
atlinks 4154 tcp atlinks device discovery Scott Griepentrog Scott Griepentrog 2002-10
atlinks 4154 udp atlinks device discovery Scott Griepentrog Scott Griepentrog 2002-10
bzr 4155 tcp Bazaar version control system Martin Pool Martin Pool 2007-02
bzr 4155 udp Bazaar version control system Martin Pool Martin Pool 2007-02
stat-results 4156 tcp STAT Results
stat-results 4156 udp STAT Results
stat-scanner 4157 tcp STAT Scanner Control
stat-scanner 4157 udp STAT Scanner Control
stat-cc 4158 tcp STAT Command Center Darwin Ammala Darwin Ammala 2007-03
stat-cc 4158 udp STAT Command Center Darwin Ammala Darwin Ammala 2007-03
nss 4159 tcp Network Security Service Dave Wierbowski Dave Wierbowski 2006-08
nss 4159 udp Network Security Service Dave Wierbowski Dave Wierbowski 2006-08
brcd-vr-req 4415 tcp Brocade Virtual Router Request Brocade Communications Systems Nick Carter 2015-11-17
4415 udp Reserved
capwap-control 5246 udp CAPWAP Control Protocol RFC 5415
capwap-data 5247 udp CAPWAP Data Protocol RFC 5415
ns-server 5415 tcp NS Server Jeffrey Chiao Jeffrey Chiao
ns-server 5415 udp NS Server Jeffrey Chiao Jeffrey Chiao
dlpx-sp 8415 tcp Delphix Session Protocol Delphix Corp Peng Dai 2012-11-01
8415 udp Reserved
vcscmd 14150 tcp Veritas Cluster Server Command Server Anand Bhalerao Anand Bhalerao 2008-10-02
14150 udp Reserved
14151-14153 Unassigned
vad 14154 tcp Veritas Application Director Rajeev Verma Rajeev Verma 2006-02
vad 14154 udp Veritas Application Director Rajeev Verma Rajeev Verma 2006-02
14155-14249 Unassigned
14415-14499 Unassigned
31401-31415 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Anand Bhalerao anand_bhalerao&symantec.com 2008-10-02
Brocade Communications Systems ncarter&brocade.com 2015-11-17
Claudio Procida claudio&emeraldion.it 2007-05
Darwin Ammala dammala&harris.com 2007-03
Dave Wierbowski wierbows&us.ibm.com 2006-08
Delphix Corp peng.dai&delphix.com 2012-11-01
Dennis Parker dparker&broadcloud.com 2002-02
Eggert Thorlacius eggert&menandmice.com 2007-08-30
Jeffrey Chiao chiaoj&netsoft.com
Jeffrey Millman jcm&dbstar.com
Jim Mertz JMertz+RV09&rvdc.unisys.com
Martin Pool mbp&canonical.com 2007-02
Mike Delgrosso Mike_Delgrosso&tripplite.com 2007-07-02
Nick Carter ncarter&brocade.com 2015-11-17
Peng Dai Delphix Corp peng.dai&delphix.com 2012-11-01
Rajeev Verma rajeev_verma&symantec.com 2006-02
Robin Findley rfindley&usa.net 2007-05
Scott Griepentrog griepentrogs&atlinks.com 2002-10
Sylvia Ross sross&codimatech.com