Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| ddm-rdb | 446 | tcp | DDM-Remote Relational Database Access | ||||||||
| ddm-rdb | 446 | udp | DDM-Remote Relational Database Access | ||||||||
| ora-lm | 1446 | tcp | Optical Research Associates License Manager | ||||||||
| ora-lm | 1446 | udp | Optical Research Associates License Manager | ||||||||
| bues-service | 2446 | tcp | bues_service IANA assigned this well-formed service name as a replacement for "bues_service". |
Leonhard Diekmann | Leonhard Diekmann | ||||||
| bues_service | 2446 | tcp | bues_service | Leonhard Diekmann | Leonhard Diekmann | This entry is an alias to "bues-service". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| bues-service | 2446 | udp | bues_service IANA assigned this well-formed service name as a replacement for "bues_service". |
Leonhard Diekmann | Leonhard Diekmann | ||||||
| bues_service | 2446 | udp | bues_service | Leonhard Diekmann | Leonhard Diekmann | This entry is an alias to "bues-service". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| 3comfaxrpc | 3446 | tcp | 3Com FAX RPC port | Christopher Wells | Christopher Wells | 2002-04 | |||||
| 3comfaxrpc | 3446 | udp | 3Com FAX RPC port | Christopher Wells | Christopher Wells | 2002-04 | |||||
| n1-fwp | 4446 | tcp | N1-FWP | ||||||||
| n1-fwp | 4446 | udp | N1-FWP | ||||||||
| ntske | 4460 | tcp | Network Time Security Key Establishment | IESG | IETF Chair | 2020-04-07 | RFC 8915 | ||||
| 4460 | udp | Reserved | |||||||||
| 4461-4479 | Unassigned | ||||||||||
| 5446-5449 | Unassigned | ||||||||||
| mysql-proxy | 6446 | tcp | MySQL Proxy | Kay Roepke | Kay Roepke | 2009-04-22 | |||||
| mysql-proxy | 6446 | udp | MySQL Proxy | Kay Roepke | Kay Roepke | 2009-04-22 | |||||
| 8446-8447 | Unassigned | ||||||||||
| 9446-9449 | Unassigned | ||||||||||
| 24387-24464 | Unassigned | ||||||||||
| tonidods | 24465 | tcp | Tonido Domain Server | Madhan Kanagavel | Madhan Kanagavel | 2008-07-18 | |||||
| tonidods | 24465 | udp | Tonido Domain Server | Madhan Kanagavel | Madhan Kanagavel | 2008-07-18 | |||||
| 24466-24553 | Unassigned | ||||||||||
| 44446-44543 | Unassigned | Known UNAUTHORIZED USE: Ports 44515 & 44516 | |||||||||
| 44600 | tcp | Reserved | |||||||||
| asihpi | 44600 | udp | AudioScience HPI | Eliot Blennerhassett | Eliot Blennerhassett | 2011-07-07 | |||||
| 44601-44817 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Christopher Wells | christopher_wells&3com.com | 2002-04 | |
| Eliot Blennerhassett | eblennerhassett&audioscience.com | 2011-07-07 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Kay Roepke | Kay.Roepke&sun.com | 2009-04-22 | |
| Leonhard Diekmann | diekmann&04.mstr02.telekom400.dbp.de | ||
| Madhan Kanagavel | madhan&codelathe.com | 2008-07-18 |