Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
scx-proxy 470 tcp scx-proxy Scott Narveson Scott Narveson
scx-proxy 470 udp scx-proxy Scott Narveson Scott Narveson
nas 991 tcp Netnews Administration System Vera Heinau; Heiko Schlichting Vera Heinau; Heiko Schlichting 2017-02-10 RFC 4707
nas 991 udp Netnews Administration System Vera Heinau; Heiko Schlichting Vera Heinau; Heiko Schlichting 2017-02-10 RFC 4707
uaiact 1470 tcp Universal Analytics Mark R. Ludwig Mark R. Ludwig
uaiact 1470 udp Universal Analytics Mark R. Ludwig Mark R. Ludwig
mil-2045-47001 1581 tcp MIL-2045-47001 Eric Whitehill Eric Whitehill
mil-2045-47001 1581 udp MIL-2045-47001 Eric Whitehill Eric Whitehill
taskman-port 2470 tcp taskman port Boris Panteleev Boris Panteleev
taskman-port 2470 udp taskman port Boris Panteleev Boris Panteleev
jt400 3470 tcp jt400
jt400 3470 udp jt400
netxms-agent 4700 tcp NetXMS Agent
netxms-agent 4700 udp NetXMS Agent
netxms-mgmt 4701 tcp NetXMS Management
netxms-mgmt 4701 udp NetXMS Management
netxms-sync 4702 tcp NetXMS Server Synchronization Victor Kirhenshtein Victor Kirhenshtein 2006-07
netxms-sync 4702 udp NetXMS Server Synchronization Victor Kirhenshtein Victor Kirhenshtein 2006-07
npqes-test 4703 tcp Network Performance Quality Evaluation System Test Service Zhengli Zhengli 2010-06-28
4703 udp Reserved
assuria-ins 4704 tcp Assuria Insider Nick Connor Nick Connor 2010-06-30
4704 udp Reserved
4705-4710 Unassigned
apsolab-col 5470 tcp The Apsolab company's data collection protocol (native api) Apsolab Inc. Jean-Francois Gauthier 2014-11-10
5470 udp Reserved
6465-6470 Unassigned
7444-7470 Unassigned
cisco-avp 8470 tcp Cisco Address Validation Protocol Cullen Jennings Cullen Jennings 2009-02-13
8470 udp Reserved
25101-25470 Unassigned
mbus 47000 tcp Message Bus Dirk Kutscher Dirk Kutscher
mbus 47000 udp Message Bus Dirk Kutscher Dirk Kutscher
winrm 47001 tcp Windows Remote Management Service Ryan Mack Ryan Mack 2009-04-29
47001 udp Reserved
47002-47099 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Apsolab Inc. admin&apsolab.com 2014-11-10
Boris Panteleev bpanteleev&himel.com
Cullen Jennings fluffy&cisco.com 2010-02-03
Dirk Kutscher dku&informatik.uni-bremen.de
Eric Whitehill Eric.Whitehill&itt.com
Heiko Schlichting heiko.schlichting&fu-berlin.de 2022-06-07
Jean-Francois Gauthier Apsolab Inc. jfgauthier&apsolab.com 2014-11-10
Mark R. Ludwig Mark-Ludwig&uai.com
Nick Connor nickc&assuria.com 2010-06-30
Ryan Mack rmack&microsoft.com 2009-04-29
Scott Narveson sjn&cray.com
Vera Heinau vera.heinau&fu-berlin.de 2022-06-07
Victor Kirhenshtein victor&opticom.lv 2006-07
Zhengli std&iwncomm.com 2010-06-28