Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| saft | 487 | tcp | saft Simple Asynchronous File Transfer | Ulli Horlacher | Ulli Horlacher | ||||||
| saft | 487 | udp | saft Simple Asynchronous File Transfer | Ulli Horlacher | Ulli Horlacher | ||||||
| localinfosrvr | 1487 | tcp | LocalInfoSrvr | Brian Matthews | Brian Matthews | ||||||
| localinfosrvr | 1487 | udp | LocalInfoSrvr | Brian Matthews | Brian Matthews | ||||||
| pns | 2487 | tcp | Policy Notice Service | Akiyoshi Ochi | Akiyoshi Ochi | ||||||
| pns | 2487 | udp | Policy Notice Service | Akiyoshi Ochi | Akiyoshi Ochi | ||||||
| ltctcp | 3487 | tcp | LISA TCP Transfer Channel | ||||||||
| ltcudp | 3487 | udp | LISA UDP Transfer Channel | Pit Vetterick | Pit Vetterick | 2002-05 | |||||
| prex-tcp | 4487 | tcp | Protocol for Remote Execution over TCP | Daniel Ruppert | Daniel Ruppert | 2010-09-16 | |||||
| 4487 | udp | Reserved | |||||||||
| cc-tracking | 4870 | tcp | Citcom Tracking Service | Wolfgang Weidner | Wolfgang Weidner | 2005-12 | |||||
| cc-tracking | 4870 | udp | Citcom Tracking Service | Wolfgang Weidner | Wolfgang Weidner | 2005-12 | |||||
| wired | 4871 | tcp | Wired | Axel Andersson | Axel Andersson | 2006-02 | |||||
| wired | 4871 | udp | Wired | Axel Andersson | Axel Andersson | 2006-02 | |||||
| 4872-4875 | Unassigned | ||||||||||
| tritium-can | 4876 | tcp | Tritium CAN Bus Bridge Service | James Kennedy | James Kennedy | 2011-02-15 | |||||
| tritium-can | 4876 | udp | Tritium CAN Bus Bridge Service | James Kennedy | James Kennedy | 2011-02-15 | |||||
| lmcs | 4877 | tcp | Lighting Management Control System | Timothy Parry | Timothy Parry | 2011-02-15 | |||||
| lmcs | 4877 | udp | Lighting Management Control System | Timothy Parry | Timothy Parry | 2011-02-15 | |||||
| 4878 | tcp | Reserved | |||||||||
| inst-discovery | 4878 | udp | Agilent Instrument Discovery | Charles F Steele | Charles F Steele | 2011-02-15 | |||||
| wsdl-event | 4879 | tcp | WSDL Event Receiver | Charles F Steele | Charles F Steele | 2011-02-15 | |||||
| 4879 | udp | Reserved | |||||||||
| sun-sr-iiop-aut | 6487 | tcp | Service Registry Default IIOPAuth Domain | Paul Sterk | Paul Sterk | 2006-03 | |||||
| sun-sr-iiop-aut | 6487 | udp | Service Registry Default IIOPAuth Domain | Paul Sterk | Paul Sterk | 2006-03 | |||||
| exoconfig | 26487 | tcp | EXOconfig | Urban Fosseus | Urban Fosseus | 2008-12-24 | |||||
| exoconfig | 26487 | udp | EXOconfig | Urban Fosseus | Urban Fosseus | 2008-12-24 | |||||
| mtrace | 33435 | udp | IP Multicast Traceroute | IESG | IETF Chair | 2017-12-13 | 2019-08-09 | RFC 8487 | Known Unauthorized Use on port 33435 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Akiyoshi Ochi | akiyoshi&net.paso.fujitsu.co.jp | ||
| Axel Andersson | axel&zankasoftware.com | 2006-02 | |
| Brian Matthews | brian_matthews&ibist.ibis.com | ||
| Charles F Steele | charles_steele&agilent.com | 2011-02-15 | |
| Daniel Ruppert | daniel&kaffi.lu | 2010-09-16 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| James Kennedy | james&tritium.com.au | 2011-02-15 | |
| Paul Sterk | paul.sterk&sun.com | 2006-03 | |
| Pit Vetterick | pit&3dgo.com | 2002-05 | |
| Timothy Parry | tim&lumenergi.com | 2011-02-15 | |
| Ulli Horlacher | framstag&rus.uni-stuttgart.de | ||
| Urban Fosseus | urban.fosseus®in.se | 2008-12-24 | |
| Wolfgang Weidner | ww&citcom.de | 2005-12 |