Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| manet | 269 | tcp | MANET Protocols | RFC 5498 | |||||||
| manet | 269 | udp | MANET Protocols | RFC 5498 | |||||||
| siam | 498 | tcp | siam | Philippe Gilbert | Philippe Gilbert | ||||||
| siam | 498 | udp | siam | Philippe Gilbert | Philippe Gilbert | ||||||
| sybase-sqlany | 1498 | tcp | Sybase SQL Any | Dave Neudoerffer | Dave Neudoerffer | ||||||
| sybase-sqlany | 1498 | udp | Sybase SQL Any | Dave Neudoerffer | Dave Neudoerffer | ||||||
| odn-castraq | 2498 | tcp | ODN-CasTraq | Richard Hodges | Richard Hodges | ||||||
| odn-castraq | 2498 | udp | ODN-CasTraq | Richard Hodges | Richard Hodges | ||||||
| dashpas-port | 3498 | tcp | DASHPAS user port | Albrecht Mayer | Albrecht Mayer | 2002-05 | |||||
| dashpas-port | 3498 | udp | DASHPAS user port | Albrecht Mayer | Albrecht Mayer | 2002-05 | |||||
| ctxs-vpp | 4980 | udp | Citrix Virtual Path | Citrix Systems | Rohith Ramkumar | 2015-04-17 | |||||
| 4980 | tcp | Reserved | |||||||||
| 4981-4982 | Unassigned | ||||||||||
| 4983 | Unassigned | 2005-12-22 | |||||||||
| webyast | 4984 | tcp | WebYast | Federico Lucifredi | Federico Lucifredi | 2009-09-25 | |||||
| 4984 | udp | Reserved | |||||||||
| gerhcs | 4985 | tcp | GER HC Standard | Roger Ward | Roger Ward | 2009-09-25 | |||||
| 4985 | udp | Reserved | |||||||||
| mrip | 4986 | tcp | Model Railway Interface Program | Howard Amos | Howard Amos | 2006-04 | |||||
| mrip | 4986 | udp | Model Railway Interface Program | Howard Amos | Howard Amos | 2006-04 | |||||
| smar-se-port1 | 4987 | tcp | SMAR Ethernet Port 1 | ||||||||
| smar-se-port1 | 4987 | udp | SMAR Ethernet Port 1 | ||||||||
| smar-se-port2 | 4988 | tcp | SMAR Ethernet Port 2 | Delcio Prizon | Delcio Prizon | ||||||
| smar-se-port2 | 4988 | udp | SMAR Ethernet Port 2 | Delcio Prizon | Delcio Prizon | ||||||
| parallel | 4989 | tcp | Parallel for GAUSS (tm) | Matthew Ford | Matthew Ford | 2003-03 | |||||
| parallel | 4989 | udp | Parallel for GAUSS (tm) | Matthew Ford | Matthew Ford | 2003-03 | |||||
| ethercat | 34980 | tcp | EtherCAT Port | Martin Rostan | Martin Rostan | 2003-11 | |||||
| ethercat | 34980 | udp | EtherCAT Port | Martin Rostan | Martin Rostan | 2003-11 | |||||
| 34981-34999 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Albrecht Mayer | albrecht.mayer&infineon.com | 2002-05 | |
| Citrix Systems | CloudBridge-PM&citrix.com | 2015-04-17 | |
| Dave Neudoerffer | Dave.Neudoerffer&ianywhere.com | ||
| Delcio Prizon | dprizon&smar.com.br | ||
| Federico Lucifredi | flucifredi&novell.com | 2009-09-25 | |
| Howard Amos | amos&ccww.co.uk | 2006-04 | |
| Martin Rostan | m.rostan&beckhoff.com | 2003-11 | |
| Matthew Ford | Matthew.Ford&forward.com.au | 2003-03 | |
| Philippe Gilbert | pgilbert&cal.fr | ||
| Richard Hodges | rh&source.net | ||
| Roger Ward | roger.ward&ger911.com | 2009-09-25 | |
| Rohith Ramkumar | Citrix Systems | CloudBridge-PM&citrix.com | 2015-04-17 |