Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
xvttp 508 tcp xvttp Keith J. Alphonso Keith J. Alphonso
xvttp 508 udp xvttp Keith J. Alphonso Keith J. Alphonso
diagmond 1508 tcp diagmond Pete Moscatelli Pete Moscatelli
diagmond 1508 udp diagmond Pete Moscatelli Pete Moscatelli
tdmoip 2142 tcp TDM OVER IP Yaakov Stein Yaakov Stein 2016-09-21 RFC 5087
tdmoip 2142 udp TDM OVER IP Yaakov Stein Yaakov Stein 2016-09-21 RFC 5087
jdatastore 2508 tcp JDataStore Tod Landis Tod Landis
jdatastore 2508 udp JDataStore Tod Landis Tod Landis
interactionweb 3508 tcp Interaction Web Mike Gagle Mike Gagle
interactionweb 3508 udp Interaction Web Mike Gagle Mike Gagle
onscreen 5080 tcp OnScreen Data Collection Service Christopher Miller Christopher Miller 2008-01-14
onscreen 5080 udp OnScreen Data Collection Service Christopher Miller Christopher Miller 2008-01-14
sdl-ets 5081 tcp SDL - Ent Trans Server Marc Morin Marc Morin 2002-04
sdl-ets 5081 udp SDL - Ent Trans Server Marc Morin Marc Morin 2002-04
qcp 5082 tcp Qpur Communication Protocol Joachim Kluemper Joachim Kluemper 2008-03-19
qcp 5082 udp Qpur Communication Protocol Joachim Kluemper Joachim Kluemper 2008-03-19
qfp 5083 tcp Qpur File Protocol Joachim Kluemper Joachim Kluemper 2008-03-19
qfp 5083 udp Qpur File Protocol Joachim Kluemper Joachim Kluemper 2008-03-19
llrp 5084 tcp EPCglobal Low-Level Reader Protocol Margaret Cullen; Paul Dietrich Margaret Cullen; Paul Dietrich 2006-11 Defined TXT keys: None. RFID reader Low Level Reader Protocol
llrp 5084 udp EPCglobal Low-Level Reader Protocol Margaret Cullen; Paul Dietrich Margaret Cullen; Paul Dietrich 2006-11 Defined TXT keys: None. RFID reader Low Level Reader Protocol
encrypted-llrp 5085 tcp EPCglobal Encrypted LLRP Margaret Cullen Margaret Cullen 2006-11
encrypted-llrp 5085 udp EPCglobal Encrypted LLRP Margaret Cullen Margaret Cullen 2006-11
aprigo-cs 5086 tcp Aprigo Collection Service Ron Zalkind Ron Zalkind 2010-05-28
5086 udp Reserved
biotic 5087 tcp BIOTIC - Binary Internet of Things Interoperable Communication Waher Data AB Peter Waher 2014-06-16 2015-11-25
5087 udp Reserved
5088-5089 Unassigned
5508-5539 Unassigned
bdir-pub 6508 tcp BoKS Dir Server, Public Port

IANA assigned this well-formed service name as a replacement for "bdir_pub".
Magnus Nystrom Magnus Nystrom
bdir_pub 6508 tcp BoKS Dir Server, Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-pub 6508 udp BoKS Dir Server, Public Port

IANA assigned this well-formed service name as a replacement for "bdir_pub".
Magnus Nystrom Magnus Nystrom
bdir_pub 6508 udp BoKS Dir Server, Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
adcp 7508 tcp Automation Device Configuration Protocol Festo AG & Co. KG Joerg Ullmann 2011-05-27 2012-07-26
7508 udp Reserved
candp 42508 tcp Computer Associates network discovery protocol Jon Press Jon Press 2005-09
candp 42508 udp Computer Associates network discovery protocol Jon Press Jon Press 2005-09

Contact Information

Name Organization Contact URI Last Updated
Christopher Miller chris.miller&versatrans.com 2008-01-14
Festo AG & Co. KG Software-Support&de.festo.com 2012-07-26
Joachim Kluemper ports&raikosoft.com 2008-03-19
Joerg Ullmann Festo AG & Co. KG jgu&de.festo.com 2012-07-26
Jon Press IANA.Registions&ca.com 2005-09
Keith J. Alphonso alphonso&ncs-ssc.com
Magnus Nystrom magnus&dynas.se
Marc Morin mmorin&sdlintl.com 2002-04
Margaret Cullen mrcullen42&gmail.com 2023-06-07
Mike Gagle mikeg&inin.com 2006-05
Paul Dietrich registrar&impinj.com
Pete Moscatelli moscat&hprdstl0.rose.hp.com
Peter Waher Waher Data AB peterwaher&hotmail.com 2015-11-25
Ron Zalkind ron&aprigo.com 2010-05-28
Tod Landis tlandis&inprise.com
Waher Data AB peterwaher&hotmail.com 2015-11-25
Yaakov Stein yaakovjstein&gmail.com 2022-02-04