Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
discard 9 dccp Discard Eddie Kohler Eddie Kohler RFC 4340 1145656131
whoami 565 tcp whoami
whoami 565 udp whoami
winddlb 1565 tcp WinDD Kelly Sims Kelly Sims
winddlb 1565 udp WinDD Kelly Sims Kelly Sims
coord-svr 2565 tcp Coordinator Server Richard Steiger Richard Steiger
coord-svr 2565 udp Coordinator Server Richard Steiger Richard Steiger
m2pa 3565 tcp M2PA RFC 4165
3565 udp Reserved
m2pa 3565 sctp M2PA RFC 4165
4564-4565 Unassigned
dp-bura 5565 tcp Data Protector BURA Micro Focus Shishir Misra 2016-01-13 2019-10-04
5565 udp Reserved
6559-6565 Unassigned
7564-7565 Unassigned
15556-15659 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Eddie Kohler IETF dccp WG kohler&cs.ucla.edu
Kelly Sims kellys&garnet.wv.tek.com
Micro Focus swpdl.dp.rd&microfocus.com 2019-09-30
Richard Steiger steiger&ensemblesoft.com
Shishir Misra shishir.misra&microfocus.com 2019-09-30