Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
sntp-heartbeat 580 tcp SNTP HEARTBEAT Louis Mamakos Louis Mamakos
sntp-heartbeat 580 udp SNTP HEARTBEAT Louis Mamakos Louis Mamakos
tn-tl-r1 1580 tcp tn-tl-r1
tn-tl-r2 1580 udp tn-tl-r2 Ed Kress Ed Kress
tributary 2580 tcp Tributary Louis Lu Louis Lu
tributary 2580 udp Tributary Louis Lu Louis Lu
nati-svrloc 3580 tcp NATI-ServiceLocator Jason Case Jason Case 2002-08
nati-svrloc 3580 udp NATI-ServiceLocator Jason Case Jason Case 2002-08
4190 udp Reserved RFC 5804
tmosms0 5580 tcp T-Mobile SMS Protocol Message 0 Ezinne Oji Ezinne Oji 2006-06
tmosms0 5580 udp T-Mobile SMS Protocol Message 0 Ezinne Oji Ezinne Oji 2006-06
parsec-master 6580 tcp Parsec Masterserver Andreas Varga Andreas Varga
parsec-master 6580 udp Parsec Masterserver Andreas Varga Andreas Varga
jnx-kcsync tcp jollys keychain cloud sync protocol Patrick Stein Patrick Stein 2011-10-24 Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa

Contact Information

Name Contact URI Last Updated
Andreas Varga sid&parsec.org
Ed Kress eskress&thinknet.com
Ezinne Oji ezinne.oji&t-mobile.com 2006-06
Jason Case jason.case&ni.com 2002-08
Louis Lu LouisL&bristol.com
Louis Mamakos louie&uu.net
Patrick Stein Patrick.Stein&jinx.eu 2011-10-24