Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
bdp 581 tcp Bundle Discovery Protocol Gary Malkin Gary Malkin
bdp 581 udp Bundle Discovery Protocol Gary Malkin Gary Malkin
mil-2045-47001 1581 tcp MIL-2045-47001 Eric Whitehill Eric Whitehill
mil-2045-47001 1581 udp MIL-2045-47001 Eric Whitehill Eric Whitehill
argis-te 2581 tcp ARGIS TE
argis-te 2581 udp ARGIS TE
kfxaclicensing 3581 tcp Ascent Capture Licensing Brad Hamilton Brad Hamilton 2002-08
kfxaclicensing 3581 udp Ascent Capture Licensing Brad Hamilton Brad Hamilton 2002-08
tmosms1 5581 tcp T-Mobile SMS Protocol Message 1 Ezinne Oji Ezinne Oji 2006-06
tmosms1 5581 udp T-Mobile SMS Protocol Message 1 Ezinne Oji Ezinne Oji 2006-06
5799-5812 Unassigned
icmpd 5813 tcp ICMPD Shane O'Donnell Shane O'Donnell
icmpd 5813 udp ICMPD Shane O'Donnell Shane O'Donnell
spt-automation 5814 tcp Support Automation Joshua Hawkins Joshua Hawkins 2003-11
spt-automation 5814 udp Support Automation Joshua Hawkins Joshua Hawkins 2003-11
5815-5819 Unassigned
parsec-peer 6581 tcp Parsec Peer-to-Peer Andreas Varga Andreas Varga
parsec-peer 6581 udp Parsec Peer-to-Peer Andreas Varga Andreas Varga
frc-hp 6704 sctp ForCES HP (High Priority) channel RFC 5811
frc-mp 6705 sctp ForCES MP (Medium Priority) channel RFC 5811
frc-lp 6706 sctp ForCES LP (Low priority) channel RFC 5811

Contact Information

Name Contact URI Last Updated
Andreas Varga sid&parsec.org
Brad Hamilton brad_hamilton&kofax.com 2002-08
Eric Whitehill Eric.Whitehill&itt.com
Ezinne Oji ezinne.oji&t-mobile.com 2006-06
Gary Malkin gmalkin&xylogics.com
Joshua Hawkins joshua.hawkins&hp.com 2003-11
Shane O'Donnell shane&opennms.org