Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
cab-protocol 595 tcp CAB Protocol Winston Hetherington Winston Hetherington
cab-protocol 595 udp CAB Protocol Winston Hetherington Winston Hetherington
radio 1595 tcp radio
radio 1595 udp radio
worldfusion1 2595 tcp World Fusion 1
worldfusion1 2595 udp World Fusion 1
shareapp 3595 tcp ShareApp Jeff King Jeff King 2002-09
shareapp 3595 udp ShareApp Jeff King Jeff King 2002-09
ias-paging 4595 tcp IAS-Paging (ANRI-ANRI)
ias-paging 4595 udp IAS-Paging (ANRI-ANRI)
pds 9595 tcp Ping Discovery Service Alan Butt Alan Butt
pds 9595 udp Ping Discovery Service Alan Butt Alan Butt
25904-25953 Unassigned
bf-game 25954 udp Bitfighter game server Christopher Eykamp Christopher Eykamp 2012-08-16
25954 tcp Reserved
bf-master 25955 udp Bitfighter master server Christopher Eykamp Christopher Eykamp 2012-08-16
25955 tcp Reserved
25956-25999 Unassigned
dccp-ping dccp ping/traceroute using DCCP Samuel Jero Samuel Jero 2012-11-14 1885957735 Defined TXT keys: None
wot tcp W3C WoT Thing Description or Directory W3C Web of Things Working Group Kazuyuki Ashimura 2022-11-22 2022-12-15

Defined TXT keys:

td: Absolute pathname of the Thing Description of the Thing or Thing Description of the Thing Description Directory.

type: Type of the Thing Description, i.e. "Thing" or "Directory". If omitted, the type is assumed to be Thing.

scheme: Scheme part of URL. One of the following values can be specified, with the standard registered URI interpretations RFC 7595: http (HTTP over TCP),https (HTTP over TLS/TCP), coap+tcp (CoAP over TCP), or coaps+tcp (CoAP over TLS/TCP). If omitted, the scheme is assumed to be http.

wot udp W3C WoT Thing Description or Directory W3C Web of Things Working Group Kazuyuki Ashimura 2022-11-22 2022-12-15

Defined TXT keys:

td: Absolute pathname of the Thing Description of the Thing or Thing Description of the Thing Description Directory.

type: Type of the Thing Description, i.e. "Thing" or "Directory". If omitted, the type is assumed to be Thing.

scheme: Scheme part of URL. One of the following values can be specified, with the standard registered URI interpretations RFC 7595: coap (CoAP over UDP), coaps CoAP over DTLS/UDP. If omitted, the scheme is assumed to be coap.


Contact Information

Name Organization Contact URI Last Updated
Alan Butt alan.butt&landesk.com 2006-03
Christopher Eykamp chris&eykamp.com 2012-08-16
Jeff King jking&wave3software.com 2002-09
Kazuyuki Ashimura ashimura&w3.org 2022-11-22
Samuel Jero sj323707&ohio.edu 2012-11-14
W3C Web of Things Working Group team-wot&w3.org 2022-11-22
Winston Hetherington