Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
urm 606 tcp Cray Unified Resource Manager
urm 606 udp Cray Unified Resource Manager
slm-api 1606 tcp Salutation Manager (SLM-API) Tohru Mori Tohru Mori
slm-api 1606 udp Salutation Manager (SLM-API) Tohru Mori Tohru Mori
netmon 2606 tcp Dell Netmon
netmon 2606 udp Dell Netmon
splitlock 3606 tcp Splitlock Server Andrew Tune Andrew Tune 2002-09
splitlock 3606 udp Splitlock Server Andrew Tune Andrew Tune 2002-09
sixid 4606 tcp Secure ID to IP registration and lookup Sixscape Communications, Pte. Ltd. Lawrence E. Hughes 2020-04-28
4606 udp Reserved
5606-5617 Unassigned
x11 6000-6063 tcp X Window System Stephen Gildea Stephen Gildea Known Unauthorized Use on port 6003
x11 6000-6063 udp X Window System Stephen Gildea Stephen Gildea Known Unauthorized Use on port 6003
ndl-ahp-svc 6064 tcp NDL-AHP-SVC John Richmond John Richmond
ndl-ahp-svc 6064 udp NDL-AHP-SVC John Richmond John Richmond
winpharaoh 6065 tcp WinPharaoh Basil Lee Basil Lee
winpharaoh 6065 udp WinPharaoh Basil Lee Basil Lee
ewctsp 6066 tcp EWCTSP Mark Bailon Mark Bailon
ewctsp 6066 udp EWCTSP Mark Bailon Mark Bailon
6067 Unassigned 2007-07-17
gsmp-ancp 6068 tcp GSMP/ANCP Avri Doria Avri Doria RFC 6320
6068 udp Reserved
trip 6069 tcp TRIP Hussein F. Salama Hussein F. Salama
trip 6069 udp TRIP Hussein F. Salama Hussein F. Salama
mipi-debug 7606 tcp MIPI Alliance Debug Mipi Alliance Peter Lefkin 2016-02-26
mipi-debug 7606 udp MIPI Alliance Debug Mipi Alliance Peter Lefkin 2016-02-26

Contact Information

Name Organization Contact URI Last Updated
Andrew Tune Andrew.Tune&splitlock.com 2003-01
Avri Doria avri.doria&nokia.com
Basil Lee basil.lee&gnnettest.com
Hussein F. Salama hsalama&cisco.com
John Richmond john&ndl.co.uk
Lawrence E. Hughes Sixscape Communications, Ltd. lhughes&sixscape.com 2014-03-17
Mark Bailon mark.bailon&ericsson.com
Mipi Alliance secretary&mipi.org 2016-02-26
Peter Lefkin peter.lefkin&mipi.org 2016-02-26
Sixscape Communications, Pte. Ltd. lhughes&sixscape.com 2014-08-26
Stephen Gildea gildea&lcs.mit.edu
Tohru Mori tmori&vnet.ibm.com