Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| bootpc | 68 | tcp | Bootstrap Protocol Client | Bill Croft | Bill Croft | ||||||
| bootpc | 68 | udp | Bootstrap Protocol Client | Bill Croft | Bill Croft | ||||||
| rsvd | 168 | tcp | RSVD | Alan Sandell | Alan Sandell | 2008-05-01 | |||||
| rsvd | 168 | udp | RSVD | Alan Sandell | Alan Sandell | 2008-05-01 | |||||
| td-replica | 268 | tcp | Tobit David Replica | Franz-Josef Leuders | Franz-Josef Leuders | ||||||
| td-replica | 268 | udp | Tobit David Replica | Franz-Josef Leuders | Franz-Josef Leuders | ||||||
| pt-tls | 271 | tcp | IETF Network Endpoint Assessment (NEA) Posture Transport Protocol over TLS (PT-TLS) | IESG | IETF Chair | 2012-07-31 | RFC 6876 | ||||
| rpki-rtr | 323 | tcp | Resource PKI to Router Protocol | IESG | IETF Chair | RFC 6810 | |||||
| rpki-rtr-tls | 324 | tcp | Resource PKI to Router Protocol over TLS | IESG | IETF Chair | RFC 6810 | |||||
| qbikgdp | 368 | tcp | QbikGDP | Adrien de Croy | Adrien de Croy | ||||||
| qbikgdp | 368 | udp | QbikGDP | Adrien de Croy | Adrien de Croy | ||||||
| snpp | 444 | tcp | Simple Network Paging Protocol | RFC 1568 | |||||||
| snpp | 444 | udp | Simple Network Paging Protocol | RFC 1568 | |||||||
| photuris | 468 | tcp | proturis | Bill Simpson | Bill Simpson | ||||||
| photuris | 468 | udp | proturis | Bill Simpson | Bill Simpson | ||||||
| ms-shuttle | 568 | tcp | microsoft shuttle | Rudolph Balaz | Rudolph Balaz | ||||||
| ms-shuttle | 568 | udp | microsoft shuttle | Rudolph Balaz | Rudolph Balaz | ||||||
| mecomm | 668 | tcp | MeComm | ||||||||
| mecomm | 668 | udp | MeComm | ||||||||
| entrust-aaas | 680 | tcp | entrust-aaas | ||||||||
| entrust-aaas | 680 | udp | entrust-aaas | ||||||||
| entrust-aams | 681 | tcp | entrust-aams | Adrian Mancini | Adrian Mancini | ||||||
| entrust-aams | 681 | udp | entrust-aams | Adrian Mancini | Adrian Mancini | ||||||
| xfr | 682 | tcp | XFR | Noah Paul | Noah Paul | ||||||
| xfr | 682 | udp | XFR | Noah Paul | Noah Paul | ||||||
| corba-iiop | 683 | tcp | CORBA IIOP | ||||||||
| corba-iiop | 683 | udp | CORBA IIOP | ||||||||
| corba-iiop-ssl | 684 | tcp | CORBA IIOP SSL | Andrew Watson | Andrew Watson | ||||||
| corba-iiop-ssl | 684 | udp | CORBA IIOP SSL | Andrew Watson | Andrew Watson | ||||||
| mdc-portmapper | 685 | tcp | MDC Port Mapper | Noah Paul | Noah Paul | ||||||
| mdc-portmapper | 685 | udp | MDC Port Mapper | Noah Paul | Noah Paul | ||||||
| hcp-wismar | 686 | tcp | Hardware Control Protocol Wismar | David Merchant | David Merchant | ||||||
| hcp-wismar | 686 | udp | Hardware Control Protocol Wismar | David Merchant | David Merchant | ||||||
| asipregistry | 687 | tcp | asipregistry | Erik Sea | Erik Sea | ||||||
| asipregistry | 687 | udp | asipregistry | Erik Sea | Erik Sea | ||||||
| realm-rusd | 688 | tcp | ApplianceWare managment protocol | Stacy Kenworthy | Stacy Kenworthy | ||||||
| realm-rusd | 688 | udp | ApplianceWare managment protocol | Stacy Kenworthy | Stacy Kenworthy | ||||||
| nmap | 689 | tcp | NMAP | Peter Dennis Bartok | Peter Dennis Bartok | ||||||
| nmap | 689 | udp | NMAP | Peter Dennis Bartok | Peter Dennis Bartok | ||||||
| tbrpf | 712 | tcp | TBRPF | RFC 3684 | |||||||
| tbrpf | 712 | udp | TBRPF | RFC 3684 | |||||||
| 768 | Unassigned | ||||||||||
| instl-bootc | 1068 | tcp | Installation Bootstrap Proto. Cli. IANA assigned this well-formed service name as a replacement for "instl_bootc". |
David Arko | David Arko | ||||||
| instl_bootc | 1068 | tcp | Installation Bootstrap Proto. Cli. | David Arko | David Arko | This entry is an alias to "instl-bootc". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| instl-bootc | 1068 | udp | Installation Bootstrap Proto. Cli. IANA assigned this well-formed service name as a replacement for "instl_bootc". |
David Arko | David Arko | ||||||
| instl_bootc | 1068 | udp | Installation Bootstrap Proto. Cli. | David Arko | David Arko | This entry is an alias to "instl-bootc". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| vchat | 1168 | tcp | VChat Conference Service | Andreas Wetzel | Andreas Wetzel | 2002-09 | |||||
| vchat | 1168 | udp | VChat Conference Service | Andreas Wetzel | Andreas Wetzel | 2002-09 | |||||
| propel-msgsys | 1268 | tcp | PROPEL-MSGSYS | Bert Van der Linden | Bert Van der Linden | ||||||
| propel-msgsys | 1268 | udp | PROPEL-MSGSYS | Bert Van der Linden | Bert Van der Linden | ||||||
| screencast | 1368 | tcp | ScreenCast | Bill Tschumy | Bill Tschumy | ||||||
| screencast | 1368 | udp | ScreenCast | Bill Tschumy | Bill Tschumy | ||||||
| csdm | 1468 | tcp | CSDM | Robert Stabl | Robert Stabl | ||||||
| csdm | 1468 | udp | CSDM | Robert Stabl | Robert Stabl | ||||||
| tsspmap | 1568 | tcp | tsspmap | Paul W. Nelson | Paul W. Nelson | ||||||
| tsspmap | 1568 | udp | tsspmap | Paul W. Nelson | Paul W. Nelson | ||||||
| netview-aix-8 | 1668 | tcp | netview-aix-8 | ||||||||
| netview-aix-8 | 1668 | udp | netview-aix-8 | ||||||||
| microcom-sbp | 1680 | tcp | microcom-sbp | Boris B. Maiden | Boris B. Maiden | ||||||
| microcom-sbp | 1680 | udp | microcom-sbp | Boris B. Maiden | Boris B. Maiden | ||||||
| sd-elmd | 1681 | tcp | sd-elmd | Bryan Otey | Bryan Otey | ||||||
| sd-elmd | 1681 | udp | sd-elmd | Bryan Otey | Bryan Otey | ||||||
| lanyon-lantern | 1682 | tcp | lanyon-lantern | Robin Lewis | Robin Lewis | ||||||
| lanyon-lantern | 1682 | udp | lanyon-lantern | Robin Lewis | Robin Lewis | ||||||
| ncpm-hip | 1683 | tcp | ncpm-hip | Ken Hearn | Ken Hearn | ||||||
| ncpm-hip | 1683 | udp | ncpm-hip | Ken Hearn | Ken Hearn | ||||||
| snaresecure | 1684 | tcp | SnareSecure | Marty Batchelder | Marty Batchelder | ||||||
| snaresecure | 1684 | udp | SnareSecure | Marty Batchelder | Marty Batchelder | ||||||
| n2nremote | 1685 | tcp | n2nremote | Kin Chan | Kin Chan | ||||||
| n2nremote | 1685 | udp | n2nremote | Kin Chan | Kin Chan | ||||||
| cvmon | 1686 | tcp | cvmon | Carol Ann Krug | Carol Ann Krug | ||||||
| cvmon | 1686 | udp | cvmon | Carol Ann Krug | Carol Ann Krug | ||||||
| nsjtp-ctrl | 1687 | tcp | nsjtp-ctrl | ||||||||
| nsjtp-ctrl | 1687 | udp | nsjtp-ctrl | ||||||||
| nsjtp-data | 1688 | tcp | nsjtp-data | Orazio Granato | Orazio Granato | ||||||
| nsjtp-data | 1688 | udp | nsjtp-data | Orazio Granato | Orazio Granato | ||||||
| firefox | 1689 | tcp | firefox | Mark S. Edwards | Mark S. Edwards | ||||||
| firefox | 1689 | udp | firefox | Mark S. Edwards | Mark S. Edwards | ||||||
| cft-7 | 1768 | tcp | cft-7 | Martine Marchand | Martine Marchand | ||||||
| cft-7 | 1768 | udp | cft-7 | Martine Marchand | Martine Marchand | ||||||
| viziblebrowser | 1868 | tcp | VizibleBrowser | Jimmy Talbot | Jimmy Talbot | ||||||
| viziblebrowser | 1868 | udp | VizibleBrowser | Jimmy Talbot | Jimmy Talbot | ||||||
| lipsinc | 1968 | tcp | LIPSinc | ||||||||
| lipsinc | 1968 | udp | LIPSinc | ||||||||
| avauthsrvprtcl | 2068 | tcp | Avocent AuthSrv Protocol | Steven W. Clark | Steven W. Clark | ||||||
| avauthsrvprtcl | 2068 | udp | Avocent AuthSrv Protocol | Steven W. Clark | Steven W. Clark | ||||||
| easy-soft-mux | 2168 | tcp | easy-soft Multiplexer | Norbert Kintzler | Norbert Kintzler | 2004-11 | |||||
| easy-soft-mux | 2168 | udp | easy-soft Multiplexer | Norbert Kintzler | Norbert Kintzler | 2004-11 | |||||
| amt | 2268 | tcp | AMT | IESG | IETF Chair | 2004-12 | 2014-12-17 | RFC 7450 | |||
| amt | 2268 | udp | AMT | IESG | IETF Chair | 2004-12 | 2014-12-17 | RFC 7450 | |||
| opentable | 2368 | tcp | OpenTable | Brett Goldstein | Brett Goldstein | ||||||
| opentable | 2368 | udp | OpenTable | Brett Goldstein | Brett Goldstein | ||||||
| qip-msgd | 2468 | tcp | qip_msgd | Mike Morgan | Mike Morgan | ||||||
| qip-msgd | 2468 | udp | qip_msgd | Mike Morgan | Mike Morgan | ||||||
| spamtrap | 2568 | tcp | SPAM TRAP | Charles Bennett | Charles Bennett | 2008-08-29 | |||||
| spamtrap | 2568 | udp | SPAM TRAP | Charles Bennett | Charles Bennett | 2008-08-29 | |||||
| alarm-clock-c | 2668 | tcp | Alarm Clock Client | ||||||||
| alarm-clock-c | 2668 | udp | Alarm Clock Client | ||||||||
| pxc-sapxom | 2680 | tcp | pxc-sapxom | Hideki Kiriyama | Hideki Kiriyama | ||||||
| pxc-sapxom | 2680 | udp | pxc-sapxom | Hideki Kiriyama | Hideki Kiriyama |