Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
owamp-control 861 tcp OWAMP-Control IESG IETF Chair RFC 4656
owamp-test 861 udp OWAMP-Test IESG IETF Chair 2018-12-21 RFC 8545
lecroy-vicp 1861 tcp LeCroy VICP Anthony Cake Anthony Cake
lecroy-vicp 1861 udp LeCroy VICP Anthony Cake Anthony Cake
dialpad-voice2 2861 tcp Dialpad Voice 2 Wongyu Cho Wongyu Cho
dialpad-voice2 2861 udp Dialpad Voice 2 Wongyu Cho Wongyu Cho
winshadow-hd 3861 tcp winShadow Host Discovery Shu-Wei Tan Shu-Wei Tan 2003-03
winshadow-hd 3861 udp winShadow Host Discovery Shu-Wei Tan Shu-Wei Tan 2003-03
canon-mfnp 8610 tcp Canon MFNP Service Ritsuto Sako Ritsuto Sako 2009-05-04
canon-mfnp 8610 udp Canon MFNP Service Ritsuto Sako Ritsuto Sako 2009-05-04
canon-bjnp1 8611 tcp Canon BJNP Port 1 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp1 8611 udp Canon BJNP Port 1 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp2 8612 tcp Canon BJNP Port 2 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp2 8612 udp Canon BJNP Port 2 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp3 8613 tcp Canon BJNP Port 3 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp3 8613 udp Canon BJNP Port 3 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp4 8614 tcp Canon BJNP Port 4 Atsushi Nakamura Atsushi Nakamura 2003-11
canon-bjnp4 8614 udp Canon BJNP Port 4 Atsushi Nakamura Atsushi Nakamura 2003-11
imink 8615 tcp Imink Service Control Canon Inc. Ken'ichi FUJII 2011-10-10
8615 udp Reserved
8616-8664 Unassigned Unauthorized Use Known on ports 8616 and 8617
10861-10879 Unassigned
48557-48618 Unassigned
iqobject 48619 tcp iqobject Bjorn de Bonnenfant Bjorn de Bonnenfant 2003-11
iqobject 48619 udp iqobject Bjorn de Bonnenfant Bjorn de Bonnenfant 2003-11
im tcp Instant Messaging RFC 3861
im udp Instant Messaging RFC 3861
pres tcp Presence RFC 3861
pres udp Presence RFC 3861

Contact Information

Name Organization Contact URI Last Updated
Anthony Cake anthonyrc&lecroy.com
Atsushi Nakamura nakamura.atsushi318&canon.co.jp 2003-11
Bjorn de Bonnenfant bdeb&iqobject.com 2003-11
Canon Inc. fujii.ken-ichi149&canon.co.jp 2011-10-10
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ken'ichi FUJII Canon Inc. fujii.ken-ichi149&canon.co.jp 2011-10-10
Ritsuto Sako sakou.ritsuto&canon.co.jp 2009-05-04
Shu-Wei Tan stan&omnicomtech.com 2003-03
Wongyu Cho wgcho&dialpad.com