Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
discard 9 sctp Discard Randall Stewart Randall Stewart 2022-02-07 RFC 9260
ftp-data 20 sctp FTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260
ftp 21 sctp FTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password> path=<path>
ssh 22 sctp SSH Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password>
http 80 sctp HTTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password> path=<path to document>
npp 92 tcp Network Printing Protocol Louis Mamakos Louis Mamakos
npp 92 udp Network Printing Protocol Louis Mamakos Louis Mamakos
bgp 179 sctp BGP Randall Stewart Randall Stewart 2022-02-07 RFC 9260
osu-nms 192 tcp OSU Network Monitoring System Doug Karl Doug Karl
osu-nms 192 udp OSU Network Monitoring System Doug Karl Doug Karl
synotics-broker 392 tcp SynOptics Port Broker Port Illan Raab Illan Raab
synotics-broker 392 udp SynOptics Port Broker Port Illan Raab Illan Raab
https 443 sctp HTTPS Randall Stewart Randall Stewart 2022-02-07 RFC 9260
ticf-1 492 tcp Transport Independent Convergence for FNA
ticf-1 492 udp Transport Independent Convergence for FNA
eudora-set 592 tcp Eudora Set Randall Gellens Randall Gellens
eudora-set 592 udp Eudora Set Randall Gellens Randall Gellens
hyperwave-isp 692 tcp Hyperwave-ISP Gerald Mesaric Gerald Mesaric
hyperwave-isp 692 udp Hyperwave-ISP Gerald Mesaric Gerald Mesaric
iris-xpcs 714 tcp IRIS over XPCS RFC 4992
iris-xpcs 714 udp IRIS over XPCS RFC 4992
domain-s 853 udp DNS query-response protocol run over DTLS or QUIC IESG IETF Chair 2015-10-08 2022-04-01 RFC 7858; RFC 8094; RFC 9250
rift-lies 914 udp Routing in Fat Trees Link Information Element IESG IETF Chair 2023-02-17 2024-06-07 RFC 9692
rift-ties 915 udp Routing in Fat Trees Topology Information Element IESG IETF Chair 2023-02-17 2024-06-07 RFC 9692
telnets 992 tcp telnet protocol over TLS/SSL
telnets 992 udp telnet protocol over TLS/SSL
exp1 1021 tcp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 udp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 sctp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 dccp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 tcp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 udp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 sctp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 dccp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
obrpd 1092 tcp Open Business Reporting Protocol William Randolph Royere III William Randolph Royere III
obrpd 1092 udp Open Business Reporting Protocol William Randolph Royere III William Randolph Royere III
caids-sensor 1192 tcp caids sensors channel Gregory Hostettler Gregory Hostettler 2004-11
caids-sensor 1192 udp caids sensors channel Gregory Hostettler Gregory Hostettler 2004-11
dsdn 1292 tcp dsdn Stanislaw Skowronek Stanislaw Skowronek
dsdn 1292 udp dsdn Stanislaw Skowronek Stanislaw Skowronek
iclpv-pm 1392 tcp Print Manager
iclpv-pm 1392 udp Print Manager
stone-design-1 1492 tcp stone-design-1 Andrew Stone Andrew Stone
stone-design-1 1492 udp stone-design-1 Andrew Stone Andrew Stone
commonspace 1592 tcp commonspace Rob Chandhok Rob Chandhok
commonspace 1592 udp commonspace Rob Chandhok Rob Chandhok
sstsys-lm 1692 tcp sstsys-lm Yih-Wu Wang Yih-Wu Wang
sstsys-lm 1692 udp sstsys-lm Yih-Wu Wang Yih-Wu Wang
ibm-dt-2 1792 tcp ibm-dt-2 Sam Borman Sam Borman
ibm-dt-2 1792 udp ibm-dt-2 Sam Borman Sam Borman
childkey-ctrl 1892 tcp ChildKey Control Ivan Berardinelli Ivan Berardinelli
childkey-ctrl 1892 udp ChildKey Control Ivan Berardinelli Ivan Berardinelli
can-ferret 1920 tcp IBM Tivoli Directory Service - FERRET Nic Catrambone Nic Catrambone
can-ferret 1920 udp IBM Tivoli Directory Service - FERRET Nic Catrambone Nic Catrambone
noadmin 1921 tcp NoAdmin Martin Bestmann Martin Bestmann
noadmin 1921 udp NoAdmin Martin Bestmann Martin Bestmann
tapestry 1922 tcp Tapestry Ken Oliver Ken Oliver
tapestry 1922 udp Tapestry Ken Oliver Ken Oliver
spice 1923 tcp SPICE Nicholas Chua Nicholas Chua
spice 1923 udp SPICE Nicholas Chua Nicholas Chua
xiip 1924 tcp XIIP Alain Robert Alain Robert
xiip 1924 udp XIIP Alain Robert Alain Robert
discovery-port 1925 tcp Surrogate Discovery Port Keith Thompson Keith Thompson
discovery-port 1925 udp Surrogate Discovery Port Keith Thompson Keith Thompson
egs 1926 tcp Evolution Game Server Simon Butcher Simon Butcher
egs 1926 udp Evolution Game Server Simon Butcher Simon Butcher
videte-cipc 1927 tcp Videte CIPC Port Videte IT Videte IT
videte-cipc 1927 udp Videte CIPC Port Videte IT Videte IT
emsd-port 1928 tcp Expnd Maui Srvr Dscovr Edo Yahav Edo Yahav
emsd-port 1928 udp Expnd Maui Srvr Dscovr Edo Yahav Edo Yahav
bandwiz-system 1929 tcp Bandwiz System - Server Joseph Weihs Joseph Weihs
bandwiz-system 1929 udp Bandwiz System - Server Joseph Weihs Joseph Weihs
stun-p3 1992 tcp cisco STUN Priority 3 port
stun-p3 1992 udp cisco STUN Priority 3 port
ipsendmsg 1992 tcp IPsendmsg Bob Kummerfeld Bob Kummerfeld This entry records an unassigned but widespread use
ipsendmsg 1992 udp IPsendmsg Bob Kummerfeld Bob Kummerfeld This entry records an unassigned but widespread use
descent3 2092 tcp Descent 3 Kevin Bentley Kevin Bentley
descent3 2092 udp Descent 3 Kevin Bentley Kevin Bentley
asdis 2192 tcp ASDIS software management ASDIS Support ASDIS Support 2005-08
asdis 2192 udp ASDIS software management ASDIS Support ASDIS Support 2005-08
mib-streaming 2292 tcp Sonus Element Management Services Linda Lin Linda Lin 2006-08
mib-streaming 2292 udp Sonus Element Management Services Linda Lin Linda Lin 2006-08
tacticalauth 2392 tcp Tactical Auth David Yon David Yon
tacticalauth 2392 udp Tactical Auth David Yon David Yon
groove 2492 tcp GROOVE Ray Ozzie Ray Ozzie
groove 2492 udp GROOVE Ray Ozzie Ray Ozzie
netrek 2592 tcp netrek Al Guetzlaff Al Guetzlaff
netrek 2592 udp netrek Al Guetzlaff Al Guetzlaff
admins-lms 2692 tcp Admins LMS Dagfinn Saether Dagfinn Saether
admins-lms 2692 udp Admins LMS Dagfinn Saether Dagfinn Saether
f5-globalsite 2792 tcp f5-globalsite Christian Saether Christian Saether
f5-globalsite 2792 udp f5-globalsite Christian Saether Christian Saether
snifferdata 2892 tcp SNIFFERDATA Jeff Mangasarian Jeff Mangasarian
snifferdata 2892 udp SNIFFERDATA Jeff Mangasarian Jeff Mangasarian
roboeda 2920 tcp roboEDA Paul Snook Paul Snook
roboeda 2920 udp roboEDA Paul Snook Paul Snook
cesdcdman 2921 tcp CESD Contents Delivery Management Shinya Abe Shinya Abe
cesdcdman 2921 udp CESD Contents Delivery Management Shinya Abe Shinya Abe
cesdcdtrn 2922 tcp CESD Contents Delivery Data Transfer Shinya Abe Shinya Abe
cesdcdtrn 2922 udp CESD Contents Delivery Data Transfer Shinya Abe Shinya Abe

Contact Information

Name Organization Contact URI Last Updated
ASDIS Support support&asdis.de 2005-08
Al Guetzlaff aeg&teamquest.com
Alain Robert Alain.Robert&hmrinc.com
Andrew Stone andrew&stone.com
Bob Kummerfeld bob&sarad.cs.su.oz.au
Christian Saether c.saether&f5.com
Dagfinn Saether Dagfinn&admins.com
David Yon yon&tactical-sw.com
Doug Karl KARL-D&osu-20.ircc.ohio-state.edu
Edo Yahav standards&expand.com
Gerald Mesaric gmesaric&hyperwave.com
Gregory Hostettler ghostettler&caracal.ch 2004-11
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Illan Raab iraab&synoptics.com
Ivan Berardinelli ivan&gestweb.com
Jeff Mangasarian jeffrey_mangasarian&nai.com
Joseph Weihs yossi&bandwiz.com
Keith Thompson keith.thompson&sun.com
Ken Oliver koliver02&yahoo.com
Kevin Bentley Kevin&outrage.com
Linda Lin llin&sonusnet.com 2006-08
Louis Mamakos louie&sayshell.umd.edu
Martin Bestmann martin&datawatch.de
Nic Catrambone ncatramb&us.ibm.com 2003-01
Nicholas Chua nick&sendit.se
Paul Snook paul.snook&itheon.com
Randall Gellens rg+ietf&coretechnologyconsulting.com 2024-07-29
Randall Stewart IETF TSVWG rrs&lakerest.net
Ray Ozzie ray&rocks.net
Rob Chandhok chandhok&within.com
Sam Borman sam_borman&uk.ibm.com
Shinya Abe abeabe&pfu.co.jp
Simon Butcher simonb&alien.net.au
Stanislaw Skowronek thesis&elementary.pl
Videte IT info&videte.com
William Randolph Royere III william&royere.net
Yih-Wu Wang sstsys&ix.netcom.com