Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| ups | 401 | tcp | Uninterruptible Power Supply | Charles Bennett | Charles Bennett | 2008-08-29 | |||||
| ups | 401 | udp | Uninterruptible Power Supply | Charles Bennett | Charles Bennett | 2008-08-29 | |||||
| upsnotifyprot | 2648 | tcp | Upsnotifyprot | Mario Leboute | Mario Leboute | ||||||
| upsnotifyprot | 2648 | udp | Upsnotifyprot | Mario Leboute | Mario Leboute | ||||||
| tmesis-upshot | 2798 | tcp | TMESIS-UPShot | Brian Schenkenberger | Brian Schenkenberger | ||||||
| tmesis-upshot | 2798 | udp | TMESIS-UPShot | Brian Schenkenberger | Brian Schenkenberger | ||||||
| santak-ups | 3038 | tcp | Santak UPS | Tom Liu | Tom Liu | ||||||
| santak-ups | 3038 | udp | Santak UPS | Tom Liu | Tom Liu | ||||||
| nut | 3493 | tcp | Network UPS Tools | Network UPS Tools Project | Evgeny Klimov | 2002-05 | 2022-05-18 | RFC 9271 | |||
| nut | 3493 | udp | Network UPS Tools | Network UPS Tools Project | Evgeny Klimov | 2002-05 | 2020-12-16 | ||||
| apcupsd | 3551 | tcp | Apcupsd Information Port | Riccardo Facchetti | Riccardo Facchetti | 2002-07 | |||||
| apcupsd | 3551 | udp | Apcupsd Information Port | Riccardo Facchetti | Riccardo Facchetti | 2002-07 | |||||
| tag-ups-1 | 3573 | tcp | Advantage Group UPS Suite | James Goddard | James Goddard | 2002-08 | |||||
| tag-ups-1 | 3573 | udp | Advantage Group UPS Suite | James Goddard | James Goddard | 2002-08 | |||||
| ups-engine | 3664 | tcp | UPS Engine Port | ||||||||
| ups-engine | 3664 | udp | UPS Engine Port | ||||||||
| upstriggervsw | 3786 | tcp | VSW Upstrigger port | Mark-Tim Junghanns | Mark-Tim Junghanns | 2003-07 | |||||
| upstriggervsw | 3786 | udp | VSW Upstrigger port | Mark-Tim Junghanns | Mark-Tim Junghanns | 2003-07 | |||||
| boxbackupstore | 4186 | tcp | Box Backup Store Service | Chris Wilson | Chris Wilson | 2008-09-11 | |||||
| mgesupervision | 4679 | tcp | MGE UPS Supervision | ||||||||
| mgesupervision | 4679 | udp | MGE UPS Supervision | ||||||||
| mgemanagement | 4680 | tcp | MGE UPS Management | Lecuivre J | Lecuivre J | 2005-08 | |||||
| mgemanagement | 4680 | udp | MGE UPS Management | Lecuivre J | Lecuivre J | 2005-08 | |||||
| afs3-prserver | 7002 | tcp | users & groups database | Known Unauthorized Use on port 7002 | |||||||
| afs3-prserver | 7002 | udp | users & groups database | Known Unauthorized Use on port 7002 | |||||||
| ups-onlinet | 7010 | tcp | onlinet uninterruptable power supplies | Jim Thompson | Jim Thompson | ||||||
| ups-onlinet | 7010 | udp | onlinet uninterruptable power supplies | Jim Thompson | Jim Thompson |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Brian Schenkenberger | VAXman&tmesis.com | ||
| Charles Bennett | bennettc&ohio.edu | 2008-08-29 | |
| Chris Wilson | chris+iana&qwirx.com | 2008-09-11 | |
| Evgeny Klimov | jimklimov+nut&gmail.com | 2020-12-16 | |
| James Goddard | jamesg&taglim.com | 2005-08 | |
| Jim Thompson | jim.thompson&powerware.com | ||
| Lecuivre J | software.team&mgeups.com | 2005-08 | |
| Mario Leboute | leboute&pro.via-rs.com.br | ||
| Mark-Tim Junghanns | mjunghanns&vangerow.de | 2003-07 | |
| Network UPS Tools Project | iana&networkupstools.org | 2020-12-16 | |
| Riccardo Facchetti | riccardo&inetcosmos.org | 2002-07 | |
| Tom Liu | ssc&sc.stk.com.cn |