Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
0 tcp Reserved 2024-12-20 RFC 6335
0 udp Reserved 2024-12-20 RFC 6335
2 tcp Reserved 2025-02-13 De-assigned on 2025-02-13, previously compressnet by Bernie Volz
2 udp Reserved 2025-02-13 De-assigned on 2025-02-13, previously compressnet by Bernie Volz
3 tcp Reserved 2025-02-13 De-assigned on 2025-02-13, previously compressnet by Bernie Volz
3 udp Reserved 2025-02-13 De-assigned on 2025-02-13, previously compressnet by Bernie Volz
discard 9 sctp Discard Randall Stewart Randall Stewart 2022-02-07 RFC 9260
discard 9 dccp Discard Eddie Kohler Eddie Kohler RFC 4340 1145656131
10 tcp Unassigned
10 udp Unassigned
ftp-data 20 tcp File Transfer [Default Data] Jon Postel Jon Postel
ftp-data 20 udp File Transfer [Default Data] Jon Postel Jon Postel
ftp-data 20 sctp FTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260
ftp 21 sctp FTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password> path=<path>
ssh 22 sctp SSH Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password>
30 tcp Unassigned
30 udp Unassigned
40 tcp Unassigned
40 udp Unassigned
47 tcp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
47 udp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
re-mail-ck 50 tcp Remote Mail Checking Protocol Steve Dorner Steve Dorner
re-mail-ck 50 udp Remote Mail Checking Protocol Steve Dorner Steve Dorner
51 Reserved 2013-05-24 This entry is being removed on 2013-05-24.
60 tcp Unassigned
60 udp Unassigned
61 tcp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
61 udp Reserved 2017-05-18 This entry has been removed on 2017-05-18.
gopher 70 tcp Gopher Mark McCahill Mark McCahill
gopher 70 udp Gopher Mark McCahill Mark McCahill
http 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
http 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 Defined TXT keys: u=<username> p=<password> path=<path to document>
www 80 tcp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
www 80 udp World Wide Web HTTP IESG IETF Chair 2021-10-01 RFC 9110 This is a duplicate of the "http" service and should not be used for discovery purposes.
www-http 80 tcp World Wide Web HTTP Tim Berners-Lee Tim Berners-Lee This is a duplicate of the "http" service and should not be used for discovery purposes. u=<username> p=<password> path=<path to document> (see txtrecords.html#http) Known Subtypes: _printer NOTE: The meaning of this service type, though called just "http", actually denotes something more precise than just "any data transported using HTTP". The DNS-SD service type "http" should only be used to advertise content that: * is served over HTTP, * can be displayed by "typical" web browser client software, and * is intented primarily to be viewed by a human user. Of course, the definition of "typical web browser" is subjective, and may change over time, but for practical purposes the DNS-SD service type "http" can be understood as meaning "human-readable HTML content served over HTTP". In some cases other widely-supported content types may also be appropriate, such as plain text over HTTP, or JPEG image over HTTP. Content types not intented primarily for viewing by a human user, or not widely-supported in web browsing clients, should not be advertised as DNS-SD service type "http", even if they do happen to be transported over HTTP. Such types should be advertised as their own logical service type with their own DNS-SD service type, for example, XUL (XML User Interface Language) transported over HTTP is advertised explicitly as DNS-SD service type "xul-http".
www-http 80 udp World Wide Web HTTP Tim Berners-Lee Tim Berners-Lee This is a duplicate of the "http" service and should not be used for discovery purposes. u=<username> p=<password> path=<path to document> (see txtrecords.html#http) Known Subtypes: _printer NOTE: The meaning of this service type, though called just "http", actually denotes something more precise than just "any data transported using HTTP". The DNS-SD service type "http" should only be used to advertise content that: * is served over HTTP, * can be displayed by "typical" web browser client software, and * is intented primarily to be viewed by a human user. Of course, the definition of "typical web browser" is subjective, and may change over time, but for practical purposes the DNS-SD service type "http" can be understood as meaning "human-readable HTML content served over HTTP". In some cases other widely-supported content types may also be appropriate, such as plain text over HTTP, or JPEG image over HTTP. Content types not intented primarily for viewing by a human user, or not widely-supported in web browsing clients, should not be advertised as DNS-SD service type "http", even if they do happen to be transported over HTTP. Such types should be advertised as their own logical service type with their own DNS-SD service type, for example, XUL (XML User Interface Language) transported over HTTP is advertised explicitly as DNS-SD service type "xul-http".
http 80 sctp HTTP Randall Stewart Randall Stewart 2022-02-07 RFC 9260 Defined TXT keys: u=<username> p=<password> path=<path to document>
kerberos 88 tcp Kerberos B. Clifford Neuman B. Clifford Neuman 2022-02-18 RFC 4120
kerberos 88 udp Kerberos B. Clifford Neuman B. Clifford Neuman 2022-02-18 RFC 4120
dnsix 90 tcp DNSIX Securit Attribute Token Map Charles Watt Charles Watt PORT 90 also being used unofficially by Pointcast
dnsix 90 udp DNSIX Securit Attribute Token Map Charles Watt Charles Watt PORT 90 also being used unofficially by Pointcast
100 Unassigned 2012-03-21 Known Unauthorized Use on 100
hostname 101 tcp NIC Host Name Server Jon Postel Jon Postel
hostname 101 udp NIC Host Name Server Jon Postel Jon Postel
iso-tsap 102 tcp ISO-TSAP Class 0 Marshall Rose Marshall Rose
iso-tsap 102 udp ISO-TSAP Class 0 Marshall Rose Marshall Rose
gppitnp 103 tcp Genesis Point-to-Point Trans Net
gppitnp 103 udp Genesis Point-to-Point Trans Net
acr-nema 104 tcp ACR-NEMA Digital Imag. & Comm. 300 Patrick McNamee Patrick McNamee
acr-nema 104 udp ACR-NEMA Digital Imag. & Comm. 300 Patrick McNamee Patrick McNamee
cso 105 tcp CCSO name server protocol Martin Hamilton Martin Hamilton
cso 105 udp CCSO name server protocol Martin Hamilton Martin Hamilton
csnet-ns 105 tcp Mailbox Name Nameserver Marvin Solomon Marvin Solomon
csnet-ns 105 udp Mailbox Name Nameserver Marvin Solomon Marvin Solomon
3com-tsmux 106 tcp 3COM-TSMUX Jeremy Siegel Jeremy Siegel Known Unauthorized Use on 106
3com-tsmux 106 udp 3COM-TSMUX Jeremy Siegel Jeremy Siegel Known Unauthorized Use on 106
rtelnet 107 tcp Remote Telnet Service Jon Postel Jon Postel
rtelnet 107 udp Remote Telnet Service Jon Postel Jon Postel
snagas 108 tcp SNA Gateway Access Server Kevin Murphy Kevin Murphy
snagas 108 udp SNA Gateway Access Server Kevin Murphy Kevin Murphy
pop2 109 tcp Post Office Protocol - Version 2 Joyce K. Reynolds Joyce K. Reynolds
pop2 109 udp Post Office Protocol - Version 2 Joyce K. Reynolds Joyce K. Reynolds
pop3 110 tcp Post Office Protocol - Version 3 Marshall Rose Marshall Rose
pop3 110 udp Post Office Protocol - Version 3 Marshall Rose Marshall Rose
114 unassigned Deprecated June 2004
cfdptkt 120 tcp CFDPTKT John Ioannidis John Ioannidis
cfdptkt 120 udp CFDPTKT John Ioannidis John Ioannidis
ntp 123 tcp Network Time Protocol Dave Mills Dave Mills RFC 5905
ntp 123 udp Network Time Protocol Dave Mills Dave Mills RFC 5905
cisco-fna 130 tcp cisco FNATIVE
cisco-fna 130 udp cisco FNATIVE
emfis-data 140 tcp EMFIS Data Service
emfis-data 140 udp EMFIS Data Service
imap 143 tcp Internet Message Access Protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 9051
143 udp Reserved 2021-02-22 RFC 9051
iso-tp0 146 tcp ISO-IP0
iso-tp0 146 udp ISO-IP0
sql-net 150 tcp SQL-NET Martin Picard Martin Picard
sql-net 150 udp SQL-NET Martin Picard Martin Picard
sgmp-traps 160 tcp SGMP-TRAPS Marty Schoffstahl Marty Schoffstahl
sgmp-traps 160 udp SGMP-TRAPS Marty Schoffstahl Marty Schoffstahl
print-srv 170 tcp Network PostScript Brian Reid Brian Reid
print-srv 170 udp Network PostScript Brian Reid Brian Reid
bgp 179 sctp BGP Randall Stewart Randall Stewart 2022-02-07 RFC 9260
ris 180 tcp Intergraph Dave Buehmann Dave Buehmann
ris 180 udp Intergraph Dave Buehmann Dave Buehmann
gacp 190 tcp Gateway Access Control Protocol C. Philip Wood C. Philip Wood
gacp 190 udp Gateway Access Control Protocol C. Philip Wood C. Philip Wood
src 200 tcp IBM System Resource Controller Gerald McBrearty Gerald McBrearty
src 200 udp IBM System Resource Controller Gerald McBrearty Gerald McBrearty
at-rtmp 201 tcp AppleTalk Routing Maintenance
at-rtmp 201 udp AppleTalk Routing Maintenance
at-nbp 202 tcp AppleTalk Name Binding
at-nbp 202 udp AppleTalk Name Binding
at-3 203 tcp AppleTalk Unused
at-3 203 udp AppleTalk Unused
at-echo 204 tcp AppleTalk Echo
at-echo 204 udp AppleTalk Echo
at-5 205 tcp AppleTalk Unused
at-5 205 udp AppleTalk Unused

Contact Information

Name Organization Contact URI Last Updated
B. Clifford Neuman bcn&isi.edu 2022-02-18
Bernie Volz volz&cisco.com
Brian Reid reid&decwrl.dec.com
C. Philip Wood cpw&lanl.gov
Charles Watt watt&sware.com
Dave Buehmann ingr!daveb&uunet.uu.net
Dave Mills mills&udel.edu 2022-06-03
Eddie Kohler IETF dccp WG kohler&cs.ucla.edu
Gerald McBrearty
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jeremy Siegel jzs&nsd.3com.com
John Ioannidis ji&close.cs.columbia.ed
Jon Postel postel&isi.edu
Joyce K. Reynolds jkrey&isi.edu
Kevin Murphy murphy&sevens.lkg.dec.com
Mark McCahill mpm&boombox.micro.umn.edu
Marshall Rose mrose17&gmail.com 2024-07-29
Martin Hamilton martin&mrrl.lut.as.uk
Martin Picard
Marty Schoffstahl schoff&nisc.nyser.net
Marvin Solomon solomon&cs.wisc.edu
Patrick McNamee
Randall Stewart IETF TSVWG rrs&lakerest.net
Steve Dorner s-dorner&uiuc.edu
Tim Berners-Lee timbl&w3.org