Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| dectalk | 2007 | tcp | |||||||||
| raid-am | 2007 | udp | |||||||||
| conf | 2008 | tcp | |||||||||
| terminaldb | 2008 | udp | |||||||||
| news | 2009 | tcp | |||||||||
| whosockami | 2009 | udp | |||||||||
| search | 2010 | tcp | |||||||||
| pipe-server | 2010 | udp | IANA assigned this well-formed service name as a replacement for "pipe_server". | ||||||||
| pipe_server | 2010 | udp | This entry is an alias to "pipe-server". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||||||
| raid-cc | 2011 | tcp | raid | ||||||||
| servserv | 2011 | udp | |||||||||
| ttyinfo | 2012 | tcp | |||||||||
| raid-ac | 2012 | udp | |||||||||
| raid-am | 2013 | tcp | |||||||||
| raid-cd | 2013 | udp | |||||||||
| troff | 2014 | tcp | |||||||||
| raid-sf | 2014 | udp | |||||||||
| cypress | 2015 | tcp | |||||||||
| raid-cs | 2015 | udp | |||||||||
| bootserver | 2016 | tcp | |||||||||
| bootserver | 2016 | udp | |||||||||
| cypress-stat | 2017 | tcp | |||||||||
| bootclient | 2017 | udp | |||||||||
| terminaldb | 2018 | tcp | |||||||||
| rellpack | 2018 | udp | |||||||||
| whosockami | 2019 | tcp | |||||||||
| about | 2019 | udp | |||||||||
| xinupageserver | 2020 | tcp | |||||||||
| xinupageserver | 2020 | udp | |||||||||
| servexec | 2021 | tcp | |||||||||
| xinuexpansion1 | 2021 | udp | |||||||||
| down | 2022 | tcp | |||||||||
| xinuexpansion2 | 2022 | udp | |||||||||
| xinuexpansion3 | 2023 | tcp | |||||||||
| xinuexpansion3 | 2023 | udp | |||||||||
| xinuexpansion4 | 2024 | tcp | |||||||||
| xinuexpansion4 | 2024 | udp | |||||||||
| ellpack | 2025 | tcp | |||||||||
| xribs | 2025 | udp | |||||||||
| scrabble | 2026 | tcp | |||||||||
| scrabble | 2026 | udp | |||||||||
| shadowserver | 2027 | tcp | |||||||||
| shadowserver | 2027 | udp | |||||||||
| submitserver | 2028 | tcp | |||||||||
| submitserver | 2028 | udp | |||||||||
| hsrpv6 | 2029 | tcp | Hot Standby Router Protocol IPv6 | Ian Wilson | Ian Wilson | 2004-11 | |||||
| hsrpv6 | 2029 | udp | Hot Standby Router Protocol IPv6 | Ian Wilson | Ian Wilson | 2004-11 | |||||
| device2 | 2030 | tcp | |||||||||
| device2 | 2030 | udp | |||||||||
| mobrien-chat | 2031 | tcp | mobrien-chat | Mike O'Brien | Mike O'Brien | 2004-11 | |||||
| mobrien-chat | 2031 | udp | mobrien-chat | Mike O'Brien | Mike O'Brien | 2004-11 | |||||
| blackboard | 2032 | tcp | |||||||||
| blackboard | 2032 | udp | |||||||||
| glogger | 2033 | tcp | |||||||||
| glogger | 2033 | udp | |||||||||
| scoremgr | 2034 | tcp | |||||||||
| scoremgr | 2034 | udp | |||||||||
| imsldoc | 2035 | tcp | |||||||||
| imsldoc | 2035 | udp | |||||||||
| e-dpnet | 2036 | tcp | Ethernet WS DP network | Peter Kaever | Peter Kaever | 2005-08 | |||||
| e-dpnet | 2036 | udp | Ethernet WS DP network | Peter Kaever | Peter Kaever | 2005-08 | |||||
| applus | 2037 | tcp | APplus Application Server | Alfred Weindl | Marcus Schairer | 2008-06-06 | 2021-07-20 | Unauthorized Use Known on port 2037 | Formerly was P2plus Application Server | ||
| applus | 2037 | udp | APplus Application Server | Alfred Weindl | Marcus Schairer | 2008-06-06 | 2021-07-20 | Unauthorized Use Known on port 2037 | Formerly was P2plus Application Server | ||
| objectmanager | 2038 | tcp | |||||||||
| objectmanager | 2038 | udp | |||||||||
| prizma | 2039 | tcp | Prizma Monitoring Service | Dotan Ofek | Dotan Ofek | 2005-12 | |||||
| prizma | 2039 | udp | Prizma Monitoring Service | Dotan Ofek | Dotan Ofek | 2005-12 | |||||
| lam | 2040 | tcp | |||||||||
| lam | 2040 | udp | |||||||||
| interbase | 2041 | tcp | |||||||||
| interbase | 2041 | udp | |||||||||
| isis | 2042 | tcp | isis | ||||||||
| isis | 2042 | udp | isis | ||||||||
| isis-bcast | 2043 | tcp | isis-bcast | Ken Chapman | Ken Chapman | ||||||
| isis-bcast | 2043 | udp | isis-bcast | Ken Chapman | Ken Chapman | ||||||
| rimsl | 2044 | tcp | |||||||||
| rimsl | 2044 | udp | |||||||||
| cdfunc | 2045 | tcp | |||||||||
| cdfunc | 2045 | udp | |||||||||
| sdfunc | 2046 | tcp | |||||||||
| sdfunc | 2046 | udp | |||||||||
| dls | 2047 | tcp | |||||||||
| dls | 2047 | udp | |||||||||
| dls-monitor | 2048 | tcp | |||||||||
| dls-monitor | 2048 | udp | |||||||||
| shilp | 2049 | tcp | <== NOTE Conflict on 2049 ! | ||||||||
| shilp | 2049 | udp | <== NOTE Conflict on 2049 ! | ||||||||
| nfs | 2049 | tcp | Network File System - Sun Microsystems | Brent Callaghan | Brent Callaghan | Defined TXT keys: path=<path to mount point> | |||||
| nfs | 2049 | udp | Network File System - Sun Microsystems | Brent Callaghan | Brent Callaghan | Defined TXT keys: path=<path to mount point> | |||||
| nfs | 2049 | sctp | Network File System | RFC 5665 | Defined TXT keys: path=<path to mount point> | ||||||
| av-emb-config | 2050 | tcp | Avaya EMB Config Port | John Yeager | John Yeager | ||||||
| av-emb-config | 2050 | udp | Avaya EMB Config Port | John Yeager | John Yeager | ||||||
| epnsdp | 2051 | tcp | EPNSDP | Hiroyasu Ogata | Hiroyasu Ogata | ||||||
| epnsdp | 2051 | udp | EPNSDP | Hiroyasu Ogata | Hiroyasu Ogata | ||||||
| clearvisn | 2052 | tcp | clearVisn Services Port | Dave Lyons | Dave Lyons | ||||||
| clearvisn | 2052 | udp | clearVisn Services Port | Dave Lyons | Dave Lyons | ||||||
| lot105-ds-upd | 2053 | tcp | Lot105 DSuper Updates | Piers Scannell | Piers Scannell | ||||||
| lot105-ds-upd | 2053 | udp | Lot105 DSuper Updates | Piers Scannell | Piers Scannell | ||||||
| weblogin | 2054 | tcp | Weblogin Port | Diego Saravia | Diego Saravia | ||||||
| weblogin | 2054 | udp | Weblogin Port | Diego Saravia | Diego Saravia | ||||||
| iop | 2055 | tcp | Iliad-Odyssey Protocol | Bruce Lueckenhoff | Bruce Lueckenhoff |
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| Alfred Weindl | alfred.weindl&assecosol.com | 2021-08-09 |
| Brent Callaghan | brent&terra.eng.sun.com | |
| Bruce Lueckenhoff | brucelu&cisco.com | |
| Dave Lyons | dlyons&dnpg.com | |
| Diego Saravia | dsa&unsa.edu.ar | |
| Dotan Ofek | dotan.ofek&prizmasoft.com | 2005-12 |
| Hiroyasu Ogata | Ogata.Hiroyasu&exc.epson.co.jp | |
| Ian Wilson | hsrp-info&cisco.com | 2004-11 |
| John Yeager | johnyeager&avaya.com | |
| Ken Chapman | kchapman&isis.com | |
| Marcus Schairer | marcus.schairer&assecosol.com | 2021-08-09 |
| Mike O'Brien | mike&mobrien.com | 2004-11 |
| Peter Kaever | kaever.peter&westfalia.com | 2005-08 |
| Piers Scannell | iana-form&lot105.com |