Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
iop 2055 tcp Iliad-Odyssey Protocol Bruce Lueckenhoff Bruce Lueckenhoff
iop 2055 udp Iliad-Odyssey Protocol Bruce Lueckenhoff Bruce Lueckenhoff
omnisky 2056 tcp OmniSky Port Oren Hurvitz Oren Hurvitz
omnisky 2056 udp OmniSky Port Oren Hurvitz Oren Hurvitz
rich-cp 2057 tcp Rich Content Protocol Ronen Vainish Ronen Vainish
rich-cp 2057 udp Rich Content Protocol Ronen Vainish Ronen Vainish
newwavesearch 2058 tcp NewWaveSearchables RMI Thomas Kerkau Thomas Kerkau
newwavesearch 2058 udp NewWaveSearchables RMI Thomas Kerkau Thomas Kerkau
bmc-messaging 2059 tcp BMC Messaging Service Portnoy Boxman Portnoy Boxman
bmc-messaging 2059 udp BMC Messaging Service Portnoy Boxman Portnoy Boxman
teleniumdaemon 2060 tcp Telenium Daemon IF Nick Woronuk Nick Woronuk
teleniumdaemon 2060 udp Telenium Daemon IF Nick Woronuk Nick Woronuk
netmount 2061 tcp NetMount Alex Oberlander Alex Oberlander
netmount 2061 udp NetMount Alex Oberlander Alex Oberlander
icg-swp 2062 tcp ICG SWP Port
icg-swp 2062 udp ICG SWP Port
icg-bridge 2063 tcp ICG Bridge Port
icg-bridge 2063 udp ICG Bridge Port
icg-iprelay 2064 tcp ICG IP Relay Port Steve Quintana Steve Quintana
icg-iprelay 2064 udp ICG IP Relay Port Steve Quintana Steve Quintana
dlsrpn 2065 tcp Data Link Switch Read Port Number Amir Peless Amir Peless
dlsrpn 2065 udp Data Link Switch Read Port Number Amir Peless Amir Peless
aura 2066 tcp AVM USB Remote Architecture Diego Friedel Diego Friedel 2006-03
aura 2066 udp AVM USB Remote Architecture Diego Friedel Diego Friedel 2006-03
dlswpn 2067 tcp Data Link Switch Write Port Number Amir Peless Amir Peless
dlswpn 2067 udp Data Link Switch Write Port Number Amir Peless Amir Peless
avauthsrvprtcl 2068 tcp Avocent AuthSrv Protocol Steven W. Clark Steven W. Clark
avauthsrvprtcl 2068 udp Avocent AuthSrv Protocol Steven W. Clark Steven W. Clark
event-port 2069 tcp HTTP Event Port Larry Emlich Larry Emlich
event-port 2069 udp HTTP Event Port Larry Emlich Larry Emlich
ah-esp-encap 2070 tcp AH and ESP Encapsulated in UDP packet Amy Weaver Amy Weaver
ah-esp-encap 2070 udp AH and ESP Encapsulated in UDP packet Amy Weaver Amy Weaver
acp-port 2071 tcp Axon Control Protocol Christiaan Simons Christiaan Simons
acp-port 2071 udp Axon Control Protocol Christiaan Simons Christiaan Simons
msync 2072 tcp GlobeCast mSync Piers Scannell Piers Scannell
msync 2072 udp GlobeCast mSync Piers Scannell Piers Scannell
gxs-data-port 2073 tcp DataReel Database Socket Douglas M. Gaer Douglas M. Gaer
gxs-data-port 2073 udp DataReel Database Socket Douglas M. Gaer Douglas M. Gaer
vrtl-vmf-sa 2074 tcp Vertel VMF SA Alan Akahoshi Alan Akahoshi
vrtl-vmf-sa 2074 udp Vertel VMF SA Alan Akahoshi Alan Akahoshi
newlixengine 2075 tcp Newlix ServerWare Engine
newlixengine 2075 udp Newlix ServerWare Engine
newlixconfig 2076 tcp Newlix JSPConfig Jean-Serge Gagnon Jean-Serge Gagnon
newlixconfig 2076 udp Newlix JSPConfig Jean-Serge Gagnon Jean-Serge Gagnon
tsrmagt 2077 tcp Old Tivoli Storage Manager
tsrmagt 2077 udp Old Tivoli Storage Manager
tpcsrvr 2078 tcp IBM Total Productivity Center Server Justin R. Bendich Justin R. Bendich
tpcsrvr 2078 udp IBM Total Productivity Center Server Justin R. Bendich Justin R. Bendich
idware-router 2079 tcp IDWARE Router Port Zdenek Kolba Zdenek Kolba
idware-router 2079 udp IDWARE Router Port Zdenek Kolba Zdenek Kolba
autodesk-nlm 2080 tcp Autodesk NLM (FLEXlm) Greg Suppes Greg Suppes
autodesk-nlm 2080 udp Autodesk NLM (FLEXlm) Greg Suppes Greg Suppes
kme-trap-port 2081 tcp KME PRINTER TRAP PORT Masakatsu Matsuo Masakatsu Matsuo
kme-trap-port 2081 udp KME PRINTER TRAP PORT Masakatsu Matsuo Masakatsu Matsuo
infowave 2082 tcp Infowave Mobility Server Kaz Kylheku Kaz Kylheku
infowave 2082 udp Infowave Mobility Server Kaz Kylheku Kaz Kylheku
radsec 2083 tcp Secure Radius Service IESG IETF Chair 2005-05 RFC 6614 The TCP port 2083 was already previously assigned by IANA for "RadSec", an early implementation of RADIUS/TLS, prior to issuance of this RFC. This early implementation can be configured to be compatible to RADIUS/TLS as specified by the IETF. See RFC 6614, Appendix A for details.
radsec 2083 udp Secure Radius Service IESG IETF Chair 2005-05 2014-07-14 RFC 7360 The UDP port 2083 was already previously assigned by IANA for "RadSec", an early implementation of RADIUS/TLS, prior to issuance of this RFC.
sunclustergeo 2084 tcp SunCluster Geographic Oracle Corporation Steve McKinty 2005-11 2013-08-14
sunclustergeo 2084 udp SunCluster Geographic Oracle Corporation Steve McKinty 2005-11 2013-08-14
ada-cip 2085 tcp ADA Control Eugene Frenkel Eugene Frenkel 2005-11
ada-cip 2085 udp ADA Control Eugene Frenkel Eugene Frenkel 2005-11
gnunet 2086 tcp GNUnet Christian Grothoff Christian Grothoff 2002-10
gnunet 2086 udp GNUnet Christian Grothoff Christian Grothoff 2002-10
eli 2087 tcp ELI - Event Logging Integration Maya Zimerman Maya Zimerman
eli 2087 udp ELI - Event Logging Integration Maya Zimerman Maya Zimerman
ip-blf 2088 tcp IP Busy Lamp Field Jeffrey Szczepanski Jeffrey Szczepanski 2005-02
ip-blf 2088 udp IP Busy Lamp Field Jeffrey Szczepanski Jeffrey Szczepanski 2005-02
sep 2089 tcp Security Encapsulation Protocol - SEP Maya Zimerman Maya Zimerman
sep 2089 udp Security Encapsulation Protocol - SEP Maya Zimerman Maya Zimerman
lrp 2090 tcp Load Report Protocol Amir Peless Amir Peless
lrp 2090 udp Load Report Protocol Amir Peless Amir Peless
prp 2091 tcp PRP Amir Peless Amir Peless
prp 2091 udp PRP Amir Peless Amir Peless
descent3 2092 tcp Descent 3 Kevin Bentley Kevin Bentley
descent3 2092 udp Descent 3 Kevin Bentley Kevin Bentley
nbx-cc 2093 tcp NBX CC
nbx-cc 2093 udp NBX CC
nbx-au 2094 tcp NBX AU
nbx-au 2094 udp NBX AU
nbx-ser 2095 tcp NBX SER
nbx-ser 2095 udp NBX SER
nbx-dir 2096 tcp NBX DIR Henry Houh Henry Houh
nbx-dir 2096 udp NBX DIR Henry Houh Henry Houh
jetformpreview 2097 tcp Jet Form Preview Zygmunt Wiercioch Zygmunt Wiercioch
jetformpreview 2097 udp Jet Form Preview Zygmunt Wiercioch Zygmunt Wiercioch
dialog-port 2098 tcp Dialog Port Joseph Mathew Joseph Mathew
dialog-port 2098 udp Dialog Port Joseph Mathew Joseph Mathew
h2250-annex-g 2099 tcp H.225.0 Annex G Signalling ITU-T ITU-T TSB 2013-01-31
h2250-annex-g 2099 udp H.225.0 Annex G Signalling ITU-T ITU-T TSB 2013-01-31
amiganetfs 2100 tcp Amiga Network Filesystem Rudi Chiarito Rudi Chiarito
amiganetfs 2100 udp Amiga Network Filesystem Rudi Chiarito Rudi Chiarito
rtcm-sc104 2101 tcp rtcm-sc104 Wolfgang Rupprecht Wolfgang Rupprecht
rtcm-sc104 2101 udp rtcm-sc104 Wolfgang Rupprecht Wolfgang Rupprecht
zephyr-srv 2102 tcp Zephyr server
zephyr-srv 2102 udp Zephyr server
zephyr-clt 2103 tcp Zephyr serv-hm connection
zephyr-clt 2103 udp Zephyr serv-hm connection
zephyr-hm 2104 tcp Zephyr hostmanager Greg Hudson Greg Hudson
zephyr-hm 2104 udp Zephyr hostmanager Greg Hudson Greg Hudson
minipay 2105 tcp MiniPay Amir Herzberg Amir Herzberg

Contact Information

Name Organization Contact URI Last Updated
Alan Akahoshi alan-akahoshi&vertel.com
Alex Oberlander alexo&netmount.com
Amir Herzberg amirh&vnet.ibm.com
Amir Peless amirp&radware.co.il
Amy Weaver aweaver&vpnet.com
Bruce Lueckenhoff brucelu&cisco.com
Christiaan Simons christiaan.simons&axon.nl
Christian Grothoff grothoff&gnunet.org 2017-11-16
Diego Friedel d.friedel&avm.de 2006-03
Douglas M. Gaer doug&datareel.com
Eugene Frenkel eugene&ada-usa.com 2005-11
Greg Hudson zephyr-bugs&mit.edu
Greg Suppes greg.suppes&autodesk.com
Henry Houh hhouh&nbxcorp.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
ITU-T tsbsg16&itu.int 2013-01-31
ITU-T TSB ITU-T tsbsg16&itu.int 2013-01-31
Jean-Serge Gagnon jean-serge.gagnon&newlix.com
Jeffrey Szczepanski jrs&inscitek.com 2005-02
Joseph Mathew mjoseph&dosa.cisco.com
Justin R. Bendich jbendich&us.ibm.com
Kaz Kylheku kkylheku&infowave.com
Kevin Bentley Kevin&outrage.com
Larry Emlich larry.emlich&compaq.com
Masakatsu Matsuo masa&sdsft.kme.mei.co.jp
Maya Zimerman mayaz&radware.co.il
Nick Woronuk nick.woronuk&megasys.com
Oracle Corporation steve.mckinty&oracle.com 2013-08-14
Oren Hurvitz oren&omnisky.com
Piers Scannell piers&globecastne.com
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Ronen Vainish ronen&digitalfountain.com
Rudi Chiarito nutello&sweetness.com
Steve McKinty Oracle Corporation steve.mckinty&oracle.com 2013-08-14
Steve Quintana steve&icgresearch.com
Steven W. Clark sclark&equinox.com
Thomas Kerkau Thomas.Kerkau&io-software.com
Wolfgang Rupprecht wolfgang&wsrcc.com
Zdenek Kolba zdenek.kolba&id-karta.cz
Zygmunt Wiercioch zyg&jetform.com