Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
minipay 2105 tcp MiniPay Amir Herzberg Amir Herzberg
minipay 2105 udp MiniPay Amir Herzberg Amir Herzberg
mzap 2106 tcp MZAP Dave Thaler Dave Thaler
mzap 2106 udp MZAP Dave Thaler Dave Thaler
bintec-admin 2107 tcp BinTec Admin Thomas Schmidt Thomas Schmidt
bintec-admin 2107 udp BinTec Admin Thomas Schmidt Thomas Schmidt
comcam 2108 tcp Comcam Don Gilbreath Don Gilbreath
comcam 2108 udp Comcam Don Gilbreath Don Gilbreath
ergolight 2109 tcp Ergolight Jindra Ryvola Jindra Ryvola
ergolight 2109 udp Ergolight Jindra Ryvola Jindra Ryvola
umsp 2110 tcp UMSP Alexander Bogdanov Alexander Bogdanov
umsp 2110 udp UMSP Alexander Bogdanov Alexander Bogdanov
qencp 2120 tcp Quick Eagle Networks CP Santa Dasu Santa Dasu
qencp 2120 udp Quick Eagle Networks CP Santa Dasu Santa Dasu
xds 2130 tcp XDS Peter Zurich Peter Zurich
xds 2130 udp XDS Peter Zurich Peter Zurich
ias-reg 2140 tcp IAS-REG
ias-reg 2140 udp IAS-REG
tdmoip 2142 tcp TDM OVER IP Yaakov Stein Yaakov Stein 2016-09-21 RFC 5087
tdmoip 2142 udp TDM OVER IP Yaakov Stein Yaakov Stein 2016-09-21 RFC 5087
dynamic3d 2150 tcp DYNAMIC3D Tobias Wegner Tobias Wegner
dynamic3d 2150 udp DYNAMIC3D Tobias Wegner Tobias Wegner
apc-2160 2160 tcp APC 2160 American Power Conversion American Power Conversion
apc-2160 2160 udp APC 2160 American Power Conversion American Power Conversion
eyetv 2170 tcp EyeTV Server Port Elgato Systems Elgato Systems 2004-11
eyetv 2170 udp EyeTV Server Port Elgato Systems Elgato Systems 2004-11
mc-gt-srv 2180 tcp Millicent Vendor Gateway Server Steve Glassman Steve Glassman
mc-gt-srv 2180 udp Millicent Vendor Gateway Server Steve Glassman Steve Glassman
tivoconnect 2190 tcp TiVoConnect Beacon Jeffrey J. Peters Jeffrey J. Peters 2002-08
tivoconnect 2190 udp TiVoConnect Beacon Jeffrey J. Peters Jeffrey J. Peters 2002-08
2200 tcp Reserved This entry has been removed on 2019-07-05.
2200 udp Reserved This entry has been removed on 2019-07-05.
ats 2201 tcp Advanced Training System Program
ats 2201 udp Advanced Training System Program
imtc-map 2202 tcp Int. Multimedia Teleconferencing Cosortium Pat Galvin Pat Galvin
imtc-map 2202 udp Int. Multimedia Teleconferencing Cosortium Pat Galvin Pat Galvin
b2-runtime 2203 tcp b2 Runtime Protocol
b2-runtime 2203 udp b2 Runtime Protocol
b2-license 2204 tcp b2 License Server Helge-Frank Zimpel Helge-Frank Zimpel 2006-01
b2-license 2204 udp b2 License Server Helge-Frank Zimpel Helge-Frank Zimpel 2006-01
jps 2205 tcp Java Presentation Server Leif Jakob Leif Jakob 2006-01
jps 2205 udp Java Presentation Server Leif Jakob Leif Jakob 2006-01
hpocbus 2206 tcp HP OpenCall bus Jerome Forissier Jerome Forissier 2005-12
hpocbus 2206 udp HP OpenCall bus Jerome Forissier Jerome Forissier 2005-12
hpssd 2207 tcp HP Status and Services Donald Welch Donald Welch 2006-05
hpssd 2207 udp HP Status and Services Donald Welch Donald Welch 2006-05
hpiod 2208 tcp HP I/O Backend David Suffield David Suffield 2006-05
hpiod 2208 udp HP I/O Backend David Suffield David Suffield 2006-05
rimf-ps 2209 tcp HP RIM for Files Portal Service Patty Ho Patty Ho 2007-05
rimf-ps 2209 udp HP RIM for Files Portal Service Patty Ho Patty Ho 2007-05
noaaport 2210 tcp NOAAPORT Broadcast Network
noaaport 2210 udp NOAAPORT Broadcast Network
netiq 2220 tcp NetIQ End2End Michael Sharpe Michael Sharpe 2010-09-14
netiq 2220 udp NetIQ End2End Michael Sharpe Michael Sharpe 2010-09-14
EtherNet-IP-1 2222 tcp EtherNet/IP I/O

IANA assigned this well-formed service name as a replacement for "EtherNet/IP-1".
Brian Batke Brian Batke New contact added for port 2222 on 2008-02-01
EtherNet/IP-1 2222 tcp EtherNet/IP I/O Brian Batke Brian Batke New contact added for port 2222 on 2008-02-01 This entry is an alias to "EtherNet-IP-1". This entry is now historic, not usable for use with many common service discovery mechanisms.
EtherNet-IP-1 2222 udp EtherNet/IP I/O

IANA assigned this well-formed service name as a replacement for "EtherNet/IP-1".
Brian Batke Brian Batke New contact added for port 2222 on 2008-02-01
EtherNet/IP-1 2222 udp EtherNet/IP I/O Brian Batke Brian Batke New contact added for port 2222 on 2008-02-01 This entry is an alias to "EtherNet-IP-1". This entry is now historic, not usable for use with many common service discovery mechanisms.
queueadm 2230 tcp MetaSoft Job Queue Administration Service Ilya Melamed Ilya Melamed 2006-06
queueadm 2230 udp MetaSoft Job Queue Administration Service Ilya Melamed Ilya Melamed 2006-06
recipe 2240 tcp RECIPe Charlie Limoges Charlie Limoges 1997-12-16
recipe 2240 udp RECIPe Charlie Limoges Charlie Limoges 1997-12-16
remote-collab 2250 tcp remote-collab Richard Walters Richard Walters
remote-collab 2250 udp remote-collab Richard Walters Richard Walters
apc-2260 2260 tcp APC 2260 American Power Conversion American Power Conversion 2002-02
apc-2260 2260 udp APC 2260 American Power Conversion American Power Conversion 2002-02
apx500api-1 2264 tcp Audio Precision Apx500 API Port 1
apx500api-1 2264 udp Audio Precision Apx500 API Port 1
apx500api-2 2265 tcp Audio Precision Apx500 API Port 2 Robert Wright, Founder and Principal Engineer Robert Wright, Founder and Principal Engineer
apx500api-2 2265 udp Audio Precision Apx500 API Port 2 Robert Wright, Founder and Principal Engineer Robert Wright, Founder and Principal Engineer
amt 2268 tcp AMT IESG IETF Chair 2004-12 2014-12-17 RFC 7450
amt 2268 udp AMT IESG IETF Chair 2004-12 2014-12-17 RFC 7450
starschool 2270 tcp starSchool Adam Ernst Adam Ernst 2004-12
starschool 2270 udp starSchool Adam Ernst Adam Ernst 2004-12
lnvpoller 2280 tcp LNVPOLLER
lnvpoller 2280 udp LNVPOLLER
sonus-logging 2290 tcp Sonus Logging Services Adwait Sathe Adwait Sathe 2005-08
sonus-logging 2290 udp Sonus Logging Services Adwait Sathe Adwait Sathe 2005-08
cvmmon 2300 tcp CVMMON Roger Kumpf Roger Kumpf
cvmmon 2300 udp CVMMON Roger Kumpf Roger Kumpf
cpq-wbem 2301 tcp Compaq HTTP Scott Shaffer Scott Shaffer
cpq-wbem 2301 udp Compaq HTTP Scott Shaffer Scott Shaffer
binderysupport 2302 tcp Bindery Support Narasimha Rao N. Narasimha Rao N.
binderysupport 2302 udp Bindery Support Narasimha Rao N. Narasimha Rao N.
proxy-gateway 2303 tcp Proxy Gateway Paul Funk Paul Funk
proxy-gateway 2303 udp Proxy Gateway Paul Funk Paul Funk
attachmate-uts 2304 tcp Attachmate UTS George Gianelos George Gianelos
attachmate-uts 2304 udp Attachmate UTS George Gianelos George Gianelos
mt-scaleserver 2305 tcp MT ScaleServer Paul Glaubitz Paul Glaubitz
mt-scaleserver 2305 udp MT ScaleServer Paul Glaubitz Paul Glaubitz
tappi-boxnet 2306 tcp TAPPI BoxNet Richard Spartz Richard Spartz
tappi-boxnet 2306 udp TAPPI BoxNet Richard Spartz Richard Spartz
pehelp 2307 tcp pehelp Jens Kilian Jens Kilian
pehelp 2307 udp pehelp Jens Kilian Jens Kilian
sdhelp 2308 tcp sdhelp Annette Klecha Annette Klecha
sdhelp 2308 udp sdhelp Annette Klecha Annette Klecha
sdserver 2309 tcp SD Server
sdserver 2309 udp SD Server
sdclient 2310 tcp SD Client Jeurgen Broesamle Jeurgen Broesamle
sdclient 2310 udp SD Client Jeurgen Broesamle Jeurgen Broesamle
siebel-ns 2320 tcp Siebel NS Gilberto Arnaiz Gilberto Arnaiz

Contact Information

Name Organization Contact URI Last Updated
Adam Ernst cosmicsoft&cosmicsoft.net 2004-12
Adwait Sathe asathe&sonusnet.com 2005-08
Alexander Bogdanov alexander_bgd&softhome.net
American Power Conversion ports&apcc.com 2002-02
Amir Herzberg amirh&vnet.ibm.com
Annette Klecha annette_klecha&bbn.hp.com
Brian Batke eip.jsig&gmail.com
Charlie Limoges Charlie.Limoges&gdc4s.com
Dave Thaler dthaler&microsoft.com
David Suffield david.suffield&hp.com 2006-05
Don Gilbreath don&comcam.net 2002-09
Donald Welch donald.welch&hp.com 2006-05
Elgato Systems portinfo&elgato.com 2004-11
George Gianelos Georgegi&attachmate.com
Gilberto Arnaiz garnaiz&siebel.com
Helge-Frank Zimpel helge.zimpel&baeurer.de 2006-01
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ilya Melamed ilya77&gmail.com 2006-06
Jeffrey J. Peters jpeters&tivo.com 2002-08
Jens Kilian jensk&hpbeo82.bbn.hp.com
Jerome Forissier Jerome.Forissier&hp.com 2005-12
Jeurgen Broesamle juergb&bbn.hp.com
Jindra Ryvola jryvola&ledalite.com
Leif Jakob leif+iana&cube.ch 2006-01
Michael Sharpe iana-ports&netiq.com 2010-09-14
Narasimha Rao N. nnarasimharao&novell.com
Pat Galvin pgalvin&databeam.com
Patty Ho rimf&core.rose.hp.com 2007-05
Paul Funk paul&funk.com
Paul Glaubitz Paul.Glaubitz&mt.com
Peter Zurich pbz&lowpft.com
Richard Spartz rspartz&alliancetechnical.com
Richard Walters walters&cs.ucdavis.edu
Robert Wright, Founder and Principal Engineer Audio Precision Inc. ianaports&ap.com 2006-05
Roger Kumpf kumpf&cup.hp.com
Santa Dasu Santa_Dasu&quickeagle.com
Scott Shaffer scott.shaffer&hp.com
Steve Glassman steveg&pa.dec.com
Thomas Schmidt ts&bintec.de
Tobias Wegner wegner&novagate.de
Yaakov Stein yaakovjstein&gmail.com 2022-02-04