Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| cspmulti | 2807 | tcp | cspmulti | Terumasa Yoneda | Terumasa Yoneda | ||||||
| cspmulti | 2807 | udp | cspmulti | Terumasa Yoneda | Terumasa Yoneda | ||||||
| j-lan-p | 2808 | tcp | J-LAN-P | Takeshi Sahara | Takeshi Sahara | ||||||
| j-lan-p | 2808 | udp | J-LAN-P | Takeshi Sahara | Takeshi Sahara | ||||||
| corbaloc | 2809 | tcp | CORBA LOC | Ted McFadden | Ted McFadden | ||||||
| corbaloc | 2809 | udp | CORBA LOC | Ted McFadden | Ted McFadden | ||||||
| netsteward | 2810 | tcp | Active Net Steward | Keith Morley | Keith Morley | ||||||
| netsteward | 2810 | udp | Active Net Steward | Keith Morley | Keith Morley | ||||||
| univision | 2820 | tcp | UniVision | Keith Ansell | Keith Ansell | ||||||
| univision | 2820 | udp | UniVision | Keith Ansell | Keith Ansell | ||||||
| ka0wuc | 2822 | tcp | ka0wuc | Kit Haskins | Kit Haskins | ||||||
| ka0wuc | 2822 | udp | ka0wuc | Kit Haskins | Kit Haskins | ||||||
| silkp2 | 2830 | tcp | silkp2 | ||||||||
| silkp2 | 2830 | udp | silkp2 | ||||||||
| l3-exprt | 2840 | tcp | l3-exprt | ||||||||
| l3-exprt | 2840 | udp | l3-exprt | ||||||||
| metaconsole | 2850 | tcp | MetaConsole | Rakesh Mahajan | Rakesh Mahajan | ||||||
| metaconsole | 2850 | udp | MetaConsole | Rakesh Mahajan | Rakesh Mahajan | ||||||
| bears-01 | 2852 | tcp | bears-01 | Bruce McKinnon | Bruce McKinnon | ||||||
| bears-01 | 2852 | udp | bears-01 | Bruce McKinnon | Bruce McKinnon | ||||||
| dialpad-voice1 | 2860 | tcp | Dialpad Voice 1 | ||||||||
| dialpad-voice1 | 2860 | udp | Dialpad Voice 1 | ||||||||
| astronova-main | 2864 | tcp | main 5001 cmd | AstroNova, Inc. | Chris Tate | 2020-03-03 | |||||
| astronova-main | 2864 | udp | main 5001 cmd | AstroNova, Inc. | Chris Tate | 2020-03-03 | |||||
| daishi | 2870 | tcp | daishi | Patrick Chipman | Patrick Chipman | ||||||
| daishi | 2870 | udp | daishi | Patrick Chipman | Patrick Chipman | ||||||
| synapse | 2880 | tcp | Synapse Transport | Ali Fracyon | Ali Fracyon | ||||||
| synapse | 2880 | udp | Synapse Transport | Ali Fracyon | Ali Fracyon | ||||||
| cspclmulti | 2890 | tcp | CSPCLMULTI | Yoneda Terumasa | Yoneda Terumasa | ||||||
| cspclmulti | 2890 | udp | CSPCLMULTI | Yoneda Terumasa | Yoneda Terumasa | ||||||
| quicksuite | 2900 | tcp | QUICKSUITE | William Egge | William Egge | ||||||
| quicksuite | 2900 | udp | QUICKSUITE | William Egge | William Egge | ||||||
| allstorcns | 2901 | tcp | ALLSTORCNS | Steve Dobson | Steve Dobson | ||||||
| allstorcns | 2901 | udp | ALLSTORCNS | Steve Dobson | Steve Dobson | ||||||
| netaspi | 2902 | tcp | NET ASPI | Johnson Luo | Johnson Luo | ||||||
| netaspi | 2902 | udp | NET ASPI | Johnson Luo | Johnson Luo | ||||||
| suitcase | 2903 | tcp | SUITCASE | Milton E. Sagen | Milton E. Sagen | ||||||
| suitcase | 2903 | udp | SUITCASE | Milton E. Sagen | Milton E. Sagen | ||||||
| m2ua | 2904 | tcp | M2UA | Lyndon Ong | Lyndon Ong | ||||||
| m2ua | 2904 | udp | M2UA | Lyndon Ong | Lyndon Ong | ||||||
| m2ua | 2904 | sctp | M2UA | Lyndon Ong | Lyndon Ong | ||||||
| m3ua | 2905 | tcp | M3UA | Lyndon Ong | Lyndon Ong | RFC 4666 | |||||
| 2905 | udp | De-registered | 2001-06-07 | ||||||||
| m3ua | 2905 | sctp | M3UA | Lyndon Ong | Lyndon Ong | RFC 4666 | |||||
| caller9 | 2906 | tcp | CALLER9 | Shams Naqi | Shams Naqi | ||||||
| caller9 | 2906 | udp | CALLER9 | Shams Naqi | Shams Naqi | ||||||
| webmethods-b2b | 2907 | tcp | WEBMETHODS B2B | Joseph Hines | Joseph Hines | ||||||
| webmethods-b2b | 2907 | udp | WEBMETHODS B2B | Joseph Hines | Joseph Hines | ||||||
| mao | 2908 | tcp | mao | Marc Baudoin | Marc Baudoin | ||||||
| mao | 2908 | udp | mao | Marc Baudoin | Marc Baudoin | ||||||
| funk-dialout | 2909 | tcp | Funk Dialout | Cimarron Boozer | Cimarron Boozer | ||||||
| funk-dialout | 2909 | udp | Funk Dialout | Cimarron Boozer | Cimarron Boozer | ||||||
| tdaccess | 2910 | tcp | TDAccess | Tom Haapanen | Tom Haapanen | ||||||
| tdaccess | 2910 | udp | TDAccess | Tom Haapanen | Tom Haapanen | ||||||
| roboeda | 2920 | tcp | roboEDA | Paul Snook | Paul Snook | ||||||
| roboeda | 2920 | udp | roboEDA | Paul Snook | Paul Snook | ||||||
| 2925 | Unassigned (FRP-Released 12/7/00) | ||||||||||
| amx-weblinx | 2930 | tcp | AMX-WEBLINX | Mike Morris | Mike Morris | ||||||
| amx-weblinx | 2930 | udp | AMX-WEBLINX | Mike Morris | Mike Morris | ||||||
| sm-pas-3 | 2940 | tcp | SM-PAS-3 | ||||||||
| sm-pas-3 | 2940 | udp | SM-PAS-3 | ||||||||
| esip | 2950 | tcp | ESIP | David Stephenson | David Stephenson | ||||||
| esip | 2950 | udp | ESIP | David Stephenson | David Stephenson | ||||||
| dfoxserver | 2960 | tcp | DFOXSERVER | David Holden | David Holden | ||||||
| dfoxserver | 2960 | udp | DFOXSERVER | David Holden | David Holden | ||||||
| index-net | 2970 | tcp | INDEX-NET | Chris J. Wren | Chris J. Wren | ||||||
| index-net | 2970 | udp | INDEX-NET | Chris J. Wren | Chris J. Wren | ||||||
| wimd | 2980 | tcp | Instant Messaging Service | Kevin Birch | Kevin Birch | ||||||
| wimd | 2980 | udp | Instant Messaging Service | Kevin Birch | Kevin Birch | ||||||
| boscap | 2990 | tcp | BOSCAP | Dirk Hillbrecht | Dirk Hillbrecht | ||||||
| boscap | 2990 | udp | BOSCAP | Dirk Hillbrecht | Dirk Hillbrecht | ||||||
| hbci | 3000 | tcp | HBCI | Kurt Haubner | Kurt Haubner | ||||||
| hbci | 3000 | udp | HBCI | Kurt Haubner | Kurt Haubner | ||||||
| remoteware-cl | 3000 | tcp | RemoteWare Client | Tim Farley | Tim Farley | This entry records an unassigned but widespread use | |||||
| remoteware-cl | 3000 | udp | RemoteWare Client | Tim Farley | Tim Farley | This entry records an unassigned but widespread use | |||||
| origo-native | 3001 | tcp | OrigoDB Server Native Interface | Devrex Labs | Robert Friberg | 2013-03-29 | port 3001 previously "Removed on 2006-05-25" | ||||
| 3001 | udp | Reserved | 2013-03-29 | port 3001 previously "Removed on 2006-05-25" | |||||||
| exlm-agent | 3002 | tcp | EXLM Agent | Randy Martin | Randy Martin | ||||||
| exlm-agent | 3002 | udp | EXLM Agent | Randy Martin | Randy Martin | ||||||
| remoteware-srv | 3002 | tcp | RemoteWare Server | Tim Farley | Tim Farley | This entry records an unassigned but widespread use | |||||
| remoteware-srv | 3002 | udp | RemoteWare Server | Tim Farley | Tim Farley | This entry records an unassigned but widespread use | |||||
| cgms | 3003 | tcp | CGMS | Corey Clinton | Corey Clinton | 2011-02-02 | |||||
| cgms | 3003 | udp | CGMS | Corey Clinton | Corey Clinton | 2011-02-02 | |||||
| csoftragent | 3004 | tcp | Csoft Agent | Nedelcho Stanev | Nedelcho Stanev | ||||||
| csoftragent | 3004 | udp | Csoft Agent | Nedelcho Stanev | Nedelcho Stanev | ||||||
| geniuslm | 3005 | tcp | Genius License Manager | Jakob Spies | Jakob Spies | ||||||
| geniuslm | 3005 | udp | Genius License Manager | Jakob Spies | Jakob Spies | ||||||
| ii-admin | 3006 | tcp | Instant Internet Admin | PerfTech, Inc. | Lewis Donzis | 2019-12-19 | |||||
| ii-admin | 3006 | udp | Instant Internet Admin | PerfTech, Inc. | Lewis Donzis | 2019-12-19 | |||||
| lotusmtap | 3007 | tcp | Lotus Mail Tracking Agent Protocol | Ken Lin | Ken Lin | ||||||
| lotusmtap | 3007 | udp | Lotus Mail Tracking Agent Protocol | Ken Lin | Ken Lin | ||||||
| midnight-tech | 3008 | tcp | Midnight Technologies | Kyle Unice | Kyle Unice | ||||||
| midnight-tech | 3008 | udp | Midnight Technologies | Kyle Unice | Kyle Unice | ||||||
| pxc-ntfy | 3009 | tcp | PXC-NTFY | Takeshi Nishizawa | Takeshi Nishizawa | ||||||
| pxc-ntfy | 3009 | udp | PXC-NTFY | Takeshi Nishizawa | Takeshi Nishizawa | ||||||
| gw | 3010 | tcp | Telerate Workstation | ||||||||
| ping-pong | 3010 | udp | Telerate Workstation | Timo Sivonen | Timo Sivonen | ||||||
| trusted-web | 3011 | tcp | Trusted Web | ||||||||
| trusted-web | 3011 | udp | Trusted Web | ||||||||
| twsdss | 3012 | tcp | Trusted Web Client | Alex Duncan | Alex Duncan | ||||||
| twsdss | 3012 | udp | Trusted Web Client | Alex Duncan | Alex Duncan |