Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
hp-pxpib 3101 udp HP PolicyXpert PIB Server Brian O'Keefe Brian O'Keefe
slslavemon 3102 tcp SoftlinK Slave Mon Port Moshe Livne Moshe Livne
slslavemon 3102 udp SoftlinK Slave Mon Port Moshe Livne Moshe Livne
autocuesmi 3103 tcp Autocue SMI Protocol
autocuesmi 3103 udp Autocue SMI Protocol
autocuelog 3104 tcp Autocue Logger Protocol
autocuetime 3104 udp Autocue Time Service Geoff Back Geoff Back
cardbox 3105 tcp Cardbox
cardbox 3105 udp Cardbox
cardbox-http 3106 tcp Cardbox HTTP Martin Kochanski Martin Kochanski
cardbox-http 3106 udp Cardbox HTTP Martin Kochanski Martin Kochanski
business 3107 tcp Business protocol
business 3107 udp Business protocol
geolocate 3108 tcp Geolocate protocol
geolocate 3108 udp Geolocate protocol
personnel 3109 tcp Personnel protocol William Randolph Royere III William Randolph Royere III
personnel 3109 udp Personnel protocol William Randolph Royere III William Randolph Royere III
sim-control 3110 tcp simulator control port Ian Bell Ian Bell
sim-control 3110 udp simulator control port Ian Bell Ian Bell
d2000kernel 3119 tcp D2000 Kernel Port
d2000kernel 3119 udp D2000 Kernel Port
d2000webserver 3120 tcp D2000 Webserver Port Tomas Rajcan Tomas Rajcan
d2000webserver 3120 udp D2000 Webserver Port Tomas Rajcan Tomas Rajcan
pcmk-remote 3121 tcp The pacemaker remote (pcmk-remote) service extends high availability functionality outside of the Linux cluster into remote nodes. David Vossel Andrew Beekhof 2013-03-15 port 3121 previously noted "Removed on 2003-09-17"
3121 udp Reserved 2013-03-15 port 3121 previously noted "Removed on 2003-09-17"
icpv2 3130 tcp ICPv2 Duane Wessels Duane Wessels
icpv2 3130 udp ICPv2 Duane Wessels Duane Wessels
ariliamulti 3140 tcp Arilia Multiplexor Stephane Bourque Stephane Bourque
ariliamulti 3140 udp Arilia Multiplexor Stephane Bourque Stephane Bourque
bears-02 3146 tcp bears-02 Bruce McKinnon Bruce McKinnon
bears-02 3146 udp bears-02 Bruce McKinnon Bruce McKinnon
nm-asses-admin 3150 tcp NetMike Assessor Administrator
nm-asses-admin 3150 udp NetMike Assessor Administrator
tip-app-server 3160 tcp TIP Application Server Integral Software Olivier Mascia 2023-11-07
tip-app-server 3160 udp TIP Application Server Integral Software Olivier Mascia 2023-11-07
serverview-asn 3170 tcp SERVERVIEW-ASN
serverview-asn 3170 udp SERVERVIEW-ASN
mc-brk-srv 3180 tcp Millicent Broker Server Steve Glassman Steve Glassman
mc-brk-srv 3180 udp Millicent Broker Server Steve Glassman Steve Glassman
csvr-proxy 3190 tcp ConServR Proxy
csvr-proxy 3190 udp ConServR Proxy
tick-port 3200 tcp Press-sense Tick Port Boris Svetlitsky Boris Svetlitsky
tick-port 3200 udp Press-sense Tick Port Boris Svetlitsky Boris Svetlitsky
cpq-tasksmart 3201 tcp CPQ-TaskSmart Jackie Lau Jackie Lau
cpq-tasksmart 3201 udp CPQ-TaskSmart Jackie Lau Jackie Lau
intraintra 3202 tcp IntraIntra Matthew Asham Matthew Asham
intraintra 3202 udp IntraIntra Matthew Asham Matthew Asham
netwatcher-mon 3203 tcp Network Watcher Monitor
netwatcher-mon 3203 udp Network Watcher Monitor
netwatcher-db 3204 tcp Network Watcher DB Access Hirokazu Fujisawa Hirokazu Fujisawa
netwatcher-db 3204 udp Network Watcher DB Access Hirokazu Fujisawa Hirokazu Fujisawa
isns 3205 tcp iSNS Server Port RFC 4171
isns 3205 udp iSNS Server Port RFC 4171
ironmail 3206 tcp IronMail POP Proxy Mike Hudack Mike Hudack
ironmail 3206 udp IronMail POP Proxy Mike Hudack Mike Hudack
vx-auth-port 3207 tcp Veritas Authentication Port Senthil Ponnuswamy Senthil Ponnuswamy
vx-auth-port 3207 udp Veritas Authentication Port Senthil Ponnuswamy Senthil Ponnuswamy
pfu-prcallback 3208 tcp PFU PR Callback Tetsuharu Hanada Tetsuharu Hanada
pfu-prcallback 3208 udp PFU PR Callback Tetsuharu Hanada Tetsuharu Hanada
netwkpathengine 3209 tcp HP OpenView Network Path Engine Server Anthony Walker Anthony Walker
netwkpathengine 3209 udp HP OpenView Network Path Engine Server Anthony Walker Anthony Walker
flamenco-proxy 3210 tcp Flamenco Networks Proxy Corey Corrick Corey Corrick
flamenco-proxy 3210 udp Flamenco Networks Proxy Corey Corrick Corey Corrick
xnm-ssl 3220 tcp XML NM over SSL
xnm-ssl 3220 udp XML NM over SSL
sftdst-port 3230 tcp Software Distributor Port Andrea Lanza Andrea Lanza 2014-02-21
sftdst-port 3230 udp Software Distributor Port Andrea Lanza Andrea Lanza 2014-02-21
triomotion 3240 tcp Trio Motion Control Port Tony Matthews Tony Matthews 2002-02
triomotion 3240 udp Trio Motion Control Port Tony Matthews Tony Matthews 2002-02
hicp 3250 tcp HMS hicp port Joel Palsson Joel Palsson 2002-02
hicp 3250 udp HMS hicp port Joel Palsson Joel Palsson 2002-02
iscsi-target 3260 tcp iSCSI port IESG IETF Chair 2013-08-27 RFC 7143
iscsi-target 3260 udp iSCSI port IESG IETF Chair 2013-08-27 RFC 7143
verismart 3270 tcp Verismart Jay Weber Jay Weber
verismart 3270 udp Verismart Jay Weber Jay Weber
vs-server 3280 tcp VS Server Scott Godlew Scott Godlew
vs-server 3280 udp VS Server Scott Godlew Scott Godlew
caps-lm 3290 tcp CAPS LOGISTICS TOOLKIT - LM Joseph Krebs Joseph Krebs
caps-lm 3290 udp CAPS LOGISTICS TOOLKIT - LM Joseph Krebs Joseph Krebs
ceph 3300 tcp Ceph monitor Sage Weil Sage Weil 2015-06-29 Known Unauthorized Use on port 3300
3300 udp Reserved
tarantool 3301 tcp Tarantool in-memory computing platform Tarantool Alexander Turenko 2022-06-10 Known Unauthorized Use on port 3301
tarantool 3301 udp Tarantool in-memory computing platform Tarantool Alexander Turenko 2022-06-10 Known Unauthorized Use on port 3301
mcs-fastmail 3302 tcp MCS Fastmail Patti Jo Newsom Patti Jo Newsom
mcs-fastmail 3302 udp MCS Fastmail Patti Jo Newsom Patti Jo Newsom
opsession-clnt 3303 tcp OP Session Client
opsession-clnt 3303 udp OP Session Client
opsession-srvr 3304 tcp OP Session Server Amir Blich Amir Blich
opsession-srvr 3304 udp OP Session Server Amir Blich Amir Blich
odette-ftp 3305 tcp ODETTE-FTP David Nash David Nash RFC 5024
odette-ftp 3305 udp ODETTE-FTP David Nash David Nash RFC 5024
mysql 3306 tcp MySQL Monty Monty
mysql 3306 udp MySQL Monty Monty
opsession-prxy 3307 tcp OP Session Proxy Amir Blich Amir Blich
opsession-prxy 3307 udp OP Session Proxy Amir Blich Amir Blich
tns-server 3308 tcp TNS Server
tns-server 3308 udp TNS Server
tns-adv 3309 tcp TNS ADV Jerome Albin Jerome Albin
tns-adv 3309 udp TNS ADV Jerome Albin Jerome Albin
dyna-access 3310 tcp Dyna Access Dave Belliveau Dave Belliveau
dyna-access 3310 udp Dyna Access Dave Belliveau Dave Belliveau

Contact Information

Name Organization Contact URI Last Updated
Alexander Turenko Tarantool alexander.turenko&tarantool.org 2022-06-10
Amir Blich amir&netmanage.co.il
Andrea Lanza andrea&andrealanza.eu 2014-02-21
Andrew Beekhof andrew&beekhof.net 2013-03-15
Anthony Walker anthony_walker&hp.com 2002-03
Boris Svetlitsky boris&press-sense.com
Brian O'Keefe bokeefe&cnd.hp.com
Bruce McKinnon brucemck&bearsolutions.com.au
Corey Corrick corey.corrick&flamenconetworks.com
Dave Belliveau DaveBelliveau&cornerstonesoftware.com
David Nash dnash&ford.com
David Vossel dvossel&redhat.com 2013-03-15
Duane Wessels wessels&nlanr.net
Geoff Back geoff&autocue.co.uk 2002-03
Hirokazu Fujisawa fujisawa&pfu.fujitsu.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ian Bell ianb&arca-technologies.com
Integral Software om&integral.software 2023-11-07
Jackie Lau jackie.lau&compaq.com
Jay Weber weber&vfi.com
Jerome Albin albin&taec.enet.dec.com
Joel Palsson HMS Industrial Networks AB ianacontact&hms.se 2002-02
Joseph Krebs joek&caps.com
Martin Kochanski martin&cardbox.co.uk
Matthew Asham matthew&asham.ca 2019-11-22
Mike Hudack mike&mhudack.com
Monty monty&analytikerna.se
Moshe Livne moshe&softlinkusa.com
Olivier Mascia om&integral.software 2023-11-07
Patti Jo Newsom pjn&mcsdallas.com
Sage Weil sage&newdream.net 2015-06-29
Scott Godlew Scott&godlew.com
Senthil Ponnuswamy senthil&veritas.com
Stephane Bourque sbourque&arilia.com
Steve Glassman steveg&pa.dec.com
Tarantool admin&tarantool.org 2022-06-10
Tetsuharu Hanada hanada&pfu.fujitsu.com
Tomas Rajcan trajcan&ipesoft.sk
Tony Matthews tmatthews&triomotion.com 2002-02
William Randolph Royere III william&royere.net