Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| dyna-access | 3310 | udp | Dyna Access | Dave Belliveau | Dave Belliveau | ||||||
| officelink2000 | 3320 | tcp | Office Link 2000 | Mike Balch | Mike Balch | ||||||
| officelink2000 | 3320 | udp | Office Link 2000 | Mike Balch | Mike Balch | ||||||
| mcs-calypsoicf | 3330 | tcp | MCS Calypso ICF | ||||||||
| mcs-calypsoicf | 3330 | udp | MCS Calypso ICF | ||||||||
| anet-m | 3340 | tcp | OMF data m | ||||||||
| anet-m | 3340 | udp | OMF data m | ||||||||
| findviatv | 3350 | tcp | FINDVIATV | Oran Davis | Oran Davis | ||||||
| findviatv | 3350 | udp | FINDVIATV | Oran Davis | Oran Davis | ||||||
| kv-server | 3360 | tcp | KV Server | ||||||||
| kv-server | 3360 | udp | KV Server | ||||||||
| sns-channels | 3380 | tcp | SNS Channels | Shekar Pasumarthi | Shekar Pasumarthi | ||||||
| sns-channels | 3380 | udp | SNS Channels | Shekar Pasumarthi | Shekar Pasumarthi | ||||||
| dsc | 3390 | tcp | Distributed Service Coordinator | Charles Honton | Charles Honton | ||||||
| dsc | 3390 | udp | Distributed Service Coordinator | Charles Honton | Charles Honton | ||||||
| csms2 | 3400 | tcp | CSMS2 | Markus Michels | Markus Michels | ||||||
| csms2 | 3400 | udp | CSMS2 | Markus Michels | Markus Michels | ||||||
| filecast | 3401 | tcp | filecast | Eden Sherry | Eden Sherry | ||||||
| filecast | 3401 | udp | filecast | Eden Sherry | Eden Sherry | ||||||
| fxaengine-net | 3402 | tcp | FXa Engine Network Port | Lucas Alonso | Lucas Alonso | 2002-02 | |||||
| fxaengine-net | 3402 | udp | FXa Engine Network Port | Lucas Alonso | Lucas Alonso | 2002-02 | |||||
| 3403 | De-registered | 2006-10-27 | |||||||||
| 3404 | Removed | 2002-05-01 | |||||||||
| nokia-ann-ch1 | 3405 | tcp | Nokia Announcement ch 1 | ||||||||
| nokia-ann-ch1 | 3405 | udp | Nokia Announcement ch 1 | ||||||||
| nokia-ann-ch2 | 3406 | tcp | Nokia Announcement ch 2 | Morteza Kalhour | Morteza Kalhour | 2002-02 | |||||
| nokia-ann-ch2 | 3406 | udp | Nokia Announcement ch 2 | Morteza Kalhour | Morteza Kalhour | 2002-02 | |||||
| ldap-admin | 3407 | tcp | LDAP admin server port | Stephen Tsun | Stephen Tsun | 2002-02 | |||||
| ldap-admin | 3407 | udp | LDAP admin server port | Stephen Tsun | Stephen Tsun | 2002-02 | |||||
| BESApi | 3408 | tcp | BES Api Port | Colin Griffiths | Colin Griffiths | 2002-02 | |||||
| BESApi | 3408 | udp | BES Api Port | Colin Griffiths | Colin Griffiths | 2002-02 | |||||
| networklens | 3409 | tcp | NetworkLens Event Port | ||||||||
| networklens | 3409 | udp | NetworkLens Event Port | ||||||||
| networklenss | 3410 | tcp | NetworkLens SSL Event | Greg Bailey | Greg Bailey | 2002-02 | |||||
| networklenss | 3410 | udp | NetworkLens SSL Event | Greg Bailey | Greg Bailey | 2002-02 | |||||
| ifcp-port | 3420 | tcp | iFCP User Port | RFC 4172 | |||||||
| ifcp-port | 3420 | udp | iFCP User Port | RFC 4172 | |||||||
| ssdispatch | 3430 | tcp | Scott Studios Dispatch | Michael Settles | Michael Settles | 2002-03 | |||||
| ssdispatch | 3430 | udp | Scott Studios Dispatch | Michael Settles | Michael Settles | 2002-03 | |||||
| ans-console | 3440 | tcp | Net Steward Mgmt Console | John Richmond | John Richmond | 2002-03 | |||||
| ans-console | 3440 | udp | Net Steward Mgmt Console | John Richmond | John Richmond | 2002-03 | |||||
| castorproxy | 3450 | tcp | CAStorProxy | Raymond J. Young | Raymond J. Young | 2002-04 | |||||
| castorproxy | 3450 | udp | CAStorProxy | Raymond J. Young | Raymond J. Young | 2002-04 | |||||
| edm-manager | 3460 | tcp | EDM Manger | ||||||||
| edm-manager | 3460 | udp | EDM Manger | ||||||||
| jt400 | 3470 | tcp | jt400 | ||||||||
| jt400 | 3470 | udp | jt400 | ||||||||
| jt400-ssl | 3471 | tcp | jt400-ssl | Clifton Nock | Clifton Nock | ||||||
| jt400-ssl | 3471 | udp | jt400-ssl | Clifton Nock | Clifton Nock | ||||||
| stun-behavior | 3478 | tcp | STUN Behavior Discovery over TCP | RFC 5780 | |||||||
| stun-behavior | 3478 | udp | STUN Behavior Discovery over UDP | RFC 5780 | |||||||
| plethora | 3480 | tcp | Secure Virtual Workspace | Tim Simms | Tim Simms | 2002-04 | |||||
| plethora | 3480 | udp | Secure Virtual Workspace | Tim Simms | Tim Simms | 2002-04 | |||||
| colubris | 3490 | tcp | Colubris Management Port | Gilbert Moineau | Gilbert Moineau | 2002-05 | |||||
| colubris | 3490 | udp | Colubris Management Port | Gilbert Moineau | Gilbert Moineau | 2002-05 | |||||
| rtmp-port | 3500 | tcp | RTMP Port | Miriam Wohlgelernter | Miriam Wohlgelernter | ||||||
| rtmp-port | 3500 | udp | RTMP Port | Miriam Wohlgelernter | Miriam Wohlgelernter | ||||||
| isoft-p2p | 3501 | tcp | iSoft-P2P | David Walling | David Walling | ||||||
| isoft-p2p | 3501 | udp | iSoft-P2P | David Walling | David Walling | ||||||
| avinstalldisc | 3502 | tcp | Avocent Install Discovery | Brian S. Stewart | Brian S. Stewart | ||||||
| avinstalldisc | 3502 | udp | Avocent Install Discovery | Brian S. Stewart | Brian S. Stewart | ||||||
| lsp-ping | 3503 | tcp | MPLS LSP-echo Port | RFC 8029 | |||||||
| lsp-ping | 3503 | udp | MPLS LSP-echo Port | RFC 8029 | |||||||
| ironstorm | 3504 | tcp | IronStorm game server | Arnaud Clermonte | Arnaud Clermonte | ||||||
| ironstorm | 3504 | udp | IronStorm game server | Arnaud Clermonte | Arnaud Clermonte | ||||||
| ccmcomm | 3505 | tcp | CCM communications port | Tom Bougan | Tom Bougan | ||||||
| ccmcomm | 3505 | udp | CCM communications port | Tom Bougan | Tom Bougan | ||||||
| apc-3506 | 3506 | tcp | APC 3506 | American Power Conversion | American Power Conversion | ||||||
| apc-3506 | 3506 | udp | APC 3506 | American Power Conversion | American Power Conversion | ||||||
| nesh-broker | 3507 | tcp | Nesh Broker Port | Jeremy Maiden | Jeremy Maiden | ||||||
| nesh-broker | 3507 | udp | Nesh Broker Port | Jeremy Maiden | Jeremy Maiden | ||||||
| interactionweb | 3508 | tcp | Interaction Web | Mike Gagle | Mike Gagle | ||||||
| interactionweb | 3508 | udp | Interaction Web | Mike Gagle | Mike Gagle | ||||||
| vt-ssl | 3509 | tcp | Virtual Token SSL Port | Libor Sykora | Libor Sykora | 2002-05 | |||||
| vt-ssl | 3509 | udp | Virtual Token SSL Port | Libor Sykora | Libor Sykora | 2002-05 | |||||
| xss-port | 3510 | tcp | XSS Port | Joe Purcell | Joe Purcell | 2002-05 | |||||
| xss-port | 3510 | udp | XSS Port | Joe Purcell | Joe Purcell | 2002-05 | |||||
| 802-11-iapp | 3517 | tcp | IEEE 802.11 WLANs WG IAPP | Stuart J. Kerry | Stuart J. Kerry | 2002-05 | |||||
| 802-11-iapp | 3517 | udp | IEEE 802.11 WLANs WG IAPP | Stuart J. Kerry | Stuart J. Kerry | 2002-05 | |||||
| galileolog | 3520 | tcp | Netvion Galileo Log Port | Ray Caruso | Ray Caruso | 2002-06 | |||||
| galileolog | 3520 | udp | Netvion Galileo Log Port | Ray Caruso | Ray Caruso | 2002-06 | |||||
| gf | 3530 | tcp | Grid Friendly | Daivd P. Chassin | Daivd P. Chassin | 2002-06 | |||||
| gf | 3530 | udp | Grid Friendly | Daivd P. Chassin | Daivd P. Chassin | 2002-06 | |||||
| pnrp-port | 3540 | tcp | PNRP User Port | Igor Kostic | Igor Kostic | 2002-07 | |||||
| pnrp-port | 3540 | udp | PNRP User Port | Igor Kostic | Igor Kostic | 2002-07 | |||||
| teredo | 3544 | tcp | Teredo Port | RFC 4380 | |||||||
| teredo | 3544 | udp | Teredo Port | RFC 4380 | |||||||
| ssmpp | 3550 | tcp | Secure SMPP | Cormac Long | Cormac Long | 2002-07 | |||||
| ssmpp | 3550 | udp | Secure SMPP | Cormac Long | Cormac Long | 2002-07 | |||||
| personalos-001 | 3557 | tcp | PersonalOS Comm Port | Shane Roberts | Shane Roberts | 2002-07 | |||||
| personalos-001 | 3557 | udp | PersonalOS Comm Port | Shane Roberts | Shane Roberts | 2002-07 | |||||
| iniserve-port | 3560 | tcp | INIServe port | Peter Moylan | Peter Moylan | 2002-08 | |||||
| iniserve-port | 3560 | udp | INIServe port | Peter Moylan | Peter Moylan | 2002-08 | |||||
| mccwebsvr-port | 3570 | tcp | MCC Web Server Port | ||||||||
| mccwebsvr-port | 3570 | udp | MCC Web Server Port | ||||||||
| nati-svrloc | 3580 | tcp | NATI-ServiceLocator | Jason Case | Jason Case | 2002-08 | |||||
| nati-svrloc | 3580 | udp | NATI-ServiceLocator | Jason Case | Jason Case | 2002-08 | |||||
| wv-csp-sms | 3590 | tcp | WV CSP SMS Binding | Matti Salmi | Matti Salmi | 2002-08 | |||||
| wv-csp-sms | 3590 | udp | WV CSP SMS Binding | Matti Salmi | Matti Salmi | 2002-08 | |||||
| trap-daemon | 3600 | tcp | text relay-answer | John Willis | John Willis | 2002-09 | 2017-07-26 | ||||
| trap-daemon | 3600 | udp | text relay-answer | John Willis | John Willis | 2002-09 | 2017-07-26 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| American Power Conversion | ports&apcc.com | 2002-02 | |
| Arnaud Clermonte | clermonte&4xtechnologies.com | ||
| Brian S. Stewart | Brian.Stewart&avovent.com | ||
| Charles Honton | chas&honton.org | ||
| Clifton Nock | cnock&us.ibm.com | ||
| Colin Griffiths | colin.griffiths&interlinksoftware.com | 2002-02 | |
| Cormac Long | webmaster&smsforum.net | 2002-07 | |
| Daivd P. Chassin | david.chassin&pnl.gov | 2002-06 | |
| Dave Belliveau | DaveBelliveau&cornerstonesoftware.com | ||
| David Walling | dwalling&isoft.com | ||
| Eden Sherry | eden&pair.com | ||
| Gilbert Moineau | gilbert.moineau&colubris.com | 2002-05 | |
| Greg Bailey | gbailey&lxpro.com | 2003-04 | |
| Igor Kostic | igorkoµsoft.com | 2002-08 | |
| Jason Case | jason.case&ni.com | 2002-08 | |
| Jeremy Maiden | jeremy&3507.uk | 2020-05-01 | |
| Joe Purcell | jpurcell&ensuretech.com | 2003-01 | |
| John Richmond | developers&securitydesigners.com | 2002-03 | |
| John Willis | jpw&coherent-logic.com | 2017-07-26 | |
| Libor Sykora | libor.sykora&st.com | 2002-05 | |
| Lucas Alonso | luke&demiurgestudios.com | 2002-02 | |
| Markus Michels | mmi&cedros.com | ||
| Matti Salmi | matti.salmi&nokia.com | 2002-08 | |
| Michael Settles | michael.settles&verizon.net | 2002-03 | |
| Mike Balch | mbalch&teltone.com | ||
| Mike Gagle | mikeg&inin.com | 2006-05 | |
| Miriam Wohlgelernter | miriamw&adirtech.com | ||
| Morteza Kalhour | Morteza.Kalhour&nokia.com | 2002-02 | |
| Oran Davis | oran&8x8.com | ||
| Peter Moylan | peter&ee.newcastle.edu.au | 2002-08 | |
| Ray Caruso | ray.caruso&netvion.com | 2002-06 | |
| Raymond J. Young | Raymond.Young&ca.com | 2002-04 | |
| Shane Roberts | iana&shaneroberts.com | 2014-12-18 | |
| Shekar Pasumarthi | shekarp&firstfloor.com | ||
| Stephen Tsun | stsun&calient.net | 2002-02 | |
| Stuart J. Kerry | Chair IEEE 802.11 WG | stuart&ok-brit.com | 2002-05 |
| Tim Simms | tsimms&plethoratech.com | 2002-04 | |
| Tom Bougan | tomb&apptechsys.com |