Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
at-5 205 udp AppleTalk Unused
at-zis 206 tcp AppleTalk Zone Information
at-zis 206 udp AppleTalk Zone Information
at-7 207 tcp AppleTalk Unused
at-7 207 udp AppleTalk Unused
at-8 208 tcp AppleTalk Unused Rob Chandhok Rob Chandhok
at-8 208 udp AppleTalk Unused Rob Chandhok Rob Chandhok
qmtp 209 tcp The Quick Mail Transfer Protocol D. J. Bernstein D. J. Bernstein 2018-04-05
qmtp 209 udp The Quick Mail Transfer Protocol D. J. Bernstein D. J. Bernstein 2018-04-05
z39-50 210 tcp ANSI Z39.50

IANA assigned this well-formed service name as a replacement for "z39.50".
Mark H. Needleman Mark H. Needleman
z39.50 210 tcp ANSI Z39.50 Mark H. Needleman Mark H. Needleman This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms.
z39-50 210 udp ANSI Z39.50

IANA assigned this well-formed service name as a replacement for "z39.50".
Mark H. Needleman Mark H. Needleman
z39.50 210 udp ANSI Z39.50 Mark H. Needleman Mark H. Needleman This entry is an alias to "z39-50". This entry is now historic, not usable for use with many common service discovery mechanisms.
imap3 220 tcp Interactive Mail Access Protocol v3 James Rice James Rice
imap3 220 udp Interactive Mail Access Protocol v3 James Rice James Rice
225-241 Reserved 2024-12-20 RFC 1060
dsp3270 246 tcp Display Systems Protocol Weldon J. Showalter Weldon J. Showalter
dsp3270 246 udp Display Systems Protocol Weldon J. Showalter Weldon J. Showalter
249-255 Reserved 2024-12-20 RFC 1060
openport 260 tcp Openport John Marland John Marland
openport 260 udp Openport John Marland John Marland
270 tcp Reserved
gist 270 udp Q-mode encapsulation for GIST messages RFC 5971
http-mgmt 280 tcp http-mgmt Adrian Pell Adrian Pell
http-mgmt 280 udp http-mgmt Adrian Pell Adrian Pell
tacacss 300 tcp TLS Secure Login Host Protocol (TACACSS) IESG IETF Chair 2025-07-15 RFC 9887
300 udp Reserved
301-307 Unassigned
novastorbakcup 308 tcp Novastor Backup Brian Dickman Brian Dickman
novastorbakcup 308 udp Novastor Backup Brian Dickman Brian Dickman
entrusttime 309 tcp EntrustTime Peter Whittaker Peter Whittaker
entrusttime 309 udp EntrustTime Peter Whittaker Peter Whittaker
bhmds 310 tcp bhmds John Kelly John Kelly
bhmds 310 udp bhmds John Kelly John Kelly
ptp-general 320 tcp PTP General Kang Lee Kang Lee 2010-07-27
ptp-general 320 udp PTP General Kang Lee Kang Lee 2010-07-27
rpki-rtr 323 tcp Resource PKI to Router Protocol IESG IETF Chair RFC 6810
rpki-rtr-tls 324 tcp Resource PKI to Router Protocol over TLS IESG IETF Chair RFC 6810
matip-type-a 350 tcp MATIP Type A Alain Robert Alain Robert RFC 2351
matip-type-a 350 udp MATIP Type A Alain Robert Alain Robert RFC 2351
359 tcp Reserved 2023-11-16 De-Assigned on 2023-11-16.
359 udp Reserved 2023-11-16 De-Assigned on 2023-11-16.
scoi2odialog 360 tcp scoi2odialog Keith Petley Keith Petley
scoi2odialog 360 udp scoi2odialog Keith Petley Keith Petley
codaauth2 370 tcp codaauth2 Robert Watson Robert Watson
codaauth2 370 udp codaauth2 Robert Watson Robert Watson
is99s 380 tcp TIA/EIA/IS-99 modem server Frank Quick Frank Quick
is99s 380 udp TIA/EIA/IS-99 modem server Frank Quick Frank Quick
uis 390 tcp UIS Ed Barron Ed Barron
uis 390 udp UIS Ed Barron Ed Barron
osb-sd 400 tcp Oracle Secure Backup Steven Wertheimer Steven Wertheimer 2008-06-06 2023-12-27 Formerly was Workstation Solutions
osb-sd 400 udp Oracle Secure Backup Steven Wertheimer Steven Wertheimer 2008-06-06 2023-12-27 Formerly was Workstation Solutions
ups 401 tcp Uninterruptible Power Supply Charles Bennett Charles Bennett 2008-08-29
ups 401 udp Uninterruptible Power Supply Charles Bennett Charles Bennett 2008-08-29
genie 402 tcp Genie Protocol Mark Hankin Mark Hankin
genie 402 udp Genie Protocol Mark Hankin Mark Hankin
decap 403 tcp decap
decap 403 udp decap
nced 404 tcp nced
nced 404 udp nced
ncld 405 tcp ncld Richard Jones Richard Jones
ncld 405 udp ncld Richard Jones Richard Jones
imsp 406 tcp Interactive Mail Support Protocol John Myers John Myers
imsp 406 udp Interactive Mail Support Protocol John Myers John Myers
timbuktu 407 tcp Timbuktu Marc Epard Marc Epard
timbuktu 407 udp Timbuktu Marc Epard Marc Epard
prm-sm 408 tcp Prospero Resource Manager Sys. Man.
prm-sm 408 udp Prospero Resource Manager Sys. Man.
prm-nm 409 tcp Prospero Resource Manager Node Man. B. Clifford Neuman B. Clifford Neuman
prm-nm 409 udp Prospero Resource Manager Node Man. B. Clifford Neuman B. Clifford Neuman
decladebug 410 tcp DECLadebug Remote Debug Protocol Hewlett Packard Hewlett Packard
decladebug 410 udp DECLadebug Remote Debug Protocol Hewlett Packard Hewlett Packard
smpte 420 tcp SMPTE Si Becker Si Becker
smpte 420 udp SMPTE Si Becker Si Becker
utmpsd 430 tcp UTMPSD
utmpsd 430 udp UTMPSD
sgcp 440 tcp sgcp Marshall Rose Marshall Rose
sgcp 440 udp sgcp Marshall Rose Marshall Rose
https 443 tcp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
https 443 udp http protocol over TLS/SSL IESG IETF Chair 2021-10-01 RFC 9110
https 443 sctp HTTPS Randall Stewart Randall Stewart 2022-02-07 RFC 9260
tserver 450 tcp Computer Supported Telecomunication Applications Harvey S. Schultz Harvey S. Schultz
tserver 450 udp Computer Supported Telecomunication Applications Harvey S. Schultz Harvey S. Schultz
skronk 460 tcp skronk Henry Strickland Henry Strickland
skronk 460 udp skronk Henry Strickland Henry Strickland
scx-proxy 470 tcp scx-proxy Scott Narveson Scott Narveson
scx-proxy 470 udp scx-proxy Scott Narveson Scott Narveson
iafdbase 480 tcp iafdbase Rick Yazwinski Rick Yazwinski
iafdbase 480 udp iafdbase Rick Yazwinski Rick Yazwinski
micom-pfs 490 tcp micom-pfs David Misunas David Misunas
micom-pfs 490 udp micom-pfs David Misunas David Misunas
isakmp 500 tcp isakmp Mark Schertler Mark Schertler
isakmp 500 udp isakmp Mark Schertler Mark Schertler
stmf 501 tcp STMF Alan Ungar Alan Ungar
stmf 501 udp STMF Alan Ungar Alan Ungar
mbap 502 tcp Modbus Application Protocol modbus.org Dennis Dube 2014-06-10
mbap 502 udp Modbus Application Protocol modbus.org Dennis Dube 2014-06-10
intrinsa 503 tcp Intrinsa Robert Ford Robert Ford
intrinsa 503 udp Intrinsa Robert Ford Robert Ford
citadel 504 tcp citadel Art Cancro Art Cancro
citadel 504 udp citadel Art Cancro Art Cancro

Contact Information

Name Organization Contact URI Last Updated
Adrian Pell PELL_ADRIAN/HP-UnitedKingdom_om6@hplb.hpl.hp.com
Alain Robert arobert&par.sita.int
Alan Ungar aungar&farradyne.com
Art Cancro ajc&citadel.org 2015-02-18
B. Clifford Neuman bcn&isi.edu 2022-02-18
Brian Dickman brian&novastor.com
Charles Bennett bennettc&ohio.edu 2008-08-29
D. J. Bernstein ports&box.cr.yp.to 2018-04-05
David Misunas DMisunas&micom.com
Dennis Dube dennis.dube&schneider-electric.com 2014-06-10
Ed Barron
Frank Quick fquick&qualcomm.com
Harvey S. Schultz harvey&acm.org
Henry Strickland strick&yak.net
Hewlett Packard
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
James Rice RICE&sumex-aim.stanford.edu
John Kelly johnk&bellhow.com
John Marland jmarland&dean.openport.com
John Myers jgm+&cmu.edu
Kang Lee I&M Society TC-9 kang.lee&nist.gov 2010-07-27
Keith Petley keithp&sco.com
Marc Epard marc&netopia.com
Mark H. Needleman markn&sirsi.com
Mark Hankin
Mark Schertler mjs&tycho.ncsc.mil
Marshall Rose mrose17&gmail.com 2024-07-29
modbus.org rbelliardi&modbus.org 2014-06-10
Peter Whittaker pww&entrust.com
Randall Stewart IETF TSVWG rrs&lakerest.net
Richard Jones
Rick Yazwinski ricky&solect.com
Rob Chandhok chandhok&gnome.cs.cmu.edu
Robert Ford robert&intrinsa.com
Robert Watson robert&cyrus.watson.org
Scott Narveson sjn&cray.com
Si Becker 71362.22&compuserve.com
Steven Wertheimer steven.wertheimer&oracle.com 2023-12-27
Weldon J. Showalter Gamma&mintaka.dca.mil