Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
toad 2669 tcp TOAD Michael Marking Michael Marking
toad 2669 udp TOAD Michael Marking Michael Marking
hp-nnm-data 2690 tcp HP NNM Embedded Database Chris Das Chris Das
hp-nnm-data 2690 udp HP NNM Embedded Database Chris Das Chris Das
itinternet 2691 tcp ITInternet ISM Server Ron Ehli Ron Ehli
itinternet 2691 udp ITInternet ISM Server Ron Ehli Ron Ehli
admins-lms 2692 tcp Admins LMS Dagfinn Saether Dagfinn Saether
admins-lms 2692 udp Admins LMS Dagfinn Saether Dagfinn Saether
2693 tcp Unassigned (Removed 2004-2-6)
2693 udp Unassigned (Removed 2004-2-6)
pwrsevent 2694 tcp pwrsevent Yoshinobu Nakamura Yoshinobu Nakamura
pwrsevent 2694 udp pwrsevent Yoshinobu Nakamura Yoshinobu Nakamura
vspread 2695 tcp VSPREAD Sumitake kobayashi Sumitake kobayashi
vspread 2695 udp VSPREAD Sumitake kobayashi Sumitake kobayashi
unifyadmin 2696 tcp Unify Admin Daegis, Inc. Chris Anderson 2012-07-31
unifyadmin 2696 udp Unify Admin Daegis, Inc. Chris Anderson 2012-07-31
oce-snmp-trap 2697 tcp Oce SNMP Trap Port Peter Teeuwen Peter Teeuwen
oce-snmp-trap 2697 udp Oce SNMP Trap Port Peter Teeuwen Peter Teeuwen
mck-ivpip 2698 tcp MCK-IVPIP Robert Vincent Robert Vincent
mck-ivpip 2698 udp MCK-IVPIP Robert Vincent Robert Vincent
csoft-plusclnt 2699 tcp Csoft Plus Client Nedelcho Stanev Nedelcho Stanev
csoft-plusclnt 2699 udp Csoft Plus Client Nedelcho Stanev Nedelcho Stanev
exce 2769 tcp eXcE Norm Freedman Norm Freedman
exce 2769 udp eXcE Norm Freedman Norm Freedman
icslap 2869 tcp ICSLAP Richard Lamb Richard Lamb
icslap 2869 udp ICSLAP Richard Lamb Richard Lamb
essp 2969 tcp ESSP Hitoshi Ishida Hitoshi Ishida
essp 2969 udp ESSP Hitoshi Ishida Hitoshi Ishida
ls3 3069 tcp ls3 Jim Thompson Jim Thompson
ls3 3069 udp ls3 Jim Thompson Jim Thompson
serverview-as 3169 tcp SERVERVIEW-AS
serverview-as 3169 udp SERVERVIEW-AS
msft-gc-ssl 3269 tcp Microsoft Global Catalog with LDAP/SSL Asaf Kashi Asaf Kashi
msft-gc-ssl 3269 udp Microsoft Global Catalog with LDAP/SSL Asaf Kashi Asaf Kashi
pluribus 3469 tcp Pluribus Mark Miller Mark Miller
pluribus 3469 udp Pluribus Mark Miller Mark Miller
mbg-ctrl 3569 tcp Meinberg Control Service Meinberg Funkuhren GmbH & Co. KG Meinberg IANA Registrations 2002-08 2019-04-23
mbg-ctrl 3569 udp Meinberg Control Service Meinberg Funkuhren GmbH & Co. KG Meinberg IANA Registrations 2002-08 2019-04-23
casanswmgmt 3669 tcp CA SAN Switch Management Emre Tunar Emre Tunar 2003-01
casanswmgmt 3669 udp CA SAN Switch Management Emre Tunar Emre Tunar 2003-01
svn 3690 tcp Subversion Greg Hudson Greg Hudson 2003-01
svn 3690 udp Subversion Greg Hudson Greg Hudson 2003-01
magaya-network 3691 tcp Magaya Network Port Jesus David Rodriguez Jesus David Rodriguez 2003-02
magaya-network 3691 udp Magaya Network Port Jesus David Rodriguez Jesus David Rodriguez 2003-02
intelsync 3692 tcp Brimstone IntelSync Davey Taylor Davey Taylor 2003-02
intelsync 3692 udp Brimstone IntelSync Davey Taylor Davey Taylor 2003-02
easl 3693 tcp Emergency Automatic Structure Lockdown System Mele Associates Greg Hansen; Randy Yates 2014-11-26 This port was previously removed on 2007-04-05.
3693 udp Reserved 2014-11-26 This port was previously removed on 2007-04-05.
3694 Unassigned 2007-04-05
bmc-data-coll 3695 tcp BMC Data Collection Portnoy Boxman Portnoy Boxman 2003-02
bmc-data-coll 3695 udp BMC Data Collection Portnoy Boxman Portnoy Boxman 2003-02
telnetcpcd 3696 tcp Telnet Com Port Control Thomas J. Pinkl Thomas J. Pinkl 2003-02
telnetcpcd 3696 udp Telnet Com Port Control Thomas J. Pinkl Thomas J. Pinkl 2003-02
nw-license 3697 tcp NavisWorks License System Tim Wiegand Tim Wiegand 2003-02
nw-license 3697 udp NavisWorks License System Tim Wiegand Tim Wiegand 2003-02
sagectlpanel 3698 tcp SAGECTLPANEL Mark Gamble Mark Gamble 2003-02
sagectlpanel 3698 udp SAGECTLPANEL Mark Gamble Mark Gamble 2003-02
kpn-icw 3699 tcp Internet Call Waiting B. J. Kortekaas B. J. Kortekaas 2003-02
kpn-icw 3699 udp Internet Call Waiting B. J. Kortekaas B. J. Kortekaas 2003-02
haipe-otnk 3769 tcp HAIPE Network Keying Mike Irani Mike Irani 2003-06
haipe-otnk 3769 udp HAIPE Network Keying Mike Irani Mike Irani 2003-06
ovsam-mgmt 3869 tcp hp OVSAM MgmtServer Disco Mike Pontillo Mike Pontillo 2003-08
ovsam-mgmt 3869 udp hp OVSAM MgmtServer Disco Mike Pontillo Mike Pontillo 2003-08
landmarks 3969 tcp Landmark Messages Petri Rauhala Petri Rauhala 2005-08
landmarks 3969 udp Landmark Messages Petri Rauhala Petri Rauhala 2005-08
minger 4069 tcp Minger Email Address Validation Service Arvel Hathcock Arvel Hathcock 2007-03
minger 4069 udp Minger Email Address Validation Service Arvel Hathcock Arvel Hathcock 2007-03
iadt 4169 tcp Automation Drive Interface Transport Paul Suhler Paul Suhler 2008-02-15
iadt-disc 4169 udp Internet ADT Discovery Protocol Paul A. Suhler Paul A. Suhler 2009-02-06
epmd 4369 tcp Erlang Port Mapper Daemon Erlang/OTP support Erlang/OTP support
epmd 4369 udp Erlang Port Mapper Daemon Erlang/OTP support Erlang/OTP support
iax 4569 tcp Inter-Asterisk eXchange Benjamin Kowarsch Benjamin Kowarsch RFC 5456 Defined TXT keys:
auth plaintext | md5 | rsakeys
userid alphanumeric, additionally '_', '+', '-'
secret any printable ASCII characters
domain any DNS domain name or IP address
extension alphanumeric, additionally '*', '#', '_', '+', '-'
context alphanumeric, additionally '_', '+', '-'
trunk yes | no | 0 | 1
welcome alphanumeric, additionally '*', '#', '_', '+', '-'
voicemail alphanumeric, additionally '*', '#', '_', '+', '-'
reception alphanumeric, additionally '*', '#', '_', '+', '-'
echotest alphanumeric, additionally '*', '#', '_', '+', '-'
ivrtest alphanumeric, additionally '*', '#', '_', '+', '-'
All of these TXT record keys are optional, they may be omitted. Further keys may be added in the future.
iax 4569 udp Inter-Asterisk eXchange Benjamin Kowarsch Benjamin Kowarsch RFC 5456 Defined TXT keys:
auth plaintext | md5 | rsakeys
userid alphanumeric, additionally '_', '+', '-'
secret any printable ASCII characters
domain any DNS domain name or IP address
extension alphanumeric, additionally '*', '#', '_', '+', '-'
context alphanumeric, additionally '_', '+', '-'
trunk yes | no | 0 | 1
welcome alphanumeric, additionally '*', '#', '_', '+', '-'
voicemail alphanumeric, additionally '*', '#', '_', '+', '-'
reception alphanumeric, additionally '*', '#', '_', '+', '-'
echotest alphanumeric, additionally '*', '#', '_', '+', '-'
ivrtest alphanumeric, additionally '*', '#', '_', '+', '-'
All of these TXT record keys are optional, they may be omitted. Further keys may be added in the future.
eportcommdata 4669 tcp E-Port Data Service Robert Shaffer Robert Shaffer 2006-02
eportcommdata 4669 udp E-Port Data Service Robert Shaffer Robert Shaffer 2006-02
prelude 4690 tcp Prelude IDS message proto Yoann Vandoorselaere Yoann Vandoorselaere 2005-08
prelude 4690 udp Prelude IDS message proto Yoann Vandoorselaere Yoann Vandoorselaere 2005-08
mtn 4691 tcp monotone Netsync Protocol Thomas Keller Thomas Keller 2010-12-22
mtn 4691 udp monotone Netsync Protocol Thomas Keller Thomas Keller 2010-12-22
conspiracy 4692 tcp Conspiracy messaging Jens Edlund Jens Edlund 2005-08
conspiracy 4692 udp Conspiracy messaging Jens Edlund Jens Edlund 2005-08
4693-4699 Unassigned
phrelaydbg 4869 tcp Photon Relay Debug Michael Hunter Michael Hunter
phrelaydbg 4869 udp Photon Relay Debug Michael Hunter Michael Hunter
ccss-qmm 4969 tcp CCSS QMessageMonitor
ccss-qmm 4969 udp CCSS QMessageMonitor
i-net-2000-npr 5069 tcp I/Net 2000-NPR Chris Megede Chris Megede
i-net-2000-npr 5069 udp I/Net 2000-NPR Chris Megede Chris Megede
5169-5171 Unassigned
xmpp-server 5269 tcp XMPP Server Connection RFC 6120
5269 udp Reserved
5466-5469 Unassigned
rdmnet-ctrl 5569 tcp PLASA E1.33, Remote Device Management (RDM) controller status notifications PLASA Simon Newton 2012-06-01
rdmnet-device 5569 udp PLASA E1.33, Remote Device Management (RDM) messages PLASA Simon Newton 2012-06-01
5667-5669 Unassigned
5690-5692 Unassigned
rbsystem 5693 tcp Robert Bosch Data Transfer Syntegon Technology GmbH Klaus Warth 2011-08-01 2020-02-04
5693 udp Reserved
5694-5695 Unassigned
kmip 5696 tcp Key Management Interoperability Protocol OASIS KMIP Technical Committee Robin Cover 2011-07-25
5696 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Arvel Hathcock arvel&altn.com 2007-03
Asaf Kashi asafk&microsoft.com
B. J. Kortekaas b.j.kortekaas&kpn.com 2003-02
Benjamin Kowarsch benjamin&sunrise-tel.com 2004-11
Chris Anderson Daegis, Inc. ianaportmaster&daegis.com 2012-07-31
Chris Das cdas&cnd.hp.com
Chris Megede chris.megede&tac.com
Daegis, Inc. ianaportmaster&daegis.com 2012-07-31
Dagfinn Saether Dagfinn&admins.com
Davey Taylor davey.taylor&brimstone.net 2003-02
Emre Tunar emre.tunar&ca.com 2004-11
Erlang/OTP support epmd&erix.ericsson.se 2004-12
Greg Hansen Mele Associates greg.hansen&meleassociates.com 2014-11-26
Greg Hudson ghudson&mit.edu 2023-11-17
Hitoshi Ishida ishida.hitoshi&exc.epson.co.jp
Jens Edlund edlund&speech.kth.se 2005-08
Jesus David Rodriguez jesusdavid&magaya.com 2003-02
Jim Thompson jim.thompson&powerware.com
Klaus Warth Syntegon Technology GmbH Klaus.Warth&Syntegon.com 2020-02-04
Mark Gamble mark.gamble&sage.com 2003-02
Mark Miller markm&caplet.com
Meinberg Funkuhren GmbH & Co. KG martin.burnicki&meinberg.de 2019-04-23
Meinberg IANA Registrations iana-admin&meinberg.de 2019-04-23
Mele Associates easl&meleassociates.com 2014-11-26
Michael Hunter mphunter&qnx.com
Michael Marking marking&tatanka.com
Mike Irani irani&spawar.navy.mil 2003-06
Mike Pontillo pontillo&hp.com 2003-08
Nedelcho Stanev nstanev&csoft.bg
Norm Freedman normfree&san.rr.com 2003-08
OASIS KMIP Technical Committee robin&oasis-open.org 2011-07-25
Paul A. Suhler paul.suhler&quantum.com 2009-02-06
Paul Suhler paul.suhler&quantum.com 2008-02-15
Peter Teeuwen ptee&oce.nl
Petri Rauhala petri.rauhala&nokia.com 2005-08
PLASA standards.na&plasa.org 2012-06-01
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Randy Yates Digital Signal Labs yates&digitalsignallabs.com 2014-11-26
Richard Lamb rlamb&microsoft.com
Robert Shaffer bob.shaffer&micmod.com 2006-02
Robert Vincent bert&mck.com
Robin Cover OASIS KMIP Technical Committee robin&oasis-open.org 2011-07-25
Ron Ehli ron&itinternet.net
Simon Newton simon&nomis52.net 2012-06-01
Sumitake kobayashi kobayashi&np.lps.cs.fujitsu.co.jp
Syntegon Technology GmbH Klaus.Warth&syntegon.com 2020-02-04
Thomas J. Pinkl tom&pinkl.com 2003-02
Thomas Keller me&thomaskeller.biz 2010-12-22
Tim Wiegand tim.wiegand&navisworks.com 2003-02
Yoann Vandoorselaere yoann&prelude-ids.org 2005-08
Yoshinobu Nakamura nakamura&np.lps.cs.fujitsu.co.jp