Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| rbakcup1 | 2773 | udp | RBackup Remote Backup | ||||||||
| psrt | 2873 | tcp | PubSub Realtime Telemetry Protocol | Altertech | Serhij Symonenko | 2021-11-12 | |||||
| psrt | 2873 | udp | PubSub Realtime Telemetry Protocol | Altertech | Serhij Symonenko | 2021-11-12 | |||||
| svnetworks | 2973 | tcp | SV Networks | Sylvia Siu | Sylvia Siu | ||||||
| svnetworks | 2973 | udp | SV Networks | Sylvia Siu | Sylvia Siu | ||||||
| vcrp | 3073 | tcp | Very simple chatroom prot | Andreas Wurf | Andreas Wurf | ||||||
| vcrp | 3073 | udp | Very simple chatroom prot | Andreas Wurf | Andreas Wurf | ||||||
| serverview-icc | 3173 | tcp | SERVERVIEW-ICC | Detlef Rothe | Detlef Rothe | 2009-05-15 | |||||
| serverview-icc | 3173 | udp | SERVERVIEW-ICC | Detlef Rothe | Detlef Rothe | 2009-05-15 | |||||
| sxmp | 3273 | tcp | Simple Extensible Multiplexed Protocol | admin | admin | ||||||
| sxmp | 3273 | udp | Simple Extensible Multiplexed Protocol | admin | admin | ||||||
| lavenir-lm | 3373 | tcp | Lavenir License Manager | Marius Matioc | Marius Matioc | ||||||
| lavenir-lm | 3373 | udp | Lavenir License Manager | Marius Matioc | Marius Matioc | ||||||
| jaugsremotec-2 | 3473 | tcp | JAUGS N-G Remotec 2 | Steven B. Cliff | Steven B. Cliff | 2002-04 | |||||
| jaugsremotec-2 | 3473 | udp | JAUGS N-G Remotec 2 | Steven B. Cliff | Steven B. Cliff | 2002-04 | |||||
| tag-ups-1 | 3573 | tcp | Advantage Group UPS Suite | James Goddard | James Goddard | 2002-08 | |||||
| tag-ups-1 | 3573 | udp | Advantage Group UPS Suite | James Goddard | James Goddard | 2002-08 | |||||
| mediavault-gui | 3673 | tcp | Openview Media Vault GUI | Stephen Gold | Stephen Gold | 2003-01 | |||||
| mediavault-gui | 3673 | udp | Openview Media Vault GUI | Stephen Gold | Stephen Gold | 2003-01 | |||||
| bts-x73 | 3681 | tcp | BTS X73 Port | Todd Cooper | Todd Cooper | 2003-01 | |||||
| bts-x73 | 3681 | udp | BTS X73 Port | Todd Cooper | Todd Cooper | 2003-01 | |||||
| client-ctrl | 3730 | tcp | Client Control | Lawrence W. Dunn | Lawrence W. Dunn | 2003-04 | |||||
| client-ctrl | 3730 | udp | Client Control | Lawrence W. Dunn | Lawrence W. Dunn | 2003-04 | |||||
| smap | 3731 | tcp | Service Manager | ||||||||
| smap | 3731 | udp | Service Manager | ||||||||
| m-wnn | 3732 | tcp | Mobile Wnn | Yasunari Yamashita | Yasunari Yamashita | 2003-04 | |||||
| m-wnn | 3732 | udp | Mobile Wnn | Yasunari Yamashita | Yasunari Yamashita | 2003-04 | |||||
| multip-msg | 3733 | tcp | Multipuesto Msg Port | Felisa Ares | Felisa Ares | 2003-04 | |||||
| multip-msg | 3733 | udp | Multipuesto Msg Port | Felisa Ares | Felisa Ares | 2003-04 | |||||
| synel-data | 3734 | tcp | Synel Data Collection Port | David Ashkenazi | David Ashkenazi | 2003-04 | |||||
| synel-data | 3734 | udp | Synel Data Collection Port | David Ashkenazi | David Ashkenazi | 2003-04 | |||||
| pwdis | 3735 | tcp | Password Distribution | Robert Erl | Robert Erl | 2003-04 | |||||
| pwdis | 3735 | udp | Password Distribution | Robert Erl | Robert Erl | 2003-04 | |||||
| rs-rmi | 3736 | tcp | RealSpace RMI | Barry McDarby | Barry McDarby | 2003-04 | |||||
| rs-rmi | 3736 | udp | RealSpace RMI | Barry McDarby | Barry McDarby | 2003-04 | |||||
| xpanel | 3737 | tcp | XPanel Daemon | Lilian Rudenco | Lilian Rudenco | 2009-03-04 | |||||
| 3737 | udp | Reserved | |||||||||
| versatalk | 3738 | tcp | versaTalk Server Port | Dr. Kingsley C. Nwosu | Dr. Kingsley C. Nwosu | 2003-04 | |||||
| versatalk | 3738 | udp | versaTalk Server Port | Dr. Kingsley C. Nwosu | Dr. Kingsley C. Nwosu | 2003-04 | |||||
| launchbird-lm | 3739 | tcp | Launchbird LicenseManager | Tom Hawkins | Tom Hawkins | 2003-04 | |||||
| launchbird-lm | 3739 | udp | Launchbird LicenseManager | Tom Hawkins | Tom Hawkins | 2003-04 | |||||
| ctdhercules | 3773 | tcp | ctdhercules | Carl Banzhof | Carl Banzhof | 2003-06 | |||||
| ctdhercules | 3773 | udp | ctdhercules | Carl Banzhof | Carl Banzhof | 2003-06 | |||||
| fagordnc | 3873 | tcp | fagordnc | Luis Zugasti | Luis Zugasti | 2003-11 | |||||
| fagordnc | 3873 | udp | fagordnc | Luis Zugasti | Luis Zugasti | 2003-11 | |||||
| progistics | 3973 | tcp | ConnectShip Progistics | ConnectShip, Inc. | Robert Kinyon | 2005-08 | 2019-12-12 | ||||
| progistics | 3973 | udp | ConnectShip Progistics | ConnectShip, Inc. | Robert Kinyon | 2005-08 | 2019-12-12 | ||||
| iRAPP | 4073 | tcp | Interactive Remote Application Pairing Protocol | Volodymyr_Bykov | Volodymyr_Bykov | 2007-08-20 | 2016-11-23 | ||||
| iRAPP | 4073 | udp | Interactive Remote Application Pairing Protocol | Volodymyr_Bykov | Volodymyr_Bykov | 2007-08-20 | 2016-11-23 | ||||
| 4173 | tcp | Reserved | |||||||||
| mma-discovery | 4173 | udp | MMA Device Discovery | MIDI Manufacturers Assoc Inc | Tom White | 2011-11-14 | |||||
| remctl | 4373 | tcp | Remote Authenticated Command Service | Russ Allbery | Russ Allbery | 2007-08-30 | |||||
| remctl | 4373 | udp | Remote Authenticated Command Service | Russ Allbery | Russ Allbery | 2007-08-30 | |||||
| cardifftec-back | 4573 | tcp | A port for communication between a server and client for a custom backup system | CardiffTec | Benjamin Misell | 2016-05-19 | |||||
| 4573 | udp | Reserved | |||||||||
| dots-signal | 4646 | tcp | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. | IESG | IETF Chair | 2020-01-16 | 2021-06-14 | RFC 8973; RFC 9132 | |||
| dots-signal | 4646 | udp | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. | IESG | IETF Chair | 2020-01-16 | 2021-06-14 | RFC 8973; RFC 9132 | |||
| cxws | 4673 | tcp | CXWS Operations | Phil Abercrombie | Phil Abercrombie | 2005-08 | |||||
| cxws | 4673 | udp | CXWS Operations | Phil Abercrombie | Phil Abercrombie | 2005-08 | |||||
| gearman | 4730 | tcp | Gearman Job Queue System | Eric Day | Eric Day | 2009-01-16 | |||||
| gearman | 4730 | udp | Gearman Job Queue System | Eric Day | Eric Day | 2009-01-16 | |||||
| remcap | 4731 | tcp | Remote Capture Protocol | Marc Donner | Marc Donner | 2009-01-16 | |||||
| 4731 | udp | Reserved | |||||||||
| 4732 | tcp | Reserved | |||||||||
| ohmtrigger | 4732 | udp | OHM server trigger | Franck Lefevre | Franck Lefevre | 2009-11-18 | |||||
| resorcs | 4733 | tcp | RES Orchestration Catalog Services | Bob Janssen | Bob Janssen | 2009-11-18 | |||||
| 4733 | udp | Reserved | |||||||||
| 4734-4736 | Unassigned | ||||||||||
| ipdr-sp | 4737 | tcp | IPDR/SP | Ken Sarno | Ken Sarno | 2005-08 | |||||
| ipdr-sp | 4737 | udp | IPDR/SP | Ken Sarno | Ken Sarno | 2005-08 | |||||
| solera-lpn | 4738 | tcp | SoleraTec Locator | Mark Armstrong | Mark Armstrong | 2005-12 | |||||
| solera-lpn | 4738 | udp | SoleraTec Locator | Mark Armstrong | Mark Armstrong | 2005-12 | |||||
| ipfix | 4739 | tcp | IP Flow Info Export | Nevil Brownlee | Nevil Brownlee | 2005-08 | |||||
| ipfix | 4739 | udp | IP Flow Info Export | Nevil Brownlee | Nevil Brownlee | 2005-08 | |||||
| ipfix | 4739 | sctp | IP Flow Info Export | Nevil Brownlee | Nevil Brownlee | 2006-01 | |||||
| 4757-4773 | Unassigned | ||||||||||
| vxlan | 4789 | udp | Virtual eXtensible Local Area Network (VXLAN) | Lawrence Kreeger | Lawrence Kreeger | 2013-04-19 | 2014-06-17 | RFC 7348 | |||
| tag-pm | 5073 | tcp | Advantage Group Port Mgr | James Goddard | James Goddard | 2005-08 | |||||
| tag-pm | 5073 | udp | Advantage Group Port Mgr | James Goddard | James Goddard | 2005-08 | |||||
| 5173-5189 | Unassigned | ||||||||||
| 5273-5279 | Unassigned | ||||||||||
| stuns | 5349 | udp | STUN over DTLS | IESG | IETF Chair | 2014-07-03 | RFC 7350 | This service name was initially created by RFC 5389. | |||
| turns | 5349 | udp | TURN over DTLS | IESG | IETF Chair | 2019-08-02 | RFC 7350 | This service name was initially created by RFC 8656. | |||
| apsolab-tags | 5473 | tcp | The Apsolab company's secure dynamic tag protocol | Apsolab Inc. | Jean-Francois Gauthier | 2014-11-10 | |||||
| 5473 | udp | Reserved | |||||||||
| sdmmp | 5573 | tcp | SAS Domain Management Messaging Protocol | Ron Zuckerman | Ron Zuckerman | 2007-08-30 | |||||
| sdmmp | 5573 | udp | SAS Domain Management Messaging Protocol | Ron Zuckerman | Ron Zuckerman | 2007-08-30 | |||||
| jms | 5673 | tcp | JACL Message Server | Stuart Allen | Stuart Allen | 2002-02 | |||||
| jms | 5673 | udp | JACL Message Server | Stuart Allen | Stuart Allen | 2002-02 | |||||
| coaps | 5684 | tcp | Constrained Application Protocol (CoAP) | IESG | IETF Chair | 2017-12-22 | RFC 7301; RFC 8323 | ||||
| unieng | 5730 | tcp | Steltor's calendar access | Bernard Desruisseaux | Bernard Desruisseaux | ||||||
| unieng | 5730 | udp | Steltor's calendar access | Bernard Desruisseaux | Bernard Desruisseaux | ||||||
| 5731-5740 | Unassigned | ||||||||||
| diameters | 5868 | tcp | Diameter over TLS/TCP | IESG | IETF Chair | RFC 6733 | |||||
| diameters | 5868 | sctp | Diameter over DTLS/SCTP | IESG | IETF Chair | RFC 6733 | |||||
| directplay8 | 6073 | tcp | DirectPlay8 | John Kane | John Kane | ||||||
| directplay8 | 6073 | udp | DirectPlay8 | John Kane | John Kane | ||||||
| ieee11073-20701 | 6464 | tcp | Port assignment for medical device communication in accordance to IEEE 11073-20701 | David Gregorczyk | David Gregorczyk | 2017-03-02 | |||||
| ieee11073-20701 | 6464 | udp | Port assignment for medical device communication in accordance to IEEE 11073-20701 | David Gregorczyk | David Gregorczyk | 2017-03-02 | |||||
| dccp-udp | 6511 | udp | Datagram Congestion Control Protocol Encapsulation for NAT Traversal | IESG | IETF Chair | RFC 6773 | |||||
| vision-elmd | 6673 | tcp | vision_elmd IANA assigned this well-formed service name as a replacement for "vision_elmd". |
Chris Kramer | Chris Kramer |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Altertech | pr&altertech.com | 2021-11-12 | |
| Andreas Wurf | a.wurf&mediatools.de | ||
| Apsolab Inc. | admin&apsolab.com | 2014-11-10 | |
| Barry McDarby | realspace&starwolf.biz | 2003-04 | |
| Benjamin Misell | beninjam174&gmail.com | 2016-05-19 | |
| Bernard Desruisseaux | bernard&steltor.com | ||
| Bob Janssen | b.janssen&ressoftware.com | 2009-11-18 | |
| CardiffTec | beninjam174&gmail.com | 2016-05-19 | |
| Carl Banzhof | cbanzhof&citadel.com | 2003-06 | |
| Chris Kramer | CKramer&gis.shl.com | ||
| ConnectShip, Inc. | ConnectShipIT&connectship.com | 2019-12-12 | |
| David Ashkenazi | david&synel.co.il | 2010-03-23 | |
| David Gregorczyk | david.gregorczyk&draeger.com | 2017-03-02 | |
| Detlef Rothe | detlef.rothe&ts.fujitsu.com | 2009-05-15 | |
| Dr. Kingsley C. Nwosu | knwosu&aglowmail.com | 2003-04 | |
| Eric Day | eday&oddments.org | 2009-01-16 | |
| Felisa Ares | faa06&tid.es | 2003-04 | |
| Franck Lefevre | franck.lefevre&digitalairways.com | 2009-11-18 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| James Goddard | jamesg&taglim.com | 2005-08 | |
| Jean-Francois Gauthier | Apsolab Inc. | jfgauthier&apsolab.com | 2014-11-10 |
| John Kane | johnkanµsoft.com | ||
| Ken Sarno | kensarno&insightbb.com | 2005-08 | |
| Lawrence Kreeger | kreeger&cisco.com | 2013-04-19 | |
| Lawrence W. Dunn | larrydunn&aptcomp.com | 2003-04 | |
| Lilian Rudenco | info&xpanel.com | 2009-03-04 | |
| Luis Zugasti | lzugasti&fagorautomation.es | 2003-11 | |
| Marc Donner | mail&poweraudio.de | 2009-01-16 | |
| Marius Matioc | marius&lavenir.com | ||
| Mark Armstrong | Mark.Armstrong&soleratec.com | 2005-12 | |
| MIDI Manufacturers Assoc Inc | info&midi.org | 2011-11-14 | |
| Nevil Brownlee | n.brownlee&auckland.ac.nz | 2006-10 | |
| Phil Abercrombie | phil.abercrombie&appiq.com | 2005-08 | |
| Robert Erl | roerl&web.de | 2003-04 | |
| Robert Kinyon | rkinyon&connectship.com | 2019-12-12 | |
| Ron Zuckerman | ron.zuckerman&lsi.com | 2007-08-30 | |
| Russ Allbery | rra&stanford.edu | 2007-08-30 | |
| Serhij Symonenko | Altertech | div&altertech.com | 2021-11-12 |
| Stephen Gold | 2003-01 | ||
| Steven B. Cliff | scliff&remotec-andros.com | 2003-07 | |
| Stuart Allen | stuart&jacl.animats.net | 2002-02 | |
| Sylvia Siu | ssiu&svnetworks.com | ||
| Todd Cooper | todd&do11073.com | 2003-01 | |
| Tom Hawkins | tom1&launchbird.com | 2003-04 | |
| Tom White | MIDI Manufacturers Assoc Inc | info&midi.org | 2011-11-14 |
| Volodymyr_Bykov | vbickov&gmail.com | 2016-11-23 | |
| Yasunari Yamashita | yamasita&omronsoft.co.jp | 2003-04 | |
| admin | iana&sightlinesystems.com |