Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| cpudpencap | 2746 | tcp | CPUDPENCAP | Tamir Zegman | Tamir Zegman | ||||||
| cpudpencap | 2746 | udp | CPUDPENCAP | Tamir Zegman | Tamir Zegman | ||||||
| fjippol-swrly | 2747 | tcp | |||||||||
| fjippol-swrly | 2747 | udp | |||||||||
| fjippol-polsvr | 2748 | tcp | |||||||||
| fjippol-polsvr | 2748 | udp | |||||||||
| fjippol-cnsl | 2749 | tcp | |||||||||
| fjippol-cnsl | 2749 | udp | |||||||||
| rbakcup2 | 2774 | tcp | RBackup Remote Backup | Rob Cosgrove | Rob Cosgrove | ||||||
| rbakcup2 | 2774 | udp | RBackup Remote Backup | Rob Cosgrove | Rob Cosgrove | ||||||
| dxmessagebase1 | 2874 | tcp | DX Message Base Transport Protocol | ||||||||
| dxmessagebase1 | 2874 | udp | DX Message Base Transport Protocol | ||||||||
| signal | 2974 | tcp | Signal | Wyatt Williams | Wyatt Williams | ||||||
| signal | 2974 | udp | Signal | Wyatt Williams | Wyatt Williams | ||||||
| xbox | 3074 | tcp | Xbox game port | Damon Danieli | Damon Danieli | ||||||
| xbox | 3074 | udp | Xbox game port | Damon Danieli | Damon Danieli | ||||||
| armi-server | 3174 | tcp | ARMI Server | Bobby Martin | Bobby Martin | ||||||
| armi-server | 3174 | udp | ARMI Server | Bobby Martin | Bobby Martin | ||||||
| ordinox-server | 3274 | tcp | Ordinox Server | Denis Ducharme | Denis Ducharme | ||||||
| ordinox-server | 3274 | udp | Ordinox Server | Denis Ducharme | Denis Ducharme | ||||||
| cluster-disc | 3374 | tcp | Cluster Disc | Jeff Hughes | Jeff Hughes | ||||||
| cluster-disc | 3374 | udp | Cluster Disc | Jeff Hughes | Jeff Hughes | ||||||
| ttntspauto | 3474 | tcp | TSP Automation | Arnie Koster | Arnie Koster | 2002-04 | |||||
| ttntspauto | 3474 | udp | TSP Automation | Arnie Koster | Arnie Koster | 2002-04 | |||||
| dmaf-server | 3574 | tcp | DMAF Server | ||||||||
| dmaf-caster | 3574 | udp | DMAF Caster | Ramakrishna Nadendla | Ramakrishna Nadendla | 2002-08 | |||||
| wininstall-ipc | 3674 | tcp | WinINSTALL IPC Port | Bill Somerville | Bill Somerville | 2008-08-13 | |||||
| wininstall-ipc | 3674 | udp | WinINSTALL IPC Port | Bill Somerville | Bill Somerville | 2008-08-13 | |||||
| heartbeat | 3740 | tcp | Heartbeat Protocol | Jeroen Massar | Jeroen Massar | 2003-04 | |||||
| heartbeat | 3740 | udp | Heartbeat Protocol | Jeroen Massar | Jeroen Massar | 2003-04 | |||||
| wysdma | 3741 | tcp | WysDM Agent | Jim McDonald | Jim McDonald | 2003-04 | |||||
| wysdma | 3741 | udp | WysDM Agent | Jim McDonald | Jim McDonald | 2003-04 | |||||
| cst-port | 3742 | tcp | CST - Configuration & Service Tracker | Hai Ou-Yang | Hai Ou-Yang | 2003-04 | |||||
| cst-port | 3742 | udp | CST - Configuration & Service Tracker | Hai Ou-Yang | Hai Ou-Yang | 2003-04 | |||||
| ipcs-command | 3743 | tcp | IP Control Systems Ltd. | Paul Anderson | Paul Anderson | 2003-04 | |||||
| ipcs-command | 3743 | udp | IP Control Systems Ltd. | Paul Anderson | Paul Anderson | 2003-04 | |||||
| sasg | 3744 | tcp | SASG | Cristian Petculescu | Cristian Petculescu | 2003-04 | |||||
| sasg | 3744 | udp | SASG | Cristian Petculescu | Cristian Petculescu | 2003-04 | |||||
| gw-call-port | 3745 | tcp | GWRTC Call Port | Felisa Ares | Felisa Ares | 2003-04 | |||||
| gw-call-port | 3745 | udp | GWRTC Call Port | Felisa Ares | Felisa Ares | 2003-04 | |||||
| linktest | 3746 | tcp | LXPRO.COM LinkTest | ||||||||
| linktest | 3746 | udp | LXPRO.COM LinkTest | ||||||||
| linktest-s | 3747 | tcp | LXPRO.COM LinkTest SSL | Greg Bailey | Greg Bailey | 2003-04 | |||||
| linktest-s | 3747 | udp | LXPRO.COM LinkTest SSL | Greg Bailey | Greg Bailey | 2003-04 | |||||
| webdata | 3748 | tcp | webData | Michael Whiteley | Michael Whiteley | 2003-04 | |||||
| webdata | 3748 | udp | webData | Michael Whiteley | Michael Whiteley | 2003-04 | |||||
| cimtrak | 3749 | tcp | CimTrak | Robert E. Johnson III | Robert E. Johnson III | 2003-04 | |||||
| cimtrak | 3749 | udp | CimTrak | Robert E. Johnson III | Robert E. Johnson III | 2003-04 | |||||
| zicom | 3774 | tcp | ZICOM | Sabu Das | Sabu Das | 2003-06 | |||||
| zicom | 3774 | udp | ZICOM | Sabu Das | Sabu Das | 2003-06 | |||||
| sixxsconfig | 3874 | tcp | SixXS Configuration | Jeroen Massar | Jeroen Massar | 2003-11 | |||||
| sixxsconfig | 3874 | udp | SixXS Configuration | Jeroen Massar | Jeroen Massar | 2003-11 | |||||
| xk22 | 3974 | tcp | Remote Applicant Tracking Service | Marc Castelluccio | Marc Castelluccio | 2005-08 | 2022-09-09 | ||||
| xk22 | 3974 | udp | Remote Applicant Tracking Service | Marc Castelluccio | Marc Castelluccio | 2005-08 | 2022-09-09 | ||||
| cequint-cityid | 4074 | tcp | Cequint City ID UI trigger | Phill Goeckler | Phill Goeckler | 2007-08-20 | |||||
| cequint-cityid | 4074 | udp | Cequint City ID UI trigger | Phill Goeckler | Phill Goeckler | 2007-08-20 | |||||
| smcluster | 4174 | tcp | StorMagic Cluster Services | Chris Farey | Chris Farey | 2011-03-09 | |||||
| sm-disc | 4174 | udp | StorMagic Discovery | StorMagic Ltd | Chris Farey | 2011-12-16 | |||||
| psi-ptt | 4374 | tcp | PSI Push-to-Talk Protocol | Frank Bredenbröcker | Frank Bredenbröcker | 2008-07-17 | |||||
| 4374 | udp | Reserved | |||||||||
| dtn-bundle | 4556 | tcp | DTN Bundle TCP CL Protocol | IESG | IETF Chair | 2021-02-22 | RFC 9174 | ||||
| 4574-4589 | Unassigned | ||||||||||
| appiq-mgmt | 4674 | tcp | AppIQ Agent Management | Phil Abercrombie | Phil Abercrombie | 2005-08 | |||||
| appiq-mgmt | 4674 | udp | AppIQ Agent Management | Phil Abercrombie | Phil Abercrombie | 2005-08 | |||||
| ipfixs | 4740 | tcp | ipfix protocol over TLS | Nevil Brownlee | Nevil Brownlee | 2006-10 | |||||
| ipfixs | 4740 | sctp | ipfix protocol over DTLS | Nevil Brownlee | Nevil Brownlee | 2006-10 | |||||
| ipfixs | 4740 | udp | ipfix protocol over DTLS | Nevil Brownlee | Nevil Brownlee | 2006-10 | |||||
| lumimgrd | 4741 | tcp | Luminizer Manager | George Hwa | George Hwa | 2007-03 | |||||
| lumimgrd | 4741 | udp | Luminizer Manager | George Hwa | George Hwa | 2007-03 | |||||
| sicct | 4742 | tcp | SICCT | ||||||||
| sicct-sdp | 4742 | udp | SICCT Service Discovery Protocol | TeleTrusT Deutschland e.V. | TeleTrusT Deutschland e.V. | 2006-04 | |||||
| openhpid | 4743 | tcp | openhpi HPI service | Thomas Kanngieser | Thomas Kanngieser | 2006-01 | |||||
| openhpid | 4743 | udp | openhpi HPI service | Thomas Kanngieser | Thomas Kanngieser | 2006-01 | |||||
| ifsp | 4744 | tcp | Internet File Synchronization Protocol | Alex White | Alex White | 2007-09-12 | |||||
| ifsp | 4744 | udp | Internet File Synchronization Protocol | Alex White | Alex White | 2007-09-12 | |||||
| fmp | 4745 | tcp | Funambol Mobile Push | Andrea Gazzaniga | Andrea Gazzaniga | 2007-01 | |||||
| fmp | 4745 | udp | Funambol Mobile Push | Andrea Gazzaniga | Andrea Gazzaniga | 2007-01 | |||||
| 4746 | tcp | Reserved | |||||||||
| intelliadm-disc | 4746 | udp | IntelliAdmin Discovery | IntelliAdmin, LLC | Steve Wiseman | 2016-11-18 | |||||
| buschtrommel | 4747 | udp | peer-to-peer file exchange protocol | Tobias Sturm | Tobias Sturm | 2013-01-14 | |||||
| 4747 | tcp | Reserved | |||||||||
| 4748-4748 | Unassigned | ||||||||||
| profilemac | 4749 | tcp | Profile for Mac | David Sinclair | David Sinclair | 2006-05 | |||||
| profilemac | 4749 | udp | Profile for Mac | David Sinclair | David Sinclair | 2006-05 | |||||
| converge | 4774 | tcp | Converge RPC | Asteris, LLC | Steven Borrelli | 2016-09-16 | |||||
| 4774 | udp | Reserved | |||||||||
| alesquery | 5074 | tcp | ALES Query | Tim Maloney | Tim Maloney | 2005-08 | |||||
| alesquery | 5074 | udp | ALES Query | Tim Maloney | Tim Maloney | 2005-08 | |||||
| apsolab-rpc | 5474 | udp | The Apsolab company's status query protocol | Apsolab Inc. | Jean-Francois Gauthier | 2014-11-10 | |||||
| 5474 | tcp | Reserved | |||||||||
| lsi-bobcat | 5574 | tcp | SAS IO Forwarding | Mandar Joshi | Mandar Joshi | 2009-02-09 | |||||
| 5574 | udp | Reserved | |||||||||
| hyperscsi-port | 5674 | tcp | HyperSCSI Port | Data Storage Institute of Singapore | Data Storage Institute of Singapore | 2002-02 | |||||
| hyperscsi-port | 5674 | udp | HyperSCSI Port | Data Storage Institute of Singapore | Data Storage Institute of Singapore | 2002-02 | |||||
| 5731-5740 | Unassigned | ||||||||||
| ida-discover1 | 5741 | tcp | IDA Discover Port 1 | MPITech Support | MPITech Support | ||||||
| ida-discover1 | 5741 | udp | IDA Discover Port 1 | MPITech Support | MPITech Support | ||||||
| ida-discover2 | 5742 | tcp | IDA Discover Port 2 | MPITech Support | MPITech Support | ||||||
| ida-discover2 | 5742 | udp | IDA Discover Port 2 | MPITech Support | MPITech Support | ||||||
| watchdoc-pod | 5743 | tcp | Watchdoc NetPOD Protocol | Christophe Chevalier | Christophe Chevalier | 2005-08 | |||||
| watchdoc-pod | 5743 | udp | Watchdoc NetPOD Protocol | Christophe Chevalier | Christophe Chevalier | 2005-08 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alex White | alex&intralan.co.uk | 2007-09-12 | |
| Andrea Gazzaniga | gazzaniga&funambol.com | 2007-01 | |
| Apsolab Inc. | admin&apsolab.com | 2014-11-10 | |
| Arnie Koster | akoster&teltone.com | 2002-04 | |
| Asteris, LLC | info&aster.is | 2016-09-16 | |
| Bill Somerville | Bill.Somerville&scalable.com | 2008-08-13 | |
| Bobby Martin | bobbymartin&hotmail.com | ||
| Chris Farey | StorMagic Ltd | chris_farey&stormagic.com | 2011-12-16 |
| Christophe Chevalier | chevalier&archimed.fr | 2005-08 | |
| Cristian Petculescu | cristp&hotmail.com | 2003-04 | |
| Damon Danieli | damondµsoft.com | ||
| Data Storage Institute of Singapore | Patrick&dsi.nus.edu.sg | 2002-02 | |
| David Sinclair | dev&profilemac.com | 2006-05 | |
| Denis Ducharme | dducharme&softek.com | ||
| Felisa Ares | faa06&tid.es | 2003-04 | |
| Frank Bredenbröcker | fbredenbroecker&psi.de | 2008-07-17 | |
| George Hwa | george.hwa&kla-tencor.com | 2016-10-17 | |
| Greg Bailey | gbailey&lxpro.com | 2003-04 | |
| Hai Ou-Yang | hai.ou-yang&sun.com | 2003-04 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| IntelliAdmin, LLC | support&intelliadmin.com | 2016-11-18 | |
| Jean-Francois Gauthier | Apsolab Inc. | jfgauthier&apsolab.com | 2014-11-10 |
| Jeff Hughes | Jeff.Hughes&columbiasc.ncr.com | ||
| Jeroen Massar | jeroen&unfix.org | 2005-08 | |
| Jim McDonald | Jim.McDonald&sysdm.com | 2003-04 | |
| MPITech Support | morten.christensen&i-data.com | ||
| Mandar Joshi | mandar.joshi&lsi.com | 2009-02-09 | |
| Marc Castelluccio | marc&xk22.com | 2022-08-16 | |
| Michael Whiteley | michael&whiteley.com | 2003-04 | |
| Nevil Brownlee | n.brownlee&auckland.ac.nz | 2006-10 | |
| Paul Anderson | paul.anderson&ip-cs.com | 2003-04 | |
| Phil Abercrombie | phil.abercrombie&appiq.com | 2005-08 | |
| Phill Goeckler | pgoeckler&cequint.com | 2007-08-20 | |
| Ramakrishna Nadendla | rama_nadendla&agilent.com | 2002-08 | |
| Rob Cosgrove | rob&alice.net | ||
| Robert E. Johnson III | johnson.robert&cimcor.com | 2003-04 | |
| Sabu Das | sabud&zicomsecure.com | 2003-06 | |
| Steve Wiseman | steve.wiseman&intelliadmin.com | 2016-11-18 | |
| Steven Borrelli | steve&aster.is | 2016-09-16 | |
| StorMagic Ltd | chris_farey&stormagic.com | 2011-12-16 | |
| Tamir Zegman | zegman&checkpoint.com | ||
| TeleTrusT Deutschland e.V. | info&teletrust.de | 2006-04 | |
| Thomas Kanngieser | thomas.kanngieser&arcor.de | 2006-01 | |
| Tim Maloney | tim.maloney&allianceconsultingllc.com | 2005-08 | |
| Tobias Sturm | tobias.sturm&student.kit.edu | 2013-01-14 | |
| Wyatt Williams | wyattw&icall.com |