Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
blockade 2911 tcp Blockade VP - Research & Development VP - Research & Development
blockade 2911 udp Blockade VP - Research & Development VP - Research & Development
epicon 2912 tcp Epicon Michael Khalandovsky Michael Khalandovsky
epicon 2912 udp Epicon Michael Khalandovsky Michael Khalandovsky
boosterware 2913 tcp Booster Ware Ido Ben-David Ido Ben-David
boosterware 2913 udp Booster Ware Ido Ben-David Ido Ben-David
gamelobby 2914 tcp Game Lobby Paul Ford-Hutchinson Paul Ford-Hutchinson
gamelobby 2914 udp Game Lobby Paul Ford-Hutchinson Paul Ford-Hutchinson
tksocket 2915 tcp TK Socket Dino Ciano Dino Ciano 2011-03-02
tksocket 2915 udp TK Socket Dino Ciano Dino Ciano 2011-03-02
elvin-server 2916 tcp Elvin Server

IANA assigned this well-formed service name as a replacement for "elvin_server".
elvin_server 2916 tcp Elvin Server This entry is an alias to "elvin-server". This entry is now historic, not usable for use with many common service discovery mechanisms.
elvin-server 2916 udp Elvin Server

IANA assigned this well-formed service name as a replacement for "elvin_server".
elvin_server 2916 udp Elvin Server This entry is an alias to "elvin-server". This entry is now historic, not usable for use with many common service discovery mechanisms.
elvin-client 2917 tcp Elvin Client

IANA assigned this well-formed service name as a replacement for "elvin_client".
David Arnold David Arnold
elvin_client 2917 tcp Elvin Client David Arnold David Arnold This entry is an alias to "elvin-client". This entry is now historic, not usable for use with many common service discovery mechanisms.
elvin-client 2917 udp Elvin Client

IANA assigned this well-formed service name as a replacement for "elvin_client".
David Arnold David Arnold
elvin_client 2917 udp Elvin Client David Arnold David Arnold This entry is an alias to "elvin-client". This entry is now historic, not usable for use with many common service discovery mechanisms.
kastenchasepad 2918 tcp Kasten Chase Pad Marc Gauthier Marc Gauthier
kastenchasepad 2918 udp Kasten Chase Pad Marc Gauthier Marc Gauthier
roboer 2919 tcp roboER Paul Snook Paul Snook
roboer 2919 udp roboER Paul Snook Paul Snook
wkstn-mon 2991 tcp WKSTN-MON William David William David
wkstn-mon 2991 udp WKSTN-MON William David William David
1ci-smcs 3091 tcp 1Ci Server Management Ralf Bensmann Ralf Bensmann
1ci-smcs 3091 udp 1Ci Server Management Ralf Bensmann Ralf Bensmann
csvr-sslproxy 3191 tcp ConServR SSL Proxy Mikhail Kruk Mikhail Kruk
csvr-sslproxy 3191 udp ConServR SSL Proxy Mikhail Kruk Mikhail Kruk
sah-lm 3291 tcp S A Holditch & Associates - LM Randy Hudgens Randy Hudgens
sah-lm 3291 udp S A Holditch & Associates - LM Randy Hudgens Randy Hudgens
savant 3391 tcp SAVANT Andy Bruce Andy Bruce
savant 3391 udp SAVANT Andy Bruce Andy Bruce
swr-port 3491 tcp SWR Port Ian Manning Ian Manning 2002-05
swr-port 3491 udp SWR Port Ian Manning Ian Manning 2002-05
gtrack-server 3591 tcp LOCANIS G-TRACK Server
gtrack-server 3591 udp LOCANIS G-TRACK Server
magaya-network 3691 tcp Magaya Network Port Jesus David Rodriguez Jesus David Rodriguez 2003-02
magaya-network 3691 udp Magaya Network Port Jesus David Rodriguez Jesus David Rodriguez 2003-02
tvnetworkvideo 3791 tcp TV NetworkVideo Data port Kevin Brunner Kevin Brunner 2003-07
tvnetworkvideo 3791 udp TV NetworkVideo Data port Kevin Brunner Kevin Brunner 2003-07
rtc-pm-port 3891 tcp Oracle RTC-PM port PV Shivkumar PV Shivkumar 2003-10
rtc-pm-port 3891 udp Oracle RTC-PM port PV Shivkumar PV Shivkumar 2003-10
prnrequest 3910 tcp Printer Request Port Brett Green Brett Green 2003-11
prnrequest 3910 udp Printer Request Port Brett Green Brett Green 2003-11
prnstatus 3911 tcp Printer Status Port Brett Green Brett Green 2003-11
prnstatus 3911 udp Printer Status Port Brett Green Brett Green 2003-11
gbmt-stars 3912 tcp Global Maintech Stars Harry Goldschmitt Harry Goldschmitt 2003-11
gbmt-stars 3912 udp Global Maintech Stars Harry Goldschmitt Harry Goldschmitt 2003-11
listcrt-port 3913 tcp ListCREATOR Port Tomokazu Asai Tomokazu Asai 2003-11
listcrt-port 3913 udp ListCREATOR Port Tomokazu Asai Tomokazu Asai 2003-11
listcrt-port-2 3914 tcp ListCREATOR Port 2 Tomokazu Asai Tomokazu Asai 2003-11
listcrt-port-2 3914 udp ListCREATOR Port 2 Tomokazu Asai Tomokazu Asai 2003-11
agcat 3915 tcp Auto-Graphics Cataloging Paul Cope Paul Cope 2003-11
agcat 3915 udp Auto-Graphics Cataloging Paul Cope Paul Cope 2003-11
wysdmc 3916 tcp WysDM Controller Jim McDonald Jim McDonald 2003-11
wysdmc 3916 udp WysDM Controller Jim McDonald Jim McDonald 2003-11
aftmux 3917 tcp AFT multiplex port Alfred Schmidt Alfred Schmidt 2003-11
aftmux 3917 udp AFT multiplex port Alfred Schmidt Alfred Schmidt 2003-11
pktcablemmcops 3918 tcp PacketCableMultimediaCOPS Eric Rosenfeld Eric Rosenfeld 2003-11
pktcablemmcops 3918 udp PacketCableMultimediaCOPS Eric Rosenfeld Eric Rosenfeld 2003-11
hyperip 3919 tcp HyperIP Network Executive Software, Inc. Nancy Golio 2003-11 2017-01-25
hyperip 3919 udp HyperIP Network Executive Software, Inc. Nancy Golio 2003-11 2017-01-25
bv-smcsrv 3991 tcp BindView-SMCServer
bv-smcsrv 3991 udp BindView-SMCServer
ewinstaller 4091 tcp EminentWare Installer
ewinstaller 4091 udp EminentWare Installer
4191 tcp Reserved
dsmipv6 4191 udp Dual Stack MIPv6 NAT Traversal RFC 5555
apwi-imserver 4391 tcp American Printware IMServer Protocol Lech Lakomy Lech Lakomy 2009-02-12
4391 udp Reserved
ntske 4460 tcp Network Time Security Key Establishment IESG IETF Chair 2020-04-07 RFC 8915
4489-4499 Unassigned Known UNAUTHORIZED USE: Ports 4490 and 4491
dtn-bundle 4556 tcp DTN Bundle TCP CL Protocol IESG IETF Chair 2021-02-22 RFC 9174
l3t-at-an 4591 tcp HRPD L3T (AT-AN) Avi Lior Avi Lior 2009-02-27
l3t-at-an 4591 udp HRPD L3T (AT-AN) Avi Lior Avi Lior 2009-02-27
dots-signal 4646 tcp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. IESG IETF Chair 2020-01-16 2021-06-14 RFC 8973; RFC 9132
dots-signal 4646 udp Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Protocol. The service name is used to construct the SRV service names "_dots-signal._udp" and "_dots-signal._tcp" for discovering DOTS servers used to establish DOTS signal channel. IESG IETF Chair 2020-01-16 2021-06-14 RFC 8973; RFC 9132
mtn 4691 tcp monotone Netsync Protocol Thomas Keller Thomas Keller 2010-12-22
mtn 4691 udp monotone Netsync Protocol Thomas Keller Thomas Keller 2010-12-22
roce 4791 udp IP Routable RocE InfiniBand Trade Association (IBTA) Diego Crupnicoff (IBTA TWG Chair) 2014-10-17
4791 tcp Reserved
4903-4911 Unassigned
lutap 4912 tcp Technicolor LUT Access Protocol Markus Loeffler Markus Loeffler 2009-02-17
4912 udp Reserved
lutcp 4913 tcp LUTher Control Protocol Markus Loeffler Markus Loeffler 2007-07-03
bones 4914 tcp Bones Remote Control Andreas Foedrowitz Andreas Foedrowitz 2008-06-18
bones 4914 udp Bones Remote Control Andreas Foedrowitz Andreas Foedrowitz 2008-06-18
frcs 4915 tcp Fibics Remote Control Service Ken Lagarec Ken Lagarec 2009-04-17
4915 udp Reserved
4916-4929 Unassigned
vrt 4991 tcp VITA Radio Transport Sam Bretheim Sam Bretheim 2009-01-08
vrt 4991 udp VITA Radio Transport Sam Bretheim Sam Bretheim 2009-01-08
cxtp 5091 sctp Context Transfer Protocol 2005-07 RFC 4065
aol-1 5191 tcp AmericaOnline1 Bruce Mackey Bruce Mackey
aol-1 5191 udp AmericaOnline1 Bruce Mackey Bruce Mackey
ats-atn 5910 tcp Air Traffic Services applications using ATN Eivan Cerasi Greg Saccone 2008-10-10 2022-08-08
ats-atn 5910 udp Air Traffic Services applications using ATN Eivan Cerasi Greg Saccone 2008-10-10 2022-08-08
cm 5910 sctp Context Management Justin Yu Justin Yu 2011-05-19
ats-acars 5911 tcp Air Traffic Services applications using ACARS Eivan Cerasi Greg Saccone 2008-10-10 2022-08-08
ats-acars 5911 udp Air Traffic Services applications using ACARS Eivan Cerasi Greg Saccone 2008-10-10 2022-08-08
cpdlc 5911 sctp Controller Pilot Data Link Communication Justin Yu Justin Yu 2011-05-18

Contact Information

Name Organization Contact URI Last Updated
Alfred Schmidt a.schmidt&aft-werdohl.de 2003-11
Andreas Foedrowitz andreas.foedrowitz&thomson.net 2008-06-18
Andy Bruce franklin_yah&yahoo.com
Avi Lior avi&bridgewatersystems.com 2009-02-27
VP - Research & Development development&blockade.com
Brett Green brett_green&hp.com 2003-11
Bruce Mackey BAMackey&aol.com
David Arnold davida&pobox.com
Diego Crupnicoff (IBTA TWG Chair) diego&mellanox.com 2014-10-17
Dino Ciano DCiano&tickets.com 2011-03-02
Eivan Cerasi eivan.cerasi&eurocontrol.int 2022-08-08
Eric Rosenfeld e.rosenfeld&cablelabs.com 2003-11
Greg Saccone gregory.t.saccone&boeing.com 2022-08-08
Harry Goldschmitt hgoldschmitt&hgac.com 2003-11
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ian Manning imanning&dtsuk.com 2002-05
Ido Ben-David dgntcom&netvision.net.il
InfiniBand Trade Association (IBTA) administration&infinibandta.org 2014-10-17
Jesus David Rodriguez jesusdavid&magaya.com 2003-02
Jim McDonald jim.mcdonald&sysdm.com 2003-11
Justin Yu yyu&mitre.org 2011-05-25
Ken Lagarec klagarec&fibics.com 2009-04-17
Kevin Brunner brunner&tivo.com 2003-07
Lech Lakomy llakomy&apwi.com 2009-02-12
Marc Gauthier mgau&kastenchase.com
Markus Loeffler markus.loeffler&thomson.net 2009-02-17
Michael Khalandovsky mlk&epicon.com
Mikhail Kruk mkruk&biscom.com
Nancy Golio nancy.golio&netex.com 2017-01-25
Network Executive Software, Inc. support&netex.com 2017-01-25
Paul Cope prc&auto-graphics.com 2003-11
Paul Ford-Hutchinson paulfordh&uk.ibm.com 2003-01
Paul Snook paul.snook&itheon.com
PV Shivkumar p.shivkumar&oracle.com 2003-10
Ralf Bensmann iana&1ci.de
Randy Hudgens rhh&nmail.holditch.com
Sam Bretheim info&opensigint.org 2009-01-08
Thomas Keller me&thomaskeller.biz 2010-12-22
Tomokazu Asai asai.tomokazu&pfu.fujitsu.com 2003-11
William David william.david&lmco.com