Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| cesdcdtrn | 2922 | udp | CESD Contents Delivery Data Transfer | Shinya Abe | Shinya Abe | ||||||
| wta-wsp-wtp-s | 2923 | tcp | WTA-WSP-WTP-S | Sebastien Bury | Sebastien Bury | ||||||
| wta-wsp-wtp-s | 2923 | udp | WTA-WSP-WTP-S | Sebastien Bury | Sebastien Bury | ||||||
| precise-vip | 2924 | tcp | PRECISE-VIP | Michael Landwehr | Michael Landwehr | ||||||
| precise-vip | 2924 | udp | PRECISE-VIP | Michael Landwehr | Michael Landwehr | ||||||
| 2925 | Unassigned (FRP-Released 12/7/00) | ||||||||||
| mobile-file-dl | 2926 | tcp | MOBILE-FILE-DL | Mitsuji Toda | Mitsuji Toda | ||||||
| mobile-file-dl | 2926 | udp | MOBILE-FILE-DL | Mitsuji Toda | Mitsuji Toda | ||||||
| unimobilectrl | 2927 | tcp | UNIMOBILECTRL | Vikas | Vikas | ||||||
| unimobilectrl | 2927 | udp | UNIMOBILECTRL | Vikas | Vikas | ||||||
| redstone-cpss | 2928 | tcp | REDSTONE-CPSS | Jeff Looman | Jeff Looman | ||||||
| redstone-cpss | 2928 | udp | REDSTONE-CPSS | Jeff Looman | Jeff Looman | ||||||
| amx-webadmin | 2929 | tcp | AMX-WEBADMIN | Mike Morris | Mike Morris | ||||||
| amx-webadmin | 2929 | udp | AMX-WEBADMIN | Mike Morris | Mike Morris | ||||||
| avenyo | 2992 | tcp | Avenyo Server | Bodo Rueskamp | Bodo Rueskamp | ||||||
| avenyo | 2992 | udp | Avenyo Server | Bodo Rueskamp | Bodo Rueskamp | ||||||
| 3092 | Unassigned | 2008-04-22 | |||||||||
| firemonrcc | 3192 | tcp | FireMon Revision Control | Michael Bishop | Michael Bishop | ||||||
| firemonrcc | 3192 | udp | FireMon Revision Control | Michael Bishop | Michael Bishop | ||||||
| cart-o-rama | 3292 | tcp | Cart O Rama | Phillip Dillinger | Phillip Dillinger | ||||||
| cart-o-rama | 3292 | udp | Cart O Rama | Phillip Dillinger | Phillip Dillinger | ||||||
| efi-lm | 3392 | tcp | EFI License Management | Ross E. Greinke | Ross E. Greinke | ||||||
| efi-lm | 3392 | udp | EFI License Management | Ross E. Greinke | Ross E. Greinke | ||||||
| tvdumtray-port | 3492 | tcp | TVDUM Tray Port | Peter Boers | Peter Boers | 2002-05 | |||||
| tvdumtray-port | 3492 | udp | TVDUM Tray Port | Peter Boers | Peter Boers | 2002-05 | |||||
| nut | 3493 | tcp | Network UPS Tools | Network UPS Tools Project | Evgeny Klimov | 2002-05 | 2022-05-18 | RFC 9271 | |||
| gtrack-ne | 3592 | tcp | LOCANIS G-TRACK NE Port | Juergen Edelhaeuser | Juergen Edelhaeuser | 2002-08 | |||||
| gtrack-ne | 3592 | udp | LOCANIS G-TRACK NE Port | Juergen Edelhaeuser | Juergen Edelhaeuser | 2002-08 | |||||
| intelsync | 3692 | tcp | Brimstone IntelSync | Davey Taylor | Davey Taylor | 2003-02 | |||||
| intelsync | 3692 | udp | Brimstone IntelSync | Davey Taylor | Davey Taylor | 2003-02 | |||||
| sitewatch | 3792 | tcp | e-Watch Corporation SiteWatch | John M. Baird | John M. Baird | 2003-07 | |||||
| sitewatch | 3792 | udp | e-Watch Corporation SiteWatch | John M. Baird | John M. Baird | 2003-07 | |||||
| pcc-image-port | 3892 | tcp | PCC-image-port | Shiro Tamoto | Shiro Tamoto | 2003-10 | |||||
| pcc-image-port | 3892 | udp | PCC-image-port | Shiro Tamoto | Shiro Tamoto | 2003-10 | |||||
| exasoftport1 | 3920 | tcp | Exasoft IP Port | Alan Malik | Alan Malik | 2003-11 | |||||
| exasoftport1 | 3920 | udp | Exasoft IP Port | Alan Malik | Alan Malik | 2003-11 | |||||
| herodotus-net | 3921 | tcp | Herodotus Net | Adam Gawne-Cain | Adam Gawne-Cain | 2003-11 | |||||
| herodotus-net | 3921 | udp | Herodotus Net | Adam Gawne-Cain | Adam Gawne-Cain | 2003-11 | |||||
| sor-update | 3922 | tcp | Soronti Update Port | Carleton Watkins | Carleton Watkins | 2003-11 | |||||
| sor-update | 3922 | udp | Soronti Update Port | Carleton Watkins | Carleton Watkins | 2003-11 | |||||
| symb-sb-port | 3923 | tcp | Symbian Service Broker | Ian McDowall | Ian McDowall | 2003-11 | |||||
| symb-sb-port | 3923 | udp | Symbian Service Broker | Ian McDowall | Ian McDowall | 2003-11 | |||||
| mpl-gprs-port | 3924 | tcp | MPL_GPRS_PORT | David Barrass | David Barrass | 2003-11 | |||||
| mpl-gprs-port | 3924 | udp | MPL_GPRS_Port | David Barrass | David Barrass | 2003-11 | |||||
| zmp | 3925 | tcp | Zoran Media Port | Gerard Cerchio | Gerard Cerchio | 2003-11 | |||||
| zmp | 3925 | udp | Zoran Media Port | Gerard Cerchio | Gerard Cerchio | 2003-11 | |||||
| winport | 3926 | tcp | WINPort | Alwin Egger | Alwin Egger | 2003-11 | |||||
| winport | 3926 | udp | WINPort | Alwin Egger | Alwin Egger | 2003-11 | |||||
| natdataservice | 3927 | tcp | ScsTsr | Ghanshyam Patel | Ghanshyam Patel | 2003-11 | |||||
| natdataservice | 3927 | udp | ScsTsr | Ghanshyam Patel | Ghanshyam Patel | 2003-11 | |||||
| netboot-pxe | 3928 | tcp | PXE NetBoot Manager | Markus Treinen | Markus Treinen | 2003-11 | |||||
| netboot-pxe | 3928 | udp | PXE NetBoot Manager | Markus Treinen | Markus Treinen | 2003-11 | |||||
| smauth-port | 3929 | tcp | AMS Port | Angelique Dokos | Angelique Dokos | 2003-11 | |||||
| smauth-port | 3929 | udp | AMS Port | Angelique Dokos | Angelique Dokos | 2003-11 | |||||
| bv-ds | 3992 | tcp | BindView-DirectoryServer | ||||||||
| bv-ds | 3992 | udp | BindView-DirectoryServer | ||||||||
| ewdgs | 4092 | tcp | EminentWare DGS | David A. Gayler | David A. Gayler | 2006-07 | |||||
| ewdgs | 4092 | udp | EminentWare DGS | David A. Gayler | David A. Gayler | 2006-07 | |||||
| azeti | 4192 | tcp | Azeti Agent Service | Uwe Holz | Uwe Holz | 2009-11-09 | |||||
| azeti-bd | 4192 | udp | azeti blinddate | Michael Werski | Michael Werski | 2010-02-18 | |||||
| apwi-rxserver | 4392 | tcp | American Printware RXServer Protocol | Lech Lakomy | Lech Lakomy | 2009-02-12 | |||||
| 4392 | udp | Reserved | |||||||||
| 4592 | tcp | Reserved | |||||||||
| hrpd-ith-at-an | 4592 | udp | HRPD-ITH (AT-AN) | David Ott | David Ott | 2008-06-05 | |||||
| conspiracy | 4692 | tcp | Conspiracy messaging | Jens Edlund | Jens Edlund | 2005-08 | |||||
| conspiracy | 4692 | udp | Conspiracy messaging | Jens Edlund | Jens Edlund | 2005-08 | |||||
| unified-bus | 4792 | tcp | IP Routable Unified Bus | Huawei | Wei Pan | 2022-07-08 | 2023-04-10 | ||||
| unified-bus | 4792 | udp | IP Routable Unified Bus | Huawei | Wei Pan | 2022-07-08 | 2023-04-10 | ||||
| 4916-4929 | Unassigned | ||||||||||
| 4992-4998 | Unassigned | ||||||||||
| 5092 | tcp | Reserved | |||||||||
| magpie | 5092 | udp | Magpie Binary | Phil Maker | Phil Maker | 2008-06-18 | |||||
| snmpssh | 5161 | tcp | SNMP over SSH Transport Model | RFC 5592 | |||||||
| snmpssh-trap | 5162 | tcp | SNMP Notification over SSH Transport Model | RFC 5592 | Known Unauthorized Use on port 5162 | ||||||
| aol-2 | 5192 | tcp | AmericaOnline2 | Bruce Mackey | Bruce Mackey | ||||||
| aol-2 | 5192 | udp | AmericaOnline2 | Bruce Mackey | Bruce Mackey | ||||||
| 5690-5692 | Unassigned | ||||||||||
| 5788-5792 | Unassigned | ||||||||||
| consul-insight | 5992 | tcp | Consul InSight Security | Arthur Hillenaar | Arthur Hillenaar | 2006-01 | |||||
| consul-insight | 5992 | udp | Consul InSight Security | Arthur Hillenaar | Arthur Hillenaar | 2006-01 | |||||
| geneve | 6081 | udp | Generic Network Virtualization Encapsulation (Geneve) | IESG | IETF Chair | 2014-03-27 | 2020-05-04 | RFC 8926 | |||
| 6792-6800 | Unassigned | ||||||||||
| 6902-6923 | Unassigned | ||||||||||
| split-ping | 6924 | tcp | Ping with RX/TX latency/loss split | Ben Cartwright-Cox | Ben Cartwright-Cox | 2020-02-12 | |||||
| split-ping | 6924 | udp | Ping with RX/TX latency/loss split | Ben Cartwright-Cox | Ben Cartwright-Cox | 2020-02-12 | |||||
| 6925-6934 | Unassigned | ||||||||||
| mrssrendezvous | 7392 | tcp | mrss-rendezvous server | Dave Porter | Dave Porter | ||||||
| mrssrendezvous | 7392 | udp | mrss-rendezvous server | Dave Porter | Dave Porter | ||||||
| 7492-7499 | Unassigned | Known Unauthorized Use on port 7499 | |||||||||
| 8092-8096 | Unassigned | ||||||||||
| spytechphone | 8192 | tcp | SpyTech Phone Service | Bill Kay | Bill Kay | 2006-04 | |||||
| spytechphone | 8192 | udp | SpyTech Phone Service | Bill Kay | Bill Kay | 2006-04 | |||||
| blp3 | 8292 | tcp | Bloomberg professional | Albert Hou | Albert Hou | 2006-05 | |||||
| blp3 | 8292 | udp | Bloomberg professional | Albert Hou | Albert Hou | 2006-05 | |||||
| 8788-8792 | Unassigned | ||||||||||
| ddi-tcp-5 | 8892 | tcp | Desktop Data TCP 4: FARM product | Fred Yao | Fred Yao | ||||||
| ddi-udp-5 | 8892 | udp | Desktop Data UDP 4: FARM product | Fred Yao | Fred Yao | ||||||
| 8992-8996 | Unassigned | ||||||||||
| XmlIpcRegSvc | 9092 | tcp | Xml-Ipc Server Reg | Casey Harrington | Casey Harrington | 2006-01 | |||||
| XmlIpcRegSvc | 9092 | udp | Xml-Ipc Server Reg | Casey Harrington | Casey Harrington | 2006-01 | |||||
| 9192-9199 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Adam Gawne-Cain | adam&gawncainresearch.co.uk | 2003-11 | |
| Alan Malik | alan&exasoft.co.uk | 2003-11 | |
| Albert Hou | ahou1&bloomberg.com | 2006-05 | |
| Alwin Egger | alwin.egger&tegonal.com | 2003-11 | |
| Angelique Dokos | angelique.dokos&hp.com | 2003-11 | |
| Arthur Hillenaar | arthur.hillenaar&consul.com | 2006-01 | |
| Ben Cartwright-Cox | ben&benjojo.co.uk | 2020-02-12 | |
| Bill Kay | bkay&spy-tec.com | 2006-04 | |
| Bodo Rueskamp | iana+spam&pinda.de | 2020-06-04 | |
| Bruce Mackey | BAMackey&aol.com | ||
| Carleton Watkins | carleton&soronti.com | 2003-11 | |
| Casey Harrington | charrington&isxinc.com | 2006-01 | |
| Dave Porter | porter&mango.com | ||
| Davey Taylor | davey.taylor&brimstone.net | 2003-02 | |
| David A. Gayler | dgayler&eminentware.com | 2006-07 | |
| David Barrass | david.barrass&minorplante.com | 2003-11 | |
| David Ott | dott&qualcomm.com | 2010-10-15 | |
| Evgeny Klimov | jimklimov+nut&gmail.com | 2020-12-16 | |
| Fred Yao | Fred_Yao&ddigate2.desktopdata.com | ||
| Gerard Cerchio | gjpc&circlesoft.com | 2003-11 | |
| Ghanshyam Patel | gpatel&natinc.com | 2003-11 | |
| Huawei | tarzan.pan&huawei.com | 2023-04-10 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Ian McDowall | ian.mcdowall&symbian.com | 2003-11 | |
| Jeff Looman | jeff&looman.org | ||
| Jens Edlund | edlund&speech.kth.se | 2005-08 | |
| John M. Baird | jbaird&e-watch.com | 2003-07 | |
| Juergen Edelhaeuser | Juergen.Edelhaeuser&locanis.com | 2002-08 | |
| Lech Lakomy | llakomy&apwi.com | 2009-02-12 | |
| Markus Treinen | markus.treinen&siemens.com | 2006-02 | |
| Michael Bishop | mbishop&fishnetsecurity.com | ||
| Michael Landwehr | mikel&precisesoft.co.il | ||
| Michael Werski | michael.werski&azeti.net | 2010-02-18 | |
| Mike Morris | mike.morris&amx.com | ||
| Mitsuji Toda | toda&mmedia.mci.mei.co.jp | ||
| Network UPS Tools Project | iana&networkupstools.org | 2020-12-16 | |
| Peter Boers | boers&isisglobal.nl | 2002-05 | |
| Phil Maker | pjm&gnu.org | 2008-06-18 | |
| Phillip Dillinger | Phillip.Dillinger&sealabs.com | ||
| Ross E. Greinke | greinker&execpc.com | ||
| Sebastien Bury | WAP Forum | sebastien.bury&art.alcatel.fr | |
| Shinya Abe | abeabe&pfu.co.jp | ||
| Shiro Tamoto | tamoto.shiro&jp.panasonic.com | 2003-10 | |
| Uwe Holz | uwe.holz&azeti.net | 2009-11-09 | |
| Vikas | vikas&graycell.com | ||
| Wei Pan | Huawei | tarzan.pan&huawei.com | 2023-04-10 |