Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
magbind 3194 udp Rockstorm MAG protocol Jens Nilsson Jens Nilsson
fg-gip 3294 tcp fg-gip Jean-Marc Frailong Jean-Marc Frailong
fg-gip 3294 udp fg-gip Jean-Marc Frailong Jean-Marc Frailong
d2k-tapestry2 3394 tcp D2K Tapestry Server to Server Eric Lan Eric Lan
d2k-tapestry2 3394 udp D2K Tapestry Server to Server Eric Lan Eric Lan
ibm3494 3494 tcp IBM 3494 Jeffrey Pilch Jeffrey Pilch
ibm3494 3494 udp IBM 3494 Jeffrey Pilch Jeffrey Pilch
mediaspace 3594 tcp MediaSpace
mediaspace 3594 udp MediaSpace
3694 Unassigned 2007-04-05
jaus 3794 tcp JAUS Robots Steven B. Cliff Steven B. Cliff 2003-07
jaus 3794 udp JAUS Robots Steven B. Cliff Steven B. Cliff 2003-07
syam-agent 3894 tcp SyAM Agent Port Michael Daniele Michael Daniele 2003-10
syam-agent 3894 udp SyAM Agent Port Michael Daniele Michael Daniele 2003-10
xecp-node 3940 tcp XeCP Node Service Brent McCullough Brent McCullough 2003-11
xecp-node 3940 udp XeCP Node Service Brent McCullough Brent McCullough 2003-11
homeportal-web 3941 tcp Home Portal Web Server Christian Beaumont Christian Beaumont 2003-11
homeportal-web 3941 udp Home Portal Web Server Christian Beaumont Christian Beaumont 2003-11
srdp 3942 tcp satellite distribution Simone Molendini Simone Molendini 2003-11
srdp 3942 udp satellite distribution Simone Molendini Simone Molendini 2003-11
tig 3943 tcp TetraNode Ip Gateway B. van Klinken B. van Klinken 2003-12
tig 3943 udp TetraNode Ip Gateway B. van Klinken B. van Klinken 2003-12
sops 3944 tcp S-Ops Management Stefan Hochuli Stefan Hochuli 2003-12
sops 3944 udp S-Ops Management Stefan Hochuli Stefan Hochuli 2003-12
emcads 3945 tcp EMCADS Server Port Lars Struwe Christensen Lars Struwe Christensen 2004-01
emcads 3945 udp EMCADS Server Port Lars Struwe Christensen Lars Struwe Christensen 2004-01
backupedge 3946 tcp BackupEDGE Server Microlite Corporation D. Thomas Podnar 2004-06
backupedge 3946 udp BackupEDGE Server Microlite Corporation D. Thomas Podnar 2004-06
ccp 3947 tcp Connect and Control Protocol for Consumer, Commercial, and Industrial Electronic Devices Aaron Myer Aaron Myer 2004-06
ccp 3947 udp Connect and Control Protocol for Consumer, Commercial, and Industrial Electronic Devices Aaron Myer Aaron Myer 2004-06
apdap 3948 tcp Anton Paar Device Administration Protocol Martin Leitner Martin Leitner 2004-06
apdap 3948 udp Anton Paar Device Administration Protocol Martin Leitner Martin Leitner 2004-06
drip 3949 tcp Dynamic Routing Information Protocol Dana Blair Dana Blair 2004-06
drip 3949 udp Dynamic Routing Information Protocol Dana Blair Dana Blair 2004-06
3994 Unassigned 2008-04-24
sysrqd 4094 tcp sysrq daemon Julien Danjou Julien Danjou 2006-07
sysrqd 4094 udp sysrq daemon Julien Danjou Julien Danjou 2006-07
spdm 4194 tcp Security Protocol and Data Model DMTF Administration Robert Keyes 2022-01-10 2025-05-30
4194 udp Reserved
4394 tcp Reserved
apwi-disc 4394 udp American Printware Discovery Lech Lakomy Lech Lakomy 2009-02-12
ipsec-nat-t 4500 udp IPsec NAT-Traversal 2017-07-07 RFC 3948; RFC 7296
ias-session 4594 tcp IAS-Session (ANRI-ANRI)
ias-session 4594 udp IAS-Session (ANRI-ANRI)
4794 tcp Reserved
veroce 4794 udp veRoCE Transport Protocol ByteDance Dai Huichen 2026-03-06
lyskom 4894 tcp LysKOM Protocol A Per Cederqvist Per Cederqvist
lyskom 4894 udp LysKOM Protocol A Per Cederqvist Per Cederqvist
eq-office-4940 4940 tcp Equitrac Office
eq-office-4940 4940 udp Equitrac Office
eq-office-4941 4941 tcp Equitrac Office
eq-office-4941 4941 udp Equitrac Office
eq-office-4942 4942 tcp Equitrac Office Tom Haapanen Tom Haapanen 2007-07-11
eq-office-4942 4942 udp Equitrac Office Tom Haapanen Tom Haapanen 2007-07-11
4943-4948 Unassigned
munin 4949 tcp Munin Graphing Framework Jimmy Olsen Jimmy Olsen 2010-12-24
munin 4949 udp Munin Graphing Framework Jimmy Olsen Jimmy Olsen 2010-12-24
hart-ip 5094 tcp HART-IP Wally Pratt Jr Wally Pratt Jr 2010-03-02
hart-ip 5094 udp HART-IP Wally Pratt Jr Wally Pratt Jr 2010-03-02
cpscomm 5194 tcp CipherPoint Config Service CipherPoint Software, inc. CipherPoint Software, inc. 2010-03-03
5194 udp Reserved
5694-5695 Unassigned
5794 tcp Reserved
spdp 5794 udp Simple Peered Discovery Protocol Dave Lindquist Dave Lindquist 2010-05-27
rms-agent 5994 tcp RMS Agent Listening Service RiverMeadow Software Inc. Greg Dennis 2021-03-24
5994 udp Reserved
reload-config 6084 tcp Peer to Peer Infrastructure Configuration IESG IETF Chair 2009-01-29 2013-03-26 RFC 6940
ircs-u 6697 tcp Internet Relay Chat via TLS/SSL 2014-02-11 RFC 7194
6937-6945 Unassigned
bioserver 6946 tcp Biometrics Server ISHII AKIO ISHII AKIO 2006-01
bioserver 6946 udp Biometrics Server ISHII AKIO ISHII AKIO 2006-01
6947-6950 Unassigned
7089-7094 Unassigned
fse 7394 tcp File system export of backup images Weibao Wu Weibao Wu 2006-04
fse 7394 udp File system export of backup images Weibao Wu Weibao Wu 2006-04
q3ade 7794 tcp Q3ADE Cluster Service Uffe Harksen Uffe Harksen 2005-08
q3ade 7794 udp Q3ADE Cluster Service Uffe Harksen Uffe Harksen 2005-08
blp1 8194 tcp Bloomberg data API Albert Hou Albert Hou 2006-05
blp1 8194 udp Bloomberg data API Albert Hou Albert Hou 2006-05
blp4 8294 tcp Bloomberg intelligent client Albert Hou Albert Hou 2006-05
blp4 8294 udp Bloomberg intelligent client Albert Hou Albert Hou 2006-05
8794-8799 Unassigned
ddi-tcp-7 8894 tcp Desktop Data TCP 6: COAL application Fred Yao Fred Yao
ddi-udp-7 8894 udp Desktop Data UDP 6: COAL application Fred Yao Fred Yao
9094-9099 Unassigned
armcenterhttp 9294 tcp ARMCenter http Service Eric Thiebaut-George Eric Thiebaut-George 2006-04
armcenterhttp 9294 udp ARMCenter http Service Eric Thiebaut-George Eric Thiebaut-George 2006-04
sec-t4net-srv 9400 tcp Samsung Twain for Network Server Dongkeun Kim Dongkeun Kim 2007-02
sec-t4net-srv 9400 udp Samsung Twain for Network Server Dongkeun Kim Dongkeun Kim 2007-02
sec-t4net-clt 9401 tcp Samsung Twain for Network Client Dongkeun Kim Dongkeun Kim 2007-02
sec-t4net-clt 9401 udp Samsung Twain for Network Client Dongkeun Kim Dongkeun Kim 2007-02
sec-pc2fax-srv 9402 tcp Samsung PC2FAX for Network Server HyeongBae Yu HyeongBae Yu 2008-07-31
sec-pc2fax-srv 9402 udp Samsung PC2FAX for Network Server HyeongBae Yu HyeongBae Yu 2008-07-31
9403-9417 Unassigned
git 9418 tcp git pack transfer service Linus Torvalds Linus Torvalds 2005-09
git 9418 udp git pack transfer service Linus Torvalds Linus Torvalds 2005-09
9419-9442 Unassigned
tungsten-https 9443 tcp WSO2 Tungsten HTTPS Afkham Azeez Afkham Azeez 2006-06
tungsten-https 9443 udp WSO2 Tungsten HTTPS Afkham Azeez Afkham Azeez 2006-06
wso2esb-console 9444 tcp WSO2 ESB Administration Console HTTPS Ruwan Linton Ruwan Linton 2008-08-20
wso2esb-console 9444 udp WSO2 ESB Administration Console HTTPS Ruwan Linton Ruwan Linton 2008-08-20

Contact Information

Name Organization Contact URI Last Updated
Aaron Myer aaron.myer&in2nets.com 2004-06
Afkham Azeez azeez&wso2.com 2006-06
Albert Hou ahou1&bloomberg.com 2006-05
B. van Klinken b.vklinken&rohill.nl 2003-12
Brent McCullough bmccullough&timemgmt.com 2003-11
ByteDance daihuichen&bytedance.com 2026-03-06
Christian Beaumont chrisb&lantronix.com 2003-11
CipherPoint Software, inc. wshea&cipherpointsoftware.com 2010-03-03
D. Thomas Podnar tom&microlite.com 2015-11-04
Dai Huichen daihuichen&bytedance.com 2026-03-06
Dana Blair dblair&cisco.com 2004-06
Dave Lindquist dlindquist&egistix.com 2010-05-27
DMTF Administration admin&dmtf.org 2025-05-30
Dongkeun Kim dongkeun70.kim&samsung.com 2007-02
Eric Lan elan&d2k.com
Eric Thiebaut-George erict&aurema.com 2006-04
Fred Yao Fred_Yao&ddigate2.desktopdata.com
Greg Dennis RiverMeadow Software Inc. gdennis&rivermeadow.com 2021-03-24
HyeongBae Yu hyeongbae.yu&samsung.com 2008-07-31
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
ISHII AKIO ishii.akio&jp.fujitsu.com 2006-01
Jean-Marc Frailong jmf&freegate.net
Jeffrey Pilch jpilch&us.ibm.com
Jens Nilsson jens&rockstorm.se
Jimmy Olsen jo&redpill-linpro.com 2010-12-24
Julien Danjou acid&debian.org 2006-07
Lars Struwe Christensen lsc&giritech.com 2004-01
Lech Lakomy llakomy&apwi.com 2009-02-12
Linus Torvalds torvalds&osdl.org 2005-09
Martin Leitner info&anton-paar.com 2004-06
Michael Daniele michael.daniele&syamsoftware.com 2003-11
Microlite Corporation tom&microlite.com 2015-11-04
Per Cederqvist ceder&lysator.liu.se
RiverMeadow Software Inc. gdennis&rivermeadow.com 2021-03-24
Robert Keyes robert&woldconsulting.com 2025-05-30
Ruwan Linton ruwan&wso2.com 2008-08-20
Simone Molendini simone.molendini&unile.it 2003-11
Stefan Hochuli iana.org&dunes.ch 2003-12
Steven B. Cliff scliff&remotec-andros.com 2003-07
Tom Haapanen tomh&equitrac.com 2007-07-11
Uffe Harksen uh&uhcommunications.com 2005-08
Wally Pratt Jr wpratt&fieldcommgroup.org 2012-12-14
Weibao Wu weibao_wu&symantec.com 2006-04