Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
sun-as-iiops-ca 3808 udp Sun App Svr-IIOPClntAuth Abhijit Kumar Abhijit Kumar 2005-11
apocd 3809 tcp Java Desktop System Configuration Agent Geoff Higgins Geoff Higgins 2006-03
apocd 3809 udp Java Desktop System Configuration Agent Geoff Higgins Geoff Higgins 2006-03
wlanauth 3810 tcp WLAN AS server Bianling Zhang Bianling Zhang 2004-02
wlanauth 3810 udp WLAN AS server Bianling Zhang Bianling Zhang 2004-02
scp 3820 tcp Siemens AuD SCP Johann Arnold Johann Arnold 2004-10
scp 3820 udp Siemens AuD SCP Johann Arnold Johann Arnold 2004-10
cernsysmgmtagt 3830 tcp Cerner System Management Agent Mike Craft Mike Craft 2008-01-29
cernsysmgmtagt 3830 udp Cerner System Management Agent Mike Craft Mike Craft 2008-01-29
flirtmitmir 3840 tcp www.FlirtMitMir.de Carsten Falticska Carsten Falticska 2003-11
flirtmitmir 3840 udp www.FlirtMitMir.de Carsten Falticska Carsten Falticska 2003-11
qtms-bootstrap 3850 tcp QTMS Bootstrap Protocol Phil Willis Phil Willis 2003-08
qtms-bootstrap 3850 udp QTMS Bootstrap Protocol Phil Willis Phil Willis 2003-08
sasp 3860 tcp Server/Application State Protocol (SASP) Alan Bivens Alan Bivens 2003-08
sasp 3860 udp Server/Application State Protocol (SASP) Alan Bivens Alan Bivens 2003-08
3864 udp Reserved This entry has been removed on 2006-06-23.
ovsam-d-agent 3870 tcp hp OVSAM HostAgent Disco Mike Pontillo Mike Pontillo 2003-08
ovsam-d-agent 3870 udp hp OVSAM HostAgent Disco Mike Pontillo Mike Pontillo 2003-08
igrs 3880 tcp IGRS Huang Jingnan Huang Jingnan 2003-10
igrs 3880 udp IGRS Huang Jingnan Huang Jingnan 2003-10
ndsconnect 3890 tcp Niche Data Server Connect Roland Schneider Roland Schneider 2003-10
ndsconnect 3890 udp Niche Data Server Connect Roland Schneider Roland Schneider 2003-10
udt-os 3900 tcp Unidata UDT OS

IANA assigned this well-formed service name as a replacement for "udt_os".
James Powell James Powell
udt_os 3900 tcp Unidata UDT OS James Powell James Powell This entry is an alias to "udt-os". This entry is now historic, not usable for use with many common service discovery mechanisms.
udt-os 3900 udp Unidata UDT OS

IANA assigned this well-formed service name as a replacement for "udt_os".
James Powell James Powell
udt_os 3900 udp Unidata UDT OS James Powell James Powell This entry is an alias to "udt-os". This entry is now historic, not usable for use with many common service discovery mechanisms.
nimsh 3901 tcp NIM Service Handler Paul B. Finley Paul B. Finley 2003-10
nimsh 3901 udp NIM Service Handler Paul B. Finley Paul B. Finley 2003-10
nimaux 3902 tcp NIMsh Auxiliary Port Paul B. Finley Paul B. Finley 2003-10
nimaux 3902 udp NIMsh Auxiliary Port Paul B. Finley Paul B. Finley 2003-10
charsetmgr 3903 tcp CharsetMGR Tatsuya Ueda Tatsuya Ueda 2003-10
charsetmgr 3903 udp CharsetMGR Tatsuya Ueda Tatsuya Ueda 2003-10
omnilink-port 3904 tcp Arnet Omnilink Port Ronen Shaul Ronen Shaul 2003-10
omnilink-port 3904 udp Arnet Omnilink Port Ronen Shaul Ronen Shaul 2003-10
mupdate 3905 tcp Mailbox Update (MUPDATE) protocol RFC 3656
mupdate 3905 udp Mailbox Update (MUPDATE) protocol RFC 3656
topovista-data 3906 tcp TopoVista elevation data Gregg Townsend Gregg Townsend 2003-11
topovista-data 3906 udp TopoVista elevation data Gregg Townsend Gregg Townsend 2003-11
imoguia-port 3907 tcp Imoguia Port Emidio Cunha Emidio Cunha 2003-11
imoguia-port 3907 udp Imoguia Port Emidio Cunha Emidio Cunha 2003-11
hppronetman 3908 tcp HP Procurve NetManagement Devon Dawson Devon Dawson 2003-11
hppronetman 3908 udp HP Procurve NetManagement Devon Dawson Devon Dawson 2003-11
surfcontrolcpa 3909 tcp SurfControl CPA Hywel Morgan Hywel Morgan 2003-11
surfcontrolcpa 3909 udp SurfControl CPA Hywel Morgan Hywel Morgan 2003-11
prnrequest 3910 tcp Printer Request Port Brett Green Brett Green 2003-11
prnrequest 3910 udp Printer Request Port Brett Green Brett Green 2003-11
exasoftport1 3920 tcp Exasoft IP Port Alan Malik Alan Malik 2003-11
exasoftport1 3920 udp Exasoft IP Port Alan Malik Alan Malik 2003-11
syam-webserver 3930 tcp Syam Web Server Port Michael Daniele Michael Daniele 2003-11
syam-webserver 3930 udp Syam Web Server Port Michael Daniele Michael Daniele 2003-11
xecp-node 3940 tcp XeCP Node Service Brent McCullough Brent McCullough 2003-11
xecp-node 3940 udp XeCP Node Service Brent McCullough Brent McCullough 2003-11
namemunge 3950 tcp Name Munging John C. Klensin John C. Klensin 2004-07
namemunge 3950 udp Name Munging John C. Klensin John C. Klensin 2004-07
bess 3960 tcp Bess Peer Assessment Peter Verdon Peter Verdon 2005-08
bess 3960 udp Bess Peer Assessment Peter Verdon Peter Verdon 2005-08
lanrevagent 3970 tcp LANrev Agent Martin Bestmann Martin Bestmann Defined TXT keys:
txtvers
server=<main LANrev server for agent>
vers=<version of LANrev Agent>
build=<build number of LANrev Agent>
id=<agent identifier>
lanrevagent 3970 udp LANrev Agent Martin Bestmann Martin Bestmann Defined TXT keys:
txtvers
server=<main LANrev server for agent>
vers=<version of LANrev Agent>
build=<build number of LANrev Agent>
id=<agent identifier>
3980 tcp Reserved 2006-06 2020-12-29 Historic usage was acms. De-Assigned on 2020-12-29
3980 udp Reserved
bv-is 3990 tcp BindView-IS
bv-is 3990 udp BindView-IS
abcsoftware 3996 tcp abcsoftware-01 Andrew Zimmerman Andrew Zimmerman 2004-06
abcsoftware 3996 udp abcsoftware-01 Andrew Zimmerman Andrew Zimmerman 2004-06
terabase 4000 tcp Terabase Thor Olson Thor Olson Potential Conflict of ports PORT 4000 also used by ICQ <www.icq.com>
terabase 4000 udp Terabase Thor Olson Thor Olson Potential Conflict of ports PORT 4000 also used by ICQ <www.icq.com>
newoak 4001 tcp NewOak Jim Philippou Jim Philippou
newoak 4001 udp NewOak Jim Philippou Jim Philippou
pxc-spvr-ft 4002 tcp pxc-spvr-ft
pxc-spvr-ft 4002 udp pxc-spvr-ft
pxc-splr-ft 4003 tcp pxc-splr-ft
pxc-splr-ft 4003 udp pxc-splr-ft
pxc-roid 4004 tcp pxc-roid
pxc-roid 4004 udp pxc-roid
pxc-pin 4005 tcp pxc-pin
pxc-pin 4005 udp pxc-pin
pxc-spvr 4006 tcp pxc-spvr
pxc-spvr 4006 udp pxc-spvr
pxc-splr 4007 tcp pxc-splr Dave Nesbitt Dave Nesbitt
pxc-splr 4007 udp pxc-splr Dave Nesbitt Dave Nesbitt
netcheque 4008 tcp NetCheque accounting B. Clifford Neuman B. Clifford Neuman
netcheque 4008 udp NetCheque accounting B. Clifford Neuman B. Clifford Neuman
chimera-hwm 4009 tcp Chimera HWM Ken Anderson Ken Anderson
chimera-hwm 4009 udp Chimera HWM Ken Anderson Ken Anderson
samsung-unidex 4010 tcp Samsung Unidex Konstantin V. Vyaznikov Konstantin V. Vyaznikov
samsung-unidex 4010 udp Samsung Unidex Konstantin V. Vyaznikov Konstantin V. Vyaznikov
altserviceboot 4011 tcp Alternate Service Boot Eric Dittert Eric Dittert
altserviceboot 4011 udp Alternate Service Boot Eric Dittert Eric Dittert
pda-gate 4012 tcp PDA Gate Masakuni Okada Masakuni Okada
pda-gate 4012 udp PDA Gate Masakuni Okada Masakuni Okada
acl-manager 4013 tcp ACL Manager Toru Murai Toru Murai
acl-manager 4013 udp ACL Manager Toru Murai Toru Murai
taiclock 4014 tcp TAICLOCK D. J. Bernstein D. J. Bernstein 2018-04-05
taiclock 4014 udp TAICLOCK D. J. Bernstein D. J. Bernstein 2018-04-05
talarian-mcast1 4015 tcp Talarian Mcast
talarian-mcast1 4015 udp Talarian Mcast
talarian-mcast2 4016 tcp Talarian Mcast
talarian-mcast2 4016 udp Talarian Mcast
talarian-mcast3 4017 tcp Talarian Mcast
talarian-mcast3 4017 udp Talarian Mcast
talarian-mcast4 4018 tcp Talarian Mcast

Contact Information

Name Contact URI Last Updated
Abhijit Kumar as-iana-ports&sun.com 2005-11
Alan Bivens jbivens&us.ibm.com 2003-08
Alan Malik alan&exasoft.co.uk 2003-11
Andrew Zimmerman andrew&zimmerman.net 2004-06
B. Clifford Neuman bcn&isi.edu 2022-02-18
Bianling Zhang blzhang&iwncomm.com 2004-02
Brent McCullough bmccullough&timemgmt.com 2003-11
Brett Green brett_green&hp.com 2003-11
Carsten Falticska falticska&freenet.de 2003-11
D. J. Bernstein ports&box.cr.yp.to 2018-04-05
Dave Nesbitt nesbitt&cp10.es.xerox.com
Devon Dawson devon.dawson&hp.com 2003-11
Emidio Cunha emidio&janeladigital.com 2003-11
Eric Dittert Eric_Dittert&ccm.jf.intel.com
Geoff Higgins geoff.higgins&sun.com 2006-03
Gregg Townsend gmt&cs.arizona.edu 2003-11
Huang Jingnan huangjnb&lenovo.com 2003-10
Hywel Morgan hywelm&surfcontrol.com 2003-11
James Powell james&mailhost.unidata.com
Jim Philippou jphilippou&newoak.com
Johann Arnold johann.arnold&siemens.com 2004-10
John C. Klensin klensin&jck.com 2004-07
Ken Anderson kanderso&kleber.ics.uci.edu
Konstantin V. Vyaznikov kv&ssm6000.samsung.ru
Martin Bestmann martin&poleposition-sw.com 2005-08
Masakuni Okada masakuni&jp.ibm.com
Michael Daniele michael.daniele&syamsoftware.com 2003-11
Mike Craft mcraft&cerner.com 2008-01-29
Mike Pontillo pontillo&hp.com 2003-08
Paul B. Finley pfinley&us.ibm.com 2003-10
Peter Verdon bess&dcs.warwick.ac.uk 2005-08
Phil Willis phil.willis&prism-uk.com 2003-08
Roland Schneider rsch&nicherms.com 2003-10
Ronen Shaul ronen&arnetsystems.com 2003-10
Tatsuya Ueda tatsu&ist.fujitsu.com 2003-10
Thor Olson Thor&terabase.com
Toru Murai murai&saint.nm.fujitsu.co.jp