Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| PowerAlert-nsa | 4150 | udp | PowerAlert Network Shutdown Agent | Mike Delgrosso | Mike Delgrosso | 2007-07-02 | |||||
| jini-discovery | 4160 | tcp | Jini Discovery | Mark Hodapp | Mark Hodapp | ||||||
| jini-discovery | 4160 | udp | Jini Discovery | Mark Hodapp | Mark Hodapp | ||||||
| d-cinema-csp | 4170 | tcp | SMPTE Content Synchonization Protocol | Michael Karagosian | Michael Karagosian | 2008-09-04 | |||||
| 4170 | udp | Reserved | |||||||||
| httpx | 4180 | tcp | HTTPX | Paul McGough | Paul McGough | 2007-02 | |||||
| httpx | 4180 | udp | HTTPX | Paul McGough | Paul McGough | 2007-02 | 2016-01-05 | ||||
| 4189 | udp | Reserved | RFC 5440 | ||||||||
| sieve | 4190 | tcp | ManageSieve Protocol | ||||||||
| 4190 | udp | Reserved | RFC 5804 | ||||||||
| vrml-multi-use | 4200-4299 | VRML Multi User Systems | Mitra | Mitra | |||||||
| corelccam | 4300 | tcp | Corel CCam | Jason Aiken | Jason Aiken | ||||||
| corelccam | 4300 | udp | Corel CCam | Jason Aiken | Jason Aiken | ||||||
| d-data | 4301 | tcp | Diagnostic Data | ||||||||
| d-data | 4301 | udp | Diagnostic Data | ||||||||
| d-data-control | 4302 | tcp | Diagnostic Data Control | Jon March | Jon March | 2006-09 | |||||
| d-data-control | 4302 | udp | Diagnostic Data Control | Jon March | Jon March | 2006-09 | |||||
| srcp | 4303 | tcp | Simple Railroad Command Protocol | Matthias Trute | Matthias Trute | 2007-01 | |||||
| srcp | 4303 | udp | Simple Railroad Command Protocol | Matthias Trute | Matthias Trute | 2007-01 | |||||
| owserver | 4304 | tcp | One-Wire Filesystem Server | Paul Alfille | Paul Alfille | 2007-01 | Defined TXT keys: txtvers | ||||
| owserver | 4304 | udp | One-Wire Filesystem Server | Paul Alfille | Paul Alfille | 2007-01 | Defined TXT keys: txtvers | ||||
| batman | 4305 | tcp | better approach to mobile ad-hoc networking | Simon Wunderlich | Simon Wunderlich | 2007-08-30 | |||||
| batman | 4305 | udp | better approach to mobile ad-hoc networking | Simon Wunderlich | Simon Wunderlich | 2007-08-30 | |||||
| pinghgl | 4306 | tcp | Hellgate London | David Berk | David Berk | 2007-08-30 | |||||
| pinghgl | 4306 | udp | Hellgate London | David Berk | David Berk | 2007-08-30 | |||||
| trueconf | 4307 | tcp | TrueConf Videoconference Service | Dmitry Odintsov | Lev Yakupov | 2007-10-22 | 2017-05-12 | ||||
| trueconf | 4307 | udp | TrueConf Videoconference Service | Dmitry Odintsov | Lev Yakupov | 2007-10-22 | 2017-05-12 | ||||
| compx-lockview | 4308 | tcp | CompX-LockView | John Payson | John Payson | 2007-10-22 | |||||
| compx-lockview | 4308 | udp | CompX-LockView | John Payson | John Payson | 2007-10-22 | |||||
| dserver | 4309 | tcp | Exsequi Appliance Discovery | Angelo Masci | Angelo Masci | 2007-01 | |||||
| dserver | 4309 | udp | Exsequi Appliance Discovery | Angelo Masci | Angelo Masci | 2007-01 | |||||
| mirrtex | 4310 | tcp | Mir-RT exchange service | Sylvain Robert | Sylvain Robert | 2008-02-14 | |||||
| mirrtex | 4310 | udp | Mir-RT exchange service | Sylvain Robert | Sylvain Robert | 2008-02-14 | |||||
| fdt-rcatp | 4320 | tcp | FDT Remote Categorization Protocol | Russell P. Holsclaw | Russell P. Holsclaw | 2006-03 | |||||
| fdt-rcatp | 4320 | udp | FDT Remote Categorization Protocol | Russell P. Holsclaw | Russell P. Holsclaw | 2006-03 | |||||
| 4324 | Reserved | 2015-05-12 | This entry is being removed on 2015-05-12. | ||||||||
| dey-sapi | 4330 | tcp | DEY Storage Administration REST API | DEY Storage Systems, Inc. | Garrett D'Amore | 2013-03-01 | |||||
| 4330 | udp | Reserved | |||||||||
| netconf-ch-ssh | 4334 | tcp | NETCONF Call Home (SSH) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| netconf-ch-tls | 4335 | tcp | NETCONF Call Home (TLS) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| restconf-ch-tls | 4336 | tcp | RESTCONF Call Home (TLS) | IESG | IETF Chair | 2016-01-12 | RFC 8071 | ||||
| gaia | 4340 | tcp | Gaia Connector Protocol | Philippe Detournay | Philippe Detournay | 2007-11-12 | |||||
| gaia | 4340 | udp | Gaia Connector Protocol | Philippe Detournay | Philippe Detournay | 2007-11-12 | |||||
| lisp-data | 4341 | udp | LISP Data Packets | IESG | IETF Chair | 2007-11-12 | 2021-02-17 | RFC 9300 | |||
| lisp-control | 4342 | udp | LISP Control Packets | IETF | IESG | 2007-05 | 2021-02-25 | RFC 9301 | |||
| net-device | 4350 | tcp | Net Device | Glenn Peterson | Glenn Peterson | ||||||
| net-device | 4350 | udp | Net Device | Glenn Peterson | Glenn Peterson | ||||||
| matrix-vnet | 4360 | tcp | Matrix VNet Communication Protocol IANA assigned this well-formed service name as a replacement for "matrix_vnet". |
Rehan Mahmood | Rehan Mahmood | 2009-03-18 | |||||
| matrix_vnet | 4360 | tcp | Matrix VNet Communication Protocol | Rehan Mahmood | Rehan Mahmood | 2009-03-18 | This entry is an alias to "matrix-vnet". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| 4360 | udp | Reserved | |||||||||
| elpro-tunnel | 4370 | tcp | ELPRO V2 Protocol Tunnel IANA assigned this well-formed service name as a replacement for "elpro_tunnel". |
Harry Courtice | Harry Courtice | 2008-04-14 | |||||
| elpro_tunnel | 4370 | tcp | ELPRO V2 Protocol Tunnel | Harry Courtice | Harry Courtice | 2008-04-14 | This entry is an alias to "elpro-tunnel". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| elpro-tunnel | 4370 | udp | ELPRO V2 Protocol Tunnel IANA assigned this well-formed service name as a replacement for "elpro_tunnel". |
Harry Courtice | Harry Courtice | 2008-04-14 | |||||
| elpro_tunnel | 4370 | udp | ELPRO V2 Protocol Tunnel | Harry Courtice | Harry Courtice | 2008-04-14 | This entry is an alias to "elpro-tunnel". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| l2c-control | 4371 | tcp | LAN2CAN Control | Phil Tolson | Phil Tolson | 2008-07-07 | Modified: 21 January 2010 | ||||
| l2c-data | 4372 | tcp | LAN2CAN Data | Phil Tolson | Phil Tolson | 2008-07-07 | Modified: 21 January 2010 | ||||
| 4380-4388 | Unassigned | ||||||||||
| wiegand | 4390 | tcp | Physical Access Control | Scott Guthery | Scott Guthery | 2008-08-25 | |||||
| wiegand | 4390 | udp | Physical Access Control | Scott Guthery | Scott Guthery | 2008-08-25 | |||||
| ds-srv | 4400 | tcp | ASIGRA Services | David Farajun | David Farajun | 2004-11 | |||||
| ds-srv | 4400 | udp | ASIGRA Services | David Farajun | David Farajun | 2004-11 | |||||
| ds-srvr | 4401 | tcp | ASIGRA Televaulting DS-System Service | ||||||||
| ds-srvr | 4401 | udp | ASIGRA Televaulting DS-System Service | ||||||||
| ds-clnt | 4402 | tcp | ASIGRA Televaulting DS-Client Service | ||||||||
| ds-clnt | 4402 | udp | ASIGRA Televaulting DS-Client Service | ||||||||
| ds-user | 4403 | tcp | ASIGRA Televaulting DS-Client Monitoring/Management | ||||||||
| ds-user | 4403 | udp | ASIGRA Televaulting DS-Client Monitoring/Management | ||||||||
| ds-admin | 4404 | tcp | ASIGRA Televaulting DS-System Monitoring/Management | ||||||||
| ds-admin | 4404 | udp | ASIGRA Televaulting DS-System Monitoring/Management | ||||||||
| ds-mail | 4405 | tcp | ASIGRA Televaulting Message Level Restore service | ||||||||
| ds-mail | 4405 | udp | ASIGRA Televaulting Message Level Restore service | ||||||||
| ds-slp | 4406 | tcp | ASIGRA Televaulting DS-Sleeper Service | Andrei Litvinn | Andrei Litvinn | 2005-01 | |||||
| ds-slp | 4406 | udp | ASIGRA Televaulting DS-Sleeper Service | Andrei Litvinn | Andrei Litvinn | 2005-01 | |||||
| nacagent | 4407 | tcp | Network Access Control Agent | ITGroup | ITGroup | 2008-06-30 | |||||
| 4407 | udp | Reserved | |||||||||
| slscc | 4408 | tcp | SLS Technology Control Centre | Steven Sweeting | Steven Sweeting | 2008-01-28 | |||||
| 4408 | udp | Reserved | |||||||||
| netcabinet-com | 4409 | tcp | Net-Cabinet comunication | Ian Manning | Ian Manning | 2009-12-16 | |||||
| 4409 | udp | Reserved | |||||||||
| itwo-server | 4410 | tcp | RIB iTWO Application Server | Kristean Heisler | Kristean Heisler | 2009-12-16 | |||||
| 4410 | udp | Reserved | |||||||||
| nvme | 4420 | tcp | NVM Express over Fabrics storage access | NVM Express, Inc. | Amber Huffman | 2016-03-31 | 2018-03-27 | ||||
| nvme | 4420 | udp | NVM Express over Fabrics storage access | NVM Express, Inc. | Amber Huffman | 2016-03-31 | 2018-03-27 | ||||
| rsqlserver | 4430 | tcp | REAL SQL Server | Marco Bambini | Marco Bambini | 2008-08-28 | |||||
| rsqlserver | 4430 | udp | REAL SQL Server | Marco Bambini | Marco Bambini | 2008-08-28 | |||||
| 4434-4440 | Unassigned | ||||||||||
| camp | 4450 | tcp | Common ASCII Messaging Protocol | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| camp | 4450 | udp | Common ASCII Messaging Protocol | Control Technology Inc. | Clint Eskew | 2011-10-28 | |||||
| ntske | 4460 | tcp | Network Time Security Key Establishment | IESG | IETF Chair | 2020-04-07 | RFC 8915 | ||||
| 4460 | udp | Reserved | |||||||||
| agtp | 4480 | tcp | Agent Transfer Protocol | Chris Hood | Chris Hood | 2026-04-30 | |||||
| agtp-quic | 4480 | udp | Agent Transfer Protocol over QUIC | Chris Hood | Chris Hood | 2026-04-30 | |||||
| 4489-4499 | Unassigned | Known UNAUTHORIZED USE: Ports 4490 and 4491 | |||||||||
| ipsec-nat-t | 4500 | tcp | IPsec NAT-Traversal | 2022-09-15 | RFC 9329 | ||||||
| ipsec-nat-t | 4500 | udp | IPsec NAT-Traversal | 2017-07-07 | RFC 3948; RFC 7296 | ||||||
| 4501 | Unassigned | IANA | IANA | De-registered 08 June 2001 | |||||||
| a25-fap-fgw | 4502 | sctp | A25 (FAP-FGW) | 3GPP2 | Zhiming Li | 2012-01-11 | |||||
| 4503 | tcp | Reserved | |||||||||
| m-bus-oms | 4503 | udp | M-Bus-OMS over UDP | OMS-Group e. V. (Open Metering System Group) | Ahmed Kasttet | 2025-05-19 | |||||
| 4504-4533 | Unassigned | ||||||||||
| gds-adppiw-db | 4550 | tcp | Perman I Interbase Server | Leo Lesage | Leo Lesage | 2006-04 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP2 | lizhiming&huawei.com | 2012-01-11 | |
| Ahmed Kasttet | OMS-Group e. V. (Open Metering System Group) | ahmed.kasttet&oms-group.org | 2025-05-19 |
| Amber Huffman | amber.huffman&intel.com | 2018-03-27 | |
| Andrei Litvinn | support&asigra.com | 2005-01 | |
| Angelo Masci | angelomasci&yahoo.co.uk | 2007-01 | |
| Chris Hood | chris&nomotic.ai | 2026-04-30 | |
| Clint Eskew | Control Technology Inc. | ceskew&controltechnology.com | 2011-10-28 |
| Control Technology Inc. | ceskew&controltechnology.com | 2011-10-28 | |
| David Berk | dberk&ping-0.com | 2007-08-30 | |
| David Farajun | dfarajun&asigra.com | 2004-11 | |
| DEY Storage Systems, Inc. | garrett&dey-sys.com | 2013-03-01 | |
| Dmitry Odintsov | dimodin&trueconf.com | 2017-05-12 | |
| Garrett D'Amore | DEY Storage Systems, Inc. | garrett&dey-sys.com | 2013-03-01 |
| Glenn Peterson | glennpµsoft.com | ||
| Harry Courtice | harry.courtice&elprotech.com | 2008-04-14 | |
| IANA | iana&iana.org | ||
| IESG | iesg&ietf.org | ||
| IETF | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| ITGroup | itgroup&stillsecure.com | 2008-06-30 | |
| Ian Manning | ian&baycastle.co.uk | 2009-12-16 | |
| Jason Aiken | jasona&corelcomputer.com | ||
| John Payson | john&circad.com | 2007-10-22 | |
| Jon March | jon.march&paget-analyst-services.co.uk | 2006-09 | |
| Kristean Heisler | Kristean.Heisler&rib-software.com | 2009-12-16 | |
| Leo Lesage | leo.lesage&adp.nl | 2006-04 | |
| Lev Yakupov | lyakupov&trueconf.com | 2017-05-12 | |
| Marco Bambini | marco&realsoftware.com | 2008-08-28 | |
| Mark Hodapp | mark.hodapp&sun.com | ||
| Matthias Trute | mtrute&web.de | 2007-01 | |
| Michael Karagosian | michael.karagosian&mkpe.com | 2008-09-04 | |
| Mike Delgrosso | Mike_Delgrosso&tripplite.com | 2007-07-02 | |
| Mitra | mitra&earth.path.net | ||
| NVM Express, Inc. | admin&nvmexpress.org | 2018-03-27 | |
| OMS-Group e. V. (Open Metering System Group) | office&oms-group.org | 2025-05-19 | |
| Paul Alfille | paul.alfille&gmail.com | 2007-01 | |
| Paul McGough | paulmcgough&yahoo.com | 2016-01-05 | |
| Phil Tolson | philtolson&eaton.com | 2010-01-21 | |
| Philippe Detournay | philippe.detournay&acrosoft.be | 2007-11-12 | |
| Rehan Mahmood | rehan&matrixmultimedia.co.uk | 2009-03-18 | |
| Russell P. Holsclaw | Fast Data Technology Inc. | rholsclaw&fastdatatech.com | 2006-03 |
| Scott Guthery | sguthery&hidcorp.com | 2008-08-25 | |
| Simon Wunderlich | siwu&hrz.tu-chemnitz.de | 2007-08-30 | |
| Steven Sweeting | ssweeting&sls-technology.com | 2008-01-28 | |
| Sylvain Robert | sylvain.robert&datadis.com | 2008-02-14 | |
| Zhiming Li | 3GPP2 | lizhiming&huawei.com | 2012-01-11 |