Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
gds-adppiw-db 4550 tcp Perman I Interbase Server Leo Lesage Leo Lesage 2006-04
gds-adppiw-db 4550 udp Perman I Interbase Server Leo Lesage Leo Lesage 2006-04
rsip 4555 tcp RSIP Port RFC 3103
rsip 4555 udp RSIP Port RFC 3103
4560-4562 Unassigned
deploymentmap 4570 tcp Service to distribute and update within a site deployment information for Oracle Communications Suite Oracle Corp. Dan Newman 2013-09-20
4570 udp Reserved
rid 4590 tcp RID over HTTP/TLS IESG IETF Chair RFC 6546
4590 udp Reserved
piranha1 4600 tcp Piranha1
piranha1 4600 udp Piranha1
piranha2 4601 tcp Piranha2 Primark Corporation Primark Corporation
piranha2 4601 udp Piranha2 Primark Corporation Primark Corporation
mtsserver 4602 tcp EAX MTS Server Pedro A Rodriguez Pedro A Rodriguez 2008-08-06
4602 udp Reserved
menandmice-upg 4603 tcp Men & Mice Upgrade Agent Eggert Thorlacius Eggert Thorlacius 2010-01-27
4603 udp Reserved
irp 4604 tcp Identity Registration Protocol Sixscape Communications, Pte. Ltd. Lawrence E. Hughes 2014-03-17 2014-08-26
4604 udp Reserved
sixchat 4605 tcp Direct End to End Secure Chat Protocol Sixscape Communications, Pte. Ltd. Lawrence E. Hughes 2014-09-11
4605 udp Reserved
sixid 4606 tcp Secure ID to IP registration and lookup Sixscape Communications, Pte. Ltd. Lawrence E. Hughes 2020-04-28
4606 udp Reserved
4607-4620 Unassigned
smaclmgr 4660 tcp smaclmgr Hiromi Taki Hiromi Taki
smaclmgr 4660 udp smaclmgr Hiromi Taki Hiromi Taki
light 4670 tcp Light packets transfer protocol Adam Golovenko Adam Golovenko 2006-10
light 4670 udp Light packets transfer protocol Adam Golovenko Adam Golovenko 2006-10
mgemanagement 4680 tcp MGE UPS Management Lecuivre J Lecuivre J 2005-08
mgemanagement 4680 udp MGE UPS Management Lecuivre J Lecuivre J 2005-08
rfid-rp1 4684 tcp RFID Reader Protocol 1.0 Michael Mealling Michael Mealling 2005-08
rfid-rp1 4684 udp RFID Reader Protocol 1.0 Michael Mealling Michael Mealling 2005-08
prelude 4690 tcp Prelude IDS message proto Yoann Vandoorselaere Yoann Vandoorselaere 2005-08
prelude 4690 udp Prelude IDS message proto Yoann Vandoorselaere Yoann Vandoorselaere 2005-08
netxms-agent 4700 tcp NetXMS Agent
netxms-agent 4700 udp NetXMS Agent
netxms-mgmt 4701 tcp NetXMS Management
netxms-mgmt 4701 udp NetXMS Management
netxms-sync 4702 tcp NetXMS Server Synchronization Victor Kirhenshtein Victor Kirhenshtein 2006-07
netxms-sync 4702 udp NetXMS Server Synchronization Victor Kirhenshtein Victor Kirhenshtein 2006-07
npqes-test 4703 tcp Network Performance Quality Evaluation System Test Service Zhengli Zhengli 2010-06-28
4703 udp Reserved
assuria-ins 4704 tcp Assuria Insider Nick Connor Nick Connor 2010-06-30
4704 udp Reserved
4705-4710 Unassigned
gearman 4730 tcp Gearman Job Queue System Eric Day Eric Day 2009-01-16
gearman 4730 udp Gearman Job Queue System Eric Day Eric Day 2009-01-16
ipfixs 4740 tcp ipfix protocol over TLS Nevil Brownlee Nevil Brownlee 2006-10
ipfixs 4740 sctp ipfix protocol over DTLS Nevil Brownlee Nevil Brownlee 2006-10
ipfixs 4740 udp ipfix protocol over DTLS Nevil Brownlee Nevil Brownlee 2006-10
ssad 4750 tcp Simple Service Auto Discovery Dr Horst Herb Dr Horst Herb 2005-12
ssad 4750 udp Simple Service Auto Discovery Dr Horst Herb Dr Horst Herb 2005-12
gre-in-udp 4754 udp GRE-in-UDP Encapsulation IESG IETF Chair 2016-10-05 RFC 8086
gre-udp-dtls 4755 udp GRE-in-UDP Encapsulation with DTLS IESG IETF Chair 2016-10-05 RFC 8086
xmcp 4788 tcp eXtensible Messaging Client Protocol Cisco Glenn Matthews 2011-05-23 2011-10-25 Defined TXT keys: txtvers=1 (as described in the draft) protovers=<comma-separated list of major/minor versions supported> (examples: "protovers=1.0" "protovers=1.1,2.0"
vxlan-gpe 4790 udp Generic Protocol Extension for Virtual eXtensible Local Area Network (VXLAN) Lawrence Kreeger Lawrence Kreeger 2014-08-26
4790 tcp Reserved
iims 4800 tcp Icona Instant Messenging System
iims 4800 udp Icona Instant Messenging System
iwec 4801 tcp Icona Web Embedded Chat
iwec 4801 udp Icona Web Embedded Chat
ilss 4802 tcp Icona License System Server Paul Stephen Borlie Paul Stephen Borlie
ilss 4802 udp Icona License System Server Paul Stephen Borlie Paul Stephen Borlie
notateit 4803 tcp Notateit Messaging
notateit-disc 4803 udp Notateit Messaging Discovery Ean Black Ean Black 2009-04-08
4804 tcp Reserved
aja-ntv4-disc 4804 udp AJA ntv4 Video System Discovery Mike Bernadett Mike Bernadett 2010-06-03
4805-4826 Unassigned
varadero-0 4837 tcp Varadero-0
varadero-0 4837 udp Varadero-0
opcua-tcp 4840 tcp OPC UA Connection Protocol OPC Foundation Randy Armstrong 2018-01-04
opcua-udp 4840 udp OPC UA Multicast Datagram Protocol OPC Foundation Randy Armstrong 2006-09 2018-01-04
sun-as-nodeagt 4850 tcp Sun App Server - NA Kedar Mhaswade Kedar Mhaswade 2004-11
sun-as-nodeagt 4850 udp Sun App Server - NA Kedar Mhaswade Kedar Mhaswade 2004-11
cc-tracking 4870 tcp Citcom Tracking Service Wolfgang Weidner Wolfgang Weidner 2005-12
cc-tracking 4870 udp Citcom Tracking Service Wolfgang Weidner Wolfgang Weidner 2005-12
hislip 4880 tcp IVI High-Speed LAN Instrument Protocol Interchangeable Virtual Instruments Foundation, Inc. Larry Ostheimer 2021-05-06
4880 udp Reserved
4890-4893 Unassigned
hfcs 4900 tcp HFSQL Client/Server Database Engine PC SOFT Jerome AERTS 2006-03-02 2014-02-02
hfcs 4900 udp HFSQL Client/Server Database Engine PC SOFT Jerome AERTS 2006-03-02 2014-02-02
flr-agent 4901 tcp FileLocator Remote Search Agent

IANA assigned this well-formed service name as a replacement for "flr_agent".
David Vest David Vest 2008-11-19
flr_agent 4901 tcp FileLocator Remote Search Agent David Vest David Vest 2008-11-19 This entry is an alias to "flr-agent". This entry is now historic, not usable for use with many common service discovery mechanisms.
4901 udp Reserved
magiccontrol 4902 tcp magicCONROL RF and Data Interface Andreas Spalenski Andreas Spalenski 2008-11-24
4902 udp Reserved
4903-4911 Unassigned
fmsg 4930 tcp Host-to-host messaging FMSG AI PTY LTD Mark Mennell 2026-10-15
4930 udp Reserved
eq-office-4940 4940 tcp Equitrac Office
eq-office-4940 4940 udp Equitrac Office
sybasesrvmon 4950 tcp Sybase Server Monitor Chris Irie Chris Irie 2008-03-26
sybasesrvmon 4950 udp Sybase Server Monitor Chris Irie Chris Irie 2008-03-26
ccss-qsm 4970 tcp CCSS QSystemMonitor David Young David Young 2006-01
ccss-qsm 4970 udp CCSS QSystemMonitor David Young David Young 2006-01
ctxs-vpp 4980 udp Citrix Virtual Path Citrix Systems Rohith Ramkumar 2015-04-17
4980 tcp Reserved
busycal 4990 tcp BusySync Calendar Synch. Protocol David Riggle David Riggle 2008-01-07 Defined TXT keys: Proprietary
busycal 4990 udp BusySync Calendar Synch. Protocol David Riggle David Riggle 2008-01-07 Defined TXT keys: Proprietary
commplex-main 5000 tcp
commplex-main 5000 udp

Contact Information

Name Organization Contact URI Last Updated
Adam Golovenko golovenko&gmail.com 2006-10
Andreas Spalenski andreas.spalenski&trsystems.de 2008-11-24
Chris Irie irie&sybase.com 2008-03-26
Cisco glenn.matthews&cisco.com 2011-10-25
Citrix Systems CloudBridge-PM&citrix.com 2015-04-17
Dan Newman Oracle Corp. dan.c.newman&oracle.com 2013-09-20
David Riggle dave&busymac.com 2008-01-07
David Vest dave&mythicsoft.com 2008-11-19
David Young david.young&ccsseurope.co.uk 2006-01
Dr Horst Herb horst&dorrigomedical.com 2005-12
Ean Black eanb&bladesoftware.co.uk 2009-04-08
Eggert Thorlacius eggi&menandmice.com 2010-01-27
Eric Day eday&oddments.org 2009-01-16
FMSG AI PTY LTD mark&fmsg.ai 2026-10-15
Glenn Matthews glenn.matthews&cisco.com 2011-05-23
Hiromi Taki stg-togo&saint.nm.fujitsu.co.jp
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Interchangeable Virtual Instruments Foundation, Inc. ivi.contact&ivifoundation.org 2021-05-06
Jerome AERTS PC SOFT jae&pcsoft.fr 2014-02-02
Kedar Mhaswade kedar.Mhaswade&sun.com 2004-11
Larry Ostheimer larry_ostheimer&keysight.com 2021-05-06
Lawrence E. Hughes Sixscape Communications, Ltd. lhughes&sixscape.com 2014-03-17
Lawrence Kreeger kreeger&cisco.com 2013-04-19
Lecuivre J software.team&mgeups.com 2005-08
Leo Lesage leo.lesage&adp.nl 2006-04
Mark Mennell mark&fmsg.ai 2026-10-15
Michael Mealling michael&refactored-networks.com 2005-08
Mike Bernadett mjbernadett&sbcglobal.net 2010-06-03
Nevil Brownlee n.brownlee&auckland.ac.nz 2006-10
Nick Connor nickc&assuria.com 2010-06-30
OPC Foundation tcb&opcfoundation.org 2017-05-23
Oracle Corp. dan.c.newman&oracle.com 2013-09-20
Paul Stephen Borlie paul&icona.it
PC SOFT jae&pcsoft.fr 2014-02-02
Pedro A Rodriguez pedro.rdz&eaxtechnologies.com.mx 2008-08-06
Primark Corporation joe.boone&primark.com
Randy Armstrong tcb&opcfoundation.org 2017-05-23
Rohith Ramkumar Citrix Systems CloudBridge-PM&citrix.com 2015-04-17
Sixscape Communications, Pte. Ltd. lhughes&sixscape.com 2014-08-26
Victor Kirhenshtein victor&opticom.lv 2006-07
Wolfgang Weidner ww&citcom.de 2005-12
Yoann Vandoorselaere yoann&prelude-ids.org 2005-08
Zhengli std&iwncomm.com 2010-06-28