Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| sds | 5059 | udp | SIP Directory Services | Arthur Wilton | Arthur Wilton | 2006-03 | |||||
| sip | 5060 | tcp | SIP | 2014-04-09 | RFC 3263 | ||||||
| sip | 5060 | udp | SIP | 2014-04-09 | RFC 3263 | ||||||
| sip | 5060 | sctp | SIP | RFC 4168 | |||||||
| sips | 5061 | tcp | SIP-TLS | 2014-04-09 | RFC 3263 | ||||||
| sips | 5061 | udp | SIP-TLS | 2014-04-09 | RFC 3263 | ||||||
| sips | 5061 | sctp | SIP-TLS | RFC 4168 | |||||||
| na-localise | 5062 | tcp | Localisation access | Jean-Pierre Garcia | Jean-Pierre Garcia | 2009-10-28 | |||||
| na-localise | 5062 | udp | Localisation access | Jean-Pierre Garcia | Jean-Pierre Garcia | 2009-10-28 | |||||
| csrpc | 5063 | tcp | centrify secure RPC | Paul Moore | Paul Moore | 2009-10-28 | |||||
| 5063 | udp | Reserved | |||||||||
| ca-1 | 5064 | tcp | Channel Access 1 | Jeffrey Hill | Jeffrey Hill | 2002-08 | |||||
| ca-1 | 5064 | udp | Channel Access 1 | Jeffrey Hill | Jeffrey Hill | 2002-08 | |||||
| ca-2 | 5065 | tcp | Channel Access 2 | Jeffrey Hill | Jeffrey Hill | 2002-08 | |||||
| ca-2 | 5065 | udp | Channel Access 2 | Jeffrey Hill | Jeffrey Hill | 2002-08 | |||||
| stanag-5066 | 5066 | tcp | STANAG-5066-SUBNET-INTF | Rickard Berg | Rickard Berg | 2025-10-22 | |||||
| stanag-5066 | 5066 | udp | STANAG-5066-SUBNET-INTF | Rickard Berg | Rickard Berg | 2025-10-22 | |||||
| authentx | 5067 | tcp | Authentx Service | Alberto Fernandez | Alberto Fernandez | 2006-01 | |||||
| authentx | 5067 | udp | Authentx Service | Alberto Fernandez | Alberto Fernandez | 2006-01 | |||||
| bitforestsrv | 5068 | tcp | Bitforest Data Service | Ville-Pekka Vahteala | Ville-Pekka Vahteala | 2008-06-05 | |||||
| 5068 | udp | Reserved | |||||||||
| i-net-2000-npr | 5069 | tcp | I/Net 2000-NPR | Chris Megede | Chris Megede | ||||||
| i-net-2000-npr | 5069 | udp | I/Net 2000-NPR | Chris Megede | Chris Megede | ||||||
| vtsas | 5070 | tcp | VersaTrans Server Agent Service | Christopher Miller | Christopher Miller | 2006-02 | |||||
| vtsas | 5070 | udp | VersaTrans Server Agent Service | Christopher Miller | Christopher Miller | 2006-02 | |||||
| powerschool | 5071 | tcp | PowerSchool | Greg Porter | Greg Porter | ||||||
| powerschool | 5071 | udp | PowerSchool | Greg Porter | Greg Porter | ||||||
| ayiya | 5072 | tcp | Anything In Anything | Jeroen Massar | Jeroen Massar | 2005-08 | |||||
| ayiya | 5072 | udp | Anything In Anything | Jeroen Massar | Jeroen Massar | 2005-08 | |||||
| tag-pm | 5073 | tcp | Advantage Group Port Mgr | James Goddard | James Goddard | 2005-08 | |||||
| tag-pm | 5073 | udp | Advantage Group Port Mgr | James Goddard | James Goddard | 2005-08 | |||||
| alesquery | 5074 | tcp | ALES Query | Tim Maloney | Tim Maloney | 2005-08 | |||||
| alesquery | 5074 | udp | ALES Query | Tim Maloney | Tim Maloney | 2005-08 | |||||
| pvaccess | 5075 | tcp | Experimental Physics and Industrial Control System | Matej Sekoranja | Matej Sekoranja | 2012-03-23 | |||||
| 5075 | udp | Reserved | |||||||||
| 5076-5077 | Unassigned | ||||||||||
| pixelpusher | 5078 | udp | PixelPusher pixel data | heroicrobotics.com | Jasmine Strong | 2014-06-24 | |||||
| 5078 | tcp | Reserved | |||||||||
| 5079 | tcp | Reserved | |||||||||
| cp-spxrpts | 5079 | udp | Cambridge Pixel SPx Reports | Richard Warren | Richard Warren | 2008-09-17 | |||||
| onscreen | 5080 | tcp | OnScreen Data Collection Service | Christopher Miller | Christopher Miller | 2008-01-14 | |||||
| onscreen | 5080 | udp | OnScreen Data Collection Service | Christopher Miller | Christopher Miller | 2008-01-14 | |||||
| sdl-ets | 5081 | tcp | SDL - Ent Trans Server | Marc Morin | Marc Morin | 2002-04 | |||||
| sdl-ets | 5081 | udp | SDL - Ent Trans Server | Marc Morin | Marc Morin | 2002-04 | |||||
| qcp | 5082 | tcp | Qpur Communication Protocol | Joachim Kluemper | Joachim Kluemper | 2008-03-19 | |||||
| qcp | 5082 | udp | Qpur Communication Protocol | Joachim Kluemper | Joachim Kluemper | 2008-03-19 | |||||
| qfp | 5083 | tcp | Qpur File Protocol | Joachim Kluemper | Joachim Kluemper | 2008-03-19 | |||||
| qfp | 5083 | udp | Qpur File Protocol | Joachim Kluemper | Joachim Kluemper | 2008-03-19 | |||||
| llrp | 5084 | tcp | EPCglobal Low-Level Reader Protocol | Margaret Cullen; Paul Dietrich | Margaret Cullen; Paul Dietrich | 2006-11 | Defined TXT keys: None. RFID reader Low Level Reader Protocol | ||||
| llrp | 5084 | udp | EPCglobal Low-Level Reader Protocol | Margaret Cullen; Paul Dietrich | Margaret Cullen; Paul Dietrich | 2006-11 | Defined TXT keys: None. RFID reader Low Level Reader Protocol | ||||
| encrypted-llrp | 5085 | tcp | EPCglobal Encrypted LLRP | Margaret Cullen | Margaret Cullen | 2006-11 | |||||
| encrypted-llrp | 5085 | udp | EPCglobal Encrypted LLRP | Margaret Cullen | Margaret Cullen | 2006-11 | |||||
| aprigo-cs | 5086 | tcp | Aprigo Collection Service | Ron Zalkind | Ron Zalkind | 2010-05-28 | |||||
| 5086 | udp | Reserved | |||||||||
| biotic | 5087 | tcp | BIOTIC - Binary Internet of Things Interoperable Communication | Waher Data AB | Peter Waher | 2014-06-16 | 2015-11-25 | ||||
| 5087 | udp | Reserved | |||||||||
| 5088-5089 | Unassigned | ||||||||||
| car | 5090 | sctp | Candidate AR | ||||||||
| cxtp | 5091 | sctp | Context Transfer Protocol | 2005-07 | RFC 4065 | ||||||
| 5092 | tcp | Reserved | |||||||||
| magpie | 5092 | udp | Magpie Binary | Phil Maker | Phil Maker | 2008-06-18 | |||||
| sentinel-lm | 5093 | tcp | Sentinel LM | Derick Snyder | Derick Snyder | ||||||
| sentinel-lm | 5093 | udp | Sentinel LM | Derick Snyder | Derick Snyder | ||||||
| hart-ip | 5094 | tcp | HART-IP | Wally Pratt Jr | Wally Pratt Jr | 2010-03-02 | |||||
| hart-ip | 5094 | udp | HART-IP | Wally Pratt Jr | Wally Pratt Jr | 2010-03-02 | |||||
| 5095-5098 | Unassigned | ||||||||||
| sentlm-srv2srv | 5099 | tcp | SentLM Srv2Srv | Derick Snyder | Derick Snyder | ||||||
| sentlm-srv2srv | 5099 | udp | SentLM Srv2Srv | Derick Snyder | Derick Snyder | ||||||
| socalia | 5100 | tcp | Socalia service mux | Alberto Raydan | Alberto Raydan | 2005-08 | |||||
| socalia | 5100 | udp | Socalia service mux | Alberto Raydan | Alberto Raydan | 2005-08 | |||||
| talarian-tcp | 5101 | tcp | Talarian_TCP | Leo Martins | Leo Martins | ||||||
| talarian-udp | 5101 | udp | Talarian_UDP | Leo Martins | Leo Martins | ||||||
| oms-nonsecure | 5102 | tcp | Oracle OMS non-secure | Todd Guay | Todd Guay | 2005-08 | |||||
| oms-nonsecure | 5102 | udp | Oracle OMS non-secure | Todd Guay | Todd Guay | 2005-08 | |||||
| actifio-c2c | 5103 | tcp | Actifio C2C | Ravi Kollipara | Ravi Kollipara | 2010-06-18 | |||||
| 5103 | udp | Reserved | |||||||||
| 5104 | tcp | Reserved | |||||||||
| tinymessage | 5104 | udp | TinyMessage | Josip Medved | Josip Medved | 2010-10-20 | |||||
| 5105 | tcp | Reserved | |||||||||
| hughes-ap | 5105 | udp | Hughes Association Protocol | Varun Santosh | Varun Santosh | 2010-10-20 | |||||
| actifioudsagent | 5106 | tcp | Actifio UDS Agent | Actifio | Madhav Mutalik | 2014-06-05 | |||||
| 5106 | udp | Reserved | |||||||||
| actifioreplic | 5107 | tcp | Disk to Disk replication between Actifio Clusters | Actifio | Madhav Mutalik | 2015-10-23 | |||||
| 5107 | udp | Reserved | |||||||||
| 5108-5110 | Unassigned | ||||||||||
| barracuda-bbs | 5120 | tcp | Barracuda Backup Protocol | Barracuda Networks | Andrew Blyler | 2013-04-05 | |||||
| barracuda-bbs | 5120 | udp | Barracuda Backup Protocol | Barracuda Networks | Andrew Blyler | 2013-04-05 | |||||
| atmp | 5150 | tcp | Ascend Tunnel Management Protocol | Kory Hamzeh | Kory Hamzeh | ||||||
| atmp | 5150 | udp | Ascend Tunnel Management Protocol | Kory Hamzeh | Kory Hamzeh | ||||||
| 5153 | tcp | Reserved | 2009-07-01 | 2018-04-19 | Historic usage was toruxserver. De-Assigned on 2018-04-19 | ||||||
| 5158-5160 | Unassigned | ||||||||||
| scte104 | 5167 | tcp | SCTE104 Connection | Thomas Russell | Thomas Russell | 2005-05 | |||||
| scte104 | 5167 | udp | SCTE104 Connection | Thomas Russell | Thomas Russell | 2005-05 | |||||
| scte30 | 5168 | tcp | SCTE30 Connection | Thomas Russell | Thomas Russell | 2005-05 | |||||
| scte30 | 5168 | udp | SCTE30 Connection | Thomas Russell | Thomas Russell | 2005-05 | |||||
| aol | 5190 | tcp | America-Online | Marty Lyons | Marty Lyons | ||||||
| aol | 5190 | udp | America-Online | Marty Lyons | Marty Lyons | ||||||
| targus-getdata | 5200 | tcp | TARGUS GetData | John Keaveney | John Keaveney | ||||||
| targus-getdata | 5200 | udp | TARGUS GetData | John Keaveney | John Keaveney | ||||||
| targus-getdata1 | 5201 | tcp | TARGUS GetData 1 | John Keaveney | John Keaveney | ||||||
| targus-getdata1 | 5201 | udp | TARGUS GetData 1 | John Keaveney | John Keaveney |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Actifio | madhav.mutalik&actifio.com | 2015-10-23 | |
| Alberto Fernandez | af&xtec.com | 2006-01 | |
| Alberto Raydan | raydan_a&socalia.com | 2005-08 | |
| Andrew Blyler | Barracuda Networks | ablyler&barracuda.com | 2013-04-05 |
| Arthur Wilton | art&awilton.com | 2006-03 | |
| Barracuda Networks | BackupEngineering_Team&barracuda.com | 2013-04-05 | |
| Chris Megede | chris.megede&tac.com | ||
| Christopher Miller | Chris.Miller&versatrans.com | 2006-02 | |
| Christopher Miller | chris.miller&versatrans.com | 2008-01-14 | |
| Derick Snyder | dsnyder&rainbow.com | ||
| Greg Porter | gporter&powerschool.com | ||
| heroicrobotics.com | jasmine&heroicrobotics.com | 2014-06-24 | |
| James Goddard | jamesg&taglim.com | 2005-08 | |
| Jasmine Strong | heroicrobotics.com | jasmine&heroicrobotics.com | 2014-06-24 |
| Jean-Pierre Garcia | jp.garcia&netia.com | 2009-10-28 | |
| Jeffrey Hill | johill&lanl.gov | 2002-08 | |
| Jeroen Massar | jeroen&unfix.org | 2005-08 | |
| Joachim Kluemper | ports&raikosoft.com | 2008-03-19 | |
| John Keaveney | johnkeaveney&targusinfo.com | ||
| Josip Medved | jmedved&jmedved.com | 2010-10-20 | |
| Kory Hamzeh | kory&ascend.com | ||
| Leo Martins | leo&talarian.com | ||
| Madhav Mutalik | Actifio | madhav.mutalik&actifio.com | 2015-10-23 |
| Marc Morin | mmorin&sdlintl.com | 2002-04 | |
| Margaret Cullen | mrcullen42&gmail.com | 2023-06-07 | |
| Marty Lyons | marty&aol.com | ||
| Matej Sekoranja | matej.sekoranja&cosylab.com | 2012-03-23 | |
| Paul Dietrich | registrar&impinj.com | ||
| Paul Moore | paul.moore¢rify.com | 2009-10-28 | |
| Peter Waher | Waher Data AB | peterwaher&hotmail.com | 2015-11-25 |
| Phil Maker | pjm&gnu.org | 2008-06-18 | |
| Ravi Kollipara | ravi.kollipara&actifio.com | 2010-06-18 | |
| Richard Warren | richard&cambridgepixel.com | 2008-09-17 | |
| Rickard Berg | rickard.berg&fmv.se | 2025-10-22 | |
| Ron Zalkind | ron&aprigo.com | 2010-05-28 | |
| Thomas Russell | trussell&scte.org | 2005-05 | |
| Tim Maloney | tim.maloney&allianceconsultingllc.com | 2005-08 | |
| Todd Guay | todd.guay&oracle.com | 2005-08 | |
| Varun Santosh | varun.santosh&hughes.com | 2010-10-20 | |
| Ville-Pekka Vahteala | ville-pekka.vahteala&bitcomp.fi | 2008-06-05 | |
| Waher Data AB | peterwaher&hotmail.com | 2015-11-25 | |
| Wally Pratt Jr | wpratt&fieldcommgroup.org | 2012-12-14 |