Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
targus-getdata1 5201 udp TARGUS GetData 1 John Keaveney John Keaveney
targus-getdata2 5202 tcp TARGUS GetData 2 John Keaveney John Keaveney
targus-getdata2 5202 udp TARGUS GetData 2 John Keaveney John Keaveney
targus-getdata3 5203 tcp TARGUS GetData 3 John Keaveney John Keaveney
targus-getdata3 5203 udp TARGUS GetData 3 John Keaveney John Keaveney
5204-5208 Unassigned
nomad 5209 tcp Nomad Device Video Transfer Morega Systems Inc. Ashraf Tahir 2012-08-20
5209 udp Reserved
5210-5214 Unassigned
5216-5220 Unassigned
xmpp-client 5222 tcp XMPP Client Connection RFC 6120
jaxflow-data 5230 tcp JaxMP RealFlow application and protocol data JaxMP Stephen Hull 2014-08-15
5230 udp Reserved
soagateway 5250 tcp soaGateway Greg Bodine Greg Bodine 2002-02
soagateway 5250 udp soaGateway Greg Bodine Greg Bodine 2002-02
xmpp-server 5269 tcp XMPP Server Connection RFC 6120
cartographerxmp 5270 tcp Cartographer XMP Bobby Krupczak Bobby Krupczak 2008-04-03 2011-08-31
cartographerxmp 5270 udp Cartographer XMP Bobby Krupczak Bobby Krupczak 2008-04-03 2011-08-31
xmpp-bosh 5280 tcp Bidirectional-streams Over Synchronous HTTP (BOSH) Peter Saint-Andre Peter Saint-Andre 2009-11-25
5280 udp Reserved
hacl-hb 5300 tcp HA cluster heartbeat Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-hb 5300 udp HA cluster heartbeat Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-gs 5301 tcp HA cluster general services Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-gs 5301 udp HA cluster general services Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-cfg 5302 tcp HA cluster configuration Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-cfg 5302 udp HA cluster configuration Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-probe 5303 tcp HA cluster probing Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-probe 5303 udp HA cluster probing Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-local 5304 tcp HA Cluster Commands Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-local 5304 udp HA Cluster Commands Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-test 5305 tcp HA Cluster Test Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
hacl-test 5305 udp HA Cluster Test Eric Soderberg; Edward Yim Eric Soderberg; Edward Yim
sun-mc-grp 5306 tcp Sun MC Group Michael DeMoney Michael DeMoney
sun-mc-grp 5306 udp Sun MC Group Michael DeMoney Michael DeMoney
sco-aip 5307 tcp SCO AIP Barrie Cooper Barrie Cooper
sco-aip 5307 udp SCO AIP Barrie Cooper Barrie Cooper
cfengine 5308 tcp CFengine Mark Burgess Mark Burgess
cfengine 5308 udp CFengine Mark Burgess Mark Burgess
jprinter 5309 tcp J Printer Ken Blackwell Ken Blackwell
jprinter 5309 udp J Printer Ken Blackwell Ken Blackwell
outlaws 5310 tcp Outlaws Richard Fife Richard Fife
outlaws 5310 udp Outlaws Richard Fife Richard Fife
pkix-cmc 5318 tcp PKIX Certificate Management using CMS (CMC) IESG IETF Chair 2026-02-13 RFC 10003
roughtime 5319 tcp Roughtime time synchronization IESG IETF Chair 2026-03-27 RFC 10049
roughtime 5319 udp Roughtime time synchronization IESG IETF Chair 2026-03-27 RFC 10049
bsfserver-zn 5320 tcp Webservices-based Zn interface of BSF Bert Paul Bert Paul 2008-05-01
5320 udp Reserved
stuns 5349 udp STUN over DTLS IESG IETF Chair 2014-07-03 RFC 7350 This service name was initially created by RFC 5389.
turns 5349 udp TURN over DTLS IESG IETF Chair 2019-08-02 RFC 7350 This service name was initially created by RFC 8656.
stun-behaviors 5349 tcp STUN Behavior Discovery over TLS RFC 5780
stun-behaviors 5349 udp Reserved for a future enhancement of STUN-BEHAVIOR RFC 5780
5350 tcp Reserved
pcp-multicast 5350 udp Port Control Protocol Multicast IESG IETF Chair RFC 6887
ms-sideshow 5360 tcp Protocol for Windows SideShow Dan Polivy Dan Polivy 2008-03-12
ms-sideshow 5360 udp Protocol for Windows SideShow Dan Polivy Dan Polivy 2008-03-12
excerpt 5400 tcp Excerpt Search John Hinsdale John Hinsdale
excerpt 5400 udp Excerpt Search John Hinsdale John Hinsdale
excerpts 5401 tcp Excerpt Search Secure John Hinsdale John Hinsdale
excerpts 5401 udp Excerpt Search Secure John Hinsdale John Hinsdale
mftp 5402 tcp OmniCast MFTP Steve Bannister Steve Bannister
mftp 5402 udp OmniCast MFTP Steve Bannister Steve Bannister
hpoms-ci-lstn 5403 tcp HPOMS-CI-LSTN Harold Froehling Harold Froehling
hpoms-ci-lstn 5403 udp HPOMS-CI-LSTN Harold Froehling Harold Froehling
hpoms-dps-lstn 5404 tcp HPOMS-DPS-LSTN Harold Froehling Harold Froehling
hpoms-dps-lstn 5404 udp HPOMS-DPS-LSTN Harold Froehling Harold Froehling
netsupport 5405 tcp NetSupport Paul Sanders Paul Sanders
netsupport 5405 udp NetSupport Paul Sanders Paul Sanders
systemics-sox 5406 tcp Systemics Sox Gary Howland Gary Howland
systemics-sox 5406 udp Systemics Sox Gary Howland Gary Howland
foresyte-clear 5407 tcp Foresyte-Clear Jorge Aldana Jorge Aldana
foresyte-clear 5407 udp Foresyte-Clear Jorge Aldana Jorge Aldana
foresyte-sec 5408 tcp Foresyte-Sec Jorge Aldana Jorge Aldana
foresyte-sec 5408 udp Foresyte-Sec Jorge Aldana Jorge Aldana
salient-dtasrv 5409 tcp Salient Data Server Richard Farnham Richard Farnham
salient-dtasrv 5409 udp Salient Data Server Richard Farnham Richard Farnham
salient-usrmgr 5410 tcp Salient User Manager Richard Farnham Richard Farnham
salient-usrmgr 5410 udp Salient User Manager Richard Farnham Richard Farnham
cylink-c 5420 tcp Cylink-C John Jobe John Jobe
cylink-c 5420 udp Cylink-C John Jobe John Jobe
radec-corp 5430 tcp RADEC CORP David Chell David Chell
radec-corp 5430 udp RADEC CORP David Chell David Chell
tiepie 5450 tcp TiePie engineering data acquisition TiePie engineering Reinder Feenstra 2016-04-01
tiepie-disc 5450 udp TiePie engineering data acquisition (discovery) TiePie engineering Reinder Feenstra 2016-04-01
5457-5460 Unassigned
apsolab-col 5470 tcp The Apsolab company's data collection protocol (native api) Apsolab Inc. Jean-Francois Gauthier 2014-11-10
5470 udp Reserved
fcp-addr-srvr1 5500 tcp fcp-addr-srvr1 Ken Wittmer Ken Wittmer
fcp-addr-srvr1 5500 udp fcp-addr-srvr1 Ken Wittmer Ken Wittmer
fcp-addr-srvr2 5501 tcp fcp-addr-srvr2 Ken Wittmer Ken Wittmer
fcp-addr-srvr2 5501 udp fcp-addr-srvr2 Ken Wittmer Ken Wittmer
fcp-srvr-inst1 5502 tcp fcp-srvr-inst1 Ken Wittmer Ken Wittmer
fcp-srvr-inst1 5502 udp fcp-srvr-inst1 Ken Wittmer Ken Wittmer
fcp-srvr-inst2 5503 tcp fcp-srvr-inst2 Ken Wittmer Ken Wittmer
fcp-srvr-inst2 5503 udp fcp-srvr-inst2 Ken Wittmer Ken Wittmer
fcp-cics-gw1 5504 tcp fcp-cics-gw1 Ken Wittmer Ken Wittmer
fcp-cics-gw1 5504 udp fcp-cics-gw1 Ken Wittmer Ken Wittmer
checkoutdb 5505 tcp Checkout Database Dirk Stoop Dirk Stoop 2007-04
checkoutdb 5505 udp Checkout Database Dirk Stoop Dirk Stoop 2007-04
amc 5506 tcp Amcom Mobile Connect Aaron Fracht-Monroe Aaron Fracht-Monroe 2010-06-03
amc 5506 udp Amcom Mobile Connect Aaron Fracht-Monroe Aaron Fracht-Monroe 2010-06-03
psl-management 5507 tcp PowerSysLab Electrical Management PowerSysLab Lucas Lorensi 2015-07-20

Contact Information

Name Organization Contact URI Last Updated
Aaron Fracht-Monroe afracht-monroe&amcomsoft.com 2010-06-03
Apsolab Inc. admin&apsolab.com 2014-11-10
Ashraf Tahir Morega Systems Inc. atahir&morega.com 2012-08-20
Barrie Cooper barrie&sco.com
Bert Paul bert.paul&apertio.com 2008-07-03
Bobby Krupczak rdk&krupczak.org 2008-04-03
Dan Polivy dpolivy&microsoft.com 2008-03-12
David Chell david&softlife.co.nz
Dirk Stoop dirk&madebysofa.com 2007-04
Edward Yim eyim&hpmfas4.cup.hp.com
Eric Soderberg seric&hposl102.cup.hp
Gary Howland gary&systemics.com
Greg Bodine gregory.bodine&ca.com 2002-02
Harold Froehling hrf&cup.hp.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
JaxMP shull&jaxmp.com 2014-08-15
Jean-Francois Gauthier Apsolab Inc. jfgauthier&apsolab.com 2014-11-10
John Hinsdale hin&alma.com
John Jobe jjobe&cylink.com
John Keaveney johnkeaveney&targusinfo.com
Jorge Aldana operator&foresyte.com
Ken Blackwell kenb&bristol.com
Ken Wittmer kenneth.m.wittmer&accenture.com
Lucas Lorensi lucas.lorensi&powersyslab.com 2015-07-20
Mark Burgess mark.burgess&iu.hioslo.no
Michael DeMoney demoney&eng.sun.com
Morega Systems Inc. atahir&morega.com 2012-08-20
Paul Sanders pe77&dial.pipex.com
Peter Saint-Andre stpeter&stpeter.im 2009-11-25
PowerSysLab info&powersyslab.com 2015-07-20
Reinder Feenstra r.feenstra&tiepie.nl 2016-04-01
Richard Farnham rfarnham&salient.com
Richard Fife richardf&lucasarts.com
Stephen Hull JaxMP shull&jaxmp.com 2014-08-15
Steve Bannister sbannister&stratacache.com
TiePie engineering tiepie&tiepie.nl 2016-04-01