Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| psl-management | 5507 | tcp | PowerSysLab Electrical Management | PowerSysLab | Lucas Lorensi | 2015-07-20 | |||||
| 5507 | udp | Reserved | |||||||||
| 5508-5539 | Unassigned | ||||||||||
| matter | 5540 | tcp | Matter Operational Discovery and Communi | Connectivity Standards Alliance | Aron Rosenberg | 2021-07-16 | |||||
| matter | 5540 | udp | Matter Operational Discovery and Communi | Connectivity Standards Alliance | Aron Rosenberg | 2021-07-16 | |||||
| cbus | 5550 | tcp | Model Railway control using the CBUS message protocol | MERG | Pete Brownlow | 2017-01-03 | |||||
| 5550 | udp | Reserved | |||||||||
| 5570-5572 | Unassigned | Known UNAUTHORIZED USE on Port 5570 | |||||||||
| tmosms0 | 5580 | tcp | T-Mobile SMS Protocol Message 0 | Ezinne Oji | Ezinne Oji | 2006-06 | |||||
| tmosms0 | 5580 | udp | T-Mobile SMS Protocol Message 0 | Ezinne Oji | Ezinne Oji | 2006-06 | |||||
| esmmanager | 5600 | tcp | Enterprise Security Manager | Kimberly Gibbs | Kimberly Gibbs | ||||||
| esmmanager | 5600 | udp | Enterprise Security Manager | Kimberly Gibbs | Kimberly Gibbs | ||||||
| esmagent | 5601 | tcp | Enterprise Security Agent | Kimberly Gibbs | Kimberly Gibbs | ||||||
| esmagent | 5601 | udp | Enterprise Security Agent | Kimberly Gibbs | Kimberly Gibbs | ||||||
| a1-msc | 5602 | tcp | A1-MSC | Mike Dolan | Mike Dolan | ||||||
| a1-msc | 5602 | udp | A1-MSC | Mike Dolan | Mike Dolan | ||||||
| a1-bs | 5603 | tcp | A1-BS | Mike Dolan | Mike Dolan | ||||||
| a1-bs | 5603 | udp | A1-BS | Mike Dolan | Mike Dolan | ||||||
| a3-sdunode | 5604 | tcp | A3-SDUNode | Mike Dolan | Mike Dolan | ||||||
| a3-sdunode | 5604 | udp | A3-SDUNode | Mike Dolan | Mike Dolan | ||||||
| a4-sdunode | 5605 | tcp | A4-SDUNode | Mike Dolan | Mike Dolan | ||||||
| a4-sdunode | 5605 | udp | A4-SDUNode | Mike Dolan | Mike Dolan | ||||||
| 5606-5617 | Unassigned | ||||||||||
| precise-comm | 5630 | tcp | PreciseCommunication | Alon Tamir | Alon Tamir | 2006-04 | |||||
| precise-comm | 5630 | udp | PreciseCommunication | Alon Tamir | Alon Tamir | 2006-04 | |||||
| 5640-5645 | Unassigned | ||||||||||
| filemq | 5670 | tcp | ZeroMQ file publish-subscribe protocol | Pieter Hintjens | Pieter Hintjens | 2012-11-01 | 2013-02-25 | ||||
| zre-disc | 5670 | udp | Local area discovery and messaging over ZeroMQ | Pieter Hintjens | Pieter Hintjens | 2012-12-17 | |||||
| v5ua | 5675 | tcp | V5UA application port | RFC 3807 | |||||||
| v5ua | 5675 | udp | V5UA application port | RFC 3807 | |||||||
| v5ua | 5675 | sctp | V5UA application port | RFC 3807 | |||||||
| auriga-router | 5680 | tcp | Auriga Router Service | Vincent Gaudeul | Vincent Gaudeul | 2006-02 | |||||
| auriga-router | 5680 | udp | Auriga Router Service | Vincent Gaudeul | Vincent Gaudeul | 2006-02 | |||||
| coaps | 5684 | tcp | Constrained Application Protocol (CoAP) | IESG | IETF Chair | 2017-12-22 | RFC 7301; RFC 8323 | ||||
| 5690-5692 | Unassigned | ||||||||||
| supportassist | 5700 | tcp | Dell SupportAssist data center management | Dell Technologies | Rohitdev Kulshrestha | 2016-07-05 | |||||
| 5700 | udp | Reserved | |||||||||
| 5701-5704 | Unassigned | ||||||||||
| storageos | 5705 | tcp | StorageOS REST API | StorageOS | Simon Croome | 2017-03-03 | |||||
| 5705 | udp | Reserved | |||||||||
| 5706-5712 | Unassigned | ||||||||||
| ms-licensing | 5720 | tcp | MS-Licensing | Thomas Lindeman | Thomas Lindeman | 2002-11 | |||||
| ms-licensing | 5720 | udp | MS-Licensing | Thomas Lindeman | Thomas Lindeman | 2002-11 | |||||
| unieng | 5730 | tcp | Steltor's calendar access | Bernard Desruisseaux | Bernard Desruisseaux | ||||||
| unieng | 5730 | udp | Steltor's calendar access | Bernard Desruisseaux | Bernard Desruisseaux | ||||||
| 5731-5740 | Unassigned | ||||||||||
| rscd | 5750 | tcp | Bladelogic Agent Service | Brian Trevor | Brian Trevor | 2008-10-24 | |||||
| rscd | 5750 | udp | Bladelogic Agent Service | Brian Trevor | Brian Trevor | 2008-10-24 | |||||
| x500ms | 5757 | tcp | OpenMail X.500 Directory Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| x500ms | 5757 | udp | OpenMail X.500 Directory Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| spramsca | 5769 | tcp | x509solutions Internal CA | Brendan Fay | Brendan Fay | 2006-02 | |||||
| spramsca | 5769 | udp | x509solutions Internal CA | Brendan Fay | Brendan Fay | 2006-02 | |||||
| spramsd | 5770 | tcp | x509solutions Secure Data | Brendan Fay | Brendan Fay | 2006-02 | |||||
| spramsd | 5770 | udp | x509solutions Secure Data | Brendan Fay | Brendan Fay | 2006-02 | |||||
| vts-rpc | 5780 | tcp | Visual Tag System RPC | Graham Bloice | Graham Bloice | 2009-09-17 | |||||
| 5780 | udp | Reserved | |||||||||
| autopassdaemon | 5820 | tcp | AutoPass licensing | opentext | AutoPass | 2022-06-10 | 2024-08-01 | ||||
| 5820 | udp | Reserved | |||||||||
| 5821-5840 | Unassigned | ||||||||||
| 5860-5862 | Unassigned | ||||||||||
| rfb | 5900 | tcp | Remote Framebuffer | Tristan Richardson | Tristan Richardson | 2006-03 | RFC 6143 | ||||
| rfb | 5900 | udp | Remote Framebuffer | Tristan Richardson | Tristan Richardson | 2006-03 | RFC 6143 | ||||
| 5901-5902 | Unassigned | ||||||||||
| ff-ice | 5903 | tcp | Flight & Flow Info for Collaborative Env | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: FF-ICE | ||||
| ff-ice | 5903 | udp | Flight & Flow Info for Collaborative Env | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: FF-ICE | ||||
| ff-ice | 5903 | sctp | Flight & Flow Info for Collaborative Env | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: FF-ICE | ||||
| ag-swim | 5904 | tcp | Air-Ground SWIM | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: AG-SWIM | ||||
| ag-swim | 5904 | udp | Air-Ground SWIM | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: AG-SWIM | ||||
| ag-swim | 5904 | sctp | Air-Ground SWIM | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: AG-SWIM | ||||
| asmgcs | 5905 | tcp | Adv Surface Mvmnt and Guidance Cont Sys | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: ASMGCS | ||||
| asmgcs | 5905 | udp | Adv Surface Mvmnt and Guidance Cont Sys | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: ASMGCS | ||||
| asmgcs | 5905 | sctp | Adv Surface Mvmnt and Guidance Cont Sys | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: ASMGCS | ||||
| rpas-c2 | 5906 | tcp | Remotely Piloted Vehicle C&C | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: RPAS-C2 | ||||
| rpas-c2 | 5906 | udp | Remotely Piloted Vehicle C&C | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: RPAS-C2 | ||||
| rpas-c2 | 5906 | sctp | Remotely Piloted Vehicle C&C | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: RPAS-C2 | ||||
| dsd | 5907 | tcp | Distress and Safety Data App | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: DSD | ||||
| dsd | 5907 | udp | Distress and Safety Data App | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: DSD | ||||
| dsd | 5907 | sctp | Distress and Safety Data App | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: DSD | ||||
| ipsma | 5908 | tcp | IPS Management Application | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: IPSMA | ||||
| ipsma | 5908 | udp | IPS Management Application | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: IPSMA | ||||
| ipsma | 5908 | sctp | IPS Management Application | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: IPSMA | ||||
| agma | 5909 | tcp | Air-ground media advisory | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: AGMA | ||||
| agma | 5909 | udp | Air-ground media advisory | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: AGMA | ||||
| agma | 5909 | sctp | Air-ground media advisory | International Civil Aviation Organisation (ICAO) | Greg Saccone | 2022-06-03 | Defined TXT keys: AGMA | ||||
| ats-atn | 5910 | tcp | Air Traffic Services applications using ATN | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| ats-atn | 5910 | udp | Air Traffic Services applications using ATN | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| cm | 5910 | sctp | Context Management | Justin Yu | Justin Yu | 2011-05-19 | |||||
| 5970-5983 | Unassigned | ||||||||||
| wbem-exp-https | 5990 | tcp | WBEM Export HTTPS | Denise Eckstein | Denise Eckstein | 2004-11 | |||||
| wbem-exp-https | 5990 | udp | WBEM Export HTTPS | Denise Eckstein | Denise Eckstein | 2004-11 | |||||
| x11 | 6000-6063 | tcp | X Window System | Stephen Gildea | Stephen Gildea | Known Unauthorized Use on port 6003 | |||||
| x11 | 6000-6063 | udp | X Window System | Stephen Gildea | Stephen Gildea | Known Unauthorized Use on port 6003 | |||||
| ndl-ahp-svc | 6064 | tcp | NDL-AHP-SVC | John Richmond | John Richmond | ||||||
| ndl-ahp-svc | 6064 | udp | NDL-AHP-SVC | John Richmond | John Richmond | ||||||
| winpharaoh | 6065 | tcp | WinPharaoh | Basil Lee | Basil Lee | ||||||
| winpharaoh | 6065 | udp | WinPharaoh | Basil Lee | Basil Lee | ||||||
| ewctsp | 6066 | tcp | EWCTSP | Mark Bailon | Mark Bailon | ||||||
| ewctsp | 6066 | udp | EWCTSP | Mark Bailon | Mark Bailon | ||||||
| 6067 | Unassigned | 2007-07-17 | |||||||||
| gsmp-ancp | 6068 | tcp | GSMP/ANCP | Avri Doria | Avri Doria | RFC 6320 | |||||
| 6068 | udp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alon Tamir | alon_tamir&symantec.com | 2006-04 | |
| Aron Rosenberg | Connectivity Standards Alliance | arosenberg&logitech.com | 2021-07-16 |
| AutoPass | MFI-swpdl.apls_core&opentext.com | 2024-08-01 | |
| Avri Doria | avri.doria&nokia.com | ||
| Basil Lee | basil.lee&gnnettest.com | ||
| Bernard Desruisseaux | bernard&steltor.com | ||
| Brendan Fay | brendan.fay&x509solutions.com | 2006-02 | |
| Brian Trevor | btrevor&bmc.com | 2008-10-24 | |
| Connectivity Standards Alliance | ianaregistrations&mail.csa-iot.org | 2021-07-23 | |
| Dell Technologies | rohitdev_kulshrestha&dell.com | 2016-07-05 | |
| Denise Eckstein | denise.eckstein&hp.com | 2004-11 | |
| Don Loughry | DON_LOUGHRY&hp-cupertino-om4.om.hp.com | ||
| Eivan Cerasi | eivan.cerasi&eurocontrol.int | 2022-08-08 | |
| Ezinne Oji | ezinne.oji&t-mobile.com | 2006-06 | |
| Graham Bloice | graham.bloice&trihedral.com | 2009-09-17 | |
| Greg Saccone | gregory.t.saccone&boeing.com | 2022-08-08 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| International Civil Aviation Organisation (ICAO) | gisinbox&icao.int | 2024-11-19 | |
| John Richmond | john&ndl.co.uk | ||
| Justin Yu | yyu&mitre.org | 2011-05-25 | |
| Kimberly Gibbs | kimgib&ccgate-ut.axent.com | ||
| Lucas Lorensi | lucas.lorensi&powersyslab.com | 2015-07-20 | |
| Mark Bailon | mark.bailon&ericsson.com | ||
| MERG | merg&upsys.co.uk | 2017-01-03 | |
| Mike Dolan | MDolan&ihcmail.ih.lucent.com | ||
| OpenMail Encyclopedia | opencyc&hpopd.pwd.hp.com | ||
| opentext | MFI-swpdl.apls_core&opentext.com | 2024-08-01 | |
| Pete Brownlow | merg&upsys.co.uk | 2017-01-03 | |
| Pieter Hintjens | ph&imatix.com | 2012-11-01 | |
| Pieter Hintjens | ph&imatix.com | 2012-12-17 | |
| PowerSysLab | info&powersyslab.com | 2015-07-20 | |
| Rohitdev Kulshrestha | rohitdev_kulshrestha&dell.com | 2016-07-05 | |
| Simon Croome | simon.croome&storageos.com | 2017-03-03 | |
| Stephen Gildea | gildea&lcs.mit.edu | ||
| StorageOS | simon.croome&storageos.com | 2017-03-03 | |
| Thomas Lindeman | tlindeµsoft.com | 2002-11 | |
| Tristan Richardson | iana&realvnc.com | 2006-03 | |
| Vincent Gaudeul | technique&auriga.fr | 2006-02 |