Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| citadel | 504 | udp | citadel | Art Cancro | Art Cancro | ||||||
| mailbox-lm | 505 | tcp | mailbox-lm | Beverly Moody | Beverly Moody | ||||||
| mailbox-lm | 505 | udp | mailbox-lm | Beverly Moody | Beverly Moody | ||||||
| ohimsrv | 506 | tcp | ohimsrv | Scott Powell | Scott Powell | ||||||
| ohimsrv | 506 | udp | ohimsrv | Scott Powell | Scott Powell | ||||||
| crs | 507 | tcp | crs | Brad Wright | Brad Wright | ||||||
| crs | 507 | udp | crs | Brad Wright | Brad Wright | ||||||
| xvttp | 508 | tcp | xvttp | Keith J. Alphonso | Keith J. Alphonso | ||||||
| xvttp | 508 | udp | xvttp | Keith J. Alphonso | Keith J. Alphonso | ||||||
| snare | 509 | tcp | snare | Dennis Batchelder | Dennis Batchelder | ||||||
| snare | 509 | udp | snare | Dennis Batchelder | Dennis Batchelder | ||||||
| fcp | 510 | tcp | FirstClass Protocol | Mike Marshburn | Mike Marshburn | ||||||
| fcp | 510 | udp | FirstClass Protocol | Mike Marshburn | Mike Marshburn | ||||||
| efs | 520 | tcp | extended file name server | ||||||||
| router | 520 | udp | local routing process (on site); uses variant of Xerox NS routing information protocol - RIP | ||||||||
| courier | 530 | tcp | rpc | ||||||||
| courier | 530 | udp | rpc | ||||||||
| uucp | 540 | tcp | uucpd | ||||||||
| uucp | 540 | udp | uucpd | ||||||||
| dhcpv6-server | 547 | tcp | DHCPv6 Server | IESG | IETF Chair | 2018-05-21 | RFC 5460 | ||||
| new-rwho | 550 | tcp | new-who | n/a | |||||||
| new-rwho | 550 | udp | new-who | n/a | |||||||
| rmonitor | 560 | tcp | rmonitord | ||||||||
| rmonitor | 560 | udp | rmonitord | ||||||||
| meter | 570 | tcp | demon | ||||||||
| meter | 570 | udp | demon | ||||||||
| sntp-heartbeat | 580 | tcp | SNTP HEARTBEAT | Louis Mamakos | Louis Mamakos | ||||||
| sntp-heartbeat | 580 | udp | SNTP HEARTBEAT | Louis Mamakos | Louis Mamakos | ||||||
| submission | 587 | tcp | Message Submission | 2011-11-17 | RFC 6409 | ||||||
| submission | 587 | udp | Message Submission | 2011-11-17 | RFC 6409 | ||||||
| tns-cml | 590 | tcp | TNS CML | Jerome Albin | Jerome Albin | ||||||
| tns-cml | 590 | udp | TNS CML | Jerome Albin | Jerome Albin | ||||||
| http-alt | 591 | tcp | FileMaker, Inc. - HTTP Alternate (see Port 80) | Clay Maeckel | Clay Maeckel | ||||||
| http-alt | 591 | udp | FileMaker, Inc. - HTTP Alternate (see Port 80) | Clay Maeckel | Clay Maeckel | ||||||
| ipcserver | 600 | tcp | Sun IPC server | Bill Schiefelbein | Bill Schiefelbein | ||||||
| ipcserver | 600 | udp | Sun IPC server | Bill Schiefelbein | Bill Schiefelbein | ||||||
| syslog-conn | 601 | tcp | Reliable Syslog Service | RFC 3195 | |||||||
| syslog-conn | 601 | udp | Reliable Syslog Service | RFC 3195 | |||||||
| xmlrpc-beep | 602 | tcp | XML-RPC over BEEP | RFC 3529 | |||||||
| xmlrpc-beep | 602 | udp | XML-RPC over BEEP | RFC 3529 | |||||||
| idxp | 603 | tcp | IDXP | RFC 4767 | |||||||
| idxp | 603 | udp | IDXP | RFC 4767 | |||||||
| tunnel | 604 | tcp | TUNNEL | RFC 3620 | |||||||
| tunnel | 604 | udp | TUNNEL | RFC 3620 | |||||||
| soap-beep | 605 | tcp | SOAP over BEEP | RFC 4227 | |||||||
| soap-beep | 605 | udp | SOAP over BEEP | RFC 4227 | |||||||
| urm | 606 | tcp | Cray Unified Resource Manager | ||||||||
| urm | 606 | udp | Cray Unified Resource Manager | ||||||||
| nqs | 607 | tcp | nqs | Bill Schiefelbein | Bill Schiefelbein | ||||||
| nqs | 607 | udp | nqs | Bill Schiefelbein | Bill Schiefelbein | ||||||
| sift-uft | 608 | tcp | Sender-Initiated/Unsolicited File Transfer | Rick Troth | Rick Troth | ||||||
| sift-uft | 608 | udp | Sender-Initiated/Unsolicited File Transfer | Rick Troth | Rick Troth | ||||||
| npmp-trap | 609 | tcp | npmp-trap | ||||||||
| npmp-trap | 609 | udp | npmp-trap | ||||||||
| npmp-local | 610 | tcp | npmp-local | ||||||||
| npmp-local | 610 | udp | npmp-local | ||||||||
| sco-websrvrmgr | 620 | tcp | SCO WebServer Manager | Christopher Durham | Christopher Durham | ||||||
| sco-websrvrmgr | 620 | udp | SCO WebServer Manager | Christopher Durham | Christopher Durham | ||||||
| rda | 630 | tcp | RDA | John Hadjioannou | John Hadjioannou | ||||||
| rda | 630 | udp | RDA | John Hadjioannou | John Hadjioannou | ||||||
| ipp | 631 | tcp | IPP (Internet Printing Protocol) | IESG | IETF Chair | 2018-07-06 | RFC 8011 | Defined TXT keys: See BonjourPrinting.pdf. | |||
| ipp | 631 | udp | IPP (Internet Printing Protocol) | IESG | IETF Chair | 2018-07-06 | RFC 8011 | Defined TXT keys: See BonjourPrinting.pdf. | |||
| ipps | 631 | tcp | Internet Printing Protocol over HTTPS | IESG | IETF Chair | 2018-07-06 | RFC 8011 | ||||
| entrust-sps | 640 | tcp | entrust-sps | Marek Buchler | Marek Buchler | ||||||
| entrust-sps | 640 | udp | entrust-sps | Marek Buchler | Marek Buchler | ||||||
| obex | 650 | tcp | OBEX | Jeff Garbers | Jeff Garbers | ||||||
| obex | 650 | udp | OBEX | Jeff Garbers | Jeff Garbers | ||||||
| mac-srvr-admin | 660 | tcp | MacOS Server Admin | Forest Hill | Forest Hill | ||||||
| mac-srvr-admin | 660 | udp | MacOS Server Admin | Forest Hill | Forest Hill | ||||||
| vacdsm-sws | 670 | tcp | VACDSM-SWS | ||||||||
| vacdsm-sws | 670 | udp | VACDSM-SWS | ||||||||
| entrust-aaas | 680 | tcp | entrust-aaas | ||||||||
| entrust-aaas | 680 | udp | entrust-aaas | ||||||||
| vatp | 690 | tcp | Velneo Application Transfer Protocol | Velneo | David Gutiérrez | 2015-02-03 | |||||
| vatp | 690 | udp | Velneo Application Transfer Protocol | Velneo | David Gutiérrez | 2015-02-03 | |||||
| epp | 700 | tcp | Extensible Provisioning Protocol | RFC 5734 | |||||||
| epp | 700 | udp | EPP running over QUIC | IESG | IETF Chair | 2026-07-23 | RFC 5734; RFC-ietf-regext-epp-quic-12 | ||||
| lmp | 701 | tcp | Link Management Protocol (LMP) | RFC 4204 | |||||||
| lmp | 701 | udp | Link Management Protocol (LMP) | RFC 4204 | |||||||
| iris-beep | 702 | tcp | IRIS over BEEP | RFC 3983 | |||||||
| iris-beep | 702 | udp | IRIS over BEEP | RFC 3983 | |||||||
| 703 | Unassigned | ||||||||||
| elcsd | 704 | tcp | errlog copy/server daemon | ||||||||
| elcsd | 704 | udp | errlog copy/server daemon | ||||||||
| agentx | 705 | tcp | AgentX | Bob Natale | Bob Natale | ||||||
| agentx | 705 | udp | AgentX | Bob Natale | Bob Natale | ||||||
| silc | 706 | tcp | SILC | Pekka Riikonen | Pekka Riikonen | ||||||
| silc | 706 | udp | SILC | Pekka Riikonen | Pekka Riikonen | ||||||
| borland-dsj | 707 | tcp | Borland DSJ | Gerg Cole | Gerg Cole | ||||||
| borland-dsj | 707 | udp | Borland DSJ | Gerg Cole | Gerg Cole | ||||||
| 708 | Unassigned | ||||||||||
| entrust-kmsh | 709 | tcp | Entrust Key Management Service Handler | ||||||||
| entrust-kmsh | 709 | udp | Entrust Key Management Service Handler | ||||||||
| entrust-ash | 710 | tcp | Entrust Administration Service Handler | Peter Whittaker | Peter Whittaker | ||||||
| entrust-ash | 710 | udp | Entrust Administration Service Handler | Peter Whittaker | Peter Whittaker | ||||||
| netviewdm1 | 729 | tcp | IBM NetView DM/6000 Server/Client | ||||||||
| netviewdm1 | 729 | udp | IBM NetView DM/6000 Server/Client | ||||||||
| netviewdm2 | 730 | tcp | IBM NetView DM/6000 send/tcp | ||||||||
| netviewdm2 | 730 | udp | IBM NetView DM/6000 send/tcp | ||||||||
| netviewdm3 | 731 | tcp | IBM NetView DM/6000 receive/tcp | Philippe Binet | Philippe Binet | ||||||
| netviewdm3 | 731 | udp | IBM NetView DM/6000 receive/tcp | Philippe Binet | Philippe Binet |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Art Cancro | ajc&citadel.org | 2015-02-18 | |
| Beverly Moody | Beverly_Moody&stercomm.com | ||
| Bill Schiefelbein | schief&aspen.cray.com | ||
| Bob Natale | bob.natale&appliedsnmp.com | ||
| Brad Wright | bradwrµsoft.com | ||
| Christopher Durham | chrisdu&sco.com | ||
| Clay Maeckel | clay&claris.com | 2023-09-12 | |
| David Gutiérrez | Velneo | velneo&velneo.com | 2015-02-03 |
| Dennis Batchelder | dennis&capres.com | ||
| Forest Hill | forest&apple.com | ||
| Gerg Cole | gcole&corp.borland.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jeff Garbers | FJG030&email.mot.com | ||
| Jerome Albin | albin&taec.enet.dec.com | ||
| John Hadjioannou | john&minster.co.uk | ||
| Keith J. Alphonso | alphonso&ncs-ssc.com | ||
| Louis Mamakos | louie&uu.net | ||
| Marek Buchler | Marek.Buchler&entrust.com | ||
| Mike Marshburn | paul&softarc.com | ||
| Pekka Riikonen | priikone&poseidon.pspt.fi | ||
| Peter Whittaker | pww&entrust.com | ||
| Philippe Binet | phbinet&vnet.ibm.com | ||
| Rick Troth | troth&rice.edu | ||
| Scott Powell | spowell&openhorizon.com | ||
| Velneo | velneo&velneo.com |