Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
unify-debug 4867 udp Unify Debugger Daegis, Inc. Chris Anderson 2006-05 2012-07-31
4954-4968 Unassigned Known UNAUTHORIZED USE: port 4967
authentx 5067 tcp Authentx Service Alberto Fernandez Alberto Fernandez 2006-01
authentx 5067 udp Authentx Service Alberto Fernandez Alberto Fernandez 2006-01
scte104 5167 tcp SCTE104 Connection Thomas Russell Thomas Russell 2005-05
scte104 5167 udp SCTE104 Connection Thomas Russell Thomas Russell 2005-05
mdns 5353 tcp Multicast DNS IESG IETF Chair RFC 6762
mdns 5353 udp Multicast DNS IESG IETF Chair RFC 6762
dof-dps-mc-sec 5567 tcp DOF Protocol Stack Multicast/Secure Transport OpenDOF Bryant Eastham 2004-11 2015-04-23
dof-dps-mc-sec 5567 udp DOF Protocol Stack Multicast/Secure Transport OpenDOF Bryant Eastham 2004-11 2015-04-23
5667-5669 Unassigned
filemq 5670 tcp ZeroMQ file publish-subscribe protocol Pieter Hintjens Pieter Hintjens 2012-11-01 2013-02-25
zre-disc 5670 udp Local area discovery and messaging over ZeroMQ Pieter Hintjens Pieter Hintjens 2012-12-17
amqps 5671 tcp amqp protocol over TLS/SSL Ted Ross Ted Ross 2008-03-26
amqps 5671 udp amqp protocol over TLS/SSL Ted Ross Ted Ross 2008-03-26
amqp 5672 tcp AMQP Pieter Hintjens Pieter Hintjens 2006-01
amqp 5672 udp AMQP Pieter Hintjens Pieter Hintjens 2006-01
amqp 5672 sctp AMQP Martin Sustrik Martin Sustrik 2007-03
jms 5673 tcp JACL Message Server Stuart Allen Stuart Allen 2002-02
jms 5673 udp JACL Message Server Stuart Allen Stuart Allen 2002-02
hyperscsi-port 5674 tcp HyperSCSI Port Data Storage Institute of Singapore Data Storage Institute of Singapore 2002-02
hyperscsi-port 5674 udp HyperSCSI Port Data Storage Institute of Singapore Data Storage Institute of Singapore 2002-02
v5ua 5675 tcp V5UA application port RFC 3807
v5ua 5675 udp V5UA application port RFC 3807
v5ua 5675 sctp V5UA application port RFC 3807
raadmin 5676 tcp RA Administration Sergei Zjaikin Sergei Zjaikin 2002-02
raadmin 5676 udp RA Administration Sergei Zjaikin Sergei Zjaikin 2002-02
questdb2-lnchr 5677 tcp Quest Central DB2 Launchr Robert M. Mackowiak Robert M. Mackowiak 2002-02
questdb2-lnchr 5677 udp Quest Central DB2 Launchr Robert M. Mackowiak Robert M. Mackowiak 2002-02
rrac 5678 tcp Remote Replication Agent Connection
rrac 5678 udp Remote Replication Agent Connection
dccm 5679 tcp Direct Cable Connect Manager Mark Miller Mark Miller
dccm 5679 udp Direct Cable Connect Manager Mark Miller Mark Miller
s-openmail 5767 tcp OpenMail Suer Agent Layer (Secure) OpenMail Encyclopedia; Don Loughry OpenMail Encyclopedia; Don Loughry
s-openmail 5767 udp OpenMail Suer Agent Layer (Secure) OpenMail Encyclopedia; Don Loughry OpenMail Encyclopedia; Don Loughry
5864-5867 Unassigned
diameters 5868 tcp Diameter over TLS/TCP IESG IETF Chair RFC 6733
diameters 5868 sctp Diameter over DTLS/SCTP IESG IETF Chair RFC 6733
5964-5967 Unassigned
6067 Unassigned 2007-07-17
gld 6267 tcp GridLAB-D User Interface David Chassin David Chassin 2010-12-10
6267 udp Reserved
dccp-udp 6511 udp Datagram Congestion Control Protocol Encapsulation for NAT Traversal IESG IETF Chair RFC 6773
6567 Reserved 2007-01 2011-08-26 This entry has been removed on 2011-08-26.
vocaltec-gold 6670 tcp Vocaltec Global Online Directory Scott Petrack Scott Petrack
vocaltec-gold 6670 udp Vocaltec Global Online Directory Scott Petrack Scott Petrack
p4p-portal 6671 tcp P4P Portal Service Chris Griffiths Chris Griffiths 2008-07-28
p4p-portal 6671 udp P4P Portal Service Chris Griffiths Chris Griffiths 2008-07-28
vision-server 6672 tcp vision_server

IANA assigned this well-formed service name as a replacement for "vision_server".
Chris Kramer Chris Kramer
vision_server 6672 tcp vision_server Chris Kramer Chris Kramer This entry is an alias to "vision-server". This entry is now historic, not usable for use with many common service discovery mechanisms.
vision-server 6672 udp vision_server

IANA assigned this well-formed service name as a replacement for "vision_server".
Chris Kramer Chris Kramer
vision_server 6672 udp vision_server Chris Kramer Chris Kramer This entry is an alias to "vision-server". This entry is now historic, not usable for use with many common service discovery mechanisms.
vision-elmd 6673 tcp vision_elmd

IANA assigned this well-formed service name as a replacement for "vision_elmd".
Chris Kramer Chris Kramer
vision_elmd 6673 tcp vision_elmd Chris Kramer Chris Kramer This entry is an alias to "vision-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms.
vision-elmd 6673 udp vision_elmd

IANA assigned this well-formed service name as a replacement for "vision_elmd".
Chris Kramer Chris Kramer
vision_elmd 6673 udp vision_elmd Chris Kramer Chris Kramer This entry is an alias to "vision-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms.
6674-6677 Unassigned
vfbp 6678 tcp Viscount Freedom Bridge Protocol Chris MacDonald Chris MacDonald 2011-03-16
vfbp-disc 6678 udp Viscount Freedom Bridge Discovery Chris MacDonald Chris MacDonald 2011-03-16
osaut 6679 tcp Osorno Automation Peter Hombach Peter Hombach 2011-03-16
osaut 6679 udp Osorno Automation Peter Hombach Peter Hombach 2011-03-16
6700 Unassigned 2010-01-26
kti-icad-srvr 6701 tcp KTI/ICAD Nameserver Stanley Knutson Stanley Knutson
kti-icad-srvr 6701 udp KTI/ICAD Nameserver Stanley Knutson Stanley Knutson
6701 sctp Unassigned 2010-01-26
e-design-net 6702 tcp e-Design network Janos Lerch Janos Lerch 2006-02
e-design-net 6702 udp e-Design network Janos Lerch Janos Lerch 2006-02
6702 sctp Unassigned 2010-01-26
e-design-web 6703 tcp e-Design web Janos Lerch Janos Lerch 2006-02
e-design-web 6703 udp e-Design web Janos Lerch Janos Lerch 2006-02
6704 udp Reserved
6704 tcp Reserved
frc-hp 6704 sctp ForCES HP (High Priority) channel RFC 5811
6705 udp Reserved
6705 tcp Reserved
frc-mp 6705 sctp ForCES MP (Medium Priority) channel RFC 5811
6706 udp Reserved
6706 tcp Reserved
frc-lp 6706 sctp ForCES LP (Low priority) channel RFC 5811
6707-6713 Unassigned
ibprotocol 6714 tcp Internet Backplane Protocol Alessandro Bassi Alessandro Bassi
ibprotocol 6714 udp Internet Backplane Protocol Alessandro Bassi Alessandro Bassi
fibotrader-com 6715 tcp Fibotrader Communications Robert Wetzold Robert Wetzold 2006-01
fibotrader-com 6715 udp Fibotrader Communications Robert Wetzold Robert Wetzold 2006-01
princity-agent 6716 tcp Princity Agent ENSTEAM Sp. z o.o. Tomasz Krakowiak 2014-07-07 2015-07-08
6716 udp Reserved
6717-6766 Unassigned
bmc-perf-agent 6767 tcp BMC PERFORM AGENT Portnoy Boxman Portnoy Boxman
bmc-perf-agent 6767 udp BMC PERFORM AGENT Portnoy Boxman Portnoy Boxman
bmc-perf-mgrd 6768 tcp BMC PERFORM MGRD Portnoy Boxman Portnoy Boxman
bmc-perf-mgrd 6768 udp BMC PERFORM MGRD Portnoy Boxman Portnoy Boxman
adi-gxp-srvprt 6769 tcp ADInstruments GxP Server Mathew Pitchforth Mathew Pitchforth 2005-08
adi-gxp-srvprt 6769 udp ADInstruments GxP Server Mathew Pitchforth Mathew Pitchforth 2005-08
plysrv-http 6770 tcp PolyServe http Mike Spitzer Mike Spitzer 2005-08
plysrv-http 6770 udp PolyServe http Mike Spitzer Mike Spitzer 2005-08
plysrv-https 6771 tcp PolyServe https Mike Spitzer Mike Spitzer 2005-08
plysrv-https 6771 udp PolyServe https Mike Spitzer Mike Spitzer 2005-08
6772-6776 Unassigned
ntz-tracker 6777 tcp netTsunami Tracker Tomahawk Holdings Ltd Sagara Wijetunga 2013-05-01
6777 udp Reserved
ntz-p2p-storage 6778 tcp netTsunami p2p storage system Tomahawk Holdings Ltd Sagara Wijetunga 2013-05-01

Contact Information

Name Organization Contact URI Last Updated
Alberto Fernandez af&xtec.com 2006-01
Alessandro Bassi abassi&cs.utk.edu
Bryant Eastham OenDOF protocol&opendof.org 2015-04-23
Chris Anderson Daegis, Inc. ianaportmaster&daegis.com 2012-07-31
Chris Griffiths chris_griffiths&cable.comcast.com 2008-07-28
Chris Kramer CKramer&gis.shl.com
Chris MacDonald chris&viscount.com 2011-03-16
Daegis, Inc. ianaportmaster&daegis.com 2012-07-31
Data Storage Institute of Singapore Patrick&dsi.nus.edu.sg 2002-02
David Chassin david.chassin&pnl.gov 2010-12-10
Don Loughry DON_LOUGHRY&hp-cupertino-om4.om.hp.com
ENSTEAM Sp. z o.o. support&ensteam.com 2015-07-08
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Janos Lerch lerch&softic.hu 2006-02
Mark Miller mmiller&microsoft.com
Martin Sustrik sustrik&imatix.com 2007-03
Mathew Pitchforth mathew&adinstruments.co.nz 2005-08
Mike Spitzer mjs&polyserve.com 2005-08
OpenDOF protocol&opendof.org 2015-04-23
OpenMail Encyclopedia opencyc&hpopd.pwd.hp.com
Peter Hombach p.hombach&osorno.ca 2011-03-16
Pieter Hintjens ph&imatix.com 2006-01
Pieter Hintjens ph&imatix.com 2012-11-01
Pieter Hintjens ph&imatix.com 2012-12-17
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Robert M. Mackowiak rmackowiak&quest.com 2002-02
Robert Wetzold robert.wetzold&fibotrader.com 2006-01
Sagara Wijetunga Tomahawk Holdings Ltd sagara&tomahawk.lk 2013-05-01
Scott Petrack Scott_Petrack&vocaltec.com
Sergei Zjaikin serge&previo.ee 2002-02
Stanley Knutson Stanley.Knutson&ktiworld.com
Stuart Allen stuart&jacl.animats.net 2002-02
Ted Ross tross&redhat.com 2008-03-26
Thomas Russell trussell&scte.org 2005-05
Tomahawk Holdings Ltd sagara&tomahawk.lk 2013-05-01
Tomasz Krakowiak ENSTEAM Sp. z o.o. tomasz.krakowiak&ensteam.com 2015-07-08